Browser XML - hospitalCreditResponse

Version 4.10

Réalisez par le Forum pour l'échange des données

Le contenu, la présentation et le logiciel ne peuvent être modifiés sans la permission expresse du Forum pour l'échange des données.

En décembre 2005.


Manuel de référence de la réponse de prise en charge hospitalière

hospitalCreditResponse_410 fra

Manuel de référence de la réponse de prise en charge hospitalière


© - copyright

hospitalCreditResponse_410 fra

© - copyright
Standard de facturation dans le domaine de la santé publique suisse
Manuel de référence: Réponse garantie hôpital version 4.10
hospitalCreditResponse_410.xsd
Date: 6.12.2005

© - copyright: Le Forum pour l'échange des données. Tous droits réservés.
Ce document peut être copié et distribué à volonté, pour autant que sa forme reste inchangée et que la reproduction et la diffusion s'effectuent à des fins non commerciales.
Les mêmes conditions s'appliquent à tous les fichiers de schéma XML référencés dans ce document.
Toutefois, le Forum pour l'échange des données décline toute responsabilité quant à l'actualité et à l'exactitude du contenu.


Forum Datenaustausch

hospitalCreditResponse_410 fra

Forum Datenaustausch

Dans Forum Datenaustausch, différents acteurs du domaine de la santé publique suisse se sont associés. Entre autre, le but que poursuit le Forum est de fixer les standards développés en commun pour l'échange électronique des données.

Les membres du Forum sont les associations des fournisseurs de prestations H+, ainsi que Société Suisse des Pharmaciens (SSPh). Du côté des répondants des coûts il s'agit de santé suisse, de l'Association suisse des assureurs (ASA), de la Suva, de l'Office fédéral pour l'Assurance militaire (OFAM) et de l'Assurance-invalidité (AI).

Les standards approuvés par le Forum comme les communications XML pour l'échange électronique des données sont publiés sur

www.forum-datenaustausch.ch

publié. En font également partie, les décomptes électroniques de prestations pour les médecins, basés sur XML.

Les tâches du Forum consistent dans l'accord de buts stratégiques, la négociation au niveau politique, ainsi qu'en des pourparlers contractuels. L'organe compétent représenté par les mêmes acteurs, comme le Forum lui-même, est subordonné au Forum.

Les tâches de l'organe compétent comprennent:

- Réalisation des buts fixés
- Négociation à l'échelon compétent (coordination et communication avec les acteurs)
- Réalisation d'organisations et consultations

La présente réponse de prise en charge hospitalière a été élaborée et définie par les membres de l'organe compétent et approuvée par le Forum Datenaustausch.


Types de données XML

hospitalCreditResponse_410 fra

Types de données XML

Le tableau ci-dessous décrit le format des types de données les plus importants dans le 'schemafile' (hospitalCreditResponse_410.xsd):

Nom | Description
anyURI | anyURI désigne tout URI valable selon RFC 2396 resp. RFC 2732.
boolean | Est le type de données booléen qui peut prendre les valeurs {true|false|1|0}. Dans ce contexte, et comme c'est usuel dans les langages de programmation séquentiels, 0 signifie false et 1 true.
dateTime | dateTime représente un moment temporel spécifié de manière précise, la zone des valeurs de dateTime étant formée d'une combinaison de la date et de l'heure selon ISO 8601. Par exemple, le code de 13:20h en date du 31.5.1999 serait "1999-05-31T13:20:00". Attention: Si lors de l'indication d'une date, l'heure ne joue aucun rôle, c'est 00:00:00h qui doit être indiqué comme heure. Exemple: "1999-05-31T00:00:00". Si une date doit être livrée avec une indication de temps, cela est réglementé dans les contrats (tarifs-/ contrats-cadre).
double | Est un type numérique de virgule flottante selon la définition IEEE double precision 64-bit floating point (IEEE 754-1985).
duration | duration représente un intervalle de temps. La zone des valeurs de duration pouvant être formée à la seconde près selon ISO 8601.
enumeration | enumeration définit une quantité limitée de valeurs fixées parmi lesquelles un élément doit être choisi, par ex. {1|2|3}.
long | Est un type numérique de nombre entier (64-bit) avec la barrière supérieure 9223372036854775807 et la barrière inférieure -9223372036854775808.
NMTOKEN | Un NMTOKEN est une séquence d'une ou de plusieurs lettres, chiffres et quelques symboles de ponctuation.
pattern | pattern désigne un "modèle" prédéfini. La syntaxe de pattern est indiquée comme grep pattern selon Perl 5 Implementation.
string | string représente le type de données character string en XML. La zone des valeurs de string est une séquence limitée de caractères.

Les standards ISO mentionnés se trouvent en partie sur 'www.w3c.org'. En tout cas, les standards ISO peuvent être commandés sous 'www.iso.ch'.

Les documents RFC de l'IETF (Internet Engineering Task Force) sont disponibles en ligne sous www.ietf.org.


Jeu de caractères

hospitalCreditResponse_410 fra

Jeu de caractères

Der für die XML-Rechnung zu verwendende Zeichensatz ist Unicode UTF-8.

Quelques signes ne peuvent pas être utilisés dans le texte d'un document XML parce qu'ils peuvent entrer en conflit avec des séparateurs markup spéciaux. < ou & ne peuvent être écrits directement dans un document XML que pour introduire un 'tag' ou une 'entity'.

Afin que la signification des signes suivants soit univoque dans le texte d'un document XML, il est recommandé de les représenter par les entités de caractères prédéfinies:

& | = | &amp
' | = | &apos
> | = | &gt
< | = | &lt
" | = | &quot

Exemples pour une ligne de codage BVR:

0100000121403>016291414110116441140576999+ 010370058> | =
<invoice:esr9 coding_line="0100000121403&gt;016291414110116441140576999+010370058&gt;"/> |
<080001000000500> 473434028588301+ 11218> | =
<invoice:esr5 coding_line="&lt;080001000000500&gt;473434028588301+ 11218&gt;"/> |


Schéma de la réponse de prise en charge hospitalière

hospitalCreditResponse_410 fra
Schéma de la réponse de prise en charge hospitalière


 Schema hospitalCreditResponse_410.xsd
attribute form default: | unqualified
element form default: | unqualified
targetNamespace: | http://www.forum-datenaustausch.ch/de
Elements | Complex types | Simple types
response | acceptedCostsType | amountType
 | companyType | eanPartyType
 | contactAddressType | nifPartyType
 | costsType | nonEmptyTextType
 | creditType | ssn13PartyType
 | detailType | ssnPartyType
 | employeeType | stringType0_350
 | employerAddressType | stringType1_12
 | errorSchemaType | stringType1_25
 | generatorType | stringType1_3
 | headerPartyType | stringType1_35
 | headerType | stringType1_350
 | insuranceAddressType | stringType1_50
 | ivgLawType | stringType1_6
 | kvgLawType | stringType1_70
 | mvgLawType | stringType1_700
 | onlineAddressType | stringType1_9
 | patientAddressType | unionPartyType
 | personType | versionType
 | postalAddressType | xtendEanPartyType
 | prologType | zsrPartyType
 | providerAddressType |
 | responseType |
 | softwareType |
 | sponsorType |
 | telecomAddressType |
 | uvgLawType |
 | vvgLawType |
 | xmlErrorType |
 | xndCostsType |
 | xtendHeaderPartyType |
 | zipType |

element response
Annotation Début du document XML

Déclaration XML, y compris jeu de caractères UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (première ligne dans le document XML)

Elément racine: credit:response

- XML Espace nominal xsi: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- Espace nominal credit: xmlns:credit="http://www.forum-datenaustausch.ch/de"
- Type: Réponse de prise en charge hospitalière 4.1
- Lieu: xsi :schemaLocation="http://www.forum-datenaustausch.ch/de hospitalCreditResponse_410.xsd"

L'espace nominal pour tous les éléments est "credit".
Dans le document XML, cet espace nominal doit être indiqué pour chaque élément!

Parla suite, la présente documentation ne fera état plus que du nom de l'élément, sans espace nominal, p. ex: "response" au lieu de "credit:response".

Pour les attributs, il n'est pas nécessaire d'indiquer un espace nominal dans le document XML.

Voir définition dans le schéma:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:responseType
properties
content complex
children | header prolog xml_error credit
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name | Notes
assignment_role | Rôle thérapeutique du fournisseur de prestations
assignment_place | Lieu de la prestation
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<element name="response" type="credit:responseType"/>

complexType acceptedCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements kvgLawType/accepted_costs uvgLawType/accepted_costs ivgLawType/accepted_costs mvgLawType/accepted_costs vvgLawType/accepted_medical_costs vvgLawType/accepted_treatment_costs kvgLawType/total_accepted_costs vvgLawType/total_accepted_costs uvgLawType/total_accepted_costs ivgLawType/total_accepted_costs mvgLawType/total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
Extensions
Annotation | Base
Type de coûts | credit:costsType
source
<complexType name="acceptedCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="percent" type="credit:amountType"/>
      <attribute name="remark" type="credit:stringType1_35"/>
    </extension>
  </complexContent>
</complexType>

complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | companyname department postal telecom online
used by
elements employerAddressType/company providerAddressType/company insuranceAddressType/company contactAddressType/company
source
<complexType name="companyType">
  <sequence>
    <element name="companyname" type="credit:stringType1_35"/>
    <element name="department" type="credit:stringType1_35" minOccurs="0" maxOccurs="3"/>
    <element name="postal" type="credit:postalAddressType"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
</complexType>

element companyType/companyname
Annotation Désignation de l'entreprise
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="credit:stringType1_35"/>

element companyType/department
Annotation Service / Division
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="credit:stringType1_35" minOccurs="0" maxOccurs="3"/>

element companyType/postal
Annotation Adresse
diagram
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="credit:postalAddressType"/>

element companyType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

element companyType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>

complexType contactAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person employee company
used by
elements creditType/contact creditType/recipient
source
<complexType name="contactAddressType">
  <choice>
    <element name="person" type="credit:personType"/>
    <sequence>
      <element name="employee" type="credit:employeeType"/>
      <element name="company" type="credit:companyType"/>
    </sequence>
  </choice>
</complexType>

element contactAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>

element contactAddressType/employee
Annotation Personne de contact
diagram
type | credit:employeeType
properties
isRef | 0
content | complex
children | familyname givenname telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel de l'interlocuteur
title | Titre de l'interlocuteur
source
<element name="employee" type="credit:employeeType"/>

element contactAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>

complexType costsType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements | kvgLawType/estimated_costs uvgLawType/estimated_costs ivgLawType/estimated_costs mvgLawType/estimated_costs kvgLawType/total_estimated_costs vvgLawType/total_estimated_costs uvgLawType/total_estimated_costs ivgLawType/total_estimated_costs mvgLawType/total_estimated_costs
complexTypes | acceptedCostsType xndCostsType
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<complexType name="costsType">
  <attribute name="amount" type="credit:amountType"/>
  <attribute name="currency" type="string" fixed="CHF"/>
</complexType>

complexType creditType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | recipient provider patient sponsor contact employer detail
used by
element responseType/credit
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
type |  |  | new |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type de demande
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<complexType name="creditType">
  <sequence>
    <element name="recipient" type="credit:contactAddressType"/>
    <element name="provider" type="credit:providerAddressType"/>
    <element name="patient" type="credit:patientAddressType"/>
    <element name="sponsor" type="credit:sponsorType"/>
    <element name="contact" type="credit:contactAddressType"/>
    <element name="employer" type="credit:employerAddressType" minOccurs="0"/>
    <element name="detail" type="credit:detailType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong" use="required"/>
  <attribute name="credit_id" type="credit:stringType1_35" use="required"/>
  <attribute name="credit_date" type="dateTime" use="required"/>
  <attribute name="type" default="new">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_timestamp" type="unsignedLong" use="required"/>
  <attribute name="response_id" type="credit:stringType1_35" use="required"/>
</complexType>

element creditType/recipient
Annotation Destinataire
diagram
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | person employee company
source
<element name="recipient" type="credit:contactAddressType"/>

element creditType/provider
Annotation Fournisseur de prestations

Désigne le bloc adresse du fournisseur de prestations (médecin).

Le numéro EAN est valable en priorité pour l'identification du fournisseur de prestations. Pour satisfaire aux exigences de santé suisse en matière de facture, le numéro RCC correspondant doit également être mentionné.

Si la teneur informative du numéro EAN est contraire à celle du numéro RCC, ce sont les indications inhérentes au numéro EAN qui sont valables.

Si le fournisseur de prestations ("provider") et le factureur ("biller") sont identiques, il faut qu'exactement les mêmes données soient mentionnées pour les deux partenaires, c.-à-d. le bloc "provider" est une copie 1:1 du bloc "biller".
diagram
type | credit:providerAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le fournisseur de prestations par le biais d'un numéro EAN univoque.
zsr | Numéro RCC RCC registre des codes créanciers de santé suisse.
specialty | Spécialité Désigne une autre spécification optionnelle au sens de la profession ou d'une activité similaire.
source
<element name="provider" type="credit:providerAddressType"/>

element creditType/patient
Annotation Patient

Désigne le bloc adresse avec les coordonnées du patient.

Si le patient ("patient") et le garant ("guarantor") sont identiques, il faut que les mêmes données à l'exception du sexe du patient et de la date de naissance du patient soient mentionnées pour les deux partenaires (c.-à-d. le bloc "guarantor" est quasiment une copie 1:1 du bloc "patient".
diagram
type | credit:patientAddressType
properties
isRef | 0
content | complex
children | person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
tax_city | Domicile fiscal
tax_canton | Canton fiscal
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
tax_canton |  | NMTOKEN | AG | Argovie
tax_canton |  | NMTOKEN | AI | Appenzell Rhodes intérieures
tax_canton |  | NMTOKEN | AR | Appenzell Rhodes extérieures
tax_canton |  | NMTOKEN | BE | Berne
tax_canton |  | NMTOKEN | BL | Bâle-Campagne
tax_canton |  | NMTOKEN | BS | Bâle-Ville
tax_canton |  | NMTOKEN | FR | Fribourg
tax_canton |  | NMTOKEN | GE | Genève
tax_canton |  | NMTOKEN | GL | Glaris
tax_canton |  | NMTOKEN | GR | Grisons
tax_canton |  | NMTOKEN | JU | Jura
tax_canton |  | NMTOKEN | LU | Lucerne
tax_canton |  | NMTOKEN | NE | Neuchâtel
tax_canton |  | NMTOKEN | NW | Nidwald
tax_canton |  | NMTOKEN | OW | Obwald
tax_canton |  | NMTOKEN | SG | St-Gall
tax_canton |  | NMTOKEN | SH | Schaffhouse
tax_canton |  | NMTOKEN | SO | Soleure
tax_canton |  | NMTOKEN | SZ | Schwyz
tax_canton |  | NMTOKEN | TI | Tessin
tax_canton |  | NMTOKEN | TG | Thurgovie
tax_canton |  | NMTOKEN | UR | Uri
tax_canton |  | NMTOKEN | VD | Vaud
tax_canton |  | NMTOKEN | VS | Valais
tax_canton |  | NMTOKEN | ZG | Zoug
tax_canton |  | NMTOKEN | ZH | Zurich
tax_canton |  | NMTOKEN | LI | Fürstentum Liechtenstein
source
<element name="patient" type="credit:patientAddressType"/>

element creditType/sponsor
Annotation Répondant des coûts
diagram
type | credit:sponsorType
properties
isRef | 0
content | complex
children | insurance kvg uvg ivg mvg vvg
attributes parameters
Name | Type | Use | Default | Fixed
billing |  |  | separate |
attributes annotations
Name | Notes
billing | Facturation
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
billing |  | NMTOKEN | separate | séparé
billing |  | NMTOKEN | combine | combiné
source
<element name="sponsor" type="credit:sponsorType"/>

element creditType/contact
Annotation Personne de contact
diagram
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | person employee company
source
<element name="contact" type="credit:contactAddressType"/>

element creditType/employer
Annotation Employeur du patient
diagram
type | credit:employerAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie l'employeur par le biais d'un numéro EAN univoque.
reg_number | Numéro d'entreprise
source
<element name="employer" type="credit:employerAddressType" minOccurs="0"/>

element creditType/detail
Annotation Détails de la facture de médecin
diagram
type | credit:detailType
properties
isRef | 0
content | complex
children | explanation supplement remark
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime |  |  |
date_end | dateTime |  |  |
days | duration |  |  |
treatment_type |  | required |  |
reason |  | required |  |
response_type |  | required |  |
response_code | credit:stringType1_6 | required |  |
response_text | credit:stringType1_50 | required |  |
attributes annotations
Name | Notes
date_begin | Garantie de
date_end | Garantie jusqu'à
days | Garantie à partir du début en jours
treatment_type | Sorte de traitement
reason | Motif de traitement
response_type | Type de réponse
response_code | Code de réponse
response_text | Texte de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
reason |  | NMTOKEN | disease | maladie
reason |  | NMTOKEN | accident | accident
reason |  | NMTOKEN | maternity | maternité
reason |  | NMTOKEN | prevention | prévention
reason |  | NMTOKEN | birthdefect | infirmité congénitale
response_type |  | NMTOKEN | accepted | accepté
response_type |  | NMTOKEN | rejected | refusé
response_type |  | NMTOKEN | limited_coverage | couverture limitée
response_type |  | NMTOKEN | preliminary | provisoire
source
<element name="detail" type="credit:detailType"/>

complexType detailType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | explanation supplement remark
used by
element creditType/detail
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime |  |  |
date_end | dateTime |  |  |
days | duration |  |  |
treatment_type |  | required |  |
reason |  | required |  |
response_type |  | required |  |
response_code | credit:stringType1_6 | required |  |
response_text | credit:stringType1_50 | required |  |
attributes annotations
Name | Notes
date_begin | Garantie de
date_end | Garantie jusqu'à
days | Garantie à partir du début en jours
treatment_type | Sorte de traitement
reason | Motif de traitement
response_type | Type de réponse
response_code | Code de réponse
response_text | Texte de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
reason |  | NMTOKEN | disease | maladie
reason |  | NMTOKEN | accident | accident
reason |  | NMTOKEN | maternity | maternité
reason |  | NMTOKEN | prevention | prévention
reason |  | NMTOKEN | birthdefect | infirmité congénitale
response_type |  | NMTOKEN | accepted | accepté
response_type |  | NMTOKEN | rejected | refusé
response_type |  | NMTOKEN | limited_coverage | couverture limitée
response_type |  | NMTOKEN | preliminary | provisoire
source
<complexType name="detailType">
  <sequence>
    <element name="explanation" type="string" minOccurs="0"/>
    <element name="supplement" type="string" minOccurs="0"/>
    <element name="remark" type="string" minOccurs="0"/>
  </sequence>
  <attribute name="date_begin" type="dateTime"/>
  <attribute name="date_end" type="dateTime"/>
  <attribute name="days" type="duration"/>
  <attribute name="treatment_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="ambulatory"/>
        <enumeration value="semi_stationary"/>
        <enumeration value="stationary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="reason" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="disease"/>
        <enumeration value="accident"/>
        <enumeration value="maternity"/>
        <enumeration value="prevention"/>
        <enumeration value="birthdefect"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="accepted"/>
        <enumeration value="rejected"/>
        <enumeration value="limited_coverage"/>
        <enumeration value="preliminary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_code" type="credit:stringType1_6" use="required"/>
  <attribute name="response_text" type="credit:stringType1_50" use="required"/>
</complexType>

element detailType/explanation
Annotation Raison
diagram
type string
properties
isRef | 0
content | simple
source
<element name="explanation" type="string" minOccurs="0"/>

element detailType/supplement
Annotation Précision et complément
diagram
type string
properties
isRef | 0
content | simple
source
<element name="supplement" type="string" minOccurs="0"/>

element detailType/remark
Annotation Remarque
diagram
type string
properties
isRef | 0
content | simple
source
<element name="remark" type="string" minOccurs="0"/>

complexType employeeType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname telecom online
used by
element contactAddressType/employee
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel de l'interlocuteur
title | Titre de l'interlocuteur
source
<complexType name="employeeType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>

element employeeType/familyname
Annotation Nom
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>

element employeeType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>

element employeeType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

element employeeType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>

complexType employerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
element creditType/employer
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie l'employeur par le biais d'un numéro EAN univoque.
reg_number | Numéro d'entreprise
source
<complexType name="employerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType"/>
  <attribute name="reg_number" type="credit:stringType1_35"/>
</complexType>

element employerAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>

element employerAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>

complexType errorSchemaType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:nonEmptyTextType
properties
base credit:nonEmptyTextType
used by
element xmlErrorType/error
facets
minLength 1
attributes parameters
Name | Type | Use | Default | Fixed
line_number | positiveInteger |  |  |
line_pos | positiveInteger |  |  |
err_code | integer |  |  |
err_text | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
line_number | Numéro de ligne
line_pos | Position de ligne
err_code | Code d'erreur
err_text | Texte d'erreur
Extensions
Annotation | Base
Erreurs | credit:nonEmptyTextType
source
<complexType name="errorSchemaType">
  <simpleContent>
    <extension base="credit:nonEmptyTextType">
      <attribute name="line_number" type="positiveInteger"/>
      <attribute name="line_pos" type="positiveInteger"/>
      <attribute name="err_code" type="integer"/>
      <attribute name="err_text" type="credit:stringType1_350"/>
    </extension>
  </simpleContent>
</complexType>

complexType generatorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | software
used by
element prologType/generator
source
<complexType name="generatorType">
  <sequence>
    <element name="software" type="credit:softwareType"/>
  </sequence>
</complexType>

element generatorType/software
Annotation Logiciel générateur

Contient le nom du logiciel ou du module du logiciel ayant produit les données XML.
diagram
type credit:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
Extensions
Annotation | Base
Software | credit:stringType1_50
source
<element name="software" type="credit:softwareType"/>

complexType headerPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element headerType/intermediate
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<complexType name="headerPartyType">
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>

complexType headerType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender intermediate recipient
used by
element responseType/header
source
<complexType name="headerType">
  <sequence>
    <element name="sender" type="credit:xtendHeaderPartyType"/>
    <element name="intermediate" type="credit:headerPartyType"/>
    <element name="recipient" type="credit:xtendHeaderPartyType"/>
  </sequence>
</complexType>

element headerType/sender
Annotation Destinataire(numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie l'expéditeur de la réponse à la facture par le biais d'un numéro EAN univoque.
diagram
type credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="sender" type="credit:xtendHeaderPartyType"/>

element headerType/intermediate
Annotation Intermédiaire (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie par le biais d'un numéro EAN univoque l'institution intermédiaire (clearing center) qui est responsable de la gestion administrative et fait office d'intermédiaire.

En cas d'envoi direct d'un document, il faut mentionner ici le numéro EAN du répondant des coûts.
Dans ce cas, le destinataire assume les tâches de l'intermédiaire.
diagram
type credit:headerPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="intermediate" type="credit:headerPartyType"/>

element headerType/recipient
Annotation Destinataire
diagram
type credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="recipient" type="credit:xtendHeaderPartyType"/>

complexType insuranceAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company
used by
element sponsorType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le répondant des coûts par le biais d'un numéro EAN univoque.
source
<complexType name="insuranceAddressType">
  <sequence>
    <element name="company" type="credit:companyType"/>
  </sequence>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>

element insuranceAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>

complexType ivgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'AI pour ce cas relevant de la LAI, le numéro de la décision AI. Le numéro de la décision AI doit être indiqué dans tous les cas, les variantes suivantes étant possibles: - Variante A: le numéro à 14 chiffres, valable depuis le 1.1.2000: format: ivsyyyynnnnnnp (IVS=office AI) exemple: 35020010000026 - Variante B: le numéro à 9 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyy exemple: 350210598 - Variante C: le numéro à 10 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyyn (N=no d'ordre) exemple: 3501004994 -Variante D: le numéro à 6 chiffres, valable pour les mesures d'instruction: format: IVS299 exemple: 350299
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAI. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro AVS doit être transmis dans tous les cas lors d'un décompte LAI. Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex.: "17856210111" et ne doit en aucun cas débuter avec les zéros de gauche.
nif | Numéro d'identification du fournisseur/fournisseur de prestations (NIF) Pour un décompte LAI, le numéro NIF doit être communiqué dans tous les cas.
source
<complexType name="ivgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="case_id" use="required">
    <simpleType>
      <restriction base="string">
        <pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType" use="required"/>
  <attribute name="nif" type="credit:nifPartyType" use="required"/>
</complexType>

element ivgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>

element ivgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>

element ivgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>

element ivgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>

complexType kvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAMal. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales (par ex. le numéro de contrat individuel selon la LAMal). Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<complexType name="kvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>

element kvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>

element kvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>

element kvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>

element kvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>

complexType mvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro de l'assuré Désigne le numéro d'assuré attribué par l'AM (n° AM).
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAM. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<complexType name="mvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>

element mvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>

element mvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>

element mvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>

element mvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>

complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | email url
used by
elements employeeType/online companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="credit:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>

element onlineAddressType/email
Annotation Adresse e-mail Désigne une adresse e-mail selon RFC821.
diagram
type restriction of credit:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="credit:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>

element onlineAddressType/url
Annotation Adresse URL

Désigne une adresse URL complète pouvant être utilisée à des fins d'information ou de prise de contact.
diagram
type restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>

complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person
used by
element creditType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
tax_city | Domicile fiscal
tax_canton | Canton fiscal
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
tax_canton |  | NMTOKEN | AG | Argovie
tax_canton |  | NMTOKEN | AI | Appenzell Rhodes intérieures
tax_canton |  | NMTOKEN | AR | Appenzell Rhodes extérieures
tax_canton |  | NMTOKEN | BE | Berne
tax_canton |  | NMTOKEN | BL | Bâle-Campagne
tax_canton |  | NMTOKEN | BS | Bâle-Ville
tax_canton |  | NMTOKEN | FR | Fribourg
tax_canton |  | NMTOKEN | GE | Genève
tax_canton |  | NMTOKEN | GL | Glaris
tax_canton |  | NMTOKEN | GR | Grisons
tax_canton |  | NMTOKEN | JU | Jura
tax_canton |  | NMTOKEN | LU | Lucerne
tax_canton |  | NMTOKEN | NE | Neuchâtel
tax_canton |  | NMTOKEN | NW | Nidwald
tax_canton |  | NMTOKEN | OW | Obwald
tax_canton |  | NMTOKEN | SG | St-Gall
tax_canton |  | NMTOKEN | SH | Schaffhouse
tax_canton |  | NMTOKEN | SO | Soleure
tax_canton |  | NMTOKEN | SZ | Schwyz
tax_canton |  | NMTOKEN | TI | Tessin
tax_canton |  | NMTOKEN | TG | Thurgovie
tax_canton |  | NMTOKEN | UR | Uri
tax_canton |  | NMTOKEN | VD | Vaud
tax_canton |  | NMTOKEN | VS | Valais
tax_canton |  | NMTOKEN | ZG | Zoug
tax_canton |  | NMTOKEN | ZH | Zurich
tax_canton |  | NMTOKEN | LI | Fürstentum Liechtenstein
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="credit:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
  <attribute name="tax_city" type="credit:stringType1_35"/>
  <attribute name="tax_canton">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="AG"/>
        <enumeration value="AI"/>
        <enumeration value="AR"/>
        <enumeration value="BE"/>
        <enumeration value="BL"/>
        <enumeration value="BS"/>
        <enumeration value="FR"/>
        <enumeration value="GE"/>
        <enumeration value="GL"/>
        <enumeration value="GR"/>
        <enumeration value="JU"/>
        <enumeration value="LU"/>
        <enumeration value="NE"/>
        <enumeration value="NW"/>
        <enumeration value="OW"/>
        <enumeration value="SG"/>
        <enumeration value="SH"/>
        <enumeration value="SO"/>
        <enumeration value="SZ"/>
        <enumeration value="TI"/>
        <enumeration value="TG"/>
        <enumeration value="UR"/>
        <enumeration value="VD"/>
        <enumeration value="VS"/>
        <enumeration value="ZG"/>
        <enumeration value="ZH"/>
        <enumeration value="LI"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>

element patientAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>

complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname postal telecom online
used by
elements employerAddressType/person providerAddressType/person patientAddressType/person contactAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<complexType name="personType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
    <element name="postal" type="credit:postalAddressType"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>

element personType/familyname
Annotation Nom
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>

element personType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>

element personType/postal
Annotation Adresse
diagram
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="credit:postalAddressType"/>

element personType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

element personType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>

complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | pobox street zip city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="credit:stringType1_35" minOccurs="0"/>
    <element name="street" type="credit:stringType1_35" minOccurs="0"/>
    <element name="zip" type="credit:zipType"/>
    <element name="city" type="credit:stringType1_35"/>
  </sequence>
</complexType>

element postalAddressType/pobox
Annotation Case postale
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="credit:stringType1_35" minOccurs="0"/>

element postalAddressType/street
Annotation Rue
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="credit:stringType1_35" minOccurs="0"/>

element postalAddressType/zip
Annotation NPA
diagram
type credit:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | credit:stringType1_9
source
<element name="zip" type="credit:zipType"/>

element postalAddressType/city
Annotation Localité
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="credit:stringType1_35"/>

complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | package generator
used by
element responseType/prolog
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="credit:softwareType" minOccurs="0"/>
    <element name="generator" type="credit:generatorType"/>
  </sequence>
</complexType>

element prologType/package
Annotation Application de la branche

Contient des informations concernant l'application prioritaire de la branche, qui est utilisée pour la facturation. Le nom de l'application de la branche sera indiqué comme contenu des données de cet élément.

Si des indications relatives à l'application de la branche sont livrées, le nom doit être mentionné.
diagram
type credit:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
source
<element name="package" type="credit:softwareType" minOccurs="0"/>

element prologType/generator
Annotation Générateur XML

Contient des informations sur le programme qui a généré et validé la facture XML et met ainsi à disposition les informations nécessaires concernant le logiciel produisant les données XML.
diagram
type | credit:generatorType
properties
isRef | 0
content | complex
children | software
source
<element name="generator" type="credit:generatorType"/>

complexType providerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
element creditType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le fournisseur de prestations par le biais d'un numéro EAN univoque.
zsr | Numéro RCC RCC registre des codes créanciers de santé suisse.
specialty | Spécialité Désigne une autre spécification optionnelle au sens de la profession ou d'une activité similaire.
source
<complexType name="providerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType" use="required"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>

element providerAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>

element providerAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>

complexType responseType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | header prolog xml_error credit
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name | Notes
assignment_role | Rôle thérapeutique du fournisseur de prestations
assignment_place | Lieu de la prestation
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<complexType name="responseType">
  <sequence>
    <element name="header" type="credit:headerType"/>
    <element name="prolog" type="credit:prologType"/>
    <choice>
      <element name="xml_error" type="credit:xmlErrorType"/>
      <element name="credit" type="credit:creditType"/>
    </choice>
  </sequence>
  <attribute name="assignment_role" fixed="physician"/>
  <attribute name="assignment_place" fixed="hospital"/>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>

element responseType/header
Annotation Informations d'en-tête

Définit les informations "routing" qui sont nécessaires ou significatives pour le flux de la facture jusqu'au destinataire final et le retour du destinataire à l'expéditeur initial.
diagram
type | credit:headerType
properties
isRef | 0
content | complex
children | sender intermediate recipient
source
<element name="header" type="credit:headerType"/>

element responseType/prolog
Annotation Prologue

Bloc avec informations sur:

- le paquet logiciel prioritaire (application de la branche)
- le générateur qui a créé et validé les structures XML correspondantes
- les validateurs de données utilisés
diagram
type | credit:prologType
properties
isRef | 0
content | complex
children | package generator
source
<element name="prolog" type="credit:prologType"/>

element responseType/xml_error
Annotation Erreur XML
diagram
type | credit:xmlErrorType
properties
isRef | 0
content | complex
children | error
attributes parameters
Name | Type | Use | Default | Fixed
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong |  |  |
credit_id | credit:stringType1_35 |  |  |
credit_date | dateTime |  |  |
type |  |  |  |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type d'erreur
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<element name="xml_error" type="credit:xmlErrorType"/>

element responseType/credit
Annotation Demande
diagram
type | credit:creditType
properties
isRef | 0
content | complex
children | recipient provider patient sponsor contact employer detail
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
type |  |  | new |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type de demande
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<element name="credit" type="credit:creditType"/>

complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType1_50
properties
base credit:stringType1_50
used by
elements prologType/package generatorType/software
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
Extensions
Annotation | Base
Software | credit:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="credit:stringType1_50">
      <attribute name="version" type="credit:versionType" use="required"/>
      <attribute name="id" default="0">
        <simpleType>
          <restriction base="integer">
            <minInclusive value="0"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </simpleContent>
</complexType>

complexType sponsorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | insurance kvg uvg ivg mvg vvg
used by
element creditType/sponsor
attributes parameters
Name | Type | Use | Default | Fixed
billing |  |  | separate |
attributes annotations
Name | Notes
billing | Facturation
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
billing |  | NMTOKEN | separate | séparé
billing |  | NMTOKEN | combine | combiné
source
<complexType name="sponsorType">
  <sequence>
    <element name="insurance" type="credit:insuranceAddressType"/>
    <choice minOccurs="0">
      <element name="kvg" type="credit:kvgLawType"/>
      <element name="uvg" type="credit:uvgLawType"/>
      <element name="ivg" type="credit:ivgLawType"/>
      <element name="mvg" type="credit:mvgLawType"/>
    </choice>
    <choice minOccurs="0">
      <element name="vvg" type="credit:vvgLawType"/>
    </choice>
  </sequence>
  <attribute name="billing" default="separate">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="separate"/>
        <enumeration value="combine"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>

element sponsorType/insurance
Annotation Répondant des coûts (assurance du patient)

Désigne le bloc adresse de l'assureur responsable.
diagram
type | credit:insuranceAddressType
properties
isRef | 0
content | complex
children | company
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le répondant des coûts par le biais d'un numéro EAN univoque.
source
<element name="insurance" type="credit:insuranceAddressType"/>

element sponsorType/kvg
Annotation Loi sur l'assurance-maladie
diagram
type | credit:kvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAMal. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales (par ex. le numéro de contrat individuel selon la LAMal). Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<element name="kvg" type="credit:kvgLawType"/>

element sponsorType/uvg
Annotation Loi sur l'assurance-accidents
diagram
type | credit:uvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré / de membre / de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance-accidents pour le cas LAA en question, par ex. n° d'accident de la Suva ou n° de cas de la Zurich Suisse. Les numéros de cas devraient toujours être transmis aux assurance-accidents.
case_date | Date de l'événement Désigne généralement la date de l'accident. Pour le motif de traitement "accident", la date d'accident doit être communiquée. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
ssn | Numéro AVS du patient Le n° AVS doit être entré comme pur nombre à 11 chiffres, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<element name="uvg" type="credit:uvgLawType"/>

element sponsorType/ivg
Annotation Loi sur l'assurance-invalidité
diagram
type | credit:ivgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'AI pour ce cas relevant de la LAI, le numéro de la décision AI. Le numéro de la décision AI doit être indiqué dans tous les cas, les variantes suivantes étant possibles: - Variante A: le numéro à 14 chiffres, valable depuis le 1.1.2000: format: ivsyyyynnnnnnp (IVS=office AI) exemple: 35020010000026 - Variante B: le numéro à 9 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyy exemple: 350210598 - Variante C: le numéro à 10 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyyn (N=no d'ordre) exemple: 3501004994 -Variante D: le numéro à 6 chiffres, valable pour les mesures d'instruction: format: IVS299 exemple: 350299
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAI. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro AVS doit être transmis dans tous les cas lors d'un décompte LAI. Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex.: "17856210111" et ne doit en aucun cas débuter avec les zéros de gauche.
nif | Numéro d'identification du fournisseur/fournisseur de prestations (NIF) Pour un décompte LAI, le numéro NIF doit être communiqué dans tous les cas.
source
<element name="ivg" type="credit:ivgLawType"/>

element sponsorType/mvg
Annotation Loi sur l'assurance militaire
diagram
type | credit:mvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro de l'assuré Désigne le numéro d'assuré attribué par l'AM (n° AM).
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAM. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<element name="mvg" type="credit:mvgLawType"/>

element sponsorType/vvg
Annotation Loi sur le contrat d'assurance
diagram
type | credit:vvgLawType
properties
isRef | 0
content | complex
children | estimated_medical_costs estimated_treatment_costs total_estimated_costs accepted_medical_costs accepted_treatment_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification généré par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LArm. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat passé entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<element name="vvg" type="credit:vvgLawType"/>

complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | phone fax
used by
elements employeeType/telecom companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="credit:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>

element telecomAddressType/phone
Annotation Numéro de téléphone

Numéro de téléphone du raccordement fixe ou du téléphone mobile
diagram
type credit:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="credit:stringType1_25" maxOccurs="3"/>

element telecomAddressType/fax
Annotation Numéro de fax
diagram
type credit:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>

complexType uvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré / de membre / de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance-accidents pour le cas LAA en question, par ex. n° d'accident de la Suva ou n° de cas de la Zurich Suisse. Les numéros de cas devraient toujours être transmis aux assurance-accidents.
case_date | Date de l'événement Désigne généralement la date de l'accident. Pour le motif de traitement "accident", la date d'accident doit être communiquée. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
ssn | Numéro AVS du patient Le n° AVS doit être entré comme pur nombre à 11 chiffres, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<complexType name="uvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>

element uvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>

element uvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>

element uvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>

element uvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>

complexType vvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_medical_costs estimated_treatment_costs total_estimated_costs accepted_medical_costs accepted_treatment_costs total_accepted_costs
used by
element sponsorType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification généré par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LArm. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat passé entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<complexType name="vvgLawType">
  <sequence>
    <sequence>
      <element name="estimated_medical_costs" type="credit:xndCostsType"/>
      <element name="estimated_treatment_costs" type="credit:xndCostsType"/>
      <element name="total_estimated_costs" type="credit:costsType"/>
      <element name="accepted_medical_costs" type="credit:acceptedCostsType"/>
      <element name="accepted_treatment_costs" type="credit:acceptedCostsType"/>
      <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
    </sequence>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>

element vvgLawType/estimated_medical_costs
Annotation Demande de coûts pour médicaments
diagram
type credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
source
<element name="estimated_medical_costs" type="credit:xndCostsType"/>

element vvgLawType/estimated_treatment_costs
Annotation Demande de coûts pour thérapie
diagram
type credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
source
<element name="estimated_treatment_costs" type="credit:xndCostsType"/>

element vvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>

element vvgLawType/accepted_medical_costs
Annotation Garantie maximale de médicament
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_medical_costs" type="credit:acceptedCostsType"/>

element vvgLawType/accepted_treatment_costs
Annotation Garantie maximale de thérapie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_treatment_costs" type="credit:acceptedCostsType"/>

element vvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>

complexType xmlErrorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | error
used by
element responseType/xml_error
attributes parameters
Name | Type | Use | Default | Fixed
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong |  |  |
credit_id | credit:stringType1_35 |  |  |
credit_date | dateTime |  |  |
type |  |  |  |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type d'erreur
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<complexType name="xmlErrorType">
  <sequence>
    <element name="error" type="credit:errorSchemaType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong"/>
  <attribute name="credit_id" type="credit:stringType1_35"/>
  <attribute name="credit_date" type="dateTime"/>
  <attribute name="type">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_timestamp" type="unsignedLong" use="required"/>
  <attribute name="response_id" type="credit:stringType1_35" use="required"/>
</complexType>

element xmlErrorType/error
Annotation Erreurs
diagram
type credit:errorSchemaType
properties
isRef | 0
content | complex
facets
minLength 1
attributes parameters
Name | Type | Use | Default | Fixed
line_number | positiveInteger |  |  |
line_pos | positiveInteger |  |  |
err_code | integer |  |  |
err_text | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
line_number | Numéro de ligne
line_pos | Position de ligne
err_code | Code d'erreur
err_text | Texte d'erreur
source
<element name="error" type="credit:errorSchemaType" maxOccurs="unbounded"/>

complexType xndCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements vvgLawType/estimated_medical_costs vvgLawType/estimated_treatment_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
Extensions
Annotation | Base
Pourcentage | credit:costsType
source
<complexType name="xndCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="class">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="private"/>
            <enumeration value="semi_private"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </complexContent>
</complexType>

complexType xtendHeaderPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements headerType/recipient headerType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<complexType name="xtendHeaderPartyType">
  <attribute name="ean_party" type="credit:xtendEanPartyType" use="required"/>
</complexType>

complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType1_9
properties
base credit:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | credit:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="credit:stringType1_9">
      <attribute name="statecode" type="credit:stringType1_9"/>
      <attribute name="countrycode" type="credit:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>

simpleType amountType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of double
used by
attributes costsType/@amount acceptedCostsType/@percent
facets
minInclusive 0
source
<simpleType name="amountType">
  <restriction base="double">
    <minInclusive value="0"/>
  </restriction>
</simpleType>

simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes employerAddressType/@ean_party providerAddressType/@ean_party insuranceAddressType/@ean_party headerPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11})"/>
  </restriction>
</simpleType>

simpleType nifPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source
<simpleType name="nifPartyType">
  <restriction base="string">
    <pattern value="[0-9]{1,7}"/>
  </restriction>
</simpleType>

simpleType nonEmptyTextType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType errorSchemaType
facets
minLength 1
source
<simpleType name="nonEmptyTextType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>

simpleType ssn13PartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
pattern [1-9][0-9]{12}
source
<simpleType name="ssn13PartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{12}"/>
  </restriction>
</simpleType>

simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes patientAddressType/@ssn uvgLawType/@ssn ivgLawType/@ssn mvgLawType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}"/>
  </restriction>
</simpleType>

simpleType stringType0_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
maxLength 350
source
<simpleType name="stringType0_350">
  <restriction base="string">
    <maxLength value="350"/>
  </restriction>
</simpleType>

simpleType stringType1_12
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
minLength | 1
maxLength | 12
source
<simpleType name="stringType1_12">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="12"/>
  </restriction>
</simpleType>

simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>

simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>

simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department employeeType/familyname personType/familyname employeeType/givenname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | xmlErrorType/@case_id creditType/@case_id uvgLawType/@case_id vvgLawType/@case_id kvgLawType/@case_id uvgLawType/@contract_number vvgLawType/@contract_number kvgLawType/@contract_number xmlErrorType/@credit_id creditType/@credit_id kvgLawType/@patient_id vvgLawType/@patient_id uvgLawType/@patient_id creditType/@patient_id mvgLawType/@patient_id employerAddressType/@reg_number acceptedCostsType/@remark xmlErrorType/@response_id creditType/@response_id personType/@salutation employeeType/@salutation patientAddressType/@tax_city personType/@title employeeType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>

simpleType stringType1_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes errorSchemaType/@err_text providerAddressType/@specialty
facets
minLength | 1
maxLength | 350
source
<simpleType name="stringType1_350">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="350"/>
  </restriction>
</simpleType>

simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | softwareType
attribute | detailType/@response_text
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>

simpleType stringType1_6
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute detailType/@response_code
facets
minLength | 1
maxLength | 6
source
<simpleType name="stringType1_6">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="6"/>
  </restriction>
</simpleType>

simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>

simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>

simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>

simpleType unionPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | union of ( credit:xtendEanPartyType , credit:zsrPartyType )
source
<simpleType name="unionPartyType">
  <union memberTypes="credit:xtendEanPartyType credit:zsrPartyType"/>
</simpleType>

simpleType versionType
namespace | http://www.forum-datenaustausch.ch/de
type | integer
used by
attribute softwareType/@version
source
<simpleType name="versionType">
  <restriction base="integer"/>
</simpleType>

simpleType xtendEanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attribute | xtendHeaderPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11}|unknown)
source
<simpleType name="xtendEanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>
  </restriction>
</simpleType>

simpleType zsrPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attribute | providerAddressType/@zsr
facets
pattern ([A-Z][0-9]{6}|[0-9]{6}[A-Z])
source
<simpleType name="zsrPartyType">
  <restriction base="string">
    <pattern value="([A-Z][0-9]{6}|[0-9]{6}[A-Z])"/>
  </restriction>
</simpleType>


Schema

1 <?xml version="1.0" encoding="UTF-8"?>

2 <!-- ==========================================================================

3

4 This is the schema definition for a "Hospital Credit Response" process encoded

5 in XML. The HospitalCreditResponse is generated as a final response related to

6 an initally sent HospitalCreditRequest process. The final response ultimately

7 ends the document cycle for that particular credit process.

8

9 This is normative for the electronic invoice/cancel project XMLInvoice.

10

11 Permission to use, and distribute this schema and its accompanying

12 documentation for any purpose and without fee is hereby granted in perpetuity,

13 provided that the above copyright notice and this paragraph appear in all copies

14 and this schema file is not altered.

15 The copyright holders make no representation about the suitability of the schema

16 for any purpose.

17

18 It is provided "as is" without expressed or implied warranty.

19

20 Copyright (c) 2005 Forum Datenaustausch,

21 All Rights Reserved.

22 ========================================================================== -->

23 <schema xmlns="http://www.w3.org/2001/XMLSchema" xmlns:credit="http://www.forum-datenaustausch.ch/de" targetNamespace="

http://www.forum-datenaustausch.ch/de" elementFormDefault="qualified" attributeFormDefault="unqualified">

24 <!-- =======================================================================

25 General data type definitions

26 ======================================================================= -->

27 <!-- generic element for non-empty text -->

28 <simpleType name="nonEmptyTextType">

29 <restriction base="string">

30 <minLength value="1"/>

31 </restriction>

32 </simpleType>

33 <!-- string type with length 1-3 characters -->

34 <simpleType name="stringType1_3">

35 <restriction base="string">

36 <minLength value="1"/>

37 <maxLength value="3"/>

38 </restriction>

39 </simpleType>

40 <!-- string type with length 1-6 characters -->

41 <simpleType name="stringType1_6">

42 <restriction base="string">

43 <minLength value="1"/>

44 <maxLength value="6"/>

45 </restriction>

46 </simpleType>

47 <!-- string type with length 1-9 characters -->

48 <simpleType name="stringType1_9">

49 <restriction base="string">

50 <minLength value="1"/>

51 <maxLength value="9"/>

52 </restriction>

53 </simpleType>

54 <!-- string type with length 1-12 characters -->

55 <simpleType name="stringType1_12">

56 <restriction base="string">

57 <minLength value="1"/>

58 <maxLength value="12"/>

59 </restriction>

60 </simpleType>

61 <!-- string type with length 1-25 characters -->

62 <simpleType name="stringType1_25">

63 <restriction base="string">

64 <minLength value="1"/>

65 <maxLength value="25"/>

66 </restriction>

67 </simpleType>

68 <!-- string type with length 1-35 characters -->

69 <simpleType name="stringType1_35">

70 <restriction base="string">

71 <minLength value="1"/>

72 <maxLength value="35"/>

73 </restriction>

74 </simpleType>

75 <!-- string type with length 1-50 characters -->

76 <simpleType name="stringType1_50">

77 <restriction base="string">

78 <minLength value="1"/>

79 <maxLength value="50"/>

80 </restriction>

81 </simpleType>

82 <!-- string type with length 1-70 characters -->

83 <simpleType name="stringType1_70">

84 <restriction base="string">

85 <minLength value="1"/>

86 <maxLength value="70"/>

87 </restriction>

88 </simpleType>

89 <!-- string type with length 1-350 characters -->

90 <simpleType name="stringType1_350">

91 <restriction base="string">

92 <minLength value="1"/>

93 <maxLength value="350"/>

94 </restriction>

95 </simpleType>

96 <!-- string type with length 0-350 characters -->

97 <simpleType name="stringType0_350">

98 <restriction base="string">

99 <maxLength value="350"/>

100 </restriction>

101 </simpleType>

102 <!-- string type with length 1-700 characters -->

103 <simpleType name="stringType1_700">

104 <restriction base="string">

105 <minLength value="1"/>

106 <maxLength value="700"/>

107 </restriction>

108 </simpleType>

109 <!-- EAN-, ZSR-, NIF-Nr. -->

110 <simpleType name="eanPartyType">

111 <restriction base="string">

112 <pattern value="(20[0-9]{11}|76[0-9]{11})"/>

113 </restriction>

114 </simpleType>

115 <simpleType name="xtendEanPartyType">

116 <restriction base="string">

117 <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>

118 </restriction>

119 </simpleType>

120 <simpleType name="zsrPartyType">

121 <restriction base="string">

122 <pattern value="([A-Z][0-9]{6}|[0-9]{6}[A-Z])"/>

123 </restriction>

124 </simpleType>

125 <simpleType name="unionPartyType">

126 <union memberTypes="credit:xtendEanPartyType credit:zsrPartyType"/>

127 </simpleType>

128 <simpleType name="nifPartyType">

129 <restriction base="string">

130 <pattern value="[0-9]{1,7}"/>

131 </restriction>

132 </simpleType>

133 <!-- SSN-Nr. -->

134 <simpleType name="ssnPartyType">

135 <restriction base="string">

136 <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}"/>

137 </restriction>

138 </simpleType>

139 <simpleType name="ssn13PartyType">

140 <restriction base="string">

141 <pattern value="[1-9][0-9]{12}"/>

142 </restriction>

143 </simpleType>

144 <!-- employee of a company -->

145 <complexType name="employeeType">

146 <sequence>

147 <element name="familyname" type="credit:stringType1_35"/>

148 <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>

149 <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

150 <element name="online" type="credit:onlineAddressType" minOccurs="0"/>

151 </sequence>

152 <attribute name="salutation" type="credit:stringType1_35"/>

153 <attribute name="title" type="credit:stringType1_35"/>

154 </complexType>

155 <!-- amount -->

156 <simpleType name="amountType">

157 <restriction base="double">

158 <minInclusive value="0"/>

159 </restriction>

160 </simpleType>

161 <!-- cost definitions -->

162 <complexType name="costsType">

163 <attribute name="amount" type="credit:amountType"/>

164 <attribute name="currency" type="string" fixed="CHF"/>

165 </complexType>

166 <complexType name="xndCostsType">

167 <complexContent>

168 <extension base="credit:costsType">

169 <attribute name="class">

170 <simpleType>

171 <restriction base="NMTOKEN">

172 <enumeration value="private"/>

173 <enumeration value="semi_private"/>

174 </restriction>

175 </simpleType>

176 </attribute>

177 </extension>

178 </complexContent>

179 </complexType>

180 <complexType name="acceptedCostsType">

181 <complexContent>

182 <extension base="credit:costsType">

183 <attribute name="percent" type="credit:amountType"/>

184 <attribute name="remark" type="credit:stringType1_35"/>

185 </extension>

186 </complexContent>

187 </complexType>

188 <!-- =======================================================================

189 address data type definitions for companies and persons

190 ======================================================================= -->

191 <!-- Company -->

192 <complexType name="companyType">

193 <sequence>

194 <element name="companyname" type="credit:stringType1_35"/>

195 <element name="department" type="credit:stringType1_35" minOccurs="0" maxOccurs="3"/>

196 <element name="postal" type="credit:postalAddressType"/>

197 <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

198 <element name="online" type="credit:onlineAddressType" minOccurs="0"/>

199 </sequence>

200 </complexType>

201 <!-- Person -->

202 <complexType name="personType">

203 <sequence>

204 <element name="familyname" type="credit:stringType1_35"/>

205 <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>

206 <element name="postal" type="credit:postalAddressType"/>

207 <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>

208 <element name="online" type="credit:onlineAddressType" minOccurs="0"/>

209 </sequence>

210 <attribute name="salutation" type="credit:stringType1_35"/>

211 <attribute name="title" type="credit:stringType1_35"/>

212 </complexType>

213 <complexType name="postalAddressType">

214 <sequence>

215 <element name="pobox" type="credit:stringType1_35" minOccurs="0"/>

216 <element name="street" type="credit:stringType1_35" minOccurs="0"/>

217 <element name="zip" type="credit:zipType"/>

218 <element name="city" type="credit:stringType1_35"/>

219 </sequence>

220 </complexType>

221 <complexType name="zipType">

222 <simpleContent>

223 <extension base="credit:stringType1_9">

224 <attribute name="statecode" type="credit:stringType1_9"/>

225 <attribute name="countrycode" type="credit:stringType1_3" default="CH"/>

226 </extension>

227 </simpleContent>

228 </complexType>

229 <complexType name="telecomAddressType">

230 <sequence>

231 <element name="phone" type="credit:stringType1_25" maxOccurs="3"/>

232 <element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>

233 </sequence>

234 </complexType>

235 <complexType name="onlineAddressType">

236 <sequence>

237 <element name="email" maxOccurs="3">

238 <simpleType>

239 <restriction base="credit:stringType1_70">

240 <pattern value=".+@.+"/>

241 </restriction>

242 </simpleType>

243 </element>

244 <element name="url" minOccurs="0" maxOccurs="3">

245 <simpleType>

246 <restriction base="anyURI">

247 <minLength value="1"/>

248 <maxLength value="100"/>

249 </restriction>

250 </simpleType>

251 </element>

252 </sequence>

253 </complexType>

254 <!-- =======================================================================

255 the specific address type data definitions

256 ======================================================================= -->

257 <!-- address = "Employer" -->

258 <complexType name="employerAddressType">

259 <choice>

260 <element name="company" type="credit:companyType"/>

261 <element name="person" type="credit:personType"/>

262 </choice>

263 <attribute name="ean_party" type="credit:eanPartyType"/>

264 <attribute name="reg_number" type="credit:stringType1_35"/>

265 </complexType>

266 <!-- address = "Provider" -->

267 <complexType name="providerAddressType">

268 <choice>

269 <element name="company" type="credit:companyType"/>

270 <element name="person" type="credit:personType"/>

271 </choice>

272 <attribute name="ean_party" type="credit:eanPartyType" use="required"/>

273 <attribute name="zsr" type="credit:zsrPartyType" use="required"/>

274 <attribute name="specialty" type="credit:stringType1_350"/>

275 </complexType>

276 <!-- address = "Insurance" -->

277 <complexType name="insuranceAddressType">

278 <sequence>

279 <element name="company" type="credit:companyType"/>

280 </sequence>

281 <attribute name="ean_party" type="credit:eanPartyType" use="required"/>

282 </complexType>

283 <!-- address = "Patient" -->

284 <complexType name="patientAddressType">

285 <sequence>

286 <element name="person" type="credit:personType"/>

287 </sequence>

288 <attribute name="gender" use="required">

289 <simpleType>

290 <restriction base="NMTOKEN">

291 <enumeration value="male"/>

292 <enumeration value="female"/>

293 </restriction>

294 </simpleType>

295 </attribute>

296 <attribute name="birthdate" type="dateTime" use="required"/>

297 <attribute name="ssn" type="credit:ssnPartyType"/>

298 <attribute name="tax_city" type="credit:stringType1_35"/>

299 <attribute name="tax_canton">

300 <simpleType>

301 <restriction base="NMTOKEN">

302 <enumeration value="AG"/>

303 <enumeration value="AI"/>

304 <enumeration value="AR"/>

305 <enumeration value="BE"/>

306 <enumeration value="BL"/>

307 <enumeration value="BS"/>

308 <enumeration value="FR"/>

309 <enumeration value="GE"/>

310 <enumeration value="GL"/>

311 <enumeration value="GR"/>

312 <enumeration value="JU"/>

313 <enumeration value="LU"/>

314 <enumeration value="NE"/>

315 <enumeration value="NW"/>

316 <enumeration value="OW"/>

317 <enumeration value="SG"/>

318 <enumeration value="SH"/>

319 <enumeration value="SO"/>

320 <enumeration value="SZ"/>

321 <enumeration value="TI"/>

322 <enumeration value="TG"/>

323 <enumeration value="UR"/>

324 <enumeration value="VD"/>

325 <enumeration value="VS"/>

326 <enumeration value="ZG"/>

327 <enumeration value="ZH"/>

328 <enumeration value="LI"/>

329 </restriction>

330 </simpleType>

331 </attribute>

332 </complexType>

333 <!-- address = "Contact" -->

334 <complexType name="contactAddressType">

335 <choice>

336 <element name="person" type="credit:personType"/>

337 <sequence>

338 <element name="employee" type="credit:employeeType"/>

339 <element name="company" type="credit:companyType"/>

340 </sequence>

341 </choice>

342 </complexType>

343 <!-- =======================================================================

344 data type definitions regarding the applied law per insurance

345 ======================================================================= -->

346 <!-- law = KVG -->

347 <complexType name="kvgLawType">

348 <sequence>

349 <element name="estimated_costs" type="credit:costsType"/>

350 <element name="total_estimated_costs" type="credit:costsType"/>

351 <element name="accepted_costs" type="credit:acceptedCostsType"/>

352 <element name="total_accepted_costs" type="credit:acceptedCostsType"/>

353 </sequence>

354 <attribute name="patient_id" type="credit:stringType1_35"/>

355 <attribute name="case_id" type="credit:stringType1_35"/>

356 <attribute name="case_date" type="dateTime"/>

357 <attribute name="contract_number" type="credit:stringType1_35"/>

358 </complexType>

359 <!-- law = VVG -->

360 <complexType name="vvgLawType">

361 <sequence>

362 <sequence>

363 <element name="estimated_medical_costs" type="credit:xndCostsType"/>

364 <element name="estimated_treatment_costs" type="credit:xndCostsType"/>

365 <element name="total_estimated_costs" type="credit:costsType"/>

366 <element name="accepted_medical_costs" type="credit:acceptedCostsType"/>

367 <element name="accepted_treatment_costs" type="credit:acceptedCostsType"/>

368 <element name="total_accepted_costs" type="credit:acceptedCostsType"/>

369 </sequence>

370 </sequence>

371 <attribute name="patient_id" type="credit:stringType1_35"/>

372 <attribute name="case_id" type="credit:stringType1_35"/>

373 <attribute name="case_date" type="dateTime"/>

374 <attribute name="contract_number" type="credit:stringType1_35"/>

375 </complexType>

376 <!-- law = UVG -->

377 <complexType name="uvgLawType">

378 <sequence>

379 <element name="estimated_costs" type="credit:costsType"/>

380 <element name="total_estimated_costs" type="credit:costsType"/>

381 <element name="accepted_costs" type="credit:acceptedCostsType"/>

382 <element name="total_accepted_costs" type="credit:acceptedCostsType"/>

383 </sequence>

384 <attribute name="patient_id" type="credit:stringType1_35"/>

385 <attribute name="case_id" type="credit:stringType1_35"/>

386 <attribute name="case_date" type="dateTime"/>

387 <attribute name="contract_number" type="credit:stringType1_35"/>

388 <attribute name="ssn" type="credit:ssnPartyType"/>

389 </complexType>

390 <!-- law = IVG -->

391 <complexType name="ivgLawType">

392 <sequence>

393 <element name="estimated_costs" type="credit:costsType"/>

394 <element name="total_estimated_costs" type="credit:costsType"/>

395 <element name="accepted_costs" type="credit:acceptedCostsType"/>

396 <element name="total_accepted_costs" type="credit:acceptedCostsType"/>

397 </sequence>

398 <attribute name="case_id" use="required">

399 <simpleType>

400 <restriction base="string">

401 <pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>

402 </restriction>

403 </simpleType>

404 </attribute>

405 <attribute name="case_date" type="dateTime"/>

406 <attribute name="ssn" type="credit:ssnPartyType" use="required"/>

407 <attribute name="nif" type="credit:nifPartyType" use="required"/>

408 </complexType>

409 <!-- law = MVG -->

410 <complexType name="mvgLawType">

411 <sequence>

412 <element name="estimated_costs" type="credit:costsType"/>

413 <element name="total_estimated_costs" type="credit:costsType"/>

414 <element name="accepted_costs" type="credit:acceptedCostsType"/>

415 <element name="total_accepted_costs" type="credit:acceptedCostsType"/>

416 </sequence>

417 <attribute name="patient_id" type="credit:stringType1_35"/>

418 <attribute name="case_date" type="dateTime"/>

419 <attribute name="ssn" type="credit:ssnPartyType"/>

420 </complexType>

421 <!-- =======================================================================

422 detailed cancel data type definitions

423 ======================================================================= -->

424 <complexType name="detailType">

425 <sequence>

426 <element name="explanation" type="string" minOccurs="0"/>

427 <element name="supplement" type="string" minOccurs="0"/>

428 <element name="remark" type="string" minOccurs="0"/>

429 </sequence>

430 <attribute name="date_begin" type="dateTime"/>

431 <attribute name="date_end" type="dateTime"/>

432 <attribute name="days" type="duration"/>

433 <attribute name="treatment_type" use="required">

434 <simpleType>

435 <restriction base="NMTOKEN">

436 <enumeration value="ambulatory"/>

437 <enumeration value="semi_stationary"/>

438 <enumeration value="stationary"/>

439 </restriction>

440 </simpleType>

441 </attribute>

442 <attribute name="reason" use="required">

443 <simpleType>

444 <restriction base="NMTOKEN">

445 <enumeration value="disease"/>

446 <enumeration value="accident"/>

447 <enumeration value="maternity"/>

448 <enumeration value="prevention"/>

449 <enumeration value="birthdefect"/>

450 </restriction>

451 </simpleType>

452 </attribute>

453 <attribute name="response_type" use="required">

454 <simpleType>

455 <restriction base="NMTOKEN">

456 <enumeration value="accepted"/>

457 <enumeration value="rejected"/>

458 <enumeration value="limited_coverage"/>

459 <enumeration value="preliminary"/>

460 </restriction>

461 </simpleType>

462 </attribute>

463 <attribute name="response_code" type="credit:stringType1_6" use="required"/>

464 <attribute name="response_text" type="credit:stringType1_50" use="required"/>

465 </complexType>

466 <!-- =======================================================================

467 Header data type definitions

468 ======================================================================= -->

469 <complexType name="headerPartyType">

470 <attribute name="ean_party" type="credit:eanPartyType" use="required"/>

471 </complexType>

472 <complexType name="xtendHeaderPartyType">

473 <attribute name="ean_party" type="credit:xtendEanPartyType" use="required"/>

474 </complexType>

475 <complexType name="headerType">

476 <sequence>

477 <element name="sender" type="credit:xtendHeaderPartyType"/>

478 <element name="intermediate" type="credit:headerPartyType"/>

479 <element name="recipient" type="credit:xtendHeaderPartyType"/>

480 </sequence>

481 </complexType>

482 <!-- =======================================================================

483 misc administrative data type definitions

484 ======================================================================= -->

485 <simpleType name="versionType">

486 <restriction base="integer"/>

487 </simpleType>

488 <complexType name="softwareType">

489 <simpleContent>

490 <extension base="credit:stringType1_50">

491 <attribute name="version" type="credit:versionType" use="required"/>

492 <attribute name="id" default="0">

493 <simpleType>

494 <restriction base="integer">

495 <minInclusive value="0"/>

496 </restriction>

497 </simpleType>

498 </attribute>

499 </extension>

500 </simpleContent>

501 </complexType>

502 <complexType name="generatorType">

503 <sequence>

504 <element name="software" type="credit:softwareType"/>

505 </sequence>

506 </complexType>

507 <!-- prolog section -->

508 <complexType name="prologType">

509 <sequence>

510 <element name="package" type="credit:softwareType" minOccurs="0"/>

511 <element name="generator" type="credit:generatorType"/>

512 </sequence>

513 </complexType>

514 <!-- =======================================================================

515 data type definitions regarding xml errors (not well formed | not valid)

516 ======================================================================= -->

517 <complexType name="xmlErrorType">

518 <sequence>

519 <element name="error" type="credit:errorSchemaType" maxOccurs="unbounded"/>

520 </sequence>

521 <attribute name="case_id" type="credit:stringType1_35"/>

522 <attribute name="credit_timestamp" type="unsignedLong"/>

523 <attribute name="credit_id" type="credit:stringType1_35"/>

524 <attribute name="credit_date" type="dateTime"/>

525 <attribute name="type">

526 <simpleType>

527 <restriction base="NMTOKEN">

528 <enumeration value="new"/>

529 <enumeration value="re-consideration"/>

530 <enumeration value="prolongation"/>

531 </restriction>

532 </simpleType>

533 </attribute>

534 <attribute name="response_timestamp" type="unsignedLong" use="required"/>

535 <attribute name="response_id" type="credit:stringType1_35" use="required"/>

536 </complexType>

537 <complexType name="errorSchemaType">

538 <simpleContent>

539 <extension base="credit:nonEmptyTextType">

540 <attribute name="line_number" type="positiveInteger"/>

541 <attribute name="line_pos" type="positiveInteger"/>

542 <attribute name="err_code" type="integer"/>

543 <attribute name="err_text" type="credit:stringType1_350"/>

544 </extension>

545 </simpleContent>

546 </complexType>

547 <!-- =======================================================================

548 data type definitions for a sponsor (aka Kostentraeger) and related data

549 ======================================================================= -->

550 <complexType name="sponsorType">

551 <sequence>

552 <element name="insurance" type="credit:insuranceAddressType"/>

553 <choice minOccurs="0">

554 <element name="kvg" type="credit:kvgLawType"/>

555 <element name="uvg" type="credit:uvgLawType"/>

556 <element name="ivg" type="credit:ivgLawType"/>

557 <element name="mvg" type="credit:mvgLawType"/>

558 </choice>

559 <choice minOccurs="0">

560 <element name="vvg" type="credit:vvgLawType"/>

561 </choice>

562 </sequence>

563 <attribute name="billing" default="separate">

564 <simpleType>

565 <restriction base="NMTOKEN">

566 <enumeration value="separate"/>

567 <enumeration value="combine"/>

568 </restriction>

569 </simpleType>

570 </attribute>

571 </complexType>

572 <!-- =======================================================================

573 credit data type definitions

574 ======================================================================= -->

575 <complexType name="creditType">

576 <sequence>

577 <element name="recipient" type="credit:contactAddressType"/>

578 <element name="provider" type="credit:providerAddressType"/>

579 <element name="patient" type="credit:patientAddressType"/>

580 <element name="sponsor" type="credit:sponsorType"/>

581 <element name="contact" type="credit:contactAddressType"/>

582 <element name="employer" type="credit:employerAddressType" minOccurs="0"/>

583 <element name="detail" type="credit:detailType"/>

584 </sequence>

585 <attribute name="patient_id" type="credit:stringType1_35"/>

586 <attribute name="case_id" type="credit:stringType1_35"/>

587 <attribute name="credit_timestamp" type="unsignedLong" use="required"/>

588 <attribute name="credit_id" type="credit:stringType1_35" use="required"/>

589 <attribute name="credit_date" type="dateTime" use="required"/>

590 <attribute name="type" default="new">

591 <simpleType>

592 <restriction base="NMTOKEN">

593 <enumeration value="new"/>

594 <enumeration value="re-consideration"/>

595 <enumeration value="prolongation"/>

596 </restriction>

597 </simpleType>

598 </attribute>

599 <attribute name="response_timestamp" type="unsignedLong" use="required"/>

600 <attribute name="response_id" type="credit:stringType1_35" use="required"/>

601 </complexType>

602 <!-- =======================================================================

603 =======================================================================

604 Here starts the request with its root element

605 =======================================================================

606 ======================================================================= -->

607 <element name="response" type="credit:responseType"/>

608 <complexType name="responseType">

609 <sequence>

610 <element name="header" type="credit:headerType"/>

611 <element name="prolog" type="credit:prologType"/>

612 <choice>

613 <element name="xml_error" type="credit:xmlErrorType"/>

614 <element name="credit" type="credit:creditType"/>

615 </choice>

616 </sequence>

617 <attribute name="assignment_role" fixed="physician"/>

618 <attribute name="assignment_place" fixed="hospital"/>

619 <attribute name="role" default="production">

620 <simpleType>

621 <restriction base="NMTOKEN">

622 <enumeration value="production"/>

623 <enumeration value="test"/>

624 </restriction>

625 </simpleType>

626 </attribute>

627 </complexType>

628 </schema>


Éléments de la réponse de prise en charge hospitalière alphabétique

hospitalCreditResponse_410 fra
Éléments de la réponse de prise en charge hospitalière alphabétique


 element response
Annotation Début du document XML

Déclaration XML, y compris jeu de caractères UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (première ligne dans le document XML)

Elément racine: credit:response

- XML Espace nominal xsi: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- Espace nominal credit: xmlns:credit="http://www.forum-datenaustausch.ch/de"
- Type: Réponse de prise en charge hospitalière 4.1
- Lieu: xsi :schemaLocation="http://www.forum-datenaustausch.ch/de hospitalCreditResponse_410.xsd"

L'espace nominal pour tous les éléments est "credit".
Dans le document XML, cet espace nominal doit être indiqué pour chaque élément!

Parla suite, la présente documentation ne fera état plus que du nom de l'élément, sans espace nominal, p. ex: "response" au lieu de "credit:response".

Pour les attributs, il n'est pas nécessaire d'indiquer un espace nominal dans le document XML.

Voir définition dans le schéma:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:responseType
properties
content complex
children | header prolog xml_error credit
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name | Notes
assignment_role | Rôle thérapeutique du fournisseur de prestations
assignment_place | Lieu de la prestation
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<element name="response" type="credit:responseType"/>


 complexType acceptedCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements kvgLawType/accepted_costs uvgLawType/accepted_costs ivgLawType/accepted_costs mvgLawType/accepted_costs vvgLawType/accepted_medical_costs vvgLawType/accepted_treatment_costs kvgLawType/total_accepted_costs vvgLawType/total_accepted_costs uvgLawType/total_accepted_costs ivgLawType/total_accepted_costs mvgLawType/total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
Extensions
Annotation | Base
Type de coûts | credit:costsType
source
<complexType name="acceptedCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="percent" type="credit:amountType"/>
      <attribute name="remark" type="credit:stringType1_35"/>
    </extension>
  </complexContent>
</complexType>


 complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | companyname department postal telecom online
used by
elements employerAddressType/company providerAddressType/company insuranceAddressType/company contactAddressType/company
source
<complexType name="companyType">
  <sequence>
    <element name="companyname" type="credit:stringType1_35"/>
    <element name="department" type="credit:stringType1_35" minOccurs="0" maxOccurs="3"/>
    <element name="postal" type="credit:postalAddressType"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
</complexType>


 element companyType/companyname
Annotation Désignation de l'entreprise
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="credit:stringType1_35"/>


 element companyType/department
Annotation Service / Division
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="credit:stringType1_35" minOccurs="0" maxOccurs="3"/>


 element companyType/postal
Annotation Adresse
diagram
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="credit:postalAddressType"/>


 element companyType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element companyType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 complexType contactAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person employee company
used by
elements creditType/contact creditType/recipient
source
<complexType name="contactAddressType">
  <choice>
    <element name="person" type="credit:personType"/>
    <sequence>
      <element name="employee" type="credit:employeeType"/>
      <element name="company" type="credit:companyType"/>
    </sequence>
  </choice>
</complexType>


 element contactAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>


 element contactAddressType/employee
Annotation Personne de contact
diagram
type | credit:employeeType
properties
isRef | 0
content | complex
children | familyname givenname telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel de l'interlocuteur
title | Titre de l'interlocuteur
source
<element name="employee" type="credit:employeeType"/>


 element contactAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>


 complexType costsType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements | kvgLawType/estimated_costs uvgLawType/estimated_costs ivgLawType/estimated_costs mvgLawType/estimated_costs kvgLawType/total_estimated_costs vvgLawType/total_estimated_costs uvgLawType/total_estimated_costs ivgLawType/total_estimated_costs mvgLawType/total_estimated_costs
complexTypes | acceptedCostsType xndCostsType
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<complexType name="costsType">
  <attribute name="amount" type="credit:amountType"/>
  <attribute name="currency" type="string" fixed="CHF"/>
</complexType>


 complexType creditType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | recipient provider patient sponsor contact employer detail
used by
element responseType/credit
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
type |  |  | new |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type de demande
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<complexType name="creditType">
  <sequence>
    <element name="recipient" type="credit:contactAddressType"/>
    <element name="provider" type="credit:providerAddressType"/>
    <element name="patient" type="credit:patientAddressType"/>
    <element name="sponsor" type="credit:sponsorType"/>
    <element name="contact" type="credit:contactAddressType"/>
    <element name="employer" type="credit:employerAddressType" minOccurs="0"/>
    <element name="detail" type="credit:detailType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong" use="required"/>
  <attribute name="credit_id" type="credit:stringType1_35" use="required"/>
  <attribute name="credit_date" type="dateTime" use="required"/>
  <attribute name="type" default="new">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_timestamp" type="unsignedLong" use="required"/>
  <attribute name="response_id" type="credit:stringType1_35" use="required"/>
</complexType>


 element creditType/recipient
Annotation Destinataire
diagram
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | person employee company
source
<element name="recipient" type="credit:contactAddressType"/>


 element creditType/provider
Annotation Fournisseur de prestations

Désigne le bloc adresse du fournisseur de prestations (médecin).

Le numéro EAN est valable en priorité pour l'identification du fournisseur de prestations. Pour satisfaire aux exigences de santé suisse en matière de facture, le numéro RCC correspondant doit également être mentionné.

Si la teneur informative du numéro EAN est contraire à celle du numéro RCC, ce sont les indications inhérentes au numéro EAN qui sont valables.

Si le fournisseur de prestations ("provider") et le factureur ("biller") sont identiques, il faut qu'exactement les mêmes données soient mentionnées pour les deux partenaires, c.-à-d. le bloc "provider" est une copie 1:1 du bloc "biller".
diagram
type | credit:providerAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le fournisseur de prestations par le biais d'un numéro EAN univoque.
zsr | Numéro RCC RCC registre des codes créanciers de santé suisse.
specialty | Spécialité Désigne une autre spécification optionnelle au sens de la profession ou d'une activité similaire.
source
<element name="provider" type="credit:providerAddressType"/>


 element creditType/patient
Annotation Patient

Désigne le bloc adresse avec les coordonnées du patient.

Si le patient ("patient") et le garant ("guarantor") sont identiques, il faut que les mêmes données à l'exception du sexe du patient et de la date de naissance du patient soient mentionnées pour les deux partenaires (c.-à-d. le bloc "guarantor" est quasiment une copie 1:1 du bloc "patient".
diagram
type | credit:patientAddressType
properties
isRef | 0
content | complex
children | person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
tax_city | Domicile fiscal
tax_canton | Canton fiscal
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
tax_canton |  | NMTOKEN | AG | Argovie
tax_canton |  | NMTOKEN | AI | Appenzell Rhodes intérieures
tax_canton |  | NMTOKEN | AR | Appenzell Rhodes extérieures
tax_canton |  | NMTOKEN | BE | Berne
tax_canton |  | NMTOKEN | BL | Bâle-Campagne
tax_canton |  | NMTOKEN | BS | Bâle-Ville
tax_canton |  | NMTOKEN | FR | Fribourg
tax_canton |  | NMTOKEN | GE | Genève
tax_canton |  | NMTOKEN | GL | Glaris
tax_canton |  | NMTOKEN | GR | Grisons
tax_canton |  | NMTOKEN | JU | Jura
tax_canton |  | NMTOKEN | LU | Lucerne
tax_canton |  | NMTOKEN | NE | Neuchâtel
tax_canton |  | NMTOKEN | NW | Nidwald
tax_canton |  | NMTOKEN | OW | Obwald
tax_canton |  | NMTOKEN | SG | St-Gall
tax_canton |  | NMTOKEN | SH | Schaffhouse
tax_canton |  | NMTOKEN | SO | Soleure
tax_canton |  | NMTOKEN | SZ | Schwyz
tax_canton |  | NMTOKEN | TI | Tessin
tax_canton |  | NMTOKEN | TG | Thurgovie
tax_canton |  | NMTOKEN | UR | Uri
tax_canton |  | NMTOKEN | VD | Vaud
tax_canton |  | NMTOKEN | VS | Valais
tax_canton |  | NMTOKEN | ZG | Zoug
tax_canton |  | NMTOKEN | ZH | Zurich
tax_canton |  | NMTOKEN | LI | Fürstentum Liechtenstein
source
<element name="patient" type="credit:patientAddressType"/>


 element creditType/sponsor
Annotation Répondant des coûts
diagram
type | credit:sponsorType
properties
isRef | 0
content | complex
children | insurance kvg uvg ivg mvg vvg
attributes parameters
Name | Type | Use | Default | Fixed
billing |  |  | separate |
attributes annotations
Name | Notes
billing | Facturation
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
billing |  | NMTOKEN | separate | séparé
billing |  | NMTOKEN | combine | combiné
source
<element name="sponsor" type="credit:sponsorType"/>


 element creditType/contact
Annotation Personne de contact
diagram
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | person employee company
source
<element name="contact" type="credit:contactAddressType"/>


 element creditType/employer
Annotation Employeur du patient
diagram
type | credit:employerAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie l'employeur par le biais d'un numéro EAN univoque.
reg_number | Numéro d'entreprise
source
<element name="employer" type="credit:employerAddressType" minOccurs="0"/>


 element creditType/detail
Annotation Détails de la facture de médecin
diagram
type | credit:detailType
properties
isRef | 0
content | complex
children | explanation supplement remark
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime |  |  |
date_end | dateTime |  |  |
days | duration |  |  |
treatment_type |  | required |  |
reason |  | required |  |
response_type |  | required |  |
response_code | credit:stringType1_6 | required |  |
response_text | credit:stringType1_50 | required |  |
attributes annotations
Name | Notes
date_begin | Garantie de
date_end | Garantie jusqu'à
days | Garantie à partir du début en jours
treatment_type | Sorte de traitement
reason | Motif de traitement
response_type | Type de réponse
response_code | Code de réponse
response_text | Texte de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
reason |  | NMTOKEN | disease | maladie
reason |  | NMTOKEN | accident | accident
reason |  | NMTOKEN | maternity | maternité
reason |  | NMTOKEN | prevention | prévention
reason |  | NMTOKEN | birthdefect | infirmité congénitale
response_type |  | NMTOKEN | accepted | accepté
response_type |  | NMTOKEN | rejected | refusé
response_type |  | NMTOKEN | limited_coverage | couverture limitée
response_type |  | NMTOKEN | preliminary | provisoire
source
<element name="detail" type="credit:detailType"/>


 complexType detailType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | explanation supplement remark
used by
element creditType/detail
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime |  |  |
date_end | dateTime |  |  |
days | duration |  |  |
treatment_type |  | required |  |
reason |  | required |  |
response_type |  | required |  |
response_code | credit:stringType1_6 | required |  |
response_text | credit:stringType1_50 | required |  |
attributes annotations
Name | Notes
date_begin | Garantie de
date_end | Garantie jusqu'à
days | Garantie à partir du début en jours
treatment_type | Sorte de traitement
reason | Motif de traitement
response_type | Type de réponse
response_code | Code de réponse
response_text | Texte de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
reason |  | NMTOKEN | disease | maladie
reason |  | NMTOKEN | accident | accident
reason |  | NMTOKEN | maternity | maternité
reason |  | NMTOKEN | prevention | prévention
reason |  | NMTOKEN | birthdefect | infirmité congénitale
response_type |  | NMTOKEN | accepted | accepté
response_type |  | NMTOKEN | rejected | refusé
response_type |  | NMTOKEN | limited_coverage | couverture limitée
response_type |  | NMTOKEN | preliminary | provisoire
source
<complexType name="detailType">
  <sequence>
    <element name="explanation" type="string" minOccurs="0"/>
    <element name="supplement" type="string" minOccurs="0"/>
    <element name="remark" type="string" minOccurs="0"/>
  </sequence>
  <attribute name="date_begin" type="dateTime"/>
  <attribute name="date_end" type="dateTime"/>
  <attribute name="days" type="duration"/>
  <attribute name="treatment_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="ambulatory"/>
        <enumeration value="semi_stationary"/>
        <enumeration value="stationary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="reason" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="disease"/>
        <enumeration value="accident"/>
        <enumeration value="maternity"/>
        <enumeration value="prevention"/>
        <enumeration value="birthdefect"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="accepted"/>
        <enumeration value="rejected"/>
        <enumeration value="limited_coverage"/>
        <enumeration value="preliminary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_code" type="credit:stringType1_6" use="required"/>
  <attribute name="response_text" type="credit:stringType1_50" use="required"/>
</complexType>


 element detailType/explanation
Annotation Raison
diagram
type string
properties
isRef | 0
content | simple
source
<element name="explanation" type="string" minOccurs="0"/>


 element detailType/supplement
Annotation Précision et complément
diagram
type string
properties
isRef | 0
content | simple
source
<element name="supplement" type="string" minOccurs="0"/>


 element detailType/remark
Annotation Remarque
diagram
type string
properties
isRef | 0
content | simple
source
<element name="remark" type="string" minOccurs="0"/>


 complexType employeeType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname telecom online
used by
element contactAddressType/employee
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel de l'interlocuteur
title | Titre de l'interlocuteur
source
<complexType name="employeeType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>


 element employeeType/familyname
Annotation Nom
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>


 element employeeType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>


 element employeeType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element employeeType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 complexType employerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
element creditType/employer
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie l'employeur par le biais d'un numéro EAN univoque.
reg_number | Numéro d'entreprise
source
<complexType name="employerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType"/>
  <attribute name="reg_number" type="credit:stringType1_35"/>
</complexType>


 element employerAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>


 element employerAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>


 complexType errorSchemaType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:nonEmptyTextType
properties
base credit:nonEmptyTextType
used by
element xmlErrorType/error
facets
minLength 1
attributes parameters
Name | Type | Use | Default | Fixed
line_number | positiveInteger |  |  |
line_pos | positiveInteger |  |  |
err_code | integer |  |  |
err_text | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
line_number | Numéro de ligne
line_pos | Position de ligne
err_code | Code d'erreur
err_text | Texte d'erreur
Extensions
Annotation | Base
Erreurs | credit:nonEmptyTextType
source
<complexType name="errorSchemaType">
  <simpleContent>
    <extension base="credit:nonEmptyTextType">
      <attribute name="line_number" type="positiveInteger"/>
      <attribute name="line_pos" type="positiveInteger"/>
      <attribute name="err_code" type="integer"/>
      <attribute name="err_text" type="credit:stringType1_350"/>
    </extension>
  </simpleContent>
</complexType>


 complexType generatorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | software
used by
element prologType/generator
source
<complexType name="generatorType">
  <sequence>
    <element name="software" type="credit:softwareType"/>
  </sequence>
</complexType>


 element generatorType/software
Annotation Logiciel générateur

Contient le nom du logiciel ou du module du logiciel ayant produit les données XML.
diagram
type credit:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
Extensions
Annotation | Base
Software | credit:stringType1_50
source
<element name="software" type="credit:softwareType"/>


 complexType headerPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element headerType/intermediate
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<complexType name="headerPartyType">
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>


 complexType headerType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender intermediate recipient
used by
element responseType/header
source
<complexType name="headerType">
  <sequence>
    <element name="sender" type="credit:xtendHeaderPartyType"/>
    <element name="intermediate" type="credit:headerPartyType"/>
    <element name="recipient" type="credit:xtendHeaderPartyType"/>
  </sequence>
</complexType>


 element headerType/sender
Annotation Destinataire(numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie l'expéditeur de la réponse à la facture par le biais d'un numéro EAN univoque.
diagram
type credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="sender" type="credit:xtendHeaderPartyType"/>


 element headerType/intermediate
Annotation Intermédiaire (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie par le biais d'un numéro EAN univoque l'institution intermédiaire (clearing center) qui est responsable de la gestion administrative et fait office d'intermédiaire.

En cas d'envoi direct d'un document, il faut mentionner ici le numéro EAN du répondant des coûts.
Dans ce cas, le destinataire assume les tâches de l'intermédiaire.
diagram
type credit:headerPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="intermediate" type="credit:headerPartyType"/>


 element headerType/recipient
Annotation Destinataire
diagram
type credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<element name="recipient" type="credit:xtendHeaderPartyType"/>


 complexType insuranceAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company
used by
element sponsorType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le répondant des coûts par le biais d'un numéro EAN univoque.
source
<complexType name="insuranceAddressType">
  <sequence>
    <element name="company" type="credit:companyType"/>
  </sequence>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>


 element insuranceAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>


 complexType ivgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'AI pour ce cas relevant de la LAI, le numéro de la décision AI. Le numéro de la décision AI doit être indiqué dans tous les cas, les variantes suivantes étant possibles: - Variante A: le numéro à 14 chiffres, valable depuis le 1.1.2000: format: ivsyyyynnnnnnp (IVS=office AI) exemple: 35020010000026 - Variante B: le numéro à 9 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyy exemple: 350210598 - Variante C: le numéro à 10 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyyn (N=no d'ordre) exemple: 3501004994 -Variante D: le numéro à 6 chiffres, valable pour les mesures d'instruction: format: IVS299 exemple: 350299
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAI. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro AVS doit être transmis dans tous les cas lors d'un décompte LAI. Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex.: "17856210111" et ne doit en aucun cas débuter avec les zéros de gauche.
nif | Numéro d'identification du fournisseur/fournisseur de prestations (NIF) Pour un décompte LAI, le numéro NIF doit être communiqué dans tous les cas.
source
<complexType name="ivgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="case_id" use="required">
    <simpleType>
      <restriction base="string">
        <pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType" use="required"/>
  <attribute name="nif" type="credit:nifPartyType" use="required"/>
</complexType>


 element ivgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>


 element ivgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>


 element ivgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>


 element ivgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>


 complexType kvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAMal. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales (par ex. le numéro de contrat individuel selon la LAMal). Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<complexType name="kvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 element kvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>


 element kvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>


 element kvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>


 element kvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>


 complexType mvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro de l'assuré Désigne le numéro d'assuré attribué par l'AM (n° AM).
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAM. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<complexType name="mvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 element mvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>


 element mvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>


 element mvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>


 element mvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>


 complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | email url
used by
elements employeeType/online companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="credit:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>


 element onlineAddressType/email
Annotation Adresse e-mail Désigne une adresse e-mail selon RFC821.
diagram
type restriction of credit:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="credit:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>


 element onlineAddressType/url
Annotation Adresse URL

Désigne une adresse URL complète pouvant être utilisée à des fins d'information ou de prise de contact.
diagram
type restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>


 complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person
used by
element creditType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
tax_city | Domicile fiscal
tax_canton | Canton fiscal
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
tax_canton |  | NMTOKEN | AG | Argovie
tax_canton |  | NMTOKEN | AI | Appenzell Rhodes intérieures
tax_canton |  | NMTOKEN | AR | Appenzell Rhodes extérieures
tax_canton |  | NMTOKEN | BE | Berne
tax_canton |  | NMTOKEN | BL | Bâle-Campagne
tax_canton |  | NMTOKEN | BS | Bâle-Ville
tax_canton |  | NMTOKEN | FR | Fribourg
tax_canton |  | NMTOKEN | GE | Genève
tax_canton |  | NMTOKEN | GL | Glaris
tax_canton |  | NMTOKEN | GR | Grisons
tax_canton |  | NMTOKEN | JU | Jura
tax_canton |  | NMTOKEN | LU | Lucerne
tax_canton |  | NMTOKEN | NE | Neuchâtel
tax_canton |  | NMTOKEN | NW | Nidwald
tax_canton |  | NMTOKEN | OW | Obwald
tax_canton |  | NMTOKEN | SG | St-Gall
tax_canton |  | NMTOKEN | SH | Schaffhouse
tax_canton |  | NMTOKEN | SO | Soleure
tax_canton |  | NMTOKEN | SZ | Schwyz
tax_canton |  | NMTOKEN | TI | Tessin
tax_canton |  | NMTOKEN | TG | Thurgovie
tax_canton |  | NMTOKEN | UR | Uri
tax_canton |  | NMTOKEN | VD | Vaud
tax_canton |  | NMTOKEN | VS | Valais
tax_canton |  | NMTOKEN | ZG | Zoug
tax_canton |  | NMTOKEN | ZH | Zurich
tax_canton |  | NMTOKEN | LI | Fürstentum Liechtenstein
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="credit:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
  <attribute name="tax_city" type="credit:stringType1_35"/>
  <attribute name="tax_canton">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="AG"/>
        <enumeration value="AI"/>
        <enumeration value="AR"/>
        <enumeration value="BE"/>
        <enumeration value="BL"/>
        <enumeration value="BS"/>
        <enumeration value="FR"/>
        <enumeration value="GE"/>
        <enumeration value="GL"/>
        <enumeration value="GR"/>
        <enumeration value="JU"/>
        <enumeration value="LU"/>
        <enumeration value="NE"/>
        <enumeration value="NW"/>
        <enumeration value="OW"/>
        <enumeration value="SG"/>
        <enumeration value="SH"/>
        <enumeration value="SO"/>
        <enumeration value="SZ"/>
        <enumeration value="TI"/>
        <enumeration value="TG"/>
        <enumeration value="UR"/>
        <enumeration value="VD"/>
        <enumeration value="VS"/>
        <enumeration value="ZG"/>
        <enumeration value="ZH"/>
        <enumeration value="LI"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 element patientAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>


 complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname postal telecom online
used by
elements employerAddressType/person providerAddressType/person patientAddressType/person contactAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<complexType name="personType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
    <element name="postal" type="credit:postalAddressType"/>
    <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
    <element name="online" type="credit:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>


 element personType/familyname
Annotation Nom
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>


 element personType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>


 element personType/postal
Annotation Adresse
diagram
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="credit:postalAddressType"/>


 element personType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | credit:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element personType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | credit:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | pobox street zip city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="credit:stringType1_35" minOccurs="0"/>
    <element name="street" type="credit:stringType1_35" minOccurs="0"/>
    <element name="zip" type="credit:zipType"/>
    <element name="city" type="credit:stringType1_35"/>
  </sequence>
</complexType>


 element postalAddressType/pobox
Annotation Case postale
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="credit:stringType1_35" minOccurs="0"/>


 element postalAddressType/street
Annotation Rue
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="credit:stringType1_35" minOccurs="0"/>


 element postalAddressType/zip
Annotation NPA
diagram
type credit:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | credit:stringType1_9
source
<element name="zip" type="credit:zipType"/>


 element postalAddressType/city
Annotation Localité
diagram
type credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="credit:stringType1_35"/>


 complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | package generator
used by
element responseType/prolog
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="credit:softwareType" minOccurs="0"/>
    <element name="generator" type="credit:generatorType"/>
  </sequence>
</complexType>


 element prologType/package
Annotation Application de la branche

Contient des informations concernant l'application prioritaire de la branche, qui est utilisée pour la facturation. Le nom de l'application de la branche sera indiqué comme contenu des données de cet élément.

Si des indications relatives à l'application de la branche sont livrées, le nom doit être mentionné.
diagram
type credit:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
source
<element name="package" type="credit:softwareType" minOccurs="0"/>


 element prologType/generator
Annotation Générateur XML

Contient des informations sur le programme qui a généré et validé la facture XML et met ainsi à disposition les informations nécessaires concernant le logiciel produisant les données XML.
diagram
type | credit:generatorType
properties
isRef | 0
content | complex
children | software
source
<element name="generator" type="credit:generatorType"/>


 complexType providerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
element creditType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le fournisseur de prestations par le biais d'un numéro EAN univoque.
zsr | Numéro RCC RCC registre des codes créanciers de santé suisse.
specialty | Spécialité Désigne une autre spécification optionnelle au sens de la profession ou d'une activité similaire.
source
<complexType name="providerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType" use="required"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 element providerAddressType/company
Annotation Adresse d'une entreprise / institution
diagram
type | credit:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
source
<element name="company" type="credit:companyType"/>


 element providerAddressType/person
Annotation Adresse d'une personne
diagram
type | credit:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="credit:personType"/>


 complexType responseType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | header prolog xml_error credit
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name | Notes
assignment_role | Rôle thérapeutique du fournisseur de prestations
assignment_place | Lieu de la prestation
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<complexType name="responseType">
  <sequence>
    <element name="header" type="credit:headerType"/>
    <element name="prolog" type="credit:prologType"/>
    <choice>
      <element name="xml_error" type="credit:xmlErrorType"/>
      <element name="credit" type="credit:creditType"/>
    </choice>
  </sequence>
  <attribute name="assignment_role" fixed="physician"/>
  <attribute name="assignment_place" fixed="hospital"/>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 element responseType/header
Annotation Informations d'en-tête

Définit les informations "routing" qui sont nécessaires ou significatives pour le flux de la facture jusqu'au destinataire final et le retour du destinataire à l'expéditeur initial.
diagram
type | credit:headerType
properties
isRef | 0
content | complex
children | sender intermediate recipient
source
<element name="header" type="credit:headerType"/>


 element responseType/prolog
Annotation Prologue

Bloc avec informations sur:

- le paquet logiciel prioritaire (application de la branche)
- le générateur qui a créé et validé les structures XML correspondantes
- les validateurs de données utilisés
diagram
type | credit:prologType
properties
isRef | 0
content | complex
children | package generator
source
<element name="prolog" type="credit:prologType"/>


 element responseType/xml_error
Annotation Erreur XML
diagram
type | credit:xmlErrorType
properties
isRef | 0
content | complex
children | error
attributes parameters
Name | Type | Use | Default | Fixed
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong |  |  |
credit_id | credit:stringType1_35 |  |  |
credit_date | dateTime |  |  |
type |  |  |  |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type d'erreur
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<element name="xml_error" type="credit:xmlErrorType"/>


 element responseType/credit
Annotation Demande
diagram
type | credit:creditType
properties
isRef | 0
content | complex
children | recipient provider patient sponsor contact employer detail
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
type |  |  | new |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type de demande
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<element name="credit" type="credit:creditType"/>


 complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType1_50
properties
base credit:stringType1_50
used by
elements prologType/package generatorType/software
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | credit:versionType | required |  |
id |  |  | 0 |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version).
id | Numéro de certification ou d'homologation de l'application du logiciel générateur/de l'application de la branche Indique le cas échéant le numéro de certification ou d'homologation existant. Dans ce contexte, "0" signifie qu'un tel numéro est inconnu ou inexistant.
Extensions
Annotation | Base
Software | credit:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="credit:stringType1_50">
      <attribute name="version" type="credit:versionType" use="required"/>
      <attribute name="id" default="0">
        <simpleType>
          <restriction base="integer">
            <minInclusive value="0"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </simpleContent>
</complexType>


 complexType sponsorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | insurance kvg uvg ivg mvg vvg
used by
element creditType/sponsor
attributes parameters
Name | Type | Use | Default | Fixed
billing |  |  | separate |
attributes annotations
Name | Notes
billing | Facturation
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
billing |  | NMTOKEN | separate | séparé
billing |  | NMTOKEN | combine | combiné
source
<complexType name="sponsorType">
  <sequence>
    <element name="insurance" type="credit:insuranceAddressType"/>
    <choice minOccurs="0">
      <element name="kvg" type="credit:kvgLawType"/>
      <element name="uvg" type="credit:uvgLawType"/>
      <element name="ivg" type="credit:ivgLawType"/>
      <element name="mvg" type="credit:mvgLawType"/>
    </choice>
    <choice minOccurs="0">
      <element name="vvg" type="credit:vvgLawType"/>
    </choice>
  </sequence>
  <attribute name="billing" default="separate">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="separate"/>
        <enumeration value="combine"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 element sponsorType/insurance
Annotation Répondant des coûts (assurance du patient)

Désigne le bloc adresse de l'assureur responsable.
diagram
type | credit:insuranceAddressType
properties
isRef | 0
content | complex
children | company
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN)) Identifie le répondant des coûts par le biais d'un numéro EAN univoque.
source
<element name="insurance" type="credit:insuranceAddressType"/>


 element sponsorType/kvg
Annotation Loi sur l'assurance-maladie
diagram
type | credit:kvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAMal. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales (par ex. le numéro de contrat individuel selon la LAMal). Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<element name="kvg" type="credit:kvgLawType"/>


 element sponsorType/uvg
Annotation Loi sur l'assurance-accidents
diagram
type | credit:uvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré / de membre / de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance-accidents pour le cas LAA en question, par ex. n° d'accident de la Suva ou n° de cas de la Zurich Suisse. Les numéros de cas devraient toujours être transmis aux assurance-accidents.
case_date | Date de l'événement Désigne généralement la date de l'accident. Pour le motif de traitement "accident", la date d'accident doit être communiquée. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
ssn | Numéro AVS du patient Le n° AVS doit être entré comme pur nombre à 11 chiffres, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<element name="uvg" type="credit:uvgLawType"/>


 element sponsorType/ivg
Annotation Loi sur l'assurance-invalidité
diagram
type | credit:ivgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'AI pour ce cas relevant de la LAI, le numéro de la décision AI. Le numéro de la décision AI doit être indiqué dans tous les cas, les variantes suivantes étant possibles: - Variante A: le numéro à 14 chiffres, valable depuis le 1.1.2000: format: ivsyyyynnnnnnp (IVS=office AI) exemple: 35020010000026 - Variante B: le numéro à 9 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyy exemple: 350210598 - Variante C: le numéro à 10 chiffres, valable jusqu'au 31.12.1999: format: ivsddmmyyn (N=no d'ordre) exemple: 3501004994 -Variante D: le numéro à 6 chiffres, valable pour les mesures d'instruction: format: IVS299 exemple: 350299
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAI. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro AVS doit être transmis dans tous les cas lors d'un décompte LAI. Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex.: "17856210111" et ne doit en aucun cas débuter avec les zéros de gauche.
nif | Numéro d'identification du fournisseur/fournisseur de prestations (NIF) Pour un décompte LAI, le numéro NIF doit être communiqué dans tous les cas.
source
<element name="ivg" type="credit:ivgLawType"/>


 element sponsorType/mvg
Annotation Loi sur l'assurance militaire
diagram
type | credit:mvgLawType
properties
isRef | 0
content | complex
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro de l'assuré Désigne le numéro d'assuré attribué par l'AM (n° AM).
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LAM. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
ssn | Numéro AVS du patient Le numéro est entré comme nombre à 11 chiffres et sans les points, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<element name="mvg" type="credit:mvgLawType"/>


 element sponsorType/vvg
Annotation Loi sur le contrat d'assurance
diagram
type | credit:vvgLawType
properties
isRef | 0
content | complex
children | estimated_medical_costs estimated_treatment_costs total_estimated_costs accepted_medical_costs accepted_treatment_costs total_accepted_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification généré par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LArm. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat passé entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<element name="vvg" type="credit:vvgLawType"/>


 complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | phone fax
used by
elements employeeType/telecom companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="credit:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>


 element telecomAddressType/phone
Annotation Numéro de téléphone

Numéro de téléphone du raccordement fixe ou du téléphone mobile
diagram
type credit:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="credit:stringType1_25" maxOccurs="3"/>


 element telecomAddressType/fax
Annotation Numéro de fax
diagram
type credit:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>


 complexType uvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_costs total_estimated_costs accepted_costs total_accepted_costs
used by
element sponsorType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré / de membre / de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification créé par l'assurance-accidents pour le cas LAA en question, par ex. n° d'accident de la Suva ou n° de cas de la Zurich Suisse. Les numéros de cas devraient toujours être transmis aux assurance-accidents.
case_date | Date de l'événement Désigne généralement la date de l'accident. Pour le motif de traitement "accident", la date d'accident doit être communiquée. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
ssn | Numéro AVS du patient Le n° AVS doit être entré comme pur nombre à 11 chiffres, par ex. "17856210111", et ne doit en aucun cas débuter avec les zéros de gauche.
source
<complexType name="uvgLawType">
  <sequence>
    <element name="estimated_costs" type="credit:costsType"/>
    <element name="total_estimated_costs" type="credit:costsType"/>
    <element name="accepted_costs" type="credit:acceptedCostsType"/>
    <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 element uvgLawType/estimated_costs
Annotation Demande des coûts
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="estimated_costs" type="credit:costsType"/>


 element uvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>


 element uvgLawType/accepted_costs
Annotation Garantie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_costs" type="credit:acceptedCostsType"/>


 element uvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>


 complexType vvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | estimated_medical_costs estimated_treatment_costs total_estimated_costs accepted_medical_costs accepted_treatment_costs total_accepted_costs
used by
element sponsorType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
patient_id | Numéro d'assuré Désigne le numéro d'assuré ou de membre ou de police de l'assuré auprès de l'assurance.
case_id | Numéro de cas de l'assurance Désigne le numéro d'identification généré par l'assurance pour le cas en question.
case_date | Date de l'événement par ex. date de l'accident lorsqu'un accident est facturé à la charge de la LArm. La date de l'accident devrait être transmise lors du décompte d'un accident. Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué.
contract_number | Numéro de contrat Désigne le numéro d'un contrat passé entre le fournisseur de prestations et l'assurance concernant la facturation de prestations médicales. Si un tel contrat existe, il y a lieu d'indiquer le numéro.
source
<complexType name="vvgLawType">
  <sequence>
    <sequence>
      <element name="estimated_medical_costs" type="credit:xndCostsType"/>
      <element name="estimated_treatment_costs" type="credit:xndCostsType"/>
      <element name="total_estimated_costs" type="credit:costsType"/>
      <element name="accepted_medical_costs" type="credit:acceptedCostsType"/>
      <element name="accepted_treatment_costs" type="credit:acceptedCostsType"/>
      <element name="total_accepted_costs" type="credit:acceptedCostsType"/>
    </sequence>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 element vvgLawType/estimated_medical_costs
Annotation Demande de coûts pour médicaments
diagram
type credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
source
<element name="estimated_medical_costs" type="credit:xndCostsType"/>


 element vvgLawType/estimated_treatment_costs
Annotation Demande de coûts pour thérapie
diagram
type credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
source
<element name="estimated_treatment_costs" type="credit:xndCostsType"/>


 element vvgLawType/total_estimated_costs
Annotation Demande des coûts totaux
diagram
type credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name | Notes
amount | Montant
currency | Monnaie
source
<element name="total_estimated_costs" type="credit:costsType"/>


 element vvgLawType/accepted_medical_costs
Annotation Garantie maximale de médicament
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_medical_costs" type="credit:acceptedCostsType"/>


 element vvgLawType/accepted_treatment_costs
Annotation Garantie maximale de thérapie
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="accepted_treatment_costs" type="credit:acceptedCostsType"/>


 element vvgLawType/total_accepted_costs
Annotation Garantie maximale total
diagram
type credit:acceptedCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
percent | credit:amountType |  |  |
remark | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
remark | Remarque
percent | pour cent
source
<element name="total_accepted_costs" type="credit:acceptedCostsType"/>


 complexType xmlErrorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | error
used by
element responseType/xml_error
attributes parameters
Name | Type | Use | Default | Fixed
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong |  |  |
credit_id | credit:stringType1_35 |  |  |
credit_date | dateTime |  |  |
type |  |  |  |
response_timestamp | unsignedLong | required |  |
response_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
case_id | Numéro de cas
credit_timestamp | Demande timbre horodateur
credit_id | Numéro de demande
credit_date | Date de demande
type | Type d'erreur
response_timestamp | Réponse timbre horodateur
response_id | Numéro de réponse
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
type |  | NMTOKEN | new | nouveau
type |  | NMTOKEN | re-consideration | reconsidération
type |  | NMTOKEN | prolongation | prolongation
source
<complexType name="xmlErrorType">
  <sequence>
    <element name="error" type="credit:errorSchemaType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong"/>
  <attribute name="credit_id" type="credit:stringType1_35"/>
  <attribute name="credit_date" type="dateTime"/>
  <attribute name="type">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="response_timestamp" type="unsignedLong" use="required"/>
  <attribute name="response_id" type="credit:stringType1_35" use="required"/>
</complexType>


 element xmlErrorType/error
Annotation Erreurs
diagram
type credit:errorSchemaType
properties
isRef | 0
content | complex
facets
minLength 1
attributes parameters
Name | Type | Use | Default | Fixed
line_number | positiveInteger |  |  |
line_pos | positiveInteger |  |  |
err_code | integer |  |  |
err_text | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
line_number | Numéro de ligne
line_pos | Position de ligne
err_code | Code d'erreur
err_text | Texte d'erreur
source
<element name="error" type="credit:errorSchemaType" maxOccurs="unbounded"/>


 complexType xndCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements vvgLawType/estimated_medical_costs vvgLawType/estimated_treatment_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name | Notes
class | Classe
Extensions
Annotation | Base
Pourcentage | credit:costsType
source
<complexType name="xndCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="class">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="private"/>
            <enumeration value="semi_private"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </complexContent>
</complexType>


 complexType xtendHeaderPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements headerType/recipient headerType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN (EAN/UCC Global Location Number (GLN))
source
<complexType name="xtendHeaderPartyType">
  <attribute name="ean_party" type="credit:xtendEanPartyType" use="required"/>
</complexType>


 complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType1_9
properties
base credit:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | credit:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="credit:stringType1_9">
      <attribute name="statecode" type="credit:stringType1_9"/>
      <attribute name="countrycode" type="credit:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>


 simpleType amountType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of double
used by
attributes costsType/@amount acceptedCostsType/@percent
facets
minInclusive 0
source
<simpleType name="amountType">
  <restriction base="double">
    <minInclusive value="0"/>
  </restriction>
</simpleType>


 simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes employerAddressType/@ean_party providerAddressType/@ean_party insuranceAddressType/@ean_party headerPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11})"/>
  </restriction>
</simpleType>


 simpleType nifPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source
<simpleType name="nifPartyType">
  <restriction base="string">
    <pattern value="[0-9]{1,7}"/>
  </restriction>
</simpleType>


 simpleType nonEmptyTextType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType errorSchemaType
facets
minLength 1
source
<simpleType name="nonEmptyTextType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>


 simpleType ssn13PartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
pattern [1-9][0-9]{12}
source
<simpleType name="ssn13PartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{12}"/>
  </restriction>
</simpleType>


 simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes patientAddressType/@ssn uvgLawType/@ssn ivgLawType/@ssn mvgLawType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}"/>
  </restriction>
</simpleType>


 simpleType stringType0_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
maxLength 350
source
<simpleType name="stringType0_350">
  <restriction base="string">
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType stringType1_12
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
minLength | 1
maxLength | 12
source
<simpleType name="stringType1_12">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="12"/>
  </restriction>
</simpleType>


 simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>


 simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>


 simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department employeeType/familyname personType/familyname employeeType/givenname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | xmlErrorType/@case_id creditType/@case_id uvgLawType/@case_id vvgLawType/@case_id kvgLawType/@case_id uvgLawType/@contract_number vvgLawType/@contract_number kvgLawType/@contract_number xmlErrorType/@credit_id creditType/@credit_id kvgLawType/@patient_id vvgLawType/@patient_id uvgLawType/@patient_id creditType/@patient_id mvgLawType/@patient_id employerAddressType/@reg_number acceptedCostsType/@remark xmlErrorType/@response_id creditType/@response_id personType/@salutation employeeType/@salutation patientAddressType/@tax_city personType/@title employeeType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>


 simpleType stringType1_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes errorSchemaType/@err_text providerAddressType/@specialty
facets
minLength | 1
maxLength | 350
source
<simpleType name="stringType1_350">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | softwareType
attribute | detailType/@response_text
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>


 simpleType stringType1_6
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute detailType/@response_code
facets
minLength | 1
maxLength | 6
source
<simpleType name="stringType1_6">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="6"/>
  </restriction>
</simpleType>


 simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>


 simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>


 simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>


 simpleType unionPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | union of ( credit:xtendEanPartyType , credit:zsrPartyType )
source
<simpleType name="unionPartyType">
  <union memberTypes="credit:xtendEanPartyType credit:zsrPartyType"/>
</simpleType>


 simpleType versionType
namespace | http://www.forum-datenaustausch.ch/de
type | integer
used by
attribute softwareType/@version
source
<simpleType name="versionType">
  <restriction base="integer"/>
</simpleType>


 simpleType xtendEanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attribute | xtendHeaderPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11}|unknown)
source
<simpleType name="xtendEanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>
  </restriction>
</simpleType>


 simpleType zsrPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attribute | providerAddressType/@zsr
facets
pattern ([A-Z][0-9]{6}|[0-9]{6}[A-Z])
source
<simpleType name="zsrPartyType">
  <restriction base="string">
    <pattern value="([A-Z][0-9]{6}|[0-9]{6}[A-Z])"/>
  </restriction>
</simpleType>


Éléments de la réponse de prise en charge hospitalièr hiérarchique

hospitalCreditResponse_410 fra
Éléments de la réponse de prise en charge hospitalièr hiérarchique

si doit - élément
peut - élément
soit ou - élément