XML Schema Browser - generalCreditResponse Version 430

Documentation - Rev. 2
generalCreditResponse V430

produced by Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as standard in the meeting on 3rd February 2011.

The standard becomes productive on 1st January 2012.

Copyright (©) by Forum Datenaustausch, 03.02.2011 - all rights reserved


Revision history of the documentation

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalCreditResponse_430.xsd schema is not changed due to such an entry.
  • Revision 2 from 15.11.2011
  • Revision 1 from 03.02.2011


Revision history: Documentation revision 1

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Documentation revision 1

Rev. 1/03.02.2011: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the generalCreditResponse_430.xsd schema


Revision history: Documentation revision 2

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Documentation revision 2

Rev. 2/15.11.2011: the following subparts of the documentation have been refined and/or added:
  • Specification for the "Sequence of Sign & Crypt" added
  • Recommendation about the <KeyName> element in the encryption part added


Preface

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Forum Datenaustausch

Im "Forum Datenaustausch" haben sich verschiedene Akteure des Schweizer Gesundheitswesens zusammengeschlossen. Das Forum verfolgt u.a. das Ziel, einheitliche, gemeinsam entwickelte Standards für den elektronischen Datenaustausch festzusetzen.

Forumsmitglieder sind die Verbände der Leistungserbringer FMH, H+ und der Schweizerische Apothekerverband (SAV), auf Seiten der Kostenträger sind es santésuisse, der Schweizerische Versicherungsverband (SVV) sowie die Suva, die Militärversicherung und die Invalidenversicherung (IV).

Die vom Forum verabschiedeten Standards, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert. Dazu gehört auch die elektronische, XML basierende Leistungsabrechnung für Ärzte und Spitäler.

Die Gesellschaft bezweckt die Vereinheitlichung der Standards des elektronischen Datenaustausches im Schweizer Gesundheitswesen zwischen Leistungserbringern und Kostenträgern. Ziel ist die Festlegung von Grundsätzen mit Bezug auf die Übermittlungsstandards, die Referenzstammdaten sowie mit Bezug auf die Kriterien betreffend die Datensicherheit. Damit soll den Gesellschaftern der Aufbau von Kooperationsbeziehungen im Bereich des elektronischen Datenaustausches erleichtert werden.
Différents acteurs du domaine de la santé publique suisse se sont joints au "Forum Datenaustausch". L'objectif du forum consiste, entre autres, à établir des standards uniformes élaborés en commun pour l'échange électronique de données.

Les membres du forum sont les associations de prestataires FMH, H+ et la Société Suisse des Pharmaciens (SSPh) ainsi que, du côté des assureurs, santésuisse, l'Association Suisse d'Assurances (ASA), la Suva, l'assurance militaire et l'assurance invalidité (AI).

Les standards établis par le forum, tels les messages XML pour l'échange électronique de données, seront publiés ici. Ils englobent également le décompte électronique de prestations basé sur XML pour les médecins et les hôpitaux.

La société a pour but d'uniformiser les standards relatifs au transfert électronique de données dans la domaine de la santé suisse entre fournisseurs de prestations et assureurs. L'objectif consiste à déterminer des principes liés aux standards de transmission, aux données de base de référence ainsi qu'aux critères concernant la sécurité des données. Pour les membres de la société, cela devrait faciliter l'établissement de relations de coopération dans le domaine du transfert électronique de données.


Copyright (©) notice

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Purpose of the schema file

This is the schema definition for a "General Credit Response" process encoded in XML. The generalCreditResponse always constitutes an answer to a received "General Credit Request". By design there can be [0,n] such responses but solely to the topmost object reference given in the request. If there is no response sent to a request then it is considered implicitly as accepted.

It is by design that almost all data from the request are copied unaltered to the response augmented by the cost bearer's data and decision. Therefore the response altogether serves as source for the final printed form including the cost bearer's decision. As a guidance the documentation includes a "copy" tag on the highest elements that are copied (including all subelements therein) from the request to the response unaltered.

The subchapter Purpose::Anatomy of a response provides a broad overview about the building blocks of a response and the subchapter Purpose::Object reference provides an in-depth description of the concept of the "topmost object reference".

The response is sent via 1 or more intermediates to the final recipient, who is the initial sender of the request by definition. The chain of intermediates from the request is reversed for the response.

There is no concept of a response reference object but only a UNIX timestamp of the generation of the response XML for legal reasons. However, all reference objects of the request must be included in the response as these serve as a unique identification.

This XML project is normative for the electronic credit process in Switzerland.


Conventions, terms, and definitions used

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities

Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;
Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Anatomy of a response

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a response.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects that is copied from the request
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request of version 4.3 is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Credit Request" can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a former "General Credit Request" process
  • a mandatory credit object reference from the initial "General Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


Notes about the signature

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/credit:response/credit:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>
  <Reference URI="#xpointer(/credit:response/credit:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#tripledes-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-1_5"/>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/credit"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:credit="http://www.forum-datenaustausch.ch/credit"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag credit followed by the element name. Furthermore, the target namespace and the specific namespace credit maps to http://www.forum-datenaustausch.ch/credit.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<credit:response xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:credit="http://www.forum-datenaustausch.ch/credit"
        xmlns="http://www.forum-datenaustausch.ch/credit"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/credit generalCreditResponse_430.xsd"
        language="de" modus="production" >
XML elements go here...

 </credit:response>


Hierarchical list of used XSD definitions

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element response down as the appropriate definition is encountered .


 element response
Annotation The response element is the root of the generalCreditResponse process.
The response is divided into 2 parts
  • the processing element supplies the necessary data for the transport process
  • the payload element supplies the response to the request credit data
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:responseType
properties
content complex
children | credit:processing credit:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required |  |
modus | derived by: NMTOKEN |  | production |
attributes annotations
Name | Notes
language | language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers. The language used is copied from and thus defined by the request.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language |  | NMTOKEN | de | the data language is german
language |  | NMTOKEN | fr | the data language is french
language |  | NMTOKEN | it | the data language is italian
modus |  | NMTOKEN | production | the modus production (default value) is for normal processing
modus |  | NMTOKEN | test | the modus test is for software developers to test the processing.
source | <element name="response" type="credit:responseType"/>


 element responseType/processing
Annotation | The processing element is a container with transport instructions basically mirrored from the request.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:processingType
properties
isRef | 0
content | complex
children | credit:transport
source | <element name="processing" type="credit:processingType"/>


 element processingType/transport
Annotation The transport element defines the routing of the infoset.
In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list.
All the involved parties are defined by EAN numbers as defined by www.medwin.ch
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:transportType
properties
isRef | 0
content | complex
children | credit:via
attributes parameters
Name | Type | Use | Default | Fixed
from | credit:eanPartyType | required |  |
to | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
from | from is the EAN party that initially sent the infoset to the first intermediate In fact this is the mirrored to attribute from the request. Note, that the private certificate of this EAN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to | to is the EAN party that eventually receives the infoset from the last intermediate. In fact this is the mirrored from attribute from the request. Note, that the public certificate of this EAN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="credit:transportType"/>


 element transportType/via
Annotation The via element defines one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly send the infoset to the next intermediate in the mirrored list of intermediates or eventually deliver the infoset to the recipient (the sender of the request).
diagram
namespace http://www.forum-datenaustausch.ch/credit
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | credit:eanPartyType | required |  |
sequence_id | unsignedShort | required |  |
attributes annotations
Name | Notes
via | via is the EAN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming the mirrored chain of intermediate hops.
source <element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="credit:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


 element responseType/payload
Annotation | The payload element supplies the response to the request data. In fact the response includes all data given in the request augmented by the response. The payload can optionally be signed by a W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:payloadType
properties
isRef | 0
content | complex
children | credit:credit_ref credit:credit credit:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN |  | new |
storno | boolean |  | false |
copy | boolean |  | false |
cost_estimate | boolean |  | false |
response_timestamp | unsignedLong | required |  |
attributes annotations
Name | Notes
type | type defines the typification of the credit request encoded by a terminal set of tokens
storno | storno augments the topmost object reference by a storno command. This attribute is copied from the received request
copy | copy augments the topmost object reference by a copy command This attribute is copied from the received request
cost_estimate | cost_estimate qualifies the credit request as a cost estimate. From a semantical point of view it is the same as a credit. However, the legal implications of a cost estimate vs a credit request might be different. But this difference is out of scope of this technical documentation. This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
attributes enumerations
Name | Extension | Base | Value | Annotations
type |  | NMTOKEN | new | the request is of type new - the new credit request
type |  | NMTOKEN | re-consideration | the request is of type re-consideration - new consideration of a previously rejected credit request
type |  | NMTOKEN | prolongation | the request is of type prolongation - the prolongation of a previously accepted credit request
source | <element name="payload" type="credit:payloadType"/>


 element payloadType/credit_ref
Annotation | The credit_ref element defines a former credit object reference to which the current credit object reference make a reference.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:creditType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | unsignedLong | required |  |
request_date | dateTime | required |  |
request_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
request_timestamp | request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date | request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id | request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit_ref" type="credit:creditType" minOccurs="0"/>


 element payloadType/credit
Annotation | The credit element defines the unique credit object reference.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:creditType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | unsignedLong | required |  |
request_date | dateTime | required |  |
request_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
request_timestamp | request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date | request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id | request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit" type="credit:creditType"/>


 element payloadType/body
Annotation | The body element contains copied data containers from the request and the answer to the request. Since there are privacy relevant patient data in the response the body element can be replace by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:bodyType
properties
isRef | 0
content | complex
children | credit:prolog credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg credit:org credit:requestor credit:contact credit:provider credit:patient credit:cost_bearer credit:basic_insurance credit:employer credit:referrer credit:family_doctor credit:surgeon credit:treatment credit:services credit:measures credit:remark credit:pending credit:accepted credit:rejected
attributes parameters
Name | Type | Use | Default | Fixed
role | derived by: NMTOKEN | required |  |
place | derived by: NMTOKEN | required |  |
role_title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
role | role defines the principal role of the main provider copied from the request and encoded by a terminal set of tokens
place | place defines the principal place of the main provider copied from the request and encoded by a terminal set of tokens
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
attributes enumerations
Name | Extension | Base | Value | Annotations
place |  | NMTOKEN | practice | the main place of the service provision is at a practice
place |  | NMTOKEN | hospital | the main place of the service provision is at a hospital
place |  | NMTOKEN | lab | the main place of the service provision is at a lab
place |  | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place |  | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role |  | NMTOKEN | physician | the principal role of the service provider is physician
role |  | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role |  | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role |  | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role |  | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role |  | NMTOKEN | midwife | the principal role of the service provider is midwife
role |  | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role |  | NMTOKEN | hospital | the principal role of the service provider is hospital
role |  | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role |  | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role |  | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role |  | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role |  | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role |  | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role |  | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role |  | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role |  | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role |  | NMTOKEN | druggist | the principal role of the service provider is druggist
role |  | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of non-conventional Western medicine/non-biomedicine)
role |  | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist non-conventional Western medicine/non-biomedicine) including wellness therapists
role |  | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source | <element name="body" type="credit:bodyType"/>


 element bodyType/prolog
Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator and main software, respectively).
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:prologType
properties
isRef | 0
content | complex
children | credit:package credit:generator
source | <element name="prolog" type="credit:prologType"/>


 element prologType/package
Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | credit:stringType1_50 | required |  |
copyright | credit:stringType1_50 |  |  |
description | credit:stringType1_50 |  |  |
version | unsignedInt |  |  |
id | unsignedInt |  | 0 |
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version | version defines the version of the software/module. Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="credit:softwareType" minOccurs="0"/>


 element softwareType/depends_on
Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | credit:stringType1_50 | required |  |
copyright | credit:stringType1_50 |  |  |
description | credit:stringType1_50 |  |  |
version | unsignedInt |  |  |
id | unsignedInt |  | 0 |
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version | version defines the version of the dependent software/module. Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="credit:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


 element prologType/generator
Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:softwareType
properties
isRef | 0
content | complex
children | credit:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | credit:stringType1_50 | required |  |
copyright | credit:stringType1_50 |  |  |
description | credit:stringType1_50 |  |  |
version | unsignedInt |  |  |
id | unsignedInt |  | 0 |
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version | version defines the version of the software/module. Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="credit:softwareType"/>


 element bodyType/kvg
Annotation The kvg element defines the applicable law as KVG ("Krankenversicherungsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:kvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach KVG").
source | <element name="kvg" type="credit:kvgLawType"/>


 element bodyType/vvg
Annotation The vvg element defines the applicable law as VVG ("Versicherungsvertragsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:vvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach VVG").
source | <element name="vvg" type="credit:vvgLawType"/>


 element bodyType/uvg
Annotation The uvg element defines the applicable law as UVG ("Unfallversicherungsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:uvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source | <element name="uvg" type="credit:uvgLawType"/>


 element bodyType/ivg
Annotation The ivg element defines the applicable law as IVG ("Invalidenversicherungsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:ivgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string | required |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType |  |  |
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (IV case number)
case_date | case_date is the treatment/case date given by the insurance (IV case date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
nif | nif is the IV specific identification number for the provider.
source | <element name="ivg" type="credit:ivgLawType"/>


 element bodyType/mvg
Annotation The mvg element defines the applicable law as MVG ("Militäversicherungsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:mvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType | required |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (MV case number)
case_date | case_date is the treatment/case date given by the insurance (MV case date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source | <element name="mvg" type="credit:mvgLawType"/>


 element bodyType/org
Annotation The org element defines the applicable law as ORG ("Obligationenrechtsgesetz")

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:orgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
source | <element name="org" type="credit:orgLawType"/>


 element bodyType/requestor
Annotation The requestor element defines the address of the entity that requests a credit from the cost bearer.

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="requestor" type="credit:baseAddressType"/>


 element baseAddressType/company
Annotation | The base address is one of a company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:subaddressing credit:postal credit:telecom credit:online
source | <element name="company" type="credit:companyType"/>


 element companyType/companyname
Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="credit:stringType1_35"/>


 element companyType/department
Annotation | The optional department element supplies the name of an involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="credit:stringType1_35" minOccurs="0"/>


 element companyType/subaddressing
Annotation | The optional subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="credit:stringType1_35" minOccurs="0"/>


 element companyType/postal
Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | credit:pobox credit:street credit:zip credit:city
source | <element name="postal" type="credit:postalAddressType"/>


 element postalAddressType/pobox
Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="credit:stringType1_35" minOccurs="0"/>


 element postalAddressType/street
Annotation | The street element supplies the street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="street" type="credit:stringType1_35" minOccurs="0"/>


 element postalAddressType/zip
Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="zip" type="credit:zipType"/>


 element postalAddressType/city
Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="credit:stringType1_35"/>


 element companyType/telecom
Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:phone credit:fax
source | <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element telecomAddressType/phone
Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="credit:stringType1_25" maxOccurs="3"/>


 element telecomAddressType/fax
Annotation | The fax element supplies a telefax number
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_25
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>


 element companyType/online
Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:email credit:url
source | <element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 element onlineAddressType/email
Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of credit:stringType1_70
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="credit:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


 element onlineAddressType/url
Annotation | The url element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 100
source <element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>


 element baseAddressType/person
Annotation | The base address is one of a person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:subaddressing credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="credit:personType"/>


 element personType/familyname
Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="credit:stringType1_35"/>


 element personType/givenname
Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="credit:stringType1_35"/>


 element personType/subaddressing
Annotation | The optional subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="credit:stringType1_35" minOccurs="0"/>


 element personType/postal
Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:postalAddressType
properties
isRef | 0
content | complex
children | credit:pobox credit:street credit:zip credit:city
source | <element name="postal" type="credit:postalAddressType"/>


 element personType/telecom
Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:phone credit:fax
source | <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element personType/online
Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:email credit:url
source | <element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 element bodyType/contact
Annotation | The contact element supplies a primary contact address at the cost bearer's site for any questions regarding this credit response
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | credit:person credit:company credit:employee
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the contact's EAN number as defined by www.medwin.ch Note, that this is the EAN number of the given person or company - it is never an EAN of an employee!
source | <element name="contact" type="credit:contactAddressType"/>


 element contactAddressType/person
Annotation | The contact is defined as person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:subaddressing credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="credit:personType"/>


 element contactAddressType/company
Annotation | The contact is defined as company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:subaddressing credit:postal credit:telecom credit:online
source | <element name="company" type="credit:companyType"/>


 element contactAddressType/employee
Annotation The optional employee element augments the company address by the data of an employee handling the request
The address of an employee is identical to a person's address except that the postal address is not given but implicitly inherited by the company's address container.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:employeeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:familyname credit:givenname credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="employee" type="credit:employeeType" minOccurs="0"/>


 element employeeType/familyname
Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="credit:stringType1_35"/>


 element employeeType/givenname
Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="credit:stringType1_35" minOccurs="0"/>


 element employeeType/telecom
Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:phone credit:fax
source | <element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>


 element employeeType/online
Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:email credit:url
source | <element name="online" type="credit:onlineAddressType" minOccurs="0"/>


 element bodyType/provider
Annotation The provider element defines the address of the main service provider

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="provider" type="credit:baseAddressType"/>


 element bodyType/patient
Annotation The patient element defines the patient with all relevant data

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:patientAddressType
properties
isRef | 0
content | complex
children | credit:person credit:card
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
gender | gender defines the gender of the patient encoded by a terminal set of tokens
birthdate | birthdate defines the patient's birthdate
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender |  | NMTOKEN | male | the gender is male
gender |  | NMTOKEN | female | the gender is female
source | <element name="patient" type="credit:patientAddressType"/>


 element patientAddressType/person
Annotation | The patient's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:subaddressing credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="credit:personType"/>


 element patientAddressType/card
Annotation | The optional card element is a container for information about the patient's insurance card (might be the patient card later on)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
card_id | credit:stringType1_35 | required |  |
expiry_date | dateTime | required |  |
validation_date | dateTime |  |  |
validation_id | credit:stringType1_35 |  |  |
validation_server | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
card_id | card_id is the unique 20 digits card identifier
expiry_date | expiry_date is the expiry date of the card
validation_date | validation_date is the date of the last validation of the card's data
validation_id | validation_id is the reply ID of the last validation of the card's data
validation_server | validation_server is the used server for the last validation process
source <element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="credit:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime" use="required"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="credit:stringType1_35"/>
<attribute name="validation_server" type="credit:stringType1_35"/>
</complexType>
</element>


 element bodyType/cost_bearer
Annotation The cost_bearer element defines the address of the cost bearer who eventually will pay the forthcoming invoice.

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="cost_bearer" type="credit:baseAddressType"/>


 element bodyType/basic_insurance
Annotation The basic_insurance element defines the address of the basic insurance that is a KVG, UVG, IVG, or MVG type insurance.

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:basicInsuranceAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:company
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
type | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
ean_party | ean_party is the insurance's EAN number as defined by www.medwin.ch
type | type qualifies the insurance by the type of applicable law encoded by a terminal set of tokens. Since a basic insurance must be qualified the range of the applicable laws is reduced.
attributes enumerations
Name | Extension | Base | Value | Annotations
type |  | NMTOKEN | kvg | the applicable law is KVG ("Krankenversicherungsgesetz")
type |  | NMTOKEN | uvg | the applicable law is UVG ("Unfallversicherungsgesetz")
type |  | NMTOKEN | ivg | the applicable law is IVG ("Invalidenversicherungsgesetz")
type |  | NMTOKEN | mvg | the applicable law is MVG ("Militäversicherungsgesetz")
source | <element name="basic_insurance" type="credit:basicInsuranceAddressType" minOccurs="0"/>


 element basicInsuranceAddressType/company
Annotation | The address of the insurance given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:subaddressing credit:postal credit:telecom credit:online
source | <element name="company" type="credit:companyType"/>


 element bodyType/employer
Annotation The employer element defines the address of the patient's employer (the employer might be important in a UVG case)

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:employerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the employer's EAN number as defined by www.medwin.ch
reg_number | reg_number is the employer's national BER or UID number as defined by Swiss Federal Statistical Office
source | <element name="employer" type="credit:employerAddressType" minOccurs="0"/>


 element employerAddressType/company
Annotation | The employer is a company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:subaddressing credit:postal credit:telecom credit:online
source | <element name="company" type="credit:companyType"/>


 element employerAddressType/person
Annotation | The employer is a person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:subaddressing credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="credit:personType"/>


 element bodyType/referrer
Annotation The optional referrer element defines the address of the referrer who has referred the patient to the main provider.

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="referrer" type="credit:baseAddressType" minOccurs="0"/>


 element bodyType/family_doctor
Annotation The optional family_doctor element defines the address of patient's family doctor

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="family_doctor" type="credit:baseAddressType" minOccurs="0"/>


 element bodyType/surgeon
Annotation The optional surgeon element defines the address of a surgeon.

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:baseAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="surgeon" type="credit:baseAddressType" minOccurs="0"/>


 element bodyType/treatment
Annotation The treatment element defines the basic treatment parameters possibly augmented by extra data in case of a stationary treatment (element stationary).

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:treatmentType
properties
isRef | 0
content | complex
children | credit:diagnosis credit:stationary
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
treatment_units | credit:stringType1_100 |  |  |
canton | derived by: NMTOKEN | required |  |
reason | derived by: NMTOKEN | required |  |
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
date_begin | date_begin is the intended start of the treatment
treatment_units | treatment_units defines the number/length and unit of treatments. The treatment units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string due to the variety of possibilities. Treatment units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or "10 physio sessions - 1 per week".
canton | canton is a Swiss canton or a country close to the border in which the treatment will take place encoded by a terminal set of tokens. Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
reason | reason is the primary reason of the intended treatment encoded by a terminal set of tokens
patient_id | patient_id is an optional patient identification of the main software ("Patientennummer").
case_id | case_id is an optional case identification of the main software ("Fallnummer"). In fact it is an ID used in the main software to identify this request and probably it is the same as the credit@request_id attribute.
attributes enumerations
Name | Extension | Base | Value | Annotations
canton |  | NMTOKEN | AG | the canton is AG - Aargau
canton |  | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
canton |  | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
canton |  | NMTOKEN | BE | the canton is BE - Bern
canton |  | NMTOKEN | BL | the canton is BL - Baselland
canton |  | NMTOKEN | BS | the canton is BS - Basel
canton |  | NMTOKEN | FR | the canton is FR - Fribourg
canton |  | NMTOKEN | GE | the canton is GE - Geneva
canton |  | NMTOKEN | GL | the canton is GL - Glarus
canton |  | NMTOKEN | GR | the canton is GR - Graubünden
canton |  | NMTOKEN | JU | the canton is JU - Jura
canton |  | NMTOKEN | LU | the canton is LU - Lucerne
canton |  | NMTOKEN | NE | the canton is NE - Neuchâtel
canton |  | NMTOKEN | NW | the canton is NW - Nidwalden
canton |  | NMTOKEN | OW | the canton is OW - Obwalden
canton |  | NMTOKEN | SG | the canton is SG - St. Gallen
canton |  | NMTOKEN | SH | the canton is SH - Schaffhausen
canton |  | NMTOKEN | SO | the canton is SO - Solothurn
canton |  | NMTOKEN | SZ | the canton is SZ - Schwyz
canton |  | NMTOKEN | TI | the canton is TI - Ticino
canton |  | NMTOKEN | TG | the canton is TG - Thurgau
canton |  | NMTOKEN | UR | the canton is UR - Uri
canton |  | NMTOKEN | VD | the canton is VD - Vaud
canton |  | NMTOKEN | VS | the canton is VS - Valais
canton |  | NMTOKEN | ZG | the canton is ZG - Zug
canton |  | NMTOKEN | ZH | the canton is ZH - Zürich
canton |  | NMTOKEN | LI | the country is LI - Liechtenstein
canton |  | NMTOKEN | A | the country is A - Austria
canton |  | NMTOKEN | D | the country is D - Germany
canton |  | NMTOKEN | F | the country is F - France
canton |  | NMTOKEN | I | the country is I - Italy
reason |  | NMTOKEN | disease | the reason of treatment is a disease
reason |  | NMTOKEN | accident | the reason of treatment is an accident
reason |  | NMTOKEN | maternity | the reason of treatment is a maternity
reason |  | NMTOKEN | prevention | the reason of treatment is prevention
reason |  | NMTOKEN | birthdefect | the reason of treatment a birthdefect
reason |  | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
source | <element name="treatment" type="credit:treatmentType"/>


 element treatmentType/diagnosis
Annotation | The diagnosis element defines diagnoses for the intended treatment
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:diagnosisType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN |  | by_contract |
code | credit:stringType1_12 |  |  |
side | derived by: NMTOKEN |  | none |
remark | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
type | type is the type of diagnosis catalog used encoded by a terminal set of tokens
code | code is the used code of the designated diagnosis catalog
side | side is the side dependency of the given diagnosis encoded by a terminal set of tokens
remark | remark is a optional textual remark/comment for the given diagnosis
attributes enumerations
Name | Extension | Base | Value | Annotations
side | tringType0_350 | NMTOKEN | none | the side dependency is none (default) - no side specific dependency
side | tringType0_350 | NMTOKEN | left | the side dependency is left - the diagnosis applies to the left body side
side | tringType0_350 | NMTOKEN | right | the side dependency is right - the diagnosis applies to the right body side
side | tringType0_350 | NMTOKEN | both | the side dependency is both - the diagnosis applies to both body sides
side | tringType0_350 | NMTOKEN | unknown | the side dependency is unknown - the side dependency is unknown
type | tringType0_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | tringType0_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | tringType0_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | tringType0_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | tringType0_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | tringType0_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | tringType0_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
source | <element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>


 element treatmentType/stationary
Annotation | The stationary element defines additional data for a stationary treatment
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stationaryType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:outercantonal
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_type | derived by: NMTOKEN |  | regular |
hospitalization_mode | derived by: NMTOKEN |  | cantonal |
insurance_class | derived by: NMTOKEN |  | general |
insurance_model | derived by: NMTOKEN |  | standard |
section_major | credit:stringType1_6 |  |  |
attributes annotations
Name | Notes
hospitalization_type | hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
hospitalization_mode | hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
insurance_class | insurance_class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
insurance_model | insurance_model is a refinement of the insurance class coding encoded by a terminal set of tokens
section_major | section_major is the main section code (BfS section code) where the treatment is taking place as defined by Swiss Federal Statistical Office
attributes enumerations
Name | Extension | Base | Value | Annotations
hospitalization_mode |  | NMTOKEN | cantonal | the mode of hospitalization is cantonal - the patient's domicile is in the treatment canton
hospitalization_mode |  | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but the treatment is indicated. This case qualifies for the definition of an outer cantonal element.
hospitalization_mode |  | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and the treatment is not indicated. This case qualifies for the definition of an outer cantonal element.
hospitalization_type |  | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type |  | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_type |  | NMTOKEN | welfare | the type of hospitalization is welfare ("Fürsorglicher Freiheitsentzug")
insurance_class |  | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
insurance_class |  | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
insurance_class |  | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
insurance_model |  | NMTOKEN | standard | standard defines the standard insurance class without further refinements
insurance_model |  | NMTOKEN | hospital_comfort | hospital_comfort defines the hospitalization comfort refinement above the given insurance class
insurance_model |  | NMTOKEN | md_free_choice | md_free_choice defines the free choice of the physician ("Freie Arztwahl") refinement above the given insurance class
insurance_model |  | NMTOKEN | other | other defines a further refinement not given above
source | <element name="stationary" type="credit:stationaryType" minOccurs="0"/>


 element stationaryType/outercantonal
Annotation The outercantonal element sets additional data relevant for the cantonal surgeon. The element is defined under 2 conditions:
  • it is a stationary treatment
  • the treatment canton (treatment@canton) differs from the patient's tax canton (outercantonal@tax_canton)
In such a case the cantonal surgeon of the tax canton is a further cost bearer.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:outerCantonalType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
tax_city | credit:stringType1_35 |  |  |
tax_canton | derived by: NMTOKEN | required |  |
emergency_city | credit:stringType1_35 |  |  |
emergency_date | dateTime |  |  |
retransfer_date | dateTime |  |  |
cantonal_surgeon_inquired | boolean |  | false |
attributes annotations
Name | Notes
tax_city | tax_city is the patient main living place
tax_canton | canton is a Swiss canton or a country close to the border where the patient is paying taxes encoded by a terminal set of tokens. Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
emergency_city | In the case of an emergency (stationary@hospitalization_type = enEmergency) emergency_city is the city where that emergency happened. If this place is unknown or it is not an emergency the attribute is not set.
emergency_date | In the case of an emergency (stationary@hospitalization_type = enEmergency) emergency_date is the date and time when that emergency happened. If this date/time is unknown or it is not an emergency the attribute is not set.
retransfer_date | In the case of an emergency (stationary@hospitalization_type = enEmergency) retransfer_date is the date of the earliest transfer to a hospital of the tax canton. If this date is unknown or it is not an emergency the attribute is not set.
cantonal_surgeon_inquired | cantonal_surgeon_inquired confirms that a credit request was sent or will be send to the cantonal surgeon. This is obviously true for the cantonal surgeon as cost bearer and should be true for the credit request for the insurance.
attributes enumerations
Name | Extension | Base | Value | Annotations
tax_canton |  | NMTOKEN | AG | the canton is AG - Aargau
tax_canton |  | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
tax_canton |  | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
tax_canton |  | NMTOKEN | BE | the canton is BE - Bern
tax_canton |  | NMTOKEN | BL | the canton is BL - Baselland
tax_canton |  | NMTOKEN | BS | the canton is BS - Basel
tax_canton |  | NMTOKEN | FR | the canton is FR - Fribourg
tax_canton |  | NMTOKEN | GE | the canton is GE - Geneva
tax_canton |  | NMTOKEN | GL | the canton is GL - Glarus
tax_canton |  | NMTOKEN | GR | the canton is GR - Graubünden
tax_canton |  | NMTOKEN | JU | the canton is JU - Jura
tax_canton |  | NMTOKEN | LU | the canton is LU - Lucerne
tax_canton |  | NMTOKEN | NE | the canton is NE - Neuchâtel
tax_canton |  | NMTOKEN | NW | the canton is NW - Nidwalden
tax_canton |  | NMTOKEN | OW | the canton is OW - Obwalden
tax_canton |  | NMTOKEN | SG | the canton is SG - St. Gallen
tax_canton |  | NMTOKEN | SH | the canton is SH - Schaffhausen
tax_canton |  | NMTOKEN | SO | the canton is SO - Solothurn
tax_canton |  | NMTOKEN | SZ | the canton is SZ - Schwyz
tax_canton |  | NMTOKEN | TI | the canton is TI - Ticino
tax_canton |  | NMTOKEN | TG | the canton is TG - Thurgau
tax_canton |  | NMTOKEN | UR | the canton is UR - Uri
tax_canton |  | NMTOKEN | VD | the canton is VD - Vaud
tax_canton |  | NMTOKEN | VS | the canton is VS - Valais
tax_canton |  | NMTOKEN | ZG | the canton is ZG - Zug
tax_canton |  | NMTOKEN | ZH | the canton is ZH - Zürich
tax_canton |  | NMTOKEN | LI | the country is LI - Liechtenstein
tax_canton |  | NMTOKEN | A | the country is A - Austria
tax_canton |  | NMTOKEN | D | the country is D - Germany
tax_canton |  | NMTOKEN | F | the country is F - France
tax_canton |  | NMTOKEN | I | the country is I - Italy
source | <element name="outercantonal" type="credit:outerCantonalType" minOccurs="0"/>


 element bodyType/services
Annotation The services element is a container for all planned and possibly granted services.
Note, that services are used in a much broader view than e.g. in an invoice as it is composed basically by a qualified code and name, and the quantity, scale factor and base price.

Copy from Request and optionally augmented by response costs

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:servicesType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:service
source | <element name="services" type="credit:servicesType" minOccurs="0"/>


 element servicesType/service
Annotation The service element defines the data of one service. service is an unaltered copy from the request optionally augmented by the costs granted (element cost_response). The presence or absence of the response_cost element has the following meaning:
  • if the response type is pending: response_cost is absent as there is no final decision yet
  • if the response type is rejected: response_cost is absent as the credit was rejected
  • if the response type is accepted: response_cost might be present if a modification to the sent request_cost element was made from the cost bearer. If the response_cost is absent then the requested costs are considered implicitly as accepted.

Note, that the notation of service here is much simpler that in an invoice as the service is basically defined by a tariff number, code and name, a quantity, a base amount and a scale factor. The latter three form the amount as quantity * scale factor * base amount. Both the base amount and the amount are in CHF.
If a Tarmed service should be included then sum the medical and technical part to form the base amount.

Note as well, that the base amount includes any VAT portion and therefore the amount includes that portion as well.

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:serviceType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | credit:cost_request credit:cost_response
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required |  |
tariff_type | derived by: string |  |  |
code | credit:stringType1_30 |  |  |
name | credit:stringType1_350 | required |  |
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
tariff_type | tariff_type is the official 3-character designator of the used tariff catalog as given by Forum Datenaustausch tariff_type might be empty in special cases where the service is not covered by a official tariff catalog
code | code is the code of the service record as given by the used tariff catalog code might be empty in special cases where the service is not covered by a official tariff catalog
name | name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort.
source | <element name="service" type="credit:serviceType" maxOccurs="unbounded"/>


 element serviceType/cost_request
Annotation | The cost_request element defines the costs involved with the service as defined by the request.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:costType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
currency | string |  |  | CHF
quantity | double |  | 1.0 |
scale_factor | derived by: double |  | 1.0 |
base_amount | derived by: double | required |  |
amount | double | required |  |
remark | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
currency | currency is the currency used for the costs. The currency is fixed to "CHF" - Swiss Francs!
quantity quantity is the used quantity of the service.
Note, that the quantity is defined as double spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute payload@storno)
  • a zero quantity is used for "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
scale_factor scale_factor is a scale factor for the given service. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service.
scale_factor is defined as double and must not be rounded but given in full precision.
base_amount base_amount is the cost in CHF of one unit including any VAT portion
base_amount is defined as double and must not be rounded but given in full precision.
amount amount is the amount in CHF of the service calculated as
«quantity * scale_factor * base_amount»

calculated in full precision and the result then rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.

Note, that amount includes any VAT portion since the multiplier base_amount does as well.

remark | remark is an optional remark for the service
source | <element name="cost_request" type="credit:costType"/>


 element serviceType/cost_response
Annotation The optional cost_request element defines the granted costs if the response is of type accepted.
If cost_response is absent but the response is of type accepted then requested costs are considered implicitly as accepted as defined by the request. In all other cases cost_response is absent and has no meaning.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:costType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
currency | string |  |  | CHF
quantity | double |  | 1.0 |
scale_factor | derived by: double |  | 1.0 |
base_amount | derived by: double | required |  |
amount | double | required |  |
remark | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
currency | currency is the currency used for the costs. The currency is fixed to "CHF" - Swiss Francs!
quantity quantity is the used quantity of the service.
Note, that the quantity is defined as double spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute payload@storno)
  • a zero quantity is used for "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
scale_factor scale_factor is a scale factor for the given service. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service.
scale_factor is defined as double and must not be rounded but given in full precision.
base_amount base_amount is the cost in CHF of one unit including any VAT portion
base_amount is defined as double and must not be rounded but given in full precision.
amount amount is the amount in CHF of the service calculated as
«quantity * scale_factor * base_amount»

calculated in full precision and the result then rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.

Note, that amount includes any VAT portion since the multiplier base_amount does as well.

remark | remark is an optional remark for the service
source | <element name="cost_response" type="credit:costType" minOccurs="0"/>


 element bodyType/measures
Annotation The measures element defines the intended measures (motives and reasons) for the treatment

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="measures" type="credit:stringType1_700" minOccurs="0"/>


 element bodyType/remark
Annotation The optional remark element possibly complements the intended measures by remarks and comments

Element and all subelements copied unaltered from request

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="remark" type="credit:stringType1_700" minOccurs="0"/>


 element bodyType/pending
Annotation The pending element defines the answer of type «pending»
Per definition this means that the request can not be processed to a final stage as some data are missing. An optional justification and [0,n] messages (instructions) are supplied to "unfreeze" the request.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:pendingType
properties
isRef | 0
content | complex
children | credit:justification credit:message credit:documents
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="pending" type="credit:pendingType"/>


 element pendingType/justification
Annotation The justification element defines the overall justification for the pending status
The justification is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="justification" type="credit:stringType1_700" minOccurs="0"/>


 element pendingType/message
Annotation The message element defines either a reason why the request is in the pending state or an instruction how to proceed for leaving this state.
There is an unbounded number of such messages possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:notificationType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | credit:stringType1_9 | required |  |
text | credit:stringType1_350 | required |  |
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source | <element name="message" type="credit:notificationType" minOccurs="0" maxOccurs="unbounded"/>


 element pendingType/documents
Annotation The documents element is a container for including external documents, either inline (base64 coded) or offline (URL reference). Keep in mind, that these documents are not copied from the request but origin from the cost bearer.

Furthermore, if such a document must be filled out by the requestor and sent back then it is never done via a credit request but always via other communication facilities!. Any such form process is handled outside the credit request/response system.

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="credit:documentsType" minOccurs="0"/>


 element documentsType/document
Annotation | The document element defines one external physical document that is included in the infoset either inline (base64 coded) or offline (URL reference)
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | credit:base64 credit:url
attributes parameters
Name | Type | Use | Default | Fixed
filename | credit:nonEmptyStringType | required |  |
mimeType | credit:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | filename defines the file name (without any path information) on the source system This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type enables applications to read the file. RFC 2046 standardizes and names the commonly used MIME types.
viewer | viewer optionally points to an URL where a viewer for the current file can be downloaded
source | <element name="document" type="credit:documentType" maxOccurs="unbounded"/>


 element documentType/base64
Annotation | The base64 element defines the document as inline that is the document is included in the infoset in a Base64 encode octet stream representation.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


 element documentType/url
Annotation | The url element defines the document as offline that is the document can be fetched via the given URL.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | anyURI
properties
isRef | 0
content | simple
source | <element name="url" type="anyURI"/>


 element bodyType/accepted
Annotation The accepted element defines the answer of type «accepted».
Per definition this means that the request is accepted and will be processed to a final stage. An optional justification and addendum as well as the coverage data are supplied.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:acceptedType
properties
isRef | 0
content | complex
children | credit:justification credit:addendum credit:coverage credit:documents
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="accepted" type="credit:acceptedType"/>


 element acceptedType/justification
Annotation The justification element defines the overall justification for the accepted status
The justification is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="justification" type="credit:stringType1_700" minOccurs="0"/>


 element acceptedType/addendum
Annotation The optional addendum element defines an addendum to the justification
The addendum is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="addendum" type="credit:stringType1_700" minOccurs="0"/>


 element acceptedType/coverage
Annotation | The coverage element defines data regarding the insurance's coverage
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:coverageType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
response_date | dateTime |  |  |
response_id | credit:stringType1_35 |  |  |
coverage_type | derived by: NMTOKEN | required |  |
coverage_begin | dateTime | required |  |
coverage_end | dateTime |  |  |
coverage_units | credit:stringType1_100 |  |  |
attributes annotations
Name | Notes
response_date | response_date is a cost bearer defined response date
response_id | response_id is a cost bearer defined response identification.
coverage_type | coverage_type is the principle type of coverage encoded by a terminal set of tokens If none of the services have been modified in terms of the cost and none are appended then there is a full coverage. In all other cases the coverage is limited.
coverage_begin | coverage_begin is the start of the coverage period
coverage_end | coverage_end optionally defines the end of the coverage period. The absence of coverage_end implies no upper boundary for the coverage.
coverage_units | coverage_units defines the number/length and unit of a covered treatment and is the counterpart of treatment@treatment_units. The coverage units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string due to the variety of possibilities. Coverage units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or "10 physio sessions - 1 per week".
attributes enumerations
Name | Extension | Base | Value | Annotations
coverage_type |  | NMTOKEN | full | the coverage is full - all services are accepted unaltered
coverage_type |  | NMTOKEN | limited | the coverage is limited - at least one service was modified
source | <element name="coverage" type="credit:coverageType"/>


 element acceptedType/documents
Annotation The documents element is a container for including external documents, either inline (base64 coded) or offline (URL reference). Keep in mind, that these documents are not copied from the request bust origin form the cost bearer.

Furthermore, if such a document must be filled out by the requestor and sent back then it is never done via a credit request but always via other communication facilities!. Any such form process is handled outside the credit request/response system if the form process is requested by the cost bearer.

diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | credit:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="credit:documentsType" minOccurs="0"/>


 element bodyType/rejected
Annotation The rejected element defines the answer of type «rejected».
Per definition this means that the request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional justification and [0,n] errors are supplied to justify the decision.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:rejectedType
properties
isRef | 0
content | complex
children | credit:justification credit:error
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="rejected" type="credit:rejectedType"/>


 element rejectedType/justification
Annotation The justification element defines the overall justification for the rejected status
The justification is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="justification" type="credit:stringType1_700" minOccurs="0"/>


 element rejectedType/error
Annotation The error element defines one detailed error why the request is rejected.
There is an unbounded number of such errors possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | credit:errorType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | credit:stringType1_9 | required |  |
text | credit:stringType1_350 | required |  |
error_value | credit:stringType1_350 |  |  |
valid_value | credit:stringType1_350 |  |  |
record_id | positiveInteger |  |  |
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id | record_id is a record sequence number from the request uniquely identifying the service record. Of course, if it is not a service related error then record_id is undefined.
source | <element name="error" type="credit:errorType" minOccurs="0" maxOccurs="unbounded"/>


 element xenc:EncryptedData
Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the recipient represented by the transport@to EAN (which is the mirrored transport@from of the request).

See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
Type | anyURI | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


 element xenc:EncryptedType/EncryptionMethod
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


 element xenc:EncryptionMethodType/KeySize
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


 element xenc:EncryptionMethodType/OAEPparams
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


 element ds:KeyInfo
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


 element ds:KeyName
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


 element ds:KeyValue
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


 element ds:DSAKeyValue
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


 element ds:DSAKeyValueType/P
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


 element ds:DSAKeyValueType/Q
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


 element ds:DSAKeyValueType/G
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


 element ds:DSAKeyValueType/Y
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


 element ds:DSAKeyValueType/J
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


 element ds:DSAKeyValueType/Seed
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


 element ds:DSAKeyValueType/PgenCounter
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


 element ds:RSAKeyValue
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


 element ds:RSAKeyValueType/Modulus
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


 element ds:RSAKeyValueType/Exponent
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


 element ds:RetrievalMethod
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI |  |  |
Type | anyURI | optional |  |
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


 element ds:Transforms
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


 element ds:Transform
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="Transform" type="ds:TransformType"/>


 element ds:TransformType/XPath
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


 element ds:X509Data
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


 element ds:X509DataType/X509IssuerSerial
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


 element ds:X509IssuerSerialType/X509IssuerName
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


 element ds:X509IssuerSerialType/X509SerialNumber
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


 element ds:X509DataType/X509SKI
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


 element ds:X509DataType/X509SubjectName
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


 element ds:X509DataType/X509Certificate
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


 element ds:X509DataType/X509CRL
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


 element ds:PGPData
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


 element ds:PGPDataType/PGPKeyID
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


 element ds:PGPDataType/PGPKeyPacket
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


 element ds:SPKIData
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


 element ds:SPKIDataType/SPKISexp
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


 element ds:MgmtData
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


 element xenc:CipherData
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


 element xenc:CipherDataType/CipherValue
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


 element xenc:CipherReference
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required |  |
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


 element xenc:CipherReferenceType/Transforms
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


 element xenc:EncryptionProperties
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


 element xenc:EncryptionProperty
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional |  |
Id | ID | optional |  |
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


 element ds:Signature
Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sender represented by the transport@from EAN (which is the mirrored transport@to of the request).
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType responseType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="Signature" type="ds:SignatureType"/>


 element ds:SignedInfo
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


 element ds:CanonicalizationMethod
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


 element ds:SignatureMethod
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


 element ds:SignatureMethodType/HMACOutputLength
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


 element ds:Reference
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
URI | anyURI | optional |  |
Type | anyURI | optional |  |
source | <element name="Reference" type="ds:ReferenceType"/>


 element ds:DigestMethod
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


 element ds:DigestValue
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


 element ds:SignatureValue
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


 element ds:Object
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Documentation of generalCreditResponse_430.xsd - Rev. 2

Copyright (©) by Forum Datenaustausch, 03.02.2011
All rights reserved

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.


 complexType acceptedType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:statusType
properties
base credit:statusType
children | credit:justification credit:addendum credit:coverage credit:documents
used by
element bodyType/accepted
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «accepted» | credit:statusType
source <complexType name="acceptedType">
<complexContent>
<extension base="credit:statusType">
<sequence>
<element name="justification" type="credit:stringType1_700" minOccurs="0"/>
<element name="addendum" type="credit:stringType1_700" minOccurs="0"/>
<element name="coverage" type="credit:coverageType"/>
<element name="documents" type="credit:documentsType" minOccurs="0"/>
</sequence>
</extension>
</complexContent>
</complexType>


 complexType baseAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:company credit:person
used by
elements bodyType/cost_bearer bodyType/family_doctor bodyType/provider bodyType/referrer bodyType/requestor bodyType/surgeon
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source <complexType name="baseAddressType">
<choice>
<element name="company" type="credit:companyType"/>
<element name="person" type="credit:personType"/>
</choice>
<attribute name="ean_party" type="credit:eanPartyType" use="required"/>
<attribute name="zsr" type="credit:zsrPartyType"/>
<attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 complexType basicInsuranceAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:company
used by
element bodyType/basic_insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
type | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
ean_party | ean_party is the insurance's EAN number as defined by www.medwin.ch
type | type qualifies the insurance by the type of applicable law encoded by a terminal set of tokens. Since a basic insurance must be qualified the range of the applicable laws is reduced.
attributes enumerations
Name | Extension | Base | Value | Annotations
type |  | NMTOKEN | kvg | the applicable law is KVG ("Krankenversicherungsgesetz")
type |  | NMTOKEN | uvg | the applicable law is UVG ("Unfallversicherungsgesetz")
type |  | NMTOKEN | ivg | the applicable law is IVG ("Invalidenversicherungsgesetz")
type |  | NMTOKEN | mvg | the applicable law is MVG ("Militäversicherungsgesetz")
source <complexType name="basicInsuranceAddressType">
<sequence>
<element name="company" type="credit:companyType"/>
</sequence>
<attribute name="ean_party" type="credit:eanPartyType"/>
<attribute name="type" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="kvg"/>
<enumeration value="ivg"/>
<enumeration value="mvg"/>
<enumeration value="uvg"/>
</restriction>
</simpleType>
</attribute>
</complexType>


 complexType bodyType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:prolog credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg credit:org credit:requestor credit:contact credit:provider credit:patient credit:cost_bearer credit:basic_insurance credit:employer credit:referrer credit:family_doctor credit:surgeon credit:treatment credit:services credit:measures credit:remark credit:pending credit:accepted credit:rejected
used by
element payloadType/body
attributes parameters
Name | Type | Use | Default | Fixed
role | derived by: NMTOKEN | required |  |
place | derived by: NMTOKEN | required |  |
role_title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
role | role defines the principal role of the main provider copied from the request and encoded by a terminal set of tokens
place | place defines the principal place of the main provider copied from the request and encoded by a terminal set of tokens
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
attributes enumerations
Name | Extension | Base | Value | Annotations
place |  | NMTOKEN | practice | the main place of the service provision is at a practice
place |  | NMTOKEN | hospital | the main place of the service provision is at a hospital
place |  | NMTOKEN | lab | the main place of the service provision is at a lab
place |  | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place |  | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role |  | NMTOKEN | physician | the principal role of the service provider is physician
role |  | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role |  | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role |  | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role |  | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role |  | NMTOKEN | midwife | the principal role of the service provider is midwife
role |  | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role |  | NMTOKEN | hospital | the principal role of the service provider is hospital
role |  | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role |  | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role |  | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role |  | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role |  | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role |  | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role |  | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role |  | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role |  | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role |  | NMTOKEN | druggist | the principal role of the service provider is druggist
role |  | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of non-conventional Western medicine/non-biomedicine)
role |  | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist non-conventional Western medicine/non-biomedicine) including wellness therapists
role |  | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="credit:prologType"/>
<choice>
<element name="kvg" type="credit:kvgLawType"/>
<element name="vvg" type="credit:vvgLawType"/>
<element name="uvg" type="credit:uvgLawType"/>
<element name="ivg" type="credit:ivgLawType"/>
<element name="mvg" type="credit:mvgLawType"/>
<element name="org" type="credit:orgLawType"/>
</choice>
<element name="requestor" type="credit:baseAddressType"/>
<element name="contact" type="credit:contactAddressType"/>
<element name="provider" type="credit:baseAddressType"/>
<element name="patient" type="credit:patientAddressType"/>
<element name="cost_bearer" type="credit:baseAddressType"/>
<element name="basic_insurance" type="credit:basicInsuranceAddressType" minOccurs="0"/>
<element name="employer" type="credit:employerAddressType" minOccurs="0"/>
<element name="referrer" type="credit:baseAddressType" minOccurs="0"/>
<element name="family_doctor" type="credit:baseAddressType" minOccurs="0"/>
<element name="surgeon" type="credit:baseAddressType" minOccurs="0"/>
<element name="treatment" type="credit:treatmentType"/>
<element name="services" type="credit:servicesType" minOccurs="0"/>
<element name="measures" type="credit:stringType1_700" minOccurs="0"/>
<element name="remark" type="credit:stringType1_700" minOccurs="0"/>
<choice>
<element name="pending" type="credit:pendingType"/>
<element name="accepted" type="credit:acceptedType"/>
<element name="rejected" type="credit:rejectedType"/>
</choice>
</sequence>
<attribute name="role" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="physician"/>
<enumeration value="physiotherapist"/>
<enumeration value="chiropractor"/>
<enumeration value="ergotherapist"/>
<enumeration value="nutritionist"/>
<enumeration value="midwife"/>
<enumeration value="logotherapist"/>
<enumeration value="hospital"/>
<enumeration value="pharmacist"/>
<enumeration value="dentist"/>
<enumeration value="labtechnician"/>
<enumeration value="dentaltechnician"/>
<enumeration value="othertechnician"/>
<enumeration value="psychologist"/>
<enumeration value="wholesaler"/>
<enumeration value="nursingstaff"/>
<enumeration value="transport"/>
<enumeration value="druggist"/>
<enumeration value="naturopathicdoctor"/>
<enumeration value="naturopathictherapist"/>
<enumeration value="other"/>
</restriction>
</simpleType>
</attribute>
<attribute name="place" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="practice"/>
<enumeration value="hospital"/>
<enumeration value="lab"/>
<enumeration value="association"/>
<enumeration value="company"/>
</restriction>
</simpleType>
</attribute>
<attribute name="role_title" type="credit:stringType1_35"/>
</complexType>


 complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:companyname credit:department credit:subaddressing credit:postal credit:telecom credit:online
used by
elements baseAddressType/company basicInsuranceAddressType/company employerAddressType/company contactAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="credit:stringType1_35"/>
<element name="department" type="credit:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="credit:stringType1_35" minOccurs="0"/>
<element name="postal" type="credit:postalAddressType"/>
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


 complexType contactAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:person credit:company credit:employee
used by
element bodyType/contact
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the contact's EAN number as defined by www.medwin.ch Note, that this is the EAN number of the given person or company - it is never an EAN of an employee!
source <complexType name="contactAddressType">
<choice>
<element name="person" type="credit:personType"/>
<sequence>
<element name="company" type="credit:companyType"/>
<element name="employee" type="credit:employeeType" minOccurs="0"/>
</sequence>
</choice>
<attribute name="ean_party" type="credit:eanPartyType"/>
</complexType>


 complexType costType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
elements serviceType/cost_request serviceType/cost_response
attributes parameters
Name | Type | Use | Default | Fixed
currency | string |  |  | CHF
quantity | double |  | 1.0 |
scale_factor | derived by: double |  | 1.0 |
base_amount | derived by: double | required |  |
amount | double | required |  |
remark | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
currency | currency is the currency used for the costs. The currency is fixed to "CHF" - Swiss Francs!
quantity quantity is the used quantity of the service.
Note, that the quantity is defined as double spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute payload@storno)
  • a zero quantity is used for "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
scale_factor scale_factor is a scale factor for the given service. In principle the scale factor is used for defining discounts or surchages. However, it can be used as well for defining cost fractions e.g. in a DRG service.
scale_factor is defined as double and must not be rounded but given in full precision.
base_amount base_amount is the cost in CHF of one unit including any VAT portion
base_amount is defined as double and must not be rounded but given in full precision.
amount amount is the amount in CHF of the service calculated as
«quantity * scale_factor * base_amount»

calculated in full precision and the result then rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.

Note, that amount includes any VAT portion since the multiplier base_amount does as well.

remark | remark is an optional remark for the service
source <complexType name="costType">
<attribute name="currency" type="string" fixed="CHF"/>
<attribute name="quantity" type="double" default="1.0"/>
<attribute name="scale_factor" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="base_amount" use="required">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount" type="double" use="required"/>
<attribute name="remark" type="credit:stringType1_350"/>
</complexType>


 complexType coverageType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element acceptedType/coverage
attributes parameters
Name | Type | Use | Default | Fixed
response_date | dateTime |  |  |
response_id | credit:stringType1_35 |  |  |
coverage_type | derived by: NMTOKEN | required |  |
coverage_begin | dateTime | required |  |
coverage_end | dateTime |  |  |
coverage_units | credit:stringType1_100 |  |  |
attributes annotations
Name | Notes
response_date | response_date is a cost bearer defined response date
response_id | response_id is a cost bearer defined response identification.
coverage_type | coverage_type is the principle type of coverage encoded by a terminal set of tokens If none of the services have been modified in terms of the cost and none are appended then there is a full coverage. In all other cases the coverage is limited.
coverage_begin | coverage_begin is the start of the coverage period
coverage_end | coverage_end optionally defines the end of the coverage period. The absence of coverage_end implies no upper boundary for the coverage.
coverage_units | coverage_units defines the number/length and unit of a covered treatment and is the counterpart of treatment@treatment_units. The coverage units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string due to the variety of possibilities. Coverage units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or "10 physio sessions - 1 per week".
attributes enumerations
Name | Extension | Base | Value | Annotations
coverage_type |  | NMTOKEN | full | the coverage is full - all services are accepted unaltered
coverage_type |  | NMTOKEN | limited | the coverage is limited - at least one service was modified
source <complexType name="coverageType">
<attribute name="response_date" type="dateTime"/>
<attribute name="response_id" type="credit:stringType1_35"/>
<attribute name="coverage_type" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="full"/>
<enumeration value="limited"/>
</restriction>
</simpleType>
</attribute>
<attribute name="coverage_begin" type="dateTime" use="required"/>
<attribute name="coverage_end" type="dateTime"/>
<attribute name="coverage_units" type="credit:stringType1_100"/>
</complexType>


 complexType creditType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
elements payloadType/credit payloadType/credit_ref
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | unsignedLong | required |  |
request_date | dateTime | required |  |
request_id | credit:stringType1_35 | required |  |
attributes annotations
Name | Notes
request_timestamp | request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date | request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id | request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response. This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source <complexType name="creditType">
<attribute name="request_timestamp" type="unsignedLong" use="required"/>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="credit:stringType1_35" use="required"/>
</complexType>


 complexType dependsOnType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | credit:stringType1_50 | required |  |
copyright | credit:stringType1_50 |  |  |
description | credit:stringType1_50 |  |  |
version | unsignedInt |  |  |
id | unsignedInt |  | 0 |
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version | version defines the version of the dependent software/module. Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="credit:stringType1_50" use="required"/>
<attribute name="copyright" type="credit:stringType1_50"/>
<attribute name="description" type="credit:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


 complexType diagnosisType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:stringType0_350
properties
base credit:stringType0_350
used by
element treatmentType/diagnosis
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN |  | by_contract |
code | credit:stringType1_12 |  |  |
side | derived by: NMTOKEN |  | none |
remark | credit:stringType1_350 |  |  |
attributes annotations
Name | Notes
type | type is the type of diagnosis catalog used encoded by a terminal set of tokens
code | code is the used code of the designated diagnosis catalog
side | side is the side dependency of the given diagnosis encoded by a terminal set of tokens
remark | remark is a optional textual remark/comment for the given diagnosis
attributes enumerations
Name | Extension | Base | Value | Annotations
side | tringType0_350 | NMTOKEN | none | the side dependency is none (default) - no side specific dependency
side | tringType0_350 | NMTOKEN | left | the side dependency is left - the diagnosis applies to the left body side
side | tringType0_350 | NMTOKEN | right | the side dependency is right - the diagnosis applies to the right body side
side | tringType0_350 | NMTOKEN | both | the side dependency is both - the diagnosis applies to both body sides
side | tringType0_350 | NMTOKEN | unknown | the side dependency is unknown - the side dependency is unknown
type | tringType0_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | tringType0_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | tringType0_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | tringType0_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | tringType0_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | tringType0_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | tringType0_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
Extensions
Annotation | Base
Definition of a diagnosis container | credit:stringType0_350
source <complexType name="diagnosisType">
<simpleContent>
<extension base="credit:stringType0_350">
<attribute name="type" default="by_contract">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ICD"/>
<enumeration value="cantonal"/>
<enumeration value="DRG"/>
<enumeration value="by_contract"/>
<enumeration value="freetext"/>
<enumeration value="birthdefect"/>
<enumeration value="ICPC"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="credit:stringType1_12"/>
<attribute name="side" default="none">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="none"/>
<enumeration value="left"/>
<enumeration value="right"/>
<enumeration value="both"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
<attribute name="remark" type="credit:stringType1_350"/>
</extension>
</simpleContent>
</complexType>


 complexType documentsType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:document
used by
elements pendingType/documents acceptedType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="credit:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


 complexType documentType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:base64 credit:url
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | credit:nonEmptyStringType | required |  |
mimeType | credit:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | filename defines the file name (without any path information) on the source system This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type enables applications to read the file. RFC 2046 standardizes and names the commonly used MIME types.
viewer | viewer optionally points to an URL where a viewer for the current file can be downloaded
source <complexType name="documentType">
<choice>
<element name="base64" type="base64Binary"/>
<element name="url" type="anyURI"/>
</choice>
<attribute name="filename" type="credit:nonEmptyStringType" use="required"/>
<attribute name="mimeType" type="credit:nonEmptyStringType" use="required"/>
<attribute name="viewer" type="anyURI"/>
</complexType>


 complexType ds:CanonicalizationMethodType
diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 complexType ds:DigestMethodType
diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 complexType ds:DSAKeyValueType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


 complexType ds:KeyInfoType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType ds:KeyValueType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


 complexType ds:ManifestType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType ds:ObjectType
diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


 complexType ds:PGPDataType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


 complexType ds:ReferenceType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
URI | anyURI | optional |  |
Type | anyURI | optional |  |
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


 complexType ds:RetrievalMethodType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI |  |  |
Type | anyURI | optional |  |
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


 complexType ds:RSAKeyValueType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


 complexType ds:SignatureMethodType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 complexType ds:SignaturePropertiesType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 element ds:SignatureProperty
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required |  |
Id | ID | optional |  |
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


 complexType ds:SignaturePropertyType
diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required |  |
Id | ID | optional |  |
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType ds:SignatureType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType ds:SignatureValueType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


 complexType ds:SignedInfoType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType ds:SPKIDataType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


 complexType ds:TransformsType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


 complexType ds:TransformType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 complexType ds:X509DataType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


 complexType ds:X509IssuerSerialType
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


 complexType employeeType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:familyname credit:givenname credit:telecom credit:online
used by
element contactAddressType/employee
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="employeeType">
<sequence>
<element name="familyname" type="credit:stringType1_35"/>
<element name="givenname" type="credit:stringType1_35" minOccurs="0"/>
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="credit:stringType1_35"/>
<attribute name="title" type="credit:stringType1_35"/>
</complexType>


 complexType employerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:company credit:person
used by
element bodyType/employer
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
ean_party | ean_party is the employer's EAN number as defined by www.medwin.ch
reg_number | reg_number is the employer's national BER or UID number as defined by Swiss Federal Statistical Office
source <complexType name="employerAddressType">
<choice>
<element name="company" type="credit:companyType"/>
<element name="person" type="credit:personType"/>
</choice>
<attribute name="ean_party" type="credit:eanPartyType"/>
<attribute name="reg_number" type="credit:stringType1_35"/>
</complexType>


 complexType errorType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:notificationType
properties
base credit:notificationType
used by
element rejectedType/error
attributes parameters
Name | Type | Use | Default | Fixed
code | credit:stringType1_9 | required |  |
text | credit:stringType1_350 | required |  |
error_value | credit:stringType1_350 |  |  |
valid_value | credit:stringType1_350 |  |  |
record_id | positiveInteger |  |  |
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id | record_id is a record sequence number from the request uniquely identifying the service record. Of course, if it is not a service related error then record_id is undefined.
Extensions
Annotation | Base
Definition for an error container | credit:notificationType
source <complexType name="errorType">
<complexContent>
<extension base="credit:notificationType">
<attribute name="error_value" type="credit:stringType1_350"/>
<attribute name="valid_value" type="credit:stringType1_350"/>
<attribute name="record_id" type="positiveInteger"/>
</extension>
</complexContent>
</complexType>


 complexType ivgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string | required |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType |  |  |
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (IV case number)
case_date | case_date is the treatment/case date given by the insurance (IV case date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
nif | nif is the IV specific identification number for the provider.
source <complexType name="ivgLawType">
<attribute name="case_id" use="required">
<simpleType>
<restriction base="string">
<pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
</restriction>
</simpleType>
</attribute>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
<attribute name="ssn" type="credit:ssnPartyType" use="required"/>
<attribute name="nif" type="credit:nifPartyType"/>
</complexType>


 complexType kvgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach KVG").
source <complexType name="kvgLawType">
<attribute name="insured_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType mvgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType | required |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (MV case number)
case_date | case_date is the treatment/case date given by the insurance (MV case date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source <complexType name="mvgLawType">
<attribute name="insured_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
<attribute name="ssn" type="credit:ssnPartyType" use="required"/>
</complexType>


 complexType notificationType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element | pendingType/message
complexType | errorType
attributes parameters
Name | Type | Use | Default | Fixed
code | credit:stringType1_9 | required |  |
text | credit:stringType1_350 | required |  |
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source <complexType name="notificationType">
<attribute name="code" type="credit:stringType1_9" use="required"/>
<attribute name="text" type="credit:stringType1_350" use="required"/>
</complexType>


 complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:email credit:url
used by
elements companyType/online personType/online employeeType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="credit:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


 complexType orgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/org
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
source <complexType name="orgLawType">
<attribute name="insured_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType outerCantonalType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element stationaryType/outercantonal
attributes parameters
Name | Type | Use | Default | Fixed
tax_city | credit:stringType1_35 |  |  |
tax_canton | derived by: NMTOKEN | required |  |
emergency_city | credit:stringType1_35 |  |  |
emergency_date | dateTime |  |  |
retransfer_date | dateTime |  |  |
cantonal_surgeon_inquired | boolean |  | false |
attributes annotations
Name | Notes
tax_city | tax_city is the patient main living place
tax_canton | canton is a Swiss canton or a country close to the border where the patient is paying taxes encoded by a terminal set of tokens. Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
emergency_city | In the case of an emergency (stationary@hospitalization_type = enEmergency) emergency_city is the city where that emergency happened. If this place is unknown or it is not an emergency the attribute is not set.
emergency_date | In the case of an emergency (stationary@hospitalization_type = enEmergency) emergency_date is the date and time when that emergency happened. If this date/time is unknown or it is not an emergency the attribute is not set.
retransfer_date | In the case of an emergency (stationary@hospitalization_type = enEmergency) retransfer_date is the date of the earliest transfer to a hospital of the tax canton. If this date is unknown or it is not an emergency the attribute is not set.
cantonal_surgeon_inquired | cantonal_surgeon_inquired confirms that a credit request was sent or will be send to the cantonal surgeon. This is obviously true for the cantonal surgeon as cost bearer and should be true for the credit request for the insurance.
attributes enumerations
Name | Extension | Base | Value | Annotations
tax_canton |  | NMTOKEN | AG | the canton is AG - Aargau
tax_canton |  | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
tax_canton |  | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
tax_canton |  | NMTOKEN | BE | the canton is BE - Bern
tax_canton |  | NMTOKEN | BL | the canton is BL - Baselland
tax_canton |  | NMTOKEN | BS | the canton is BS - Basel
tax_canton |  | NMTOKEN | FR | the canton is FR - Fribourg
tax_canton |  | NMTOKEN | GE | the canton is GE - Geneva
tax_canton |  | NMTOKEN | GL | the canton is GL - Glarus
tax_canton |  | NMTOKEN | GR | the canton is GR - Graubünden
tax_canton |  | NMTOKEN | JU | the canton is JU - Jura
tax_canton |  | NMTOKEN | LU | the canton is LU - Lucerne
tax_canton |  | NMTOKEN | NE | the canton is NE - Neuchâtel
tax_canton |  | NMTOKEN | NW | the canton is NW - Nidwalden
tax_canton |  | NMTOKEN | OW | the canton is OW - Obwalden
tax_canton |  | NMTOKEN | SG | the canton is SG - St. Gallen
tax_canton |  | NMTOKEN | SH | the canton is SH - Schaffhausen
tax_canton |  | NMTOKEN | SO | the canton is SO - Solothurn
tax_canton |  | NMTOKEN | SZ | the canton is SZ - Schwyz
tax_canton |  | NMTOKEN | TI | the canton is TI - Ticino
tax_canton |  | NMTOKEN | TG | the canton is TG - Thurgau
tax_canton |  | NMTOKEN | UR | the canton is UR - Uri
tax_canton |  | NMTOKEN | VD | the canton is VD - Vaud
tax_canton |  | NMTOKEN | VS | the canton is VS - Valais
tax_canton |  | NMTOKEN | ZG | the canton is ZG - Zug
tax_canton |  | NMTOKEN | ZH | the canton is ZH - Zürich
tax_canton |  | NMTOKEN | LI | the country is LI - Liechtenstein
tax_canton |  | NMTOKEN | A | the country is A - Austria
tax_canton |  | NMTOKEN | D | the country is D - Germany
tax_canton |  | NMTOKEN | F | the country is F - France
tax_canton |  | NMTOKEN | I | the country is I - Italy
source <complexType name="outerCantonalType">
<attribute name="tax_city" type="credit:stringType1_35"/>
<attribute name="tax_canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="emergency_city" type="credit:stringType1_35"/>
<attribute name="emergency_date" type="dateTime"/>
<attribute name="retransfer_date" type="dateTime"/>
<attribute name="cantonal_surgeon_inquired" type="boolean" default="false"/>
</complexType>


 complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:person credit:card
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
gender | gender defines the gender of the patient encoded by a terminal set of tokens
birthdate | birthdate defines the patient's birthdate
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender |  | NMTOKEN | male | the gender is male
gender |  | NMTOKEN | female | the gender is female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="credit:personType"/>
<element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="credit:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime" use="required"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="credit:stringType1_35"/>
<attribute name="validation_server" type="credit:stringType1_35"/>
</complexType>
</element>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType payloadType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:credit_ref credit:credit credit:body xenc:EncryptedData
used by
element responseType/payload
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN |  | new |
storno | boolean |  | false |
copy | boolean |  | false |
cost_estimate | boolean |  | false |
response_timestamp | unsignedLong | required |  |
attributes annotations
Name | Notes
type | type defines the typification of the credit request encoded by a terminal set of tokens
storno | storno augments the topmost object reference by a storno command. This attribute is copied from the received request
copy | copy augments the topmost object reference by a copy command This attribute is copied from the received request
cost_estimate | cost_estimate qualifies the credit request as a cost estimate. From a semantical point of view it is the same as a credit. However, the legal implications of a cost estimate vs a credit request might be different. But this difference is out of scope of this technical documentation. This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
attributes enumerations
Name | Extension | Base | Value | Annotations
type |  | NMTOKEN | new | the request is of type new - the new credit request
type |  | NMTOKEN | re-consideration | the request is of type re-consideration - new consideration of a previously rejected credit request
type |  | NMTOKEN | prolongation | the request is of type prolongation - the prolongation of a previously accepted credit request
source <complexType name="payloadType">
<sequence>
<element name="credit_ref" type="credit:creditType" minOccurs="0"/>
<element name="credit" type="credit:creditType"/>
<choice>
<element name="body" type="credit:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="type" default="new">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="new"/>
<enumeration value="re-consideration"/>
<enumeration value="prolongation"/>
</restriction>
</simpleType>
</attribute>
<attribute name="storno" type="boolean" default="false"/>
<attribute name="copy" type="boolean" default="false"/>
<attribute name="cost_estimate" type="boolean" default="false"/>
<attribute name="response_timestamp" type="unsignedLong" use="required"/>
</complexType>


 complexType pendingType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:statusType
properties
base credit:statusType
children | credit:justification credit:message credit:documents
used by
element bodyType/pending
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «pending» | credit:statusType
source <complexType name="pendingType">
<complexContent>
<extension base="credit:statusType">
<sequence>
<element name="justification" type="credit:stringType1_700" minOccurs="0"/>
<element name="message" type="credit:notificationType" minOccurs="0" maxOccurs="unbounded"/>
<element name="documents" type="credit:documentsType" minOccurs="0"/>
</sequence>
</extension>
</complexContent>
</complexType>


 complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:familyname credit:givenname credit:subaddressing credit:postal credit:telecom credit:online
used by
elements baseAddressType/person patientAddressType/person employerAddressType/person contactAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="credit:stringType1_35"/>
<element name="givenname" type="credit:stringType1_35"/>
<element name="subaddressing" type="credit:stringType1_35" minOccurs="0"/>
<element name="postal" type="credit:postalAddressType"/>
<element name="telecom" type="credit:telecomAddressType" minOccurs="0"/>
<element name="online" type="credit:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="credit:stringType1_35"/>
<attribute name="title" type="credit:stringType1_35"/>
</complexType>


 complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:pobox credit:street credit:zip credit:city
used by
elements companyType/postal personType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="credit:stringType1_35" minOccurs="0"/>
<element name="street" type="credit:stringType1_35" minOccurs="0"/>
<element name="zip" type="credit:zipType"/>
<element name="city" type="credit:stringType1_35"/>
</sequence>
</complexType>


 complexType processingType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:transport
used by
element responseType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="credit:transportType"/>
</sequence>
</complexType>


 complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:package credit:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="credit:softwareType" minOccurs="0"/>
<element name="generator" type="credit:softwareType"/>
</sequence>
</complexType>


 complexType rejectedType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:statusType
properties
base credit:statusType
children | credit:justification credit:error
used by
element bodyType/rejected
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «rejected» | credit:statusType
source <complexType name="rejectedType">
<complexContent>
<extension base="credit:statusType">
<sequence>
<element name="justification" type="credit:stringType1_700" minOccurs="0"/>
<element name="error" type="credit:errorType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


 complexType responseType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:processing credit:payload ds:Signature
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required |  |
modus | derived by: NMTOKEN |  | production |
attributes annotations
Name | Notes
language | language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers. The language used is copied from and thus defined by the request.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language |  | NMTOKEN | de | the data language is german
language |  | NMTOKEN | fr | the data language is french
language |  | NMTOKEN | it | the data language is italian
modus |  | NMTOKEN | production | the modus production (default value) is for normal processing
modus |  | NMTOKEN | test | the modus test is for software developers to test the processing.
source <complexType name="responseType">
<sequence>
<element name="processing" type="credit:processingType"/>
<element name="payload" type="credit:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
</complexType>


 complexType servicesType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:service
used by
element bodyType/services
source <complexType name="servicesType">
<sequence>
<element name="service" type="credit:serviceType" maxOccurs="unbounded"/>
</sequence>
</complexType>


 complexType serviceType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:cost_request credit:cost_response
used by
element servicesType/service
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required |  |
tariff_type | derived by: string |  |  |
code | credit:stringType1_30 |  |  |
name | credit:stringType1_350 | required |  |
attributes annotations
Name | Notes
record_id | record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
tariff_type | tariff_type is the official 3-character designator of the used tariff catalog as given by Forum Datenaustausch tariff_type might be empty in special cases where the service is not covered by a official tariff catalog
code | code is the code of the service record as given by the used tariff catalog code might be empty in special cases where the service is not covered by a official tariff catalog
name | name is the official service name as given by the used tariff catalog. If it is not a service in the narrow sense (not covered by an official tariff catalog) then it describes that service with best effort.
source <complexType name="serviceType">
<sequence>
<element name="cost_request" type="credit:costType"/>
<element name="cost_response" type="credit:costType" minOccurs="0"/>
</sequence>
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_type">
<simpleType>
<restriction base="string">
<pattern value="[0-9A-Z]{3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="credit:stringType1_30"/>
<attribute name="name" type="credit:stringType1_350" use="required"/>
</complexType>


 complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | credit:stringType1_50 | required |  |
copyright | credit:stringType1_50 |  |  |
description | credit:stringType1_50 |  |  |
version | unsignedInt |  |  |
id | unsignedInt |  | 0 |
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version | version defines the version of the software/module. Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="credit:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="credit:stringType1_50" use="required"/>
<attribute name="copyright" type="credit:stringType1_50"/>
<attribute name="description" type="credit:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


 complexType stationaryType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:outercantonal
used by
element treatmentType/stationary
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_type | derived by: NMTOKEN |  | regular |
hospitalization_mode | derived by: NMTOKEN |  | cantonal |
insurance_class | derived by: NMTOKEN |  | general |
insurance_model | derived by: NMTOKEN |  | standard |
section_major | credit:stringType1_6 |  |  |
attributes annotations
Name | Notes
hospitalization_type | hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
hospitalization_mode | hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
insurance_class | insurance_class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
insurance_model | insurance_model is a refinement of the insurance class coding encoded by a terminal set of tokens
section_major | section_major is the main section code (BfS section code) where the treatment is taking place as defined by Swiss Federal Statistical Office
attributes enumerations
Name | Extension | Base | Value | Annotations
hospitalization_mode |  | NMTOKEN | cantonal | the mode of hospitalization is cantonal - the patient's domicile is in the treatment canton
hospitalization_mode |  | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but the treatment is indicated. This case qualifies for the definition of an outer cantonal element.
hospitalization_mode |  | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and the treatment is not indicated. This case qualifies for the definition of an outer cantonal element.
hospitalization_type |  | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type |  | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_type |  | NMTOKEN | welfare | the type of hospitalization is welfare ("Fürsorglicher Freiheitsentzug")
insurance_class |  | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
insurance_class |  | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
insurance_class |  | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
insurance_model |  | NMTOKEN | standard | standard defines the standard insurance class without further refinements
insurance_model |  | NMTOKEN | hospital_comfort | hospital_comfort defines the hospitalization comfort refinement above the given insurance class
insurance_model |  | NMTOKEN | md_free_choice | md_free_choice defines the free choice of the physician ("Freie Arztwahl") refinement above the given insurance class
insurance_model |  | NMTOKEN | other | other defines a further refinement not given above
source <complexType name="stationaryType">
<sequence>
<element name="outercantonal" type="credit:outerCantonalType" minOccurs="0"/>
</sequence>
<attribute name="hospitalization_type" default="regular">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="regular"/>
<enumeration value="emergency"/>
<enumeration value="welfare"/>
</restriction>
</simpleType>
</attribute>
<attribute name="hospitalization_mode" default="cantonal">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="cantonal"/>
<enumeration value="noncantonal_indicated"/>
<enumeration value="noncantonal_nonindicated"/>
</restriction>
</simpleType>
</attribute>
<attribute name="insurance_class" default="general">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="private"/>
<enumeration value="semi_private"/>
<enumeration value="general"/>
</restriction>
</simpleType>
</attribute>
<attribute name="insurance_model" default="standard">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="standard"/>
<enumeration value="hospital_comfort"/>
<enumeration value="md_free_choice"/>
<enumeration value="other"/>
</restriction>
</simpleType>
</attribute>
<attribute name="section_major" type="credit:stringType1_6"/>
</complexType>


 complexType statusType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
complexTypes acceptedType pendingType rejectedType
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required |  |
status_out | derived by: NMTOKEN | required |  |
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
status_in |  | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_in |  | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_in |  | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_in |  | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_in |  | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_in |  | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_in |  | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
status_out |  | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_out |  | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_out |  | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_out |  | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_out |  | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_out |  | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_out |  | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
source <complexType name="statusType">
<attribute name="status_in" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
<attribute name="status_out" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
</complexType>


 complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:phone credit:fax
used by
elements companyType/telecom personType/telecom employeeType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="credit:stringType1_25" maxOccurs="3"/>
<element name="fax" type="credit:stringType1_25" minOccurs="0" maxOccurs="3"/>
</sequence>
</complexType>


 complexType transportType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | credit:eanPartyType | required |  |
to | credit:eanPartyType | required |  |
attributes annotations
Name | Notes
from | from is the EAN party that initially sent the infoset to the first intermediate In fact this is the mirrored to attribute from the request. Note, that the private certificate of this EAN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to | to is the EAN party that eventually receives the infoset from the last intermediate. In fact this is the mirrored from attribute from the request. Note, that the public certificate of this EAN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="credit:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="credit:eanPartyType" use="required"/>
<attribute name="to" type="credit:eanPartyType" use="required"/>
</complexType>


 complexType treatmentType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
children | credit:diagnosis credit:stationary
used by
element bodyType/treatment
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
treatment_units | credit:stringType1_100 |  |  |
canton | derived by: NMTOKEN | required |  |
reason | derived by: NMTOKEN | required |  |
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
date_begin | date_begin is the intended start of the treatment
treatment_units | treatment_units defines the number/length and unit of treatments. The treatment units are in fact context sensitive in their semantical meaning and therefore they are encoded by a string due to the variety of possibilities. Treatment units for stationary treatment are e.g. "4 days" whereas for a physio therapy it could be "6 physio sessions" or "10 physio sessions - 1 per week".
canton | canton is a Swiss canton or a country close to the border in which the treatment will take place encoded by a terminal set of tokens. Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
reason | reason is the primary reason of the intended treatment encoded by a terminal set of tokens
patient_id | patient_id is an optional patient identification of the main software ("Patientennummer").
case_id | case_id is an optional case identification of the main software ("Fallnummer"). In fact it is an ID used in the main software to identify this request and probably it is the same as the credit@request_id attribute.
attributes enumerations
Name | Extension | Base | Value | Annotations
canton |  | NMTOKEN | AG | the canton is AG - Aargau
canton |  | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
canton |  | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
canton |  | NMTOKEN | BE | the canton is BE - Bern
canton |  | NMTOKEN | BL | the canton is BL - Baselland
canton |  | NMTOKEN | BS | the canton is BS - Basel
canton |  | NMTOKEN | FR | the canton is FR - Fribourg
canton |  | NMTOKEN | GE | the canton is GE - Geneva
canton |  | NMTOKEN | GL | the canton is GL - Glarus
canton |  | NMTOKEN | GR | the canton is GR - Graubünden
canton |  | NMTOKEN | JU | the canton is JU - Jura
canton |  | NMTOKEN | LU | the canton is LU - Lucerne
canton |  | NMTOKEN | NE | the canton is NE - Neuchâtel
canton |  | NMTOKEN | NW | the canton is NW - Nidwalden
canton |  | NMTOKEN | OW | the canton is OW - Obwalden
canton |  | NMTOKEN | SG | the canton is SG - St. Gallen
canton |  | NMTOKEN | SH | the canton is SH - Schaffhausen
canton |  | NMTOKEN | SO | the canton is SO - Solothurn
canton |  | NMTOKEN | SZ | the canton is SZ - Schwyz
canton |  | NMTOKEN | TI | the canton is TI - Ticino
canton |  | NMTOKEN | TG | the canton is TG - Thurgau
canton |  | NMTOKEN | UR | the canton is UR - Uri
canton |  | NMTOKEN | VD | the canton is VD - Vaud
canton |  | NMTOKEN | VS | the canton is VS - Valais
canton |  | NMTOKEN | ZG | the canton is ZG - Zug
canton |  | NMTOKEN | ZH | the canton is ZH - Zürich
canton |  | NMTOKEN | LI | the country is LI - Liechtenstein
canton |  | NMTOKEN | A | the country is A - Austria
canton |  | NMTOKEN | D | the country is D - Germany
canton |  | NMTOKEN | F | the country is F - France
canton |  | NMTOKEN | I | the country is I - Italy
reason |  | NMTOKEN | disease | the reason of treatment is a disease
reason |  | NMTOKEN | accident | the reason of treatment is an accident
reason |  | NMTOKEN | maternity | the reason of treatment is a maternity
reason |  | NMTOKEN | prevention | the reason of treatment is prevention
reason |  | NMTOKEN | birthdefect | the reason of treatment a birthdefect
reason |  | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
source <complexType name="treatmentType">
<sequence>
<element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>
<element name="stationary" type="credit:stationaryType" minOccurs="0"/>
</sequence>
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="treatment_units" type="credit:stringType1_100"/>
<attribute name="canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="reason" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="disease"/>
<enumeration value="accident"/>
<enumeration value="maternity"/>
<enumeration value="prevention"/>
<enumeration value="birthdefect"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
<attribute name="patient_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
</complexType>


 complexType uvgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
source <complexType name="uvgLawType">
<attribute name="insured_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
<attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType vvgLawType
diagram
namespace http://www.forum-datenaustausch.ch/credit
used by
element bodyType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach VVG").
source <complexType name="vvgLawType">
<attribute name="insured_id" type="credit:stringType1_35"/>
<attribute name="case_id" type="credit:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType xenc:AgreementMethodType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 element xenc:AgreementMethodType/KA-Nonce
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


 element xenc:AgreementMethodType/OriginatorKeyInfo
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


 element xenc:AgreementMethodType/RecipientKeyInfo
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


 complexType xenc:CipherDataType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


 complexType xenc:CipherReferenceType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required |  |
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


 complexType xenc:EncryptedDataType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
Type | anyURI | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


 complexType xenc:EncryptedKeyType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
Type | anyURI | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
Recipient | string | optional |  |
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


 element xenc:ReferenceList
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


 element xenc:EncryptedKeyType/CarriedKeyName
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


 complexType xenc:EncryptedType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
Type | anyURI | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


 complexType xenc:EncryptionMethodType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


 complexType xenc:EncryptionPropertiesType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


 complexType xenc:EncryptionPropertyType
diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional |  |
Id | ID | optional |  |
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


 complexType xenc:ReferenceType
diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required |  |
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


 complexType xenc:TransformsType
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


 complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/credit
type | extension of credit:stringType1_9
properties
base credit:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | credit:stringType1_9 |  |  |
countrycode | credit:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code | credit:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="credit:stringType1_9">
<attribute name="statecode" type="credit:stringType1_9"/>
<attribute name="countrycode" type="credit:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


 element ds:Manifest
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="Manifest" type="ds:ManifestType"/>


 element ds:SignatureProperties
Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


 element xenc:AgreementMethod
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required |  |
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


 element xenc:EncryptedKey
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional |  |
Type | anyURI | optional |  |
MimeType | string | optional |  |
Encoding | anyURI | optional |  |
Recipient | string | optional |  |
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


 element xenc:ReferenceList/DataReference
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required |  |
source | <element name="DataReference" type="xenc:ReferenceType"/>


 element xenc:ReferenceList/KeyReference
Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required |  |
source | <element name="KeyReference" type="xenc:ReferenceType"/>


 simpleType ds:CryptoBinary
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


 simpleType ds:DigestValueType
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


 simpleType ds:HMACOutputLengthType
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


 simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes baseAddressType/@ean_party basicInsuranceAddressType/@ean_party employerAddressType/@ean_party contactAddressType/@ean_party transportType/@from transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="eanPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


 simpleType nifPartyType
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source <simpleType name="nifPartyType">
<restriction base="string">
<pattern value="[0-9]{1,7}"/>
</restriction>
</simpleType>


 simpleType nonEmptyStringType
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes documentType/@filename documentType/@mimeType
facets
minLength 1
source <simpleType name="nonEmptyStringType">
<restriction base="string">
<minLength value="1"/>
</restriction>
</simpleType>


 simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes patientAddressType/@ssn uvgLawType/@ssn ivgLawType/@ssn mvgLawType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}"/>
</restriction>
</simpleType>


 simpleType stringType0_350
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
complexType diagnosisType
facets
maxLength 350
source <simpleType name="stringType0_350">
<restriction base="string">
<maxLength value="350"/>
</restriction>
</simpleType>


 simpleType stringType1_100
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes coverageType/@coverage_units treatmentType/@treatment_units
facets
minLength | 1
maxLength | 100
source <simpleType name="stringType1_100">
<restriction base="string">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>


 simpleType stringType1_12
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute diagnosisType/@code
facets
minLength | 1
maxLength | 12
source <simpleType name="stringType1_12">
<restriction base="string">
<minLength value="1"/>
<maxLength value="12"/>
</restriction>
</simpleType>


 simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


 simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


 simpleType stringType1_30
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute serviceType/@code
facets
minLength | 1
maxLength | 30
source <simpleType name="stringType1_30">
<restriction base="string">
<minLength value="1"/>
<maxLength value="30"/>
</restriction>
</simpleType>


 simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname employeeType/familyname personType/givenname employeeType/givenname postalAddressType/pobox postalAddressType/street companyType/subaddressing personType/subaddressing
attributes | patientAddressType/card/@card_id orgLawType/@case_id treatmentType/@case_id mvgLawType/@case_id uvgLawType/@case_id kvgLawType/@case_id vvgLawType/@case_id orgLawType/@contract_number mvgLawType/@contract_number ivgLawType/@contract_number uvgLawType/@contract_number vvgLawType/@contract_number kvgLawType/@contract_number outerCantonalType/@emergency_city vvgLawType/@insured_id uvgLawType/@insured_id kvgLawType/@insured_id mvgLawType/@insured_id orgLawType/@insured_id treatmentType/@patient_id employerAddressType/@reg_number creditType/@request_id coverageType/@response_id bodyType/@role_title employeeType/@salutation personType/@salutation outerCantonalType/@tax_city employeeType/@title personType/@title patientAddressType/card/@validation_id patientAddressType/card/@validation_server
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


 simpleType stringType1_350
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes errorType/@error_value serviceType/@name diagnosisType/@remark costType/@remark baseAddressType/@specialty notificationType/@text errorType/@valid_value
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


 simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


 simpleType stringType1_6
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute stationaryType/@section_major
facets
minLength | 1
maxLength | 6
source <simpleType name="stringType1_6">
<restriction base="string">
<minLength value="1"/>
<maxLength value="6"/>
</restriction>
</simpleType>


 simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


 simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
elements acceptedType/addendum pendingType/justification acceptedType/justification rejectedType/justification bodyType/measures bodyType/remark
facets
minLength | 1
maxLength | 700
source <simpleType name="stringType1_700">
<restriction base="string">
<minLength value="1"/>
<maxLength value="700"/>
</restriction>
</simpleType>


 simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
complexType | zipType
attributes | notificationType/@code zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


 simpleType zsrPartyType
namespace | http://www.forum-datenaustausch.ch/credit
type | restriction of string
used by
attribute baseAddressType/@zsr
facets
pattern ([A-Z][0-9]{6})
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="([A-Z][0-9]{6})"/>
</restriction>
</simpleType>