XML Schema Browser - generalFormRequest Version 450

Documentation
generalFormRequest V450

produced by Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as standard in the meeting on 2nd September 2016.

The standard becomes applicable on 1st January 2017.

Copyright (©) by Forum Datenaustausch, 02.09.2016 - all rights reserved


Revision history of the documentation

Documentation of generalFormRequest_450.xsd

Copyright (©) by Forum Datenaustausch, 02.09.2016
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalFormRequest_450.xsd schema is not changed due to such an entry.
  • Revision 1 from 02.09.2016


Revision history: Documentation revision 1

Documentation revision 1

Rev. 1/02.09.2016: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the generalFormRequest_450.xsd schema


Preface

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Forum Datenaustausch

Im "Forum Datenaustausch" haben sich verschiedene Akteure des Schweizer Gesundheitswesens zusammengeschlossen. Das Forum verfolgt u.a. das Ziel, einheitliche, gemeinsam entwickelte Standards für den elektronischen Datenaustausch festzusetzen.

Forumsmitglieder sind die Verbände der Leistungserbringer FMH, H+ und der Schweizerische Apothekerverband (SAV), auf Seiten der Kostenträger sind es santésuisse, der Schweizerische Versicherungsverband (SVV) sowie die Suva, die Militärversicherung und die Invalidenversicherung (IV).

Die vom Forum verabschiedeten Standards, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert. Dazu gehört auch die elektronische, XML basierende Leistungsabrechnung für Ärzte und Spitäler.

Die Gesellschaft bezweckt die Vereinheitlichung der Standards des elektronischen Datenaustausches im Schweizer Gesundheitswesen zwischen Leistungserbringern und Kostenträgern. Ziel ist die Festlegung von Grundsätzen mit Bezug auf die Übermittlungsstandards, die Referenzstammdaten sowie mit Bezug auf die Kriterien betreffend die Datensicherheit. Damit soll den Gesellschaftern der Aufbau von Kooperationsbeziehungen im Bereich des elektronischen Datenaustausches erleichtert werden.
Différents acteurs du domaine de la santé publique suisse se sont joints au "Forum Datenaustausch". L'objectif du forum consiste, entre autres, à établir des standards uniformes élaborés en commun pour l'échange électronique de données.

Les membres du forum sont les associations de prestataires FMH, H+ et la Société Suisse des Pharmaciens (SSPh) ainsi que, du côté des assureurs, santésuisse, l'Association Suisse d'Assurances (ASA), la Suva, l'assurance militaire et l'assurance invalidité (AI).

Les standards établis par le forum, tels les messages XML pour l'échange électronique de données, seront publiés ici. Ils englobent également le décompte électronique de prestations basé sur XML pour les médecins et les hôpitaux.

La société a pour but d'uniformiser les standards relatifs au transfert électronique de données dans la domaine de la santé suisse entre fournisseurs de prestations et assureurs. L'objectif consiste à déterminer des principes liés aux standards de transmission, aux données de base de référence ainsi qu'aux critères concernant la sécurité des données. Pour les membres de la société, cela devrait faciliter l'établissement de relations de coopération dans le domaine du transfert électronique de données.


Copyright (©) notice

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Purpose of the schema file

This is the schema definition for a "General Form Request" process encoded in XML. The content basically is a filled out and Base64 encoded PDF form as well as the extracted list of all PDF tokens (variable name/variable value pairs). Furthermore, relevant subsets of the tokens are joined to form structured addresses of a defined semantical meaning.

The request is sent via 1 or more intermediates to the final recipient. It is the intermediate's responsibility to route the request to another intermediate until it can be delivered to the final recipient.

The subchapter Purpose::Anatomy of a request provides a broad overview about the building blocks of a request.
Each individual request is defined by a unique triple of data denoted as object reference. A "General Form Request" can hold a maximum of 2 object references, namely

  • an optional dependent object reference of type { credit | invoice | reminder | mcd | form } to link the current form request to that dependent object reference
  • a mandatory form object reference generated in the initial "General Form Request" process
This set of object references by itself defines an ordered object reference chain (e.g. invoice -> form) with the topmost object reference as unique identification of the XML request. The subchapter Purpose::Object reference provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

Besides the topmost object reference the XML request is further specified by a set of process attributes, namely

  • the optional copy attribute defining the XML request as an identical copy of an initial request.
  • the optional storno attribute cancelling the XML request defined by the topmost object reference.
The copy and storno attributes can be combined to form a total of 4 different combinations. The subchapter Purpose::Process attributes provides an in-depth description of these attributes.

Upon receiving the XML request the recipient can respond by [0,n] "General Form Response" messages, whereas the content per definition defines an answer to the topmost object reference - and only to that object!

This xmlForm project is normative for the electronic form process in Switzerland.


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Anatomy of a request

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a request.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information or external institutions must validate the data, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Form Request" can hold a maximum of 2 object references, namely
  • an optional dependent object reference of type { credit | invoice | reminder | mcd | form | notification } due to which a form process was initiated
  • a mandatory form object reference from the initial "General Form Request" process itself
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> form) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


Process attributes

Process attributes

An XML request is primarily defined by its topmost object reference (see Purpose::Object reference). However, the XML request is further characterized by a state that is formed by a set of Boolean process attributes, namely

copy attribute

The copy attribute defines the XML request as an identical copy of an initial request.
The absence of the copy attribute in reverse defines the XML request as "normal" (initial) request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

storno attribute

The storno attribute cancels the XML request defined by the topmost reference object.
The absence of the storno attribute in reverse defines the XML request as "normal" request.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

The copy and storno attributes can be combined to form a total of 4 different combinations.


Notes about the signature

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/form:request/form:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>
  <Reference URI="#xpointer(/form:request/form:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#tripledes-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-1_5"/>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/form"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:form="http://www.forum-datenaustausch.ch/form"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag form followed by the element name. Furthermore, the target namespace and the specific namespace form maps to http://www.forum-datenaustausch.ch/form.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<form:request xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:form="http://www.forum-datenaustausch.ch/form"
        xmlns="http://www.forum-datenaustausch.ch/form"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/form generalFormRequest_450.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </form:request>


Notes about forms...

Notes about forms...

The following paragraphs outline the blue print of the form system and supplies information about the involved PDF forms.
  • generalFormRequest_450 / generalFormRequest430 schemas:
    The generalFormRequest_450.xsd or generalFormRequest_430.xsd schemas build the skeleton to exchange a filled out form from the producer to the consumer. The form itself is a PDF form built on Adobe's PDF form technology. The XML infoset basically holds two types of data.
    1. the filled out PDF form as a BASE64 coded octet stream as legal and visual representation of the form
    2. the full list of tokens (variable name/value pairs) of the PDF itself extracted as semantical essence from the PDF and supplied as list of XML elements.

  • Identification of a PDF form:
    The PDF form itself is identified in the XML infoset by a unique OID that stems from an official form provider system. The form OID is a unique identification for the corresponding PDF form and is never re-defined or used in any other context.

    Since the number of PDF forms is dynamically growing as the system evolves the corresponding the OID space can not be defined in advanced and once forever. Therefore, the list of current PDF forms and corresponding OIDs are maintained on a form provider's website. The list of these form providers is supplied on the Forum Datenaustausch website.
  • Mechanism for starting a form process:
    A form process is started -apart from any verbal communication- by setting the pdf_form_oid attribute in a general notification process. Under such a condition the recipient of the notification starts a form process as outlined e.g. in the documentation of the generalNotification_450.xsd.


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element request down as the appropriate definition is encountered.


element request

Annotation The request element is the root of the formRequest process.
The request is divided into 2 parts
  • the processing element supplies the necessary data for the transport
  • the payload element supplies the structured form data as well as the filled out PDF form as Base64 inline document
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:requestType
properties
content complex
children | form:processing form:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name | Notes
language | language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus is production (default value) for normal processing
modus | NMTOKEN | test | the modus is test for software developers to test the processing.
source | <element name="request" type="form:requestType"/>


element requestType/processing

Annotation | The processing element is a container for processing instructions at an intermediate's site (e.g. printing a patient copy, transport routing etc.) as well as processing and validations at external sites.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:processingType
properties
isRef | 0
content | complex
children | form:transport
source | <element name="processing" type="form:processingType"/>


element processingType/transport

Annotation | The transport element defines the routing of the infoset going from a sender party over any number of intermediates to a receiver party. All the involved parties are defined by Global Location Numbers (GLN) as defined by RefData
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:transportType
properties
isRef | 0
content | complex
children | form:via
attributes parameters
Name | Type | Use | Default | Fixed
from | form:eanPartyType | required
to | form:eanPartyType | required
attributes annotations
Name | Notes
from | from is the GLN party that initially sent the infoset to the first intermediate
to | to is the GLN party that eventually receives the infoset from the last intermediate
source | <element name="transport" type="form:transportType"/>


element transportType/via

Annotation The via element is one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly add a further via element if this intermediate has to route the infoset to another intermediate instead of deliver to the recipient.
diagram
namespace http://www.forum-datenaustausch.ch/form
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | form:eanPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is an GLN party of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming a chain of intermediate hops
source <element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="form:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element requestType/payload

Annotation | The payload element supplies the invoice/reminder data and will not be altered in the transport process. The payload can optionally be signed by at W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:payloadType
properties
isRef | 0
content | complex
children | form:credit_ref form:invoice_ref form:reminder_ref form:mcd_ref form:form_ref form:notification_ref form:form form:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
attributes annotations
Name | Notes
storno | storno augments the form reference object by a storno command.
copy | copy augments the form reference object by a copy command that is the form reference object is an identical clone (except for the copy attribute) of a prior sent request.
source | <element name="payload" type="form:payloadType"/>


element payloadType/credit_ref

Annotation The credit_ref element defines the dependent object reference of type credit. By definition this constitutes a object reference chain (credit_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="credit_ref" type="form:objectType"/>


element payloadType/invoice_ref

Annotation The invoice_ref element defines the dependent object reference of type invoice. By definition this constitutes a object reference chain (invoice_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="invoice_ref" type="form:objectType"/>


element payloadType/reminder_ref

Annotation The reminder_ref element defines the dependent object reference of type reminder. By definition this constitutes a object reference chain (reminder_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="reminder_ref" type="form:objectType"/>


element payloadType/mcd_ref

Annotation The mcd_ref element defines the dependent object reference of type MCD. By definition this constitutes a object reference chain (mcd_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="mcd_ref" type="form:objectType"/>


element payloadType/form_ref

Annotation The form_ref element defines the dependent object reference of type form. By definition this constitutes a object reference chain (form_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="form_ref" type="form:objectType"/>


element payloadType/notification_ref

Annotation The notification_ref element defines the dependent object reference of type notification. By definition this constitutes a object reference chain (notification_ref >> form).
This reference object is the primary reason why the form request was initiated. This object reference is mirrored unaltered in any response to that request.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="notification_ref" type="form:objectType"/>


element payloadType/form

Annotation The form element defines the unique form reference object.
This object is firstly produced when generating the original for infoset. Any further processing (sending a copy or cancelling the form) references this same object unaltered!
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="form" type="form:objectType"/>


element payloadType/body

Annotation | The body element contains all the structured form data including possibly sensitive patient data (data privacy relevant). Therefore the body element can be replace by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:bodyType
properties
isRef | 0
content | complex
children | form:prolog form:producer form:consumer form:patient form:data form:documents
attributes parameters
Name | Type | Use | Default | Fixed
role_title | form:stringType1_35
role | derived by: NMTOKEN | required
place | derived by: NMTOKEN | required
attributes annotations
Name | Notes
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
role | role defines the principal role of the main provider ("what is the main provider") encoded by a terminal set of tokens
place | place defines the principal place of the main provider ("where is the main provider") encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
place | NMTOKEN | practice | the main place of the service provision is at a practice
place | NMTOKEN | hospital | the main place of the service provision is at a hospital
place | NMTOKEN | lab | the main place of the service provision is at a lab
place | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role | NMTOKEN | physician | the principal role of the service provider is physician
role | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role | NMTOKEN | midwife | the principal role of the service provider is midwife
role | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role | NMTOKEN | hospital | the principal role of the service provider is hospital
role | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role | NMTOKEN | druggist | the principal role of the service provider is druggist
role | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
role | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
role | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source | <element name="body" type="form:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator, tariff validators, and main software).
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:prologType
properties
isRef | 0
content | complex
children | form:package form:generator
source | <element name="prolog" type="form:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_50 | required
copyright | form:stringType1_50
description | form:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="form:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_50 | required
copyright | form:stringType1_50
description | form:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="form:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:softwareType
properties
isRef | 0
content | complex
children | form:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_50 | required
copyright | form:stringType1_50
description | form:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="form:softwareType"/>


element bodyType/producer

Annotation | The producer element defines the legal producing entity of the form request. In most cases this address party is identical to the provider address party who is by definition the originator of all medical data involved. However, it might be possible that the legal responsible is different as e.g. in a hospital where the hospital itself is the responsible but the medical data stem from a physician of that hospital.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:baseAddressType
properties
isRef | 0
content | complex
children | form:company form:person
attributes parameters
Name | Type | Use | Default | Fixed
ean | form:eanPartyType | required
zsr | form:zsrPartyType
specialty | form:stringType1_350
attributes annotations
Name | Notes
ean | ean is the company's/person's GLN as defined by RefData
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="producer" type="form:baseAddressType"/>


element baseAddressType/company

Annotation | The base address is one of a company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:companyType
properties
isRef | 0
content | complex
children | form:companyname form:department form:subaddressing form:postal form:telecom form:online
source | <element name="company" type="form:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="form:stringType1_35"/>


element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="form:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="form:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:postalAddressType
properties
isRef | 0
content | complex
children | form:pobox form:street form:zip form:city
source | <element name="postal" type="form:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="form:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="street" type="form:stringType1_35" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | form:stringType1_9
countrycode | form:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="zip" type="form:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="form:stringType1_35"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:phone form:fax
source | <element name="telecom" type="form:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either fixnet or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="form:stringType1_25" maxOccurs="3"/>


element telecomAddressType/fax

Annotation | The fax element supplies a telefax number
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_25
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="fax" type="form:stringType1_25" minOccurs="0" maxOccurs="3"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:email form:url
source | <element name="online" type="form:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | restriction of form:stringType1_70
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 70
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="form:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/url

Annotation | The url element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 100
source <element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>


element baseAddressType/person

Annotation | The base address is one of a person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:personType
properties
isRef | 0
content | complex
children | form:familyname form:givenname form:subaddressing form:postal form:telecom form:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | form:stringType1_35
title | form:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="form:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="form:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="form:stringType1_35" minOccurs="0"/>


element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="form:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:postalAddressType
properties
isRef | 0
content | complex
children | form:pobox form:street form:zip form:city
source | <element name="postal" type="form:postalAddressType"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:phone form:fax
source | <element name="telecom" type="form:telecomAddressType" minOccurs="0"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:email form:url
source | <element name="online" type="form:onlineAddressType" minOccurs="0"/>


element bodyType/consumer

Annotation | The consumer element defines the consuming entity of the form request. From a semantical point of view the consumer is identical to the recipient. However, recipient would become sender in a response while consumer does not change.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:baseAddressType
properties
isRef | 0
content | complex
children | form:company form:person
attributes parameters
Name | Type | Use | Default | Fixed
ean | form:eanPartyType | required
zsr | form:zsrPartyType
specialty | form:stringType1_350
attributes annotations
Name | Notes
ean | ean is the company's/person's GLN as defined by RefData
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="consumer" type="form:baseAddressType"/>


element bodyType/patient

Annotation | The optional patient element defines the patient's address if defined inside the PDF document
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:patientAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:person form:card
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN
birthdate | dateTime
ssn | form:ssnPartyType
attributes annotations
Name | Notes
gender | gender defines the gender of the patient encoded by a terminal set of tokens
birthdate | birthdate defines the patient's birthdate
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source | <element name="patient" type="form:patientAddressType" minOccurs="0"/>


element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:personType
properties
isRef | 0
content | complex
children | form:familyname form:givenname form:subaddressing form:postal form:telecom form:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | form:stringType1_35
title | form:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="form:personType"/>


element patientAddressType/card

Annotation | The card element is a container for information about the patient's insurance card (might be about the patient card later on)
diagram
namespace | http://www.forum-datenaustausch.ch/form
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
card_id | form:stringType1_35 | required
expiry_date | dateTime | required
validation_date | dateTime
validation_id form:stringType1_35
validation_server form:stringType1_35
attributes annotations
Name | Notes
card_id | card_id is the unique 20 digits card identifier
expiry_date | expiry_date is the expiry date of the card
validation_date | validation_date is the date of the last validation of the card's data
validation_id | validation_id is the replied id of the last validation of the card's data
validation_server | validation_server is the used server for the last validation process
source <element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="form:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime" use="required"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="form:stringType1_35"/>
<attribute name="validation_server" type="form:stringType1_35"/>
</complexType>
</element>


element bodyType/data

Annotation | The data element encapsulates the PDF data. The element contains all PDF variables found inside the given PDF form as well as the PDF form itself defined as a Base64 encoded octet stream.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:dataType
properties
isRef | 0
content | complex
children | form:pdf_data form:pdf_file
attributes parameters
Name | Type | Use | Default | Fixed
pdf_form_oid | form:stringType1_255
pdf_form_version | unsignedInt
attributes annotations
Name | Notes
pdf_form_oid | pdf_form_oid is a unique OID of the PDF form used in the form process.
pdf_form_version pdf_form_version defines the version of the PDF form used in the form process.
Since this is an integer coding use 100*main version + minor version as the version
source | <element name="data" type="form:dataType"/>


element dataType/pdf_data

Annotation | The pdf_data element is the container for all structured and unstructured PDF variables found inside the given PDF form.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:pdfDataType
properties
isRef | 0
content | complex
children | form:address form:kvg form:vvg form:uvg form:ivg form:mvg form:org form:tokens
source | <element name="pdf_data" type="form:pdfDataType"/>


element pdfDataType/address

Annotation | The optional address element defines all structured addresses available in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:genericAddressType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
children | form:company form:person
attributes parameters
Name | Type | Use | Default | Fixed
ean | form:eanPartyType
zsr | form:zsrPartyType
nif | form:nifPartyType
reg_number | form:stringType1_35
specialty | form:stringType1_350
address_role_type | derived by: NMTOKEN | required
address_role_name | form:stringType1_35
attributes annotations
Name | Notes
ean | ean is the optional GLN of the addressee as defined by RefData
zsr | zsr is the optional ZSR (KSK) number of the addressee as defined by Santésuisse
nif | nif is the optional IV specific identification number of the addressee
reg_number | reg_number is the optional national BUR number of the addressee as defined by Swiss Federal Statistical Office
specialty | specialty is the optional addressee's specialty (branch of medical science a doctor practices)
address_role_type | address_role_type is qualification of the address role encoded by a terminal set of tokens
address_role_name | address_role_type optionally further defines the address_role_type if the address_role_type=other!
attributes enumerations
Name | Extension | Base | Value | Annotations
address_role_type | NMTOKEN | producer | the supplied address if of type producer - the address party that is the legal responsible for the form.
address_role_type | NMTOKEN | consumer | the supplied address if of type consumer - the address party to whom the filled out form is sent.
address_role_type | NMTOKEN | guarantor | the supplied address if of type guarantor - the address party that is the legal representative of the patient
address_role_type | NMTOKEN | provider | the supplied address if of type provider - the address party that by definition provides any medical data defined in the form.
address_role_type | NMTOKEN | referrer | the supplied address if of type referrer - the address party that originally sent a request for treatment to the provider address party.
address_role_type | NMTOKEN | insurance | the supplied address if of type insurance - the address part of the health insurance of the patient.
address_role_type | NMTOKEN | employer | the supplied address if of type employer - the address party of the patient's employer.
address_role_type | NMTOKEN | other | the supplied address if of type other - an address party that is not covered by one of the specified address roles defined above.
source | <element name="address" type="form:genericAddressType" minOccurs="0" maxOccurs="unbounded"/>


element genericAddressType/company

Annotation | The generic address is defined by a company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:companyType
properties
isRef | 0
content | complex
children | form:companyname form:department form:subaddressing form:postal form:telecom form:online
source | <element name="company" type="form:companyType"/>


element genericAddressType/person

Annotation | The generic address is defined by a person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:personType
properties
isRef | 0
content | complex
children | form:familyname form:givenname form:subaddressing form:postal form:telecom form:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | form:stringType1_35
title | form:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="form:personType"/>


element pdfDataType/kvg

Annotation | The kvg element defines the applicable law as KVG ("Krankenversicherungsgesetz") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:kvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | form:stringType1_35
case_id | form:stringType1_35
case_date | dateTime
contract_number | form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach KVG").
source | <element name="kvg" type="form:kvgLawType"/>


element pdfDataType/vvg

Annotation | The vvg element defines the applicable law as VVG ("Versicherungsvertragsgesetz") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:vvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | form:stringType1_35
case_id | form:stringType1_35
case_date | dateTime
contract_number | form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach VVG").
source | <element name="vvg" type="form:vvgLawType"/>


element pdfDataType/uvg

Annotation | The uvg element defines the applicable law as UVG ("Unfallversicherungsgesetz") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:uvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | form:stringType1_35
case_id | form:stringType1_35
case_date | dateTime
contract_number | form:stringType1_35
ssn | form:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
source | <element name="uvg" type="form:uvgLawType"/>


element pdfDataType/ivg

Annotation | The ivg element defines the applicable law as IVG ("Invalidenversicherungsgesetz") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:ivgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string
case_date | dateTime
contract_number | form:stringType1_35
ssn | form:ssnPartyType
nif | form:nifPartyType
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
nif | nif is the IV specific identification number for the provider.
source | <element name="ivg" type="form:ivgLawType"/>


element pdfDataType/mvg

Annotation | The mvg element defines the applicable law as MVG ("Militäversicherungsgesetz") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:mvgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | form:stringType1_35
case_id | form:stringType1_35
case_date | dateTime
contract_number | form:stringType1_35
ssn | form:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
source | <element name="mvg" type="form:mvgLawType"/>


element pdfDataType/org

Annotation | The org element defines the applicable law as ORG ("Obligationenrecht") if defined in the PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:orgLawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
insured_id | form:stringType1_35
case_id | form:stringType1_35
case_date | dateTime
contract_number | form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
source | <element name="org" type="form:orgLawType"/>


element pdfDataType/tokens

Annotation The tokens element is the container for all tokens (variable name/variable value pairs) defined in the PDF form document.
Note that all tokens are given here even so some of these tokens are defined already in a structured parts like the address.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:tokensType
properties
isRef | 0
content | complex
children | form:string_token form:int_token form:float_token form:date_token form:boolean_token
source | <element name="tokens" type="form:tokensType"/>


element tokensType/string_token

Annotation The string_token element defines string token (variable name/variable value pair).
The value range for the string is [0,700] characters.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:stringTokenType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | form:stringType0_700
attributes annotations
Name | Notes
name | name defines the name of the string token
value | value is value of the string token
source | <element name="string_token" type="form:stringTokenType"/>


element tokensType/int_token

Annotation The int_token element defines integer token (variable name/variable value pair)
The value range is a 32-bit signed integer as defined by W3C
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:intTokenType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | int
attributes annotations
Name | Notes
name | name defines the name of the integer number token
value | value is value of the integer number token
source | <element name="int_token" type="form:intTokenType"/>


element tokensType/float_token

Annotation The float_token element defines floating point number token (variable name/variable value pair)
The value range is a IEEE 32-bit floating point number as defined by W3C
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:floatTokenType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | float
attributes annotations
Name | Notes
name | name defines the name of the floating point number token
value | value is value of the floating point number token
source | <element name="float_token" type="form:floatTokenType"/>


element tokensType/date_token

Annotation The date_token element defines date/time token (variable name/variable value pair)
The value range is an instant of time as type dateTime as defined by W3C
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:dateTokenType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | dateTime
attributes annotations
Name | Notes
name | name defines the name of the date&time token
value | value is value of the date&time token
source | <element name="date_token" type="form:dateTokenType"/>


element tokensType/boolean_token

Annotation The boolean_token element defines boolean token (variable name/variable value pair)
The value range is a boolean with {true | false} as defined by W3C
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:booleanTokenType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | boolean
attributes annotations
Name | Notes
name | name defines the name of the boolean token
value | value is value of the boolean token
source | <element name="boolean_token" type="form:booleanTokenType"/>


element dataType/pdf_file

Annotation | The pdf_file element is the container for the Base64 encoded PDF form document.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:pdfFileType
properties
isRef | 0
content | complex
children | form:base64
attributes parameters
Name | Type | Use | Default | Fixed
filename | form:stringType1_255 | required
mimeType | form:stringType1_35 | application/pdf
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. Since the coded document is a PDF, this MIME is fixed to application/pdf.
source | <element name="pdf_file" type="form:pdfFileType"/>


element pdfFileType/base64

Annotation | The base64 element includes the PDF into the infoset as a Base64 encode octet stream representation.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element bodyType/documents

Annotation | The documents element is an optional container for including inline, Base64-coded documents.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | form:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="form:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline and Base64-coded.
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | form:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | form:base64
attributes parameters
Name | Type | Use | Default | Fixed
title | form:stringType1_35 | required
filename | form:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Forum Datenaustausch.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source | <element name="document" type="form:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet streams
diagram
namespace | http://www.forum-datenaustausch.ch/form
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the end recipient of this infoset (mostly the insurance).
See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the biller.
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType requestType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

B
baseAddressType
bodyType
booleanTokenType
C
companyType
D
dataType
dateTokenType
dependsOnType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
eanPartyType
F
floatTokenType
G
genericAddressType
I
intTokenType
ivgLawType
K
kvgLawType
M
mvgLawType
N
nifPartyType
O
objectType
onlineAddressType
orgLawType
P
patientAddressType
payloadType
pdfDataType
pdfFileType
personType
postalAddressType
processingType
prologType
R
requestType
S
softwareType
ssnPartyType
stringTokenType
stringType0_700
stringType1_100
stringType1_25
stringType1_255
stringType1_3
stringType1_35
stringType1_350
stringType1_50
stringType1_70
stringType1_9
T
telecomAddressType
tokensType
transportType
U
uvgLawType
V
vvgLawType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z


complexType baseAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:company form:person
used by
elements bodyType/consumer bodyType/producer
attributes parameters
Name | Type | Use | Default | Fixed
ean | form:eanPartyType | required
zsr form:zsrPartyType
specialty form:stringType1_350
attributes annotations
Name | Notes
ean | ean is the company's/person's GLN as defined by RefData
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source <complexType name="baseAddressType">
<choice>
<element name="company" type="form:companyType"/>
<element name="person" type="form:personType"/>
</choice>
<attribute name="ean" type="form:eanPartyType" use="required"/>
<attribute name="zsr" type="form:zsrPartyType"/>
<attribute name="specialty" type="form:stringType1_350"/>
</complexType>


complexType bodyType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:prolog form:producer form:consumer form:patient form:data form:documents
used by
element payloadType/body
attributes parameters
Name | Type | Use | Default | Fixed
role_title form:stringType1_35
role | derived by: NMTOKEN | required
place | derived by: NMTOKEN | required
attributes annotations
Name | Notes
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
role | role defines the principal role of the main provider ("what is the main provider") encoded by a terminal set of tokens
place | place defines the principal place of the main provider ("where is the main provider") encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
place | NMTOKEN | practice | the main place of the service provision is at a practice
place | NMTOKEN | hospital | the main place of the service provision is at a hospital
place | NMTOKEN | lab | the main place of the service provision is at a lab
place | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role | NMTOKEN | physician | the principal role of the service provider is physician
role | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role | NMTOKEN | midwife | the principal role of the service provider is midwife
role | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role | NMTOKEN | hospital | the principal role of the service provider is hospital
role | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role | NMTOKEN | druggist | the principal role of the service provider is druggist
role | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
role | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
role | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="form:prologType"/>
<element name="producer" type="form:baseAddressType"/>
<element name="consumer" type="form:baseAddressType"/>
<element name="patient" type="form:patientAddressType" minOccurs="0"/>
<element name="data" type="form:dataType"/>
<element name="documents" type="form:documentsType" minOccurs="0"/>
</sequence>
<attribute name="role_title" type="form:stringType1_35"/>
<attribute name="role" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="physician"/>
<enumeration value="physiotherapist"/>
<enumeration value="chiropractor"/>
<enumeration value="ergotherapist"/>
<enumeration value="nutritionist"/>
<enumeration value="midwife"/>
<enumeration value="logotherapist"/>
<enumeration value="hospital"/>
<enumeration value="pharmacist"/>
<enumeration value="dentist"/>
<enumeration value="labtechnician"/>
<enumeration value="dentaltechnician"/>
<enumeration value="othertechnician"/>
<enumeration value="psychologist"/>
<enumeration value="wholesaler"/>
<enumeration value="nursingstaff"/>
<enumeration value="transport"/>
<enumeration value="druggist"/>
<enumeration value="naturopathicdoctor"/>
<enumeration value="naturopathictherapist"/>
<enumeration value="other"/>
</restriction>
</simpleType>
</attribute>
<attribute name="place" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="practice"/>
<enumeration value="hospital"/>
<enumeration value="lab"/>
<enumeration value="association"/>
<enumeration value="company"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType booleanTokenType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element tokensType/boolean_token
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | boolean
attributes annotations
Name | Notes
name | name defines the name of the boolean token
value | value is value of the boolean token
source <complexType name="booleanTokenType">
<attribute name="name" type="form:stringType1_100" use="required"/>
<attribute name="value" type="boolean"/>
</complexType>


complexType companyType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:companyname form:department form:subaddressing form:postal form:telecom form:online
used by
elements baseAddressType/company genericAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="form:stringType1_35"/>
<element name="department" type="form:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="form:stringType1_35" minOccurs="0"/>
<element name="postal" type="form:postalAddressType"/>
<element name="telecom" type="form:telecomAddressType" minOccurs="0"/>
<element name="online" type="form:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType dataType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:pdf_data form:pdf_file
used by
element bodyType/data
attributes parameters
Name | Type | Use | Default | Fixed
pdf_form_oid form:stringType1_255
pdf_form_version | unsignedInt
attributes annotations
Name | Notes
pdf_form_oid | pdf_form_oid is a unique OID of the PDF form used in the form process.
pdf_form_version pdf_form_version defines the version of the PDF form used in the form process.
Since this is an integer coding use 100*main version + minor version as the version
source <complexType name="dataType">
<sequence>
<element name="pdf_data" type="form:pdfDataType"/>
<element name="pdf_file" type="form:pdfFileType"/>
</sequence>
<attribute name="pdf_form_oid" type="form:stringType1_255"/>
<attribute name="pdf_form_version" type="unsignedInt"/>
</complexType>


complexType dateTokenType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element tokensType/date_token
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | dateTime
attributes annotations
Name | Notes
name | name defines the name of the date&time token
value | value is value of the date&time token
source <complexType name="dateTokenType">
<attribute name="name" type="form:stringType1_100" use="required"/>
<attribute name="value" type="dateTime"/>
</complexType>


complexType dependsOnType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_50 | required
copyright form:stringType1_50
description form:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="form:stringType1_50" use="required"/>
<attribute name="copyright" type="form:stringType1_50"/>
<attribute name="description" type="form:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType documentsType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="form:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
title | form:stringType1_35 | required
filename | form:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Forum Datenaustausch.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="title" type="form:stringType1_35" use="required"/>
<attribute name="filename" type="form:stringType1_255" use="required"/>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType floatTokenType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element tokensType/float_token
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | float
attributes annotations
Name | Notes
name | name defines the name of the floating point number token
value | value is value of the floating point number token
source <complexType name="floatTokenType">
<attribute name="name" type="form:stringType1_100" use="required"/>
<attribute name="value" type="float"/>
</complexType>


complexType genericAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:company form:person
used by
element pdfDataType/address
attributes parameters
Name | Type | Use | Default | Fixed
ean form:eanPartyType
zsr form:zsrPartyType
nif form:nifPartyType
reg_number form:stringType1_35
specialty form:stringType1_350
address_role_type | derived by: NMTOKEN | required
address_role_name form:stringType1_35
attributes annotations
Name | Notes
ean | ean is the optional GLN of the addressee as defined by RefData
zsr | zsr is the optional ZSR (KSK) number of the addressee as defined by Santésuisse
nif | nif is the optional IV specific identification number of the addressee
reg_number | reg_number is the optional national BUR number of the addressee as defined by Swiss Federal Statistical Office
specialty | specialty is the optional addressee's specialty (branch of medical science a doctor practices)
address_role_type | address_role_type is qualification of the address role encoded by a terminal set of tokens
address_role_name | address_role_type optionally further defines the address_role_type if the address_role_type=other!
attributes enumerations
Name | Extension | Base | Value | Annotations
address_role_type | NMTOKEN | producer | the supplied address if of type producer - the address party that is the legal responsible for the form.
address_role_type | NMTOKEN | consumer | the supplied address if of type consumer - the address party to whom the filled out form is sent.
address_role_type | NMTOKEN | guarantor | the supplied address if of type guarantor - the address party that is the legal representative of the patient
address_role_type | NMTOKEN | provider | the supplied address if of type provider - the address party that by definition provides any medical data defined in the form.
address_role_type | NMTOKEN | referrer | the supplied address if of type referrer - the address party that originally sent a request for treatment to the provider address party.
address_role_type | NMTOKEN | insurance | the supplied address if of type insurance - the address part of the health insurance of the patient.
address_role_type | NMTOKEN | employer | the supplied address if of type employer - the address party of the patient's employer.
address_role_type | NMTOKEN | other | the supplied address if of type other - an address party that is not covered by one of the specified address roles defined above.
source <complexType name="genericAddressType">
<choice>
<element name="company" type="form:companyType"/>
<element name="person" type="form:personType"/>
</choice>
<attribute name="ean" type="form:eanPartyType"/>
<attribute name="zsr" type="form:zsrPartyType"/>
<attribute name="nif" type="form:nifPartyType"/>
<attribute name="reg_number" type="form:stringType1_35"/>
<attribute name="specialty" type="form:stringType1_350"/>
<attribute name="address_role_type" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="producer"/>
<enumeration value="consumer"/>
<enumeration value="guarantor"/>
<enumeration value="provider"/>
<enumeration value="referrer"/>
<enumeration value="insurance"/>
<enumeration value="employer"/>
<enumeration value="other"/>
</restriction>
</simpleType>
</attribute>
<attribute name="address_role_name" type="form:stringType1_35"/>
</complexType>


complexType intTokenType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element tokensType/int_token
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value | int
attributes annotations
Name | Notes
name | name defines the name of the integer number token
value | value is value of the integer number token
source <complexType name="intTokenType">
<attribute name="name" type="form:stringType1_100" use="required"/>
<attribute name="value" type="int"/>
</complexType>


complexType ivgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id | derived by: string
case_date | dateTime
contract_number form:stringType1_35
ssn form:ssnPartyType
nif form:nifPartyType
attributes annotations
Name | Notes
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
nif | nif is the IV specific identification number for the provider.
source <complexType name="ivgLawType">
<attribute name="case_id">
<simpleType>
<restriction base="string">
<pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
</restriction>
</simpleType>
</attribute>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
<attribute name="ssn" type="form:ssnPartyType"/>
<attribute name="nif" type="form:nifPartyType"/>
</complexType>


complexType kvgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id form:stringType1_35
case_id form:stringType1_35
case_date | dateTime
contract_number form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach KVG").
source <complexType name="kvgLawType">
<attribute name="insured_id" type="form:stringType1_35"/>
<attribute name="case_id" type="form:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
</complexType>


complexType mvgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id form:stringType1_35
case_id form:stringType1_35
case_date | dateTime
contract_number form:stringType1_35
ssn form:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
source <complexType name="mvgLawType">
<attribute name="insured_id" type="form:stringType1_35"/>
<attribute name="case_id" type="form:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
<attribute name="ssn" type="form:ssnPartyType"/>
</complexType>


complexType objectType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
elements payloadType/credit_ref payloadType/form payloadType/form_ref payloadType/invoice_ref payloadType/mcd_ref payloadType/notification_ref payloadType/reminder_ref
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | form:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_id will be generated once for a certain object reference and thereafter is always referenced!
source <complexType name="objectType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="form:stringType1_35" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:email form:url
used by
elements personType/online companyType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="form:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType orgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/org
attributes parameters
Name | Type | Use | Default | Fixed
insured_id form:stringType1_35
case_id form:stringType1_35
case_date | dateTime
contract_number form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
source <complexType name="orgLawType">
<attribute name="insured_id" type="form:stringType1_35"/>
<attribute name="case_id" type="form:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
</complexType>


complexType patientAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:person form:card
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN
birthdate | dateTime
ssn form:ssnPartyType
attributes annotations
Name | Notes
gender | gender defines the gender of the patient encoded by a terminal set of tokens
birthdate | birthdate defines the patient's birthdate
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="form:personType"/>
<element name="card" minOccurs="0">
<complexType>
<attribute name="card_id" type="form:stringType1_35" use="required"/>
<attribute name="expiry_date" type="dateTime" use="required"/>
<attribute name="validation_date" type="dateTime"/>
<attribute name="validation_id" type="form:stringType1_35"/>
<attribute name="validation_server" type="form:stringType1_35"/>
</complexType>
</element>
</sequence>
<attribute name="gender">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime"/>
<attribute name="ssn" type="form:ssnPartyType"/>
</complexType>


complexType payloadType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:credit_ref form:invoice_ref form:reminder_ref form:mcd_ref form:form_ref form:notification_ref form:form form:body xenc:EncryptedData
used by
element requestType/payload
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
attributes annotations
Name | Notes
storno | storno augments the form reference object by a storno command.
copy | copy augments the form reference object by a copy command that is the form reference object is an identical clone (except for the copy attribute) of a prior sent request.
source <complexType name="payloadType">
<sequence>
<choice minOccurs="0">
<element name="credit_ref" type="form:objectType"/>
<element name="invoice_ref" type="form:objectType"/>
<element name="reminder_ref" type="form:objectType"/>
<element name="mcd_ref" type="form:objectType"/>
<element name="form_ref" type="form:objectType"/>
<element name="notification_ref" type="form:objectType"/>
</choice>
<element name="form" type="form:objectType"/>
<choice>
<element name="body" type="form:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="storno" type="boolean" default="false"/>
<attribute name="copy" type="boolean" default="false"/>
</complexType>


complexType pdfDataType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:address form:kvg form:vvg form:uvg form:ivg form:mvg form:org form:tokens
used by
element dataType/pdf_data
source <complexType name="pdfDataType">
<sequence>
<element name="address" type="form:genericAddressType" minOccurs="0" maxOccurs="unbounded"/>
<choice minOccurs="0">
<element name="kvg" type="form:kvgLawType"/>
<element name="vvg" type="form:vvgLawType"/>
<element name="uvg" type="form:uvgLawType"/>
<element name="ivg" type="form:ivgLawType"/>
<element name="mvg" type="form:mvgLawType"/>
<element name="org" type="form:orgLawType"/>
</choice>
<element name="tokens" type="form:tokensType"/>
</sequence>
</complexType>


complexType pdfFileType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:base64
used by
element dataType/pdf_file
attributes parameters
Name | Type | Use | Default | Fixed
filename | form:stringType1_255 | required
mimeType | form:stringType1_35 | application/pdf
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. Since the coded document is a PDF, this MIME is fixed to application/pdf.
source <complexType name="pdfFileType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="filename" type="form:stringType1_255" use="required"/>
<attribute name="mimeType" type="form:stringType1_35" fixed="application/pdf"/>
</complexType>


complexType personType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:familyname form:givenname form:subaddressing form:postal form:telecom form:online
used by
elements baseAddressType/person patientAddressType/person genericAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation form:stringType1_35
title form:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="form:stringType1_35"/>
<element name="givenname" type="form:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="form:stringType1_35" minOccurs="0"/>
<element name="postal" type="form:postalAddressType"/>
<element name="telecom" type="form:telecomAddressType" minOccurs="0"/>
<element name="online" type="form:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="form:stringType1_35"/>
<attribute name="title" type="form:stringType1_35"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:pobox form:street form:zip form:city
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="form:stringType1_35" minOccurs="0"/>
<element name="street" type="form:stringType1_35" minOccurs="0"/>
<element name="zip" type="form:zipType"/>
<element name="city" type="form:stringType1_35"/>
</sequence>
</complexType>


complexType processingType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:transport
used by
element requestType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="form:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:package form:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="form:softwareType" minOccurs="0"/>
<element name="generator" type="form:softwareType"/>
</sequence>
</complexType>


complexType requestType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:processing form:payload ds:Signature
used by
element request
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name | Notes
language | language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus is production (default value) for normal processing
modus | NMTOKEN | test | the modus is test for software developers to test the processing.
source <complexType name="requestType">
<sequence>
<element name="processing" type="form:processingType"/>
<element name="payload" type="form:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType softwareType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_50 | required
copyright form:stringType1_50
description form:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="form:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="form:stringType1_50" use="required"/>
<attribute name="copyright" type="form:stringType1_50"/>
<attribute name="description" type="form:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType stringTokenType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element tokensType/string_token
attributes parameters
Name | Type | Use | Default | Fixed
name | form:stringType1_100 | required
value form:stringType0_700
attributes annotations
Name | Notes
name | name defines the name of the string token
value | value is value of the string token
source <complexType name="stringTokenType">
<attribute name="name" type="form:stringType1_100" use="required"/>
<attribute name="value" type="form:stringType0_700"/>
</complexType>


complexType telecomAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:phone form:fax
used by
elements personType/telecom companyType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="form:stringType1_25" maxOccurs="3"/>
<element name="fax" type="form:stringType1_25" minOccurs="0" maxOccurs="3"/>
</sequence>
</complexType>


complexType tokensType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:string_token form:int_token form:float_token form:date_token form:boolean_token
used by
element pdfDataType/tokens
source <complexType name="tokensType">
<sequence maxOccurs="unbounded">
<choice>
<element name="string_token" type="form:stringTokenType"/>
<element name="int_token" type="form:intTokenType"/>
<element name="float_token" type="form:floatTokenType"/>
<element name="date_token" type="form:dateTokenType"/>
<element name="boolean_token" type="form:booleanTokenType"/>
</choice>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://www.forum-datenaustausch.ch/form
children | form:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | form:eanPartyType | required
to | form:eanPartyType | required
attributes annotations
Name | Notes
from | from is the GLN party that initially sent the infoset to the first intermediate
to | to is the GLN party that eventually receives the infoset from the last intermediate
source <complexType name="transportType">
<sequence>
<element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="form:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="form:eanPartyType" use="required"/>
<attribute name="to" type="form:eanPartyType" use="required"/>
</complexType>


complexType uvgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id form:stringType1_35
case_id form:stringType1_35
case_date | dateTime
contract_number form:stringType1_35
ssn form:ssnPartyType
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance (accident number)
case_date | case_date is the treatment/case date given by the insurance (accident date)
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services.
ssn ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
source <complexType name="uvgLawType">
<attribute name="insured_id" type="form:stringType1_35"/>
<attribute name="case_id" type="form:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
<attribute name="ssn" type="form:ssnPartyType"/>
</complexType>


complexType vvgLawType

diagram
namespace http://www.forum-datenaustausch.ch/form
used by
element pdfDataType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
insured_id form:stringType1_35
case_id form:stringType1_35
case_date | dateTime
contract_number form:stringType1_35
attributes annotations
Name | Notes
insured_id | insured_id is the patient's identification number at the insurance (policy number),
case_id | case_id is the treatment/case identification given by the insurance
case_date | case_date is the treatment/case date given by the insurance
contract_number | contract_number is an individual contract number negotiated between provider and insurance regarding the accounting of medical services ("Einzelvertragsnummer nach VVG").
source <complexType name="vvgLawType">
<attribute name="insured_id" type="form:stringType1_35"/>
<attribute name="case_id" type="form:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
<attribute name="contract_number" type="form:stringType1_35"/>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://www.forum-datenaustausch.ch/form
type | extension of form:stringType1_9
properties
base form:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode form:stringType1_9
countrycode | form:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code | form:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="form:stringType1_9">
<attribute name="statecode" type="form:stringType1_9"/>
<attribute name="countrycode" type="form:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType eanPartyType

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes baseAddressType/@ean genericAddressType/@ean transportType/@from transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="eanPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType nifPartyType

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes genericAddressType/@nif ivgLawType/@nif
facets
pattern [0-9]{1,7}
source <simpleType name="nifPartyType">
<restriction base="string">
<pattern value="[0-9]{1,7}"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes patientAddressType/@ssn uvgLawType/@ssn ivgLawType/@ssn mvgLawType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType0_700

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attribute stringTokenType/@value
facets
minLength | 0
maxLength | 700
source <simpleType name="stringType0_700">
<restriction base="string">
<minLength value="0"/>
<maxLength value="700"/>
</restriction>
</simpleType>


simpleType stringType1_100

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes stringTokenType/@name intTokenType/@name floatTokenType/@name dateTokenType/@name booleanTokenType/@name
facets
minLength | 1
maxLength | 100
source <simpleType name="stringType1_100">
<restriction base="string">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes pdfFileType/@filename documentType/@filename dataType/@pdf_form_oid
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street personType/subaddressing companyType/subaddressing
attributes | genericAddressType/@address_role_name patientAddressType/card/@card_id orgLawType/@case_id mvgLawType/@case_id kvgLawType/@case_id vvgLawType/@case_id uvgLawType/@case_id mvgLawType/@contract_number orgLawType/@contract_number ivgLawType/@contract_number kvgLawType/@contract_number uvgLawType/@contract_number vvgLawType/@contract_number orgLawType/@insured_id mvgLawType/@insured_id uvgLawType/@insured_id vvgLawType/@insured_id kvgLawType/@insured_id pdfFileType/@mimeType genericAddressType/@reg_number objectType/@request_id bodyType/@role_title personType/@salutation personType/@title documentType/@title patientAddressType/card/@validation_id patientAddressType/card/@validation_server
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes baseAddressType/@specialty genericAddressType/@specialty
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


simpleType zsrPartyType

namespace | http://www.forum-datenaustausch.ch/form
type | restriction of string
used by
attributes baseAddressType/@zsr genericAddressType/@zsr
facets
pattern ([A-Z][0-9]{6})
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="([A-Z][0-9]{6})"/>
</restriction>
</simpleType>


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>