XML Schema Browser - careCreditResponse Version 450

Schema Documentation of
careCreditResponse V450

produced by Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as standard in the meeting on 27th November 2024.

The standard becomes applicable on 1st January 2025.

Copyright (©) by Forum Datenaustausch, 27.11.2024 - all rights reserved


Revision history of the documentation

Documentation of careCreditResponse450.xsd

Copyright (©) by Forum Datenaustausch, 06.05.2019
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this Documentation of careCreditResponse450.xsd.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying careCreditResponse_450.xsd schema is not changed due to such an entry.
  • Revision 1 from 27.11.2024 (initial version)


Preface

Copyright (©) by Forum Datenaustausch, 06.05.2019

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Copyright (©) by Forum Datenaustausch, 06.05.2019

Forum Datenaustausch

Der Verein "Forum Datenaustausch" (FoDa) fördert den effizienten und sicheren digitalen Datenaustausch zwischen Leistungserbringern und Kostenträgern im administrativen Gesundheitswesen. Er tut dies, indem er sich für folgende, grundsätzliche Ziele einsetzt:
  • Leistungserbringer und Kostenträger nutzen für die digitale Kommunikation untereinander die gleichen, gemeinsam entwickelten und festgelegten Standards.
  • Die digitale Kommunikation zwischen Leistungserbringern und Kostenträger ist sicher, verlässlich und Datenschutzkonform. Sie fördert die Effizienz der Prozesse und ist für alle Partner mit einem positiven Kosten-/Nutzenverhältnis verbunden.

Mitglieder des Forums sind nationale Verbände und Organisationen der Leistungserbringer und der Kostenträger, sowie Körperschaften und Anstalten des öffentlichen Rechts. Hier finden Sie die aktuelle Mitgliederliste.

Die vom Forum Datenaustausch freigegebenen Standards bzw. neue Standard-Versionen, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert.
L'association "Forum Datenaustausch" (FoDa) promeut un échange de données numériques efficace et sûr entre les fournisseurs de prestations et les organismes payeurs dans le domaine administratif de la santé. Pour ce faire, elle s'engage en faveur des objectifs fondamentaux suivants:
  • Les fournisseurs de prestations et les organismes payeurs utilisent les mêmes normes, développées et définies en commun, pour la communication numérique entre eux.
  • La communication numérique entre les fournisseurs de prestations et les organismes payeurs est sûre, fiable et conforme à la protection des données. Elle favorise l'efficacité des processus et est liée à un rapport coûts/bénéfices positif pour tous les partenaires.

Les membres du forum sont des associations nationales et des organisations de prestataires de services et de payeurs, ainsi que des collectivités et des établissements de droit public. Vous trouverez ici la liste actuelle des membres.

Les normes validées par le forum ou les nouvelles versions de normes, comme les messages XML pour l'échange électronique de données, sont publiées ici.


Copyright (©) notice

Copyright (©) by Forum Datenaustausch, 27.11.2024

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying Documentation of careCreditResponse450.xsd for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Copyright (©) by Forum Datenaustausch, 06.05.2019

Purpose of the schema file

This is the schema definition for a nursing "Care Credit Response" process encoded in XML. The careCreditResponse always constitutes an answer to a received "Care Credit Request". By design there can be [0,n] such responses but solely to the topmost object reference given in the request. If there is no response sent to a request then it is considered implicitly as accepted.
The subchapter Purpose/Anatomy of a response provides a broad overview about the building blocks of a response and the subchapter Purpose/Object reference provides an in-depth description of the concept of a "object reference".

The response is sent via 1 or more intermediates to the final recipient, who is the initial sender of the request by definition. The chain of intermediates from the request is reversed for the response.

There is no concept of a response reference object but only a UNIX timestamp of the generation of the response XML for legal reasons. However, all reference objects of the request must be included in the response as these serve as a unique identification.

This XML project is normative for the electronic care credit process in Switzerland.


Conventions, terms, and definitions used

Copyright (©) by Forum Datenaustausch, 06.05.2019

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Copyright (©) by Forum Datenaustausch, 06.05.2019

Anatomy of a response

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a response.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects that is copied from the request
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Copyright (©) by Forum Datenaustausch, 06.05.2019

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Invoice Request" can hold a maximum of 3 object references, namely
  • an optional credit object reference from the "General Invoice Request" process
  • a mandatory invoice object reference from the initial "General Invoice Request" process
  • an optional reminder object reference given if the process encodes a reminder
whereas a "Care Credit Request" needs only 1 object reference
  • a mandatory credit object reference from the "Care Credit Request" process

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference – and only for that.

For example: a reminder XML request does reference an optional credit XML request (if the object reference was given in the initial invoice XML request). However, the reference of the initial invoice XML request for which a reminder process is started, is mandatory. The topmost object reference is then the object reference of the generated reminder process. Each XML response then references the topmost object reference for which it is a response. Such a response is never targeted for the corresponding invoice but only for the reminder!


Notes about the signature

Copyright (©) by Forum Datenaustausch, 06.05.2019

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/ccr:response/ccr:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>
  <Reference URI="#xpointer(/ccr:response/ccr:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Copyright (©) by Forum Datenaustausch, 06.05.2019

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#tripledes-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-1_5"/>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Copyright (©) by Forum Datenaustausch, 06.05.2019

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Copyright (©) by Forum Datenaustausch, 06.05.2019

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/ccr"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:ccr="http://www.forum-datenaustausch.ch/ccr"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag ccr followed by the element name. Furthermore, the target namespace and the specific namespace ccr maps to http://www.forum-datenaustausch.ch/ccr.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ccr:response xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:ccr="http://www.forum-datenaustausch.ch/ccr"
        xmlns="http://www.forum-datenaustausch.ch/ccr"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/ccr careCreditResponse_450.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </ccr:response>


Hierarchical list of used XSD definitions

Copyright (©) by Forum Datenaustausch, 06.05.2019

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from
the topmost element response down as the appropriate definition is encountered.


element response

Annotation The response element is the root of the careCreditResponse process.
The response is divided into 2 parts
  • the processing element supplies the necessary data for the transport process
  • the payload element supplies the response to the care credit request data
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:responseType
properties
content complex
children | ccr:processing ccr:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
The language used is copied from and thus defined by the request.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
    By definition there must not be any money flow!
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus NMTOKEN test the modus test is for software developers to test the processing.
By definition there must not be any money flow!
source | <element name="response" type="ccr:responseType"/>


element responseType/processing

Annotation | The processing element is a container with transport instructions basically mirrored from the request.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:processingType
properties
isRef | 0
content | complex
children | ccr:transport
source | <element name="processing" type="ccr:processingType"/>


element processingType/transport

Annotation The transport element defines the routing of the infoset.
In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list.
All the involved parties are defined by GLN as defined by RefData
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:transportType
properties
isRef | 0
content | complex
children | ccr:via
attributes parameters
Name | Type | Use | Default | Fixed
from | ccr:eanPartyType | required
to | ccr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="ccr:transportType"/>


element transportType/via

Annotation The via element defines one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly send the infoset to the next intermediate in the mirrored list of intermediates or eventually deliver the infoset to the recipient (the sender of the request).
diagram
namespace http://www.forum-datenaustausch.ch/ccr
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | ccr:eanPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming the mirrored chain of intermediate hops.
source <element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="ccr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element responseType/payload

Annotation | The payload element supplies the response to the care credit request data. The payload can optionally be signed by at W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:payloadType
properties
isRef | 0
content | complex
children | ccr:credit ccr:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
storno storno augments the topmost object reference by a storno command.
This attribute is copied from the received request
copy copy augments the topmost object reference by a copy command
This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
source | <element name="payload" type="ccr:payloadType"/>


element payloadType/credit

Annotation The credit element defines the care credit reference object of the request.
This element is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:creditType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | ccr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the care credit's infoset generation
This is one of 3 identifiers that form the care credit object reference. request_timestamp will be generated once for a certain care credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the care credit request
This is one of 3 identifiers that form the care credit object reference. request_date must always be the same for a certain care credit object reference!
request_id request_id is the main software's ID of the care credit request
This is one of 3 identifiers that form the care credit object reference. request_id must always be the same for a certain care credit object reference!
source | <element name="credit" type="ccr:creditType"/>


element payloadType/body

Annotation | The body element contains copied data containers from the request and the answer to the request. Since there are privacy relevant patient data in the response the body element can be replace by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:bodyType
properties
isRef | 0
content | complex
children | ccr:prolog ccr:biller ccr:provider ccr:insurance ccr:patient ccr:debitor ccr:contact ccr:treatment ccr:pending ccr:accepted ccr:rejected ccr:documents
source | <element name="body" type="ccr:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator, validators, and main software).
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:prologType
properties
isRef | 0
content | complex
children | ccr:package ccr:generator
source | <element name="prolog" type="ccr:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="ccr:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="ccr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:softwareType
properties
isRef | 0
content | complex
children | ccr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright | ccr:stringType1_50
description | ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="ccr:softwareType"/>


element bodyType/biller

Annotation The biller element defines the biller of the corresponding request. However, only the GLN is used as unique identifier.
The GLN is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:partyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is an GLN used as unique identifier for a person or company as defined by RefData.
The GLN is copied from the received request
source | <element name="biller" type="ccr:partyType"/>


element bodyType/provider

Annotation The provider element defines the provider of the corresponding request. However, only the GLN is used as unique identifier.
The GLN is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:partyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is an GLN used as unique identifier for a person or company as defined by RefData.
The GLN is copied from the received request
source | <element name="provider" type="ccr:partyType"/>


element bodyType/insurance

Annotation The insurance element defines the insurance of the corresponding request. However, only the GLN is used as unique identifier.
The GLN is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:partyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is an GLN used as unique identifier for a person or company as defined by RefData.
The GLN is copied from the received request
source | <element name="insurance" type="ccr:partyType"/>


element bodyType/patient

Annotation The patient element defines the patient of the corresponding request.
This element is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:patientAddressType
properties
isRef | 0
content | complex
children | ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | ccr:ssnPartyType
attributes annotations
Name | Notes
gender gender defines the gender encoded by a terminal set of tokens
  • male: the patient identifies with the gender of male
  • female: the patient identifies with the gender of female
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source | <element name="patient" type="ccr:patientAddressType"/>


element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="ccr:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="ccr:stringType1_35"/>


element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:postalAddressType
properties
isRef | 0
content | complex
children | ccr:pobox ccr:street ccr:zip ccr:city
source | <element name="postal" type="ccr:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="ccr:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="street" type="ccr:stringType1_35" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | ccr:stringType1_9
countrycode | ccr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="zip" type="ccr:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="ccr:stringType1_35"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:phone ccr:fax
source | <element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="ccr:stringType1_25" maxOccurs="3"/>


element telecomAddressType/fax

Annotation | The fax element supplies a telefax number
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_25
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="fax" type="ccr:stringType1_25" minOccurs="0" maxOccurs="3"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:email ccr:url
source | <element name="online" type="ccr:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of ccr:stringType1_70
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 70
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="ccr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/url

Annotation | The url element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 100
source <element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>


element bodyType/debitor

Annotation The debitor element defines the debitor of the corresponding request which is of course the current sender.
This element is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:debitorAddressType
properties
isRef | 0
content | complex
children | ccr:company ccr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
source | <element name="debitor" type="ccr:debitorAddressType"/>


element debitorAddressType/company

Annotation | The debitor is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="ccr:stringType1_35"/>


element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="ccr:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:postalAddressType
properties
isRef | 0
content | complex
children | ccr:pobox ccr:street ccr:zip ccr:city
source | <element name="postal" type="ccr:postalAddressType"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:phone ccr:fax
source | <element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:email ccr:url
source | <element name="online" type="ccr:onlineAddressType" minOccurs="0"/>


element debitorAddressType/person

Annotation | The debitor is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element bodyType/contact

Annotation | The contact element defines a contact for the response coded either as person or company address. The latter can optionally be augmented by data of an employee.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:contactAddressType
properties
isRef | 0
content | complex
children | ccr:person ccr:company ccr:employee
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType
attributes annotations
Name Notes
ean_party ean_party is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never an GLN of an employee!)
source | <element name="contact" type="ccr:contactAddressType"/>


element contactAddressType/person

Annotation | The contact is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:personType
properties
isRef | 0
content | complex
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="ccr:personType"/>


element contactAddressType/company

Annotation | The contact is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:companyType
properties
isRef | 0
content | complex
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
source | <element name="company" type="ccr:companyType"/>


element contactAddressType/employee

Annotation The optional employee element augments the company address by the data of an employee handling the request
The address of an employee is identical to a person's address except that the postal address is not given but implicitly inherited by the company's address container.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:employeeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:familyname ccr:givenname ccr:telecom ccr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | ccr:stringType1_35
title | ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="employee" type="ccr:employeeType" minOccurs="0"/>


element employeeType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="ccr:stringType1_35"/>


element employeeType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="ccr:stringType1_35" minOccurs="0"/>


element employeeType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:phone ccr:fax
source | <element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>


element employeeType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:email ccr:url
source | <element name="online" type="ccr:onlineAddressType" minOccurs="0"/>


element bodyType/treatment

Annotation The treatment element defines the essential treatment data copied from the corresponding request.
This element is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:treatmentType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
treatment_days | duration | required
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
attributes annotations
Name | Notes
date_begin | date_begin is the start of the supposed treatment interval
date_end | date_end is the end of the supposed treatment interval
treatment_days | treatment_days is the number of planned treatment days within the given treatment period.
treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations.
  • AG: the canton is AG - Aargau
  • AI: the canton is AI - Appenzell Innerrhoden
  • AR: the canton is AR - Appenzell Ausserrhoden
  • BE: the canton is BE - Bern
  • BL: the canton is BL - Baselland
  • BS: the canton is BS - Basel
  • FR: the canton is FR - Fribourg
  • GE: the canton is GE - Geneva
  • GL: the canton is GL - Glarus
  • GR: the canton is GR - Graubünden
  • JU: the canton is JU - Jura
  • LU: the canton is LU - Lucerne
  • NE: the canton is NE - Neuchâtel
  • NW: the canton is NW - Nidwalden
  • OW: the canton is OW - Obwalden
  • SG: the canton is SG - St. Gallen
  • SH: the canton is SH - Schaffhausen
  • SO: the canton is SO - Solothurn
  • SZ: the canton is SZ - Schwyz
  • TI: the canton is TI - Ticino
  • TG: the canton is TG - Thurgau
  • UR: the canton is UR - Uri
  • VD: the canton is VD - Vaud
  • VS: the canton is VS - Valais
  • ZG: the canton is ZG - Zug
  • ZH: the canton is ZH - Zürich
  • LI: the country is LI - Liechtenstein
  • A: the country is A - Austria
  • D: the country is D - Germany
  • F: the country is F - France
  • I: the country is I - Italy
treatment_type treatment_type is the principle type of treatment encoded by a terminal set of tokens.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
treatment_reason treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens
  • disease: the reason of treatment is a disease
  • accident: the reason of treatment is an accident
  • maternity: the reason of treatment is a maternity
  • prevention: the reason of treatment is prevention
  • birthdefect: the reason of treatment a birthdefect
  • unknown: the reason of treatment is unknown (or something not mentioned above)
attributes enumerations
Name | Extension | Base | Value | Annotations
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source | <element name="treatment" type="ccr:treatmentType"/>


element bodyType/pending

Annotation The pending element defines the answer of type «pending»
Per definition this means that the request can not be processed to a final stage as some data are missing. An optional explanation and [0,n] messages (instructions) are supplied to "unfreeze" the request.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:pendingType
properties
isRef | 0
content | complex
children | ccr:explanation ccr:message
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
source | <element name="pending" type="ccr:pendingType"/>


element pendingType/explanation

Annotation The explanation element defines the overall explanation for the pending status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>


element pendingType/message

Annotation The message element defines either a reason why the request is in the pending state or an instruction how to proceed for leaving this state. E.g. the insurance is awaiting further documents like the "Minimal clinical dataset" (mcdRequest).
There is an unbounded number of such messages possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:notificationType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | ccr:stringType1_35 | required
text | ccr:stringType1_350 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source | <element name="message" type="ccr:notificationType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/accepted

Annotation The accepted element defines the answer of type «accepted».
Per definition this means that the request is fully accepted and will be processed to a final stage. An optional explanation is supplied to justify the decision.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:acceptedType
properties
isRef | 0
content | complex
children | ccr:explanation
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
source | <element name="accepted" type="ccr:acceptedType"/>


element acceptedType/explanation

Annotation The optional explanation element defines the overall explanation for the accepted status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>


element bodyType/rejected

Annotation The rejected element defines the answer of type «rejected».
Per definition this means that the request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional explanation and [0,n] errors are supplied to justify the decision.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:rejectedType
properties
isRef | 0
content | complex
children | ccr:explanation ccr:error
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
source | <element name="rejected" type="ccr:rejectedType"/>


element rejectedType/explanation

Annotation The explanation element defines the overall explanation for the rejected status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:stringType1_700
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 700
source | <element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>


element rejectedType/error

Annotation The error element defines one detailed error why the request is rejected.
There is an unbounded number of such errors possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:errorType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | ccr:stringType1_35 | required
text | ccr:stringType1_350 | required
error_value | ccr:stringType1_350
valid_value | ccr:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
source | <element name="error" type="ccr:errorType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/documents

Annotation | The documents element is an optional container for including inline, Base64-coded documents.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ccr:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="ccr:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline and Base64-coded.
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | ccr:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | ccr:base64
attributes parameters
Name | Type | Use | Default | Fixed
title | ccr:stringType1_35 | required
filename | ccr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title | title is the document's title on the primary system and thus describes the document in terms of its semantic content.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source | <element name="document" type="ccr:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet streams
diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the end recipient of this infoset (the biller of the request).
See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sending party represented by the transport@to GLN (the mirrored transport@from from the request).
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType responseType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Copyright (©) by Forum Datenaustausch, 06.05.2019

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

A
acceptedType
B
bodyType
C
companyType
contactAddressType
creditType
D
debitorAddressType
dependsOnType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
eanPartyType
employeeType
errorType
N
notificationType
O
onlineAddressType
P
partyType
patientAddressType
payloadType
pendingType
personType
postalAddressType
processingType
prologType
R
rejectedType
responseType
S
softwareType
ssnPartyType
statusType
stringType1_15
stringType1_25
stringType1_255
stringType1_3
stringType1_35
stringType1_350
stringType1_50
stringType1_70
stringType1_700
stringType1_9
T
telecomAddressType
transportType
treatmentType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z
zipType


complexType acceptedType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | extension of ccr:statusType
properties
base ccr:statusType
children | ccr:explanation
used by
element bodyType/accepted
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
Extensions
Annotation | Base
Definition for a response status container of type «accepted» | ccr:statusType
source <complexType name="acceptedType">
<complexContent>
<extension base="ccr:statusType">
<sequence>
<element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType bodyType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:prolog ccr:biller ccr:provider ccr:insurance ccr:patient ccr:debitor ccr:contact ccr:treatment ccr:pending ccr:accepted ccr:rejected ccr:documents
used by
element payloadType/body
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="ccr:prologType"/>
<element name="biller" type="ccr:partyType"/>
<element name="provider" type="ccr:partyType"/>
<element name="insurance" type="ccr:partyType"/>
<element name="patient" type="ccr:patientAddressType"/>
<element name="debitor" type="ccr:debitorAddressType"/>
<element name="contact" type="ccr:contactAddressType"/>
<element name="treatment" type="ccr:treatmentType"/>
<choice>
<element name="pending" type="ccr:pendingType"/>
<element name="accepted" type="ccr:acceptedType"/>
<element name="rejected" type="ccr:rejectedType"/>
</choice>
<element name="documents" type="ccr:documentsType" minOccurs="0"/>
</sequence>
</complexType>


complexType companyType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:companyname ccr:department ccr:subaddressing ccr:postal ccr:telecom ccr:online
used by
elements debitorAddressType/company contactAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="ccr:stringType1_35"/>
<element name="department" type="ccr:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>
<element name="postal" type="ccr:postalAddressType"/>
<element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>
<element name="online" type="ccr:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType contactAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:person ccr:company ccr:employee
used by
element bodyType/contact
attributes parameters
Name Type Use Default Fixed
ean_party ccr:eanPartyType
attributes annotations
Name Notes
ean_party ean_party is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never an GLN of an employee!)
source <complexType name="contactAddressType">
<choice>
<element name="person" type="ccr:personType"/>
<sequence>
<element name="company" type="ccr:companyType"/>
<element name="employee" type="ccr:employeeType" minOccurs="0"/>
</sequence>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType"/>
</complexType>


complexType creditType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
element payloadType/credit
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | ccr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the care credit's infoset generation
This is one of 3 identifiers that form the care credit object reference. request_timestamp will be generated once for a certain care credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the care credit request
This is one of 3 identifiers that form the care credit object reference. request_date must always be the same for a certain care credit object reference!
request_id request_id is the main software's ID of the care credit request
This is one of 3 identifiers that form the care credit object reference. request_id must always be the same for a certain care credit object reference!
source <complexType name="creditType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="ccr:stringType1_35" use="required"/>
</complexType>


complexType debitorAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:company ccr:person
used by
element bodyType/debitor
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
source <complexType name="debitorAddressType">
<choice>
<element name="company" type="ccr:companyType"/>
<element name="person" type="ccr:personType"/>
</choice>
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType dependsOnType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright ccr:stringType1_50
description ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="ccr:stringType1_50" use="required"/>
<attribute name="copyright" type="ccr:stringType1_50"/>
<attribute name="description" type="ccr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType documentsType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="ccr:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
title | ccr:stringType1_35 | required
filename | ccr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title | title is the document's title on the primary system and thus describes the document in terms of its semantic content.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="title" type="ccr:stringType1_35" use="required"/>
<attribute name="filename" type="ccr:stringType1_255" use="required"/>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType employeeType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:familyname ccr:givenname ccr:telecom ccr:online
used by
element contactAddressType/employee
attributes parameters
Name Type Use Default Fixed
salutation ccr:stringType1_35
title ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="employeeType">
<sequence>
<element name="familyname" type="ccr:stringType1_35"/>
<element name="givenname" type="ccr:stringType1_35" minOccurs="0"/>
<element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>
<element name="online" type="ccr:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="ccr:stringType1_35"/>
<attribute name="title" type="ccr:stringType1_35"/>
</complexType>


complexType errorType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | extension of ccr:notificationType
properties
base ccr:notificationType
used by
element rejectedType/error
attributes parameters
Name | Type | Use | Default | Fixed
code | ccr:stringType1_35 | required
text | ccr:stringType1_350 | required
error_value ccr:stringType1_350
valid_value ccr:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
Extensions
Annotation | Base
Definition for an error container | ccr:notificationType
source <complexType name="errorType">
<complexContent>
<extension base="ccr:notificationType">
<attribute name="error_value" type="ccr:stringType1_350"/>
<attribute name="valid_value" type="ccr:stringType1_350"/>
<attribute name="record_id" type="positiveInteger"/>
</extension>
</complexContent>
</complexType>


complexType notificationType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
element | pendingType/message
complexType | errorType
attributes parameters
Name | Type | Use | Default | Fixed
code | ccr:stringType1_35 | required
text | ccr:stringType1_350 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source <complexType name="notificationType">
<attribute name="code" type="ccr:stringType1_35" use="required"/>
<attribute name="text" type="ccr:stringType1_350" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:email ccr:url
used by
elements personType/online companyType/online employeeType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="ccr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType partyType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
elements bodyType/biller bodyType/insurance bodyType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | ccr:eanPartyType | required
attributes annotations
Name Notes
ean_party ean_party is an GLN used as unique identifier for a person or company as defined by RefData.
The GLN is copied from the received request
source <complexType name="partyType">
<attribute name="ean_party" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType patientAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:person
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn ccr:ssnPartyType
attributes annotations
Name | Notes
gender gender defines the gender encoded by a terminal set of tokens
  • male: the patient identifies with the gender of male
  • female: the patient identifies with the gender of female
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="ccr:personType"/>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="ccr:ssnPartyType"/>
</complexType>


complexType payloadType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:credit ccr:body xenc:EncryptedData
used by
element responseType/payload
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
storno storno augments the topmost object reference by a storno command.
This attribute is copied from the received request
copy copy augments the topmost object reference by a copy command
This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
source <complexType name="payloadType">
<sequence>
<element name="credit" type="ccr:creditType"/>
<choice>
<element name="body" type="ccr:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="storno" type="boolean" default="false"/>
<attribute name="copy" type="boolean" default="false"/>
<attribute name="response_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType pendingType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | extension of ccr:statusType
properties
base ccr:statusType
children | ccr:explanation ccr:message
used by
element bodyType/pending
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
Extensions
Annotation | Base
Definition for a response status container of type «pending» | ccr:statusType
source <complexType name="pendingType">
<complexContent>
<extension base="ccr:statusType">
<sequence>
<element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>
<element name="message" type="ccr:notificationType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType personType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:familyname ccr:givenname ccr:subaddressing ccr:postal ccr:telecom ccr:online
used by
elements patientAddressType/person debitorAddressType/person contactAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation ccr:stringType1_35
title ccr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="ccr:stringType1_35"/>
<element name="givenname" type="ccr:stringType1_35"/>
<element name="subaddressing" type="ccr:stringType1_35" minOccurs="0"/>
<element name="postal" type="ccr:postalAddressType"/>
<element name="telecom" type="ccr:telecomAddressType" minOccurs="0"/>
<element name="online" type="ccr:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="ccr:stringType1_35"/>
<attribute name="title" type="ccr:stringType1_35"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:pobox ccr:street ccr:zip ccr:city
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="ccr:stringType1_35" minOccurs="0"/>
<element name="street" type="ccr:stringType1_35" minOccurs="0"/>
<element name="zip" type="ccr:zipType"/>
<element name="city" type="ccr:stringType1_35"/>
</sequence>
</complexType>


complexType processingType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:transport
used by
element responseType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="ccr:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:package ccr:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="ccr:softwareType" minOccurs="0"/>
<element name="generator" type="ccr:softwareType"/>
</sequence>
</complexType>


complexType rejectedType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | extension of ccr:statusType
properties
base ccr:statusType
children | ccr:explanation ccr:error
used by
element bodyType/rejected
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
Extensions
Annotation | Base
Definition for a response status container of type «rejected» | ccr:statusType
source <complexType name="rejectedType">
<complexContent>
<extension base="ccr:statusType">
<sequence>
<element name="explanation" type="ccr:stringType1_700" minOccurs="0"/>
<element name="error" type="ccr:errorType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType responseType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:processing ccr:payload ds:Signature
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
The language used is copied from and thus defined by the request.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
    By definition there must not be any money flow!
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus NMTOKEN test the modus test is for software developers to test the processing.
By definition there must not be any money flow!
source <complexType name="responseType">
<sequence>
<element name="processing" type="ccr:processingType"/>
<element name="payload" type="ccr:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType softwareType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | ccr:stringType1_50 | required
copyright ccr:stringType1_50
description ccr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="ccr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="ccr:stringType1_50" use="required"/>
<attribute name="copyright" type="ccr:stringType1_50"/>
<attribute name="description" type="ccr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType statusType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
complexTypes acceptedType pendingType rejectedType
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name Notes
status_in status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
  • unknown: the status is unknown - the given object reference is unknown
  • ambiguous: the status is ambiguous - the given object reference delivers more than one result
  • received: the status is received - nothing done so far except receiving the request
  • frozen: the status is frozen - the request is not processed until further data is provided
  • processed: the status is processed - the request has passed all processing and analysis
  • granted: the status is granted - the request is accepted and archived.
  • canceled: the status is granted - the request is accepted and archived.
status_out status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
  • yyyyyyyyyyyy: yyyyyyyyy
attributes enumerations
Name | Extension | Base | Value | Annotations
status_in | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_in | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_in | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_in | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_in | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_in | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_in | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
status_out | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_out | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_out | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_out | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_out | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_out | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_out | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
source <complexType name="statusType">
<attribute name="status_in" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
<attribute name="status_out" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType telecomAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:phone ccr:fax
used by
elements personType/telecom companyType/telecom employeeType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="ccr:stringType1_25" maxOccurs="3"/>
<element name="fax" type="ccr:stringType1_25" minOccurs="0" maxOccurs="3"/>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
children | ccr:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | ccr:eanPartyType | required
to | ccr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="ccr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="ccr:eanPartyType" use="required"/>
<attribute name="to" type="ccr:eanPartyType" use="required"/>
</complexType>


complexType treatmentType

diagram
namespace http://www.forum-datenaustausch.ch/ccr
used by
element bodyType/treatment
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
treatment_days | duration | required
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
attributes annotations
Name | Notes
date_begin | date_begin is the start of the supposed treatment interval
date_end | date_end is the end of the supposed treatment interval
treatment_days | treatment_days is the number of planned treatment days within the given treatment period.
treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations.
  • AG: the canton is AG - Aargau
  • AI: the canton is AI - Appenzell Innerrhoden
  • AR: the canton is AR - Appenzell Ausserrhoden
  • BE: the canton is BE - Bern
  • BL: the canton is BL - Baselland
  • BS: the canton is BS - Basel
  • FR: the canton is FR - Fribourg
  • GE: the canton is GE - Geneva
  • GL: the canton is GL - Glarus
  • GR: the canton is GR - Graubünden
  • JU: the canton is JU - Jura
  • LU: the canton is LU - Lucerne
  • NE: the canton is NE - Neuchâtel
  • NW: the canton is NW - Nidwalden
  • OW: the canton is OW - Obwalden
  • SG: the canton is SG - St. Gallen
  • SH: the canton is SH - Schaffhausen
  • SO: the canton is SO - Solothurn
  • SZ: the canton is SZ - Schwyz
  • TI: the canton is TI - Ticino
  • TG: the canton is TG - Thurgau
  • UR: the canton is UR - Uri
  • VD: the canton is VD - Vaud
  • VS: the canton is VS - Valais
  • ZG: the canton is ZG - Zug
  • ZH: the canton is ZH - Zürich
  • LI: the country is LI - Liechtenstein
  • A: the country is A - Austria
  • D: the country is D - Germany
  • F: the country is F - France
  • I: the country is I - Italy
treatment_type treatment_type is the principle type of treatment encoded by a terminal set of tokens.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
treatment_reason treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens
  • disease: the reason of treatment is a disease
  • accident: the reason of treatment is an accident
  • maternity: the reason of treatment is a maternity
  • prevention: the reason of treatment is prevention
  • birthdefect: the reason of treatment a birthdefect
  • unknown: the reason of treatment is unknown (or something not mentioned above)
attributes enumerations
Name | Extension | Base | Value | Annotations
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source <complexType name="treatmentType">
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime" use="required"/>
<attribute name="treatment_days" type="duration" use="required"/>
<attribute name="treatment_canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_type" default="ambulatory">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_reason" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="disease"/>
<enumeration value="accident"/>
<enumeration value="maternity"/>
<enumeration value="prevention"/>
<enumeration value="birthdefect"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://www.forum-datenaustausch.ch/ccr
type | extension of ccr:stringType1_9
properties
base ccr:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode ccr:stringType1_9
countrycode | ccr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code | ccr:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="ccr:stringType1_9">
<attribute name="statecode" type="ccr:stringType1_9"/>
<attribute name="countrycode" type="ccr:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType eanPartyType

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attributes debitorAddressType/@ean_party contactAddressType/@ean_party partyType/@ean_party transportType/@from transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="eanPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType1_15

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
facets
minLength | 1
maxLength | 15
source <simpleType name="stringType1_15">
<restriction base="string">
<minLength value="1"/>
<maxLength value="15"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attribute documentType/@filename
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname employeeType/familyname personType/givenname employeeType/givenname postalAddressType/pobox postalAddressType/street personType/subaddressing companyType/subaddressing
attributes | notificationType/@code creditType/@request_id personType/@salutation employeeType/@salutation personType/@title employeeType/@title documentType/@title
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attributes errorType/@error_value notificationType/@text errorType/@valid_value
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_700

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
elements pendingType/explanation acceptedType/explanation rejectedType/explanation
facets
minLength | 1
maxLength | 700
source <simpleType name="stringType1_700">
<restriction base="string">
<minLength value="1"/>
<maxLength value="700"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://www.forum-datenaustausch.ch/ccr
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


Revision history: Documentation of Revision 1

Documentation of careCreditResponse_450.xsd

Documentation of Revision 1

Rev. 1/27.11.2024: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the careRequestResponse_450.xsd schema


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>