XML Schema Browser - careCreditRequest Version 450

Schema Documentation of
generalContainer V500

produced by Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as a standard at its meeting on 27th November 2024.

The standard becomes applicable on 1st January 2026.

Copyright (©) by Forum Datenaustausch, 27.11.2024 - all rights reserved


Preface

Documentation of generalContainer500.xsd

Copyright (©) by Forum Datenaustausch, 27.11.2024
All rights reserved

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this Documentation of generalContainer500.xsd.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Forum Datenaustausch

Der Verein "Forum Datenaustausch" (FoDa) fördert den effizienten und sicheren digitalen Datenaustausch zwischen Leistungserbringern und Kostenträgern im administrativen Gesundheitswesen. Er tut dies, indem er sich für folgende, grundsätzliche Ziele einsetzt:
  • Leistungserbringer und Kostenträger nutzen für die digitale Kommunikation untereinander die gleichen, gemeinsam entwickelten und festgelegten Standards.
  • Die digitale Kommunikation zwischen Leistungserbringern und Kostenträger ist sicher, verlässlich und Datenschutzkonform. Sie fördert die Effizienz der Prozesse und ist für alle Partner mit einem positiven Kosten-/Nutzenverhältnis verbunden.

Mitglieder des Forums sind nationale Verbände und Organisationen der Leistungserbringer und der Kostenträger, sowie Körperschaften und Anstalten des öffentlichen Rechts. Hier finden Sie die aktuelle Mitgliederliste.

Die vom Forum Datenaustausch freigegebenen Standards bzw. neue Standard-Versionen, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert.
L'association "Forum Datenaustausch" (FoDa) promeut un échange de données numériques efficace et sûr entre les fournisseurs de prestations et les organismes payeurs dans le domaine administratif de la santé. Pour ce faire, elle s'engage en faveur des objectifs fondamentaux suivants:
  • Les fournisseurs de prestations et les organismes payeurs utilisent les mêmes normes, développées et définies en commun, pour la communication numérique entre eux.
  • La communication numérique entre les fournisseurs de prestations et les organismes payeurs est sûre, fiable et conforme à la protection des données. Elle favorise l'efficacité des processus et est liée à un rapport coûts/bénéfices positif pour tous les partenaires.

Les membres du forum sont des associations nationales et des organisations de prestataires de services et de payeurs, ainsi que des collectivités et des établissements de droit public. Vous trouverez ici la liste actuelle des membres.

Les normes validées par le forum ou les nouvelles versions de normes, comme les messages XML pour l'échange électronique de données, sont publiées ici.


Copyright (©) notice

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying Documentation of generalContainer500.xsd for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Purpose of the schema file

This is the schema definition for a "General Container" process encoded in XML. The content is a full XML definition of an invoice request and/or a MCD request both generated by a health care provider.

As the name implies this is a container definition that holds together an invoice and its corresponding MCD.

Upon receiving the container infoset the recipient must divide the process into 2 individual processes. Therefore, the recipient responds to the "General Invoice Request" by [0,n] "General Invoice Response" messages and/or to the "Hospital MCD Request" by [0,n] "Hospital MCD Response" messages independently! As a consequence there is no response to a "General Container" infoset!

This XML project is normative for the electronic containerd process in Switzerland.


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the Documentation of generalContainer500.xsd of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient Documentation of generalContainer500.xsd regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/container"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:container="http://www.forum-datenaustausch.ch/container"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag container followed by the element name. Furthermore, the target namespace and the specific namespace container maps to http://www.forum-datenaustausch.ch/container.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<container:request xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:container="http://www.forum-datenaustausch.ch/container"
        xmlns="http://www.forum-datenaustausch.ch/container"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/container generalContainer_500.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </container:request>


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element request down as the appropriate definition is encountered.


element request

Annotation The request element is the root of the generalContainer process.
The request is divided into 2 parts
  • the invoice element contains the necessary invoice data as a full XML infoset of type generalInvoiceRequest500
  • the mcd element contains the MCD data that corresponds with the supplied invoice data, given as a full XML infoset of type generalMCDRequest500
diagram
namespace | http://www.forum-datenaustausch.ch/container
type | container:requestType
properties
content complex
children | container:invoice container:mcd
source | <element name="request" type="container:requestType"/>


element requestType/invoice

Annotation The optional invoice element is a container that allows to include one full XML infoset of type generalInvoiceRequest500 using the namespace of http://www.forum-datenaustausch.ch/invoice via an any mechanism.

Note, that since the any container is defined with processContents="strict" the included XML infoset must be schema valid otherwise a schema validation error occurs.
diagram
namespace | http://www.forum-datenaustausch.ch/container
type | container:invoiceType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
source | <element name="invoice" type="container:invoiceType" minOccurs="0"/>


element requestType/mcd

Annotation The optional mcd element is a container that allows to include one full XML infoset of type generalMCDRequest500 using a namespace of http://www.forum-datenaustausch.ch/mcd via an any mechanism.

Note, that since the any container is defined with processContents="strict" the included XML infoset must be schema valid otherwise an schema validation error occurs.
diagram
namespace | http://www.forum-datenaustausch.ch/container
type | container:mcdType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
source | <element name="mcd" type="container:mcdType" minOccurs="0"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

I
invoiceType
M
mcdType
R
requestType


complexType invoiceType

diagram
namespace http://www.forum-datenaustausch.ch/container
used by
element requestType/invoice
source <complexType name="invoiceType">
<sequence>
<any namespace="http://www.forum-datenaustausch.ch/invoice" processContents="strict"/>
</sequence>
</complexType>


complexType mcdType

diagram
namespace http://www.forum-datenaustausch.ch/container
used by
element requestType/mcd
source <complexType name="mcdType">
<sequence>
<any namespace="http://www.forum-datenaustausch.ch/mcd" processContents="strict"/>
</sequence>
</complexType>


complexType requestType

diagram
namespace | http://www.forum-datenaustausch.ch/container
children | container:invoice container:mcd
used by
element request
source <complexType name="requestType">
<sequence>
<element name="invoice" type="container:invoiceType" minOccurs="0"/>
<element name="mcd" type="container:mcdType" minOccurs="0"/>
</sequence>
</complexType>