XML Schema Browser - generalMCDResponse Version 500

Documentation
generalMCDResponse V500

produced by the standardization body
Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as a standard at its meeting on 27th November 2024.

The standard becomes applicable on 1st January 2026.

Copyright (©) by Forum Datenaustausch, 27.11.2024 - all rights reserved


Revision history of the documentation

Documentation of generalMCDResponse_500.xsd

Copyright (©) by Forum Datenaustausch, 27.11.2024
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalMCDResponse_500.xsd schema is not changed due to such an entry.
  • Revision 1 from 27.11.2024 (initial version)


Revision history of the documentation

Documentation of Revision 1

Rev. 1/27.11.2024: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the generalMCDResponse_500.xsd schema


Preface

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Forum Datenaustausch

Im "Forum Datenaustausch" haben sich verschiedene Akteure des Schweizer Gesundheitswesens zusammengeschlossen. Das Forum verfolgt u.a. das Ziel, einheitliche, gemeinsam entwickelte Standards für den elektronischen Datenaustausch festzusetzen.

Forumsmitglieder sind die Verbände der Leistungserbringer FMH, H+ und der Schweizerische Apothekerverband (SAV), auf Seiten der Kostenträger sind es santésuisse, der Schweizerische Versicherungsverband (SVV) sowie die Suva, die Militärversicherung und die Invalidenversicherung (IV).

Die vom Forum verabschiedeten Standards, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert. Dazu gehört auch die elektronische, XML basierende Leistungsabrechnung für Ärzte und Spitäler.

Die Gesellschaft bezweckt die Vereinheitlichung der Standards des elektronischen Datenaustausches im Schweizer Gesundheitswesen zwischen Leistungserbringern und Kostenträgern. Ziel ist die Festlegung von Grundsätzen mit Bezug auf die Übermittlungsstandards, die Referenzstammdaten sowie mit Bezug auf die Kriterien betreffend die Datensicherheit. Damit soll den Gesellschaftern der Aufbau von Kooperationsbeziehungen im Bereich des elektronischen Datenaustausches erleichtert werden.
Différents acteurs du domaine de la santé publique suisse se sont joints au "Forum Datenaustausch". L'objectif du forum consiste, entre autres, à établir des standards uniformes élaborés en commun pour l'échange électronique de données.

Les membres du forum sont les associations de prestataires FMH, H+ et la Société Suisse des Pharmaciens (SSPh) ainsi que, du côté des assureurs, santésuisse, l'Association Suisse d'Assurances (ASA), la Suva, l'assurance militaire et l'assurance invalidité (AI).

Les standards établis par le forum, tels les messages XML pour l'échange électronique de données, seront publiés ici. Ils englobent également le décompte électronique de prestations basé sur XML pour les médecins et les hôpitaux.

La société a pour but d'uniformiser les standards relatifs au transfert électronique de données dans la domaine de la santé suisse entre fournisseurs de prestations et assureurs. L'objectif consiste à déterminer des principes liés aux standards de transmission, aux données de base de référence ainsi qu'aux critères concernant la sécurité des données. Pour les membres de la société, cela devrait faciliter l'établissement de relations de coopération dans le domaine du transfert électronique de données.


Copyright (©) notice

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Purpose of the schema file

This is the schema definition for a "General MCD Response" process encoded in XML. The generalMCDResponse always constitutes an answer to a received "General MCD Request" and by design there can be [0,n] such responses but solely to the topmost object reference given in the request. If there is no response sent to a request then it is considered implicitly as accepted.
The subchapter Purpose/Anatomy of a response provides a broad overview about the building blocks of a response and the subchapter Purpose/Object reference provides an in-depth description of the concept of "topmost object reference".

The response is sent via 1 or more intermediates to the final recipient, who is the initial sender of the request by definition. The chain of intermediates from the request is reversed for the response.

There is no concept of response object but only a UNIX timestamp of the generation of the repsonse XML for legal reasons. However, all reference objects of the request must be included in the response as these serve as a unique identification.

This XML project is normative for the electronic MCD process in Switzerland.


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Anatomy of a response

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a response.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects that is copied from the request
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Invoice Request" can hold a maximum of 3 object references, namely
  • an optional credit object reference from the "General Credit Request" process
  • a mandatory invoice object reference from the initial "General Invoice Request" process
  • an optional reminder object reference given if the process encodes a reminder
whereas a "General MCD Request" needs 2 object references
  • a mandatory invoice object reference from the "General Invoice Request" process
  • a mandatory mcd object reference from the "General MCD Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit -> invoice -> reminder or invoice -> mcd) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference – and only for that.

For example: a reminder XML request does reference an optional credit XML request (if the object reference was given in the initial invoice XML request). However, the reference of the initial invoice XML request for which a reminder process is started, is mandatory. The topmost object reference is then the object reference of the generated reminder process. Each XML response then references the topmost object reference for which it is a response. Such a response is never targeted for the corresponding invoice but only for the reminder!


Notes about the signature

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the GLN given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/mcd:response/mcd:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA256) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-256
  • the used canonicalization algorithm must be http://www.w3.org/2010/xml-c14n2, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2010/xml-c14n2"/>
  <SignatureMethod Algorithm="http://www.w3.org/2001/04/xmlenc#sha256"/>
  <Reference URI="#xpointer(/mcd:response/mcd:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2001/04/xmlenc#sha256"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the GLN given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used - cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to RSA-OAEP (including MGF1 and SHA1)
  • The block encryption algorithm is fixed to AES256-GCM
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
   <EncryptionMethod Algorithm="http://www.w3.org/2009/xmlenc11#aes256-gcm"/>
   <ds:KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
      <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
         <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p">
           <OAEPparams>...</OAEPparams>
         </EncryptionMethod>
         <ds:KeyInfo>
            <ds:KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</ds:KeyName>
         </ds:KeyInfo>
         <CipherData>
            <CipherValue>...(asymmetrically encrypted key)...</CipherValue>
         </CipherData>
      </EncryptedKey>
   </ds:KeyInfo>
   <CipherData>
      <CipherValue>...(symmetrically encrypted content)...</CipherValue>
   </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/mcd"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:mcd="http://www.forum-datenaustausch.ch/mcd"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag mcd followed by the element name. Furthermore, the target namespace and the specific namespace mcd maps to http://www.forum-datenaustausch.ch/mcd.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<mcd:response xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:mcd="http://www.forum-datenaustausch.ch/mcd"
        xmlns="http://www.forum-datenaustausch.ch/mcd"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/mcd generalMCDResponse_500.xsd"
        language="de" modus="production" >
XML elements go here...

 </mcd:response>


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element response down as the appropriate definition is encountered.


element response

Annotation The response element is the root of the generalMCDResponse process.
The response is divided into 2 parts
  • the processing element supplies the necessary data for the transport process
  • the payload element supplies the response to the request invoice/reminder data
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:responseType
properties
content complex
children | mcd:processing mcd:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
guid | mcd:guidType | required
attributes annotations
Name Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian

The language used is copied from and thus defined by the request.
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing.

By definition there must not be any money flow!
guid the required guid (Globally Unique IDentifier) is an unique identifier for the current XML infoset defined as a 32 hex-digit string covered by the pattern [A-Fa-f0-9]{32}.
Please note that the generation of the guid must be in accordance with RFC 9562.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source | <element name="response" type="mcd:responseType"/>


element responseType/processing

Annotation | The processing element is a container with transport instructions basically mirrored from the request.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:processingType
properties
isRef | 0
content | complex
children | mcd:transport
source | <element name="processing" type="mcd:processingType"/>


element processingType/transport

Annotation The transport element defines the routing of the infoset.
In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list.
All the involved parties are defined by GLN as defined by RefData
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:transportType
properties
isRef | 0
content | complex
children | mcd:via
attributes parameters
Name | Type | Use | Default | Fixed
from | mcd:glnPartyType | required
to | mcd:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="mcd:transportType"/>


element transportType/via

Annotation The via element defines one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly send the infoset to the next intermediate in the mirrored list of intermediates or eventually deliver the infoset to the recipient (the sender of the request).
diagram
namespace http://www.forum-datenaustausch.ch/mcd
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | mcd:glnPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming the mirrored chain of intermediate hops.
source <element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="mcd:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element responseType/payload

Annotation | The payload element supplies the response to the request mcd data. The payload can optionally be signed by at W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:payloadType
properties
isRef | 0
content | complex
children | mcd:invoice mcd:mcd mcd:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
request_subtype | derived by: NMTOKEN | normal
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
request_subtype request_subtype specifies the XML infoset with respect to its modification from the standard data space. Such a modification can be seen as a request variation, subsuming a specific data set, where the set of discrete subtypes is encoded by a terminal set of tokens.
  • normal: normal defines the standard (normal) XML infoset describing an ordinary MCD infoset (Default)
  • copy: copy qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the copy flag.
  • storno: storno qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the storno flag.

    It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
attributes enumerations
Name | Extension | Base | Value | Annotations
request_subtype | NMTOKEN | normal | normal defines the standard (normal) XML infoset describing an ordinary MCD infoset (Default)
request_subtype | NMTOKEN | copy | copy qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the copy flag.
request_subtype | NMTOKEN | storno | storno qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the storno flag.
source | <element name="payload" type="mcd:payloadType"/>


element payloadType/invoice

Annotation The invoice element defines the unique invoice reference object of the request.
This element is copied from the received request
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:invoiceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | mcd:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the invoice's infoset generation
This is one of 3 identifiers that form the invoice object reference. request_timestamp will be generated once for a certain invoice object reference and thereafter always referenced!
request_date request_date is the main software's date of the invoice request ("Rechnungsdatum")
This is one of 3 identifiers that form the invoice object reference. request_date must always be the same for a certain invoice object reference!
request_id request_id is the main software's ID of the invoice request ("Rechnungsnummer")
This is one of 3 identifiers that form the invoice object reference. request_id must always be the same for a certain invoice object reference!
source | <element name="invoice" type="mcd:invoiceType"/>


element payloadType/mcd

Annotation The mcd element defines the unique MCD object of the request.
This element is copied from the received request.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:mcdType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | mcd:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the MCD's infoset generation
This is one of 3 identifiers that form the MCD object reference. request_timestamp will be generated once for a certain MCD object reference and thereafter always referenced!
request_date request_date is the main software's date of the MCD request
This is one of 3 identifiers that form the MCD object reference. request_date must be identical for the same MCD object reference!
request_id request_id is the main software's ID of the MCD request
This is one of 3 identifiers that form the MCD object reference. request_id must be identical for the same MCD object reference!
source | <element name="mcd" type="mcd:mcdType"/>


element payloadType/body

Annotation | The body element contains copied data containers from the request and the answer to the request. Since there are privacy relevant patient data in the response the body element can be replace by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:bodyType
properties
isRef | 0
content | complex
children | mcd:prolog mcd:billers mcd:providers mcd:insurance mcd:patient mcd:contact mcd:grouper mcd:pending mcd:rejected mcd:accepted mcd:documents
source | <element name="body" type="mcd:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator, validators, and main software).
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:prologType
properties
isRef | 0
content | complex
children | mcd:package mcd:generator
source | <element name="prolog" type="mcd:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | mcd:stringType1_50 | required
copyright | mcd:stringType1_50
description | mcd:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="mcd:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | mcd:stringType1_50 | required
copyright | mcd:stringType1_50
description | mcd:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="mcd:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:softwareType
properties
isRef | 0
content | complex
children | mcd:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | mcd:stringType1_50 | required
copyright | mcd:stringType1_50
description | mcd:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="mcd:softwareType"/>


element bodyType/billers

Annotation The billers element is the container holding the different flavors of the biller definitions basically differing in the unique keys like GLN or ZSR
This billers section is copied unaltered from the received request into this response.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:billersAddressType
properties
isRef | 0
content | complex
children | mcd:biller_gln mcd:biller_zsr
source | <element name="billers" type="mcd:billersAddressType"/>


element billersAddressType/biller_gln

Annotation | The biller_gln element defines the biller's address and its mandatory GLN.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:billerGLNAddressType
properties
isRef | 0
content | complex
children | mcd:company mcd:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
attributes annotations
Name Notes
gln The gln is the biller's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the corresponding treatment is carried out by the patient himself or a relative of the patient.
source | <element name="biller_gln" type="mcd:billerGLNAddressType"/>


element billerGLNAddressType/company

Annotation | The biller is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:companyType
properties
isRef | 0
content | complex
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
source | <element name="company" type="mcd:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="mcd:stringType1_35"/>


element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="mcd:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="mcd:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:postalAddressType
properties
isRef | 0
content | complex
children | mcd:pobox mcd:street mcd:zip mcd:city mcd:country
source | <element name="postal" type="mcd:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="mcd:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the full street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:streetType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
facets
minLength | 1
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
street_name | mcd:stringType1_35
house_no | mcd:stringType1_10
attributes annotations
Name | Notes
street_name | street_name is the optional street name being part of the full street definition. Please note that the street name is an extracted copy from the full street definition.
house_no | house_no is the optional house number being part of full street definition. Please note that the house number is an extracted copy from the full street definition.
source | <element name="street" type="mcd:streetType" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
state_code | mcd:stringType1_9
attributes annotations
Name | Notes
state_code | state_code is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
source | <element name="zip" type="mcd:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="mcd:stringType1_35"/>


element postalAddressType/country

Annotation The optional country element supplies the country name and country abbreviation of the postal address.

Please note that the absence of the country element implies that the country is Switzerland and consequently the country abbreviation is ISO 3166-1 alpha-2 = CH.

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:countryType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
facets
minLength | 1
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
country_code | mcd:iso3166A2Type
attributes annotations
Name | Notes
country_code | the optional country_code is the ISO designator of the country as two-letter ISO 3166-1 alpha-2 code.
source | <element name="country" type="mcd:countryType" minOccurs="0"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:phone
source | <element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="mcd:stringType1_25" maxOccurs="3"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:email mcd:uri
source | <element name="online" type="mcd:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of mcd:stringType1_80
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 80
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="mcd:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/uri

Annotation | The uri element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 160
source <element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>


element billerGLNAddressType/person

Annotation | The biller is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:personType
properties
isRef | 0
content | complex
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="mcd:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="mcd:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="mcd:stringType1_35"/>


element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="mcd:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:postalAddressType
properties
isRef | 0
content | complex
children | mcd:pobox mcd:street mcd:zip mcd:city mcd:country
source | <element name="postal" type="mcd:postalAddressType"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:phone
source | <element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:email mcd:uri
source | <element name="online" type="mcd:onlineAddressType" minOccurs="0"/>


element billersAddressType/biller_zsr

Annotation The optional biller_zsr element defines the billers's address and its mandatory ZSR number.

Note that the billers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification.
A more detailed view of the use of the biller_zsr element can be found elsewhere on the Forum Datenaustausch website.

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:zsrAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:company mcd:person
attributes parameters
Name | Type | Use | Default | Fixed
zsr | mcd:zsrPartyType | required
attributes annotations
Name | Notes
zsr | zsr is the biller's or provider's required ZSR as defined by Santésuisse
source | <element name="biller_zsr" type="mcd:zsrAddressType" minOccurs="0"/>


element zsrAddressType/company

Annotation | The biller or provider is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:companyType
properties
isRef | 0
content | complex
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
source | <element name="company" type="mcd:companyType"/>


element zsrAddressType/person

Annotation | The biller or provider is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:personType
properties
isRef | 0
content | complex
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="mcd:personType"/>


element bodyType/providers

Annotation The providers element is the container holding the different flavors of the provider definitions basically differing in the unique key like GLN or ZSR
This providers section is copied unaltered from the received request into this response.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:providersAddressType
properties
isRef | 0
content | complex
children | mcd:provider_gln mcd:provider_zsr
source | <element name="providers" type="mcd:providersAddressType"/>


element providersAddressType/provider_gln

Annotation | The required provider_gln element defines the provider's address and its mandatory GLN.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:providerGLNAddressType
properties
isRef | 0
content | complex
children | mcd:company mcd:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
gln_location | mcd:glnPartyType | required
uid | mcd:stringType1_15
attributes annotations
Name | Notes
gln The gln is the provider's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
gln_location | The gln_location codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace defined then input the gln as gln_location, basically defining the default workplace/location.
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source | <element name="provider_gln" type="mcd:providerGLNAddressType"/>


element providerGLNAddressType/company

Annotation | The provider is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:companyType
properties
isRef | 0
content | complex
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
source | <element name="company" type="mcd:companyType"/>


element providerGLNAddressType/person

Annotation | The provider is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:personType
properties
isRef | 0
content | complex
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="mcd:personType"/>


element providersAddressType/provider_zsr

Annotation The optional provider_zsr element defines the provider's address and its mandatory ZSR number.

Note that the providers's ZSR address is optional in terms of the XSD schema definition. However, it may be the case that the underlying tariff contracts, applied law and/or special contracts between service providers and insurances change the optionality into a mandatory data specification.
A more detailed view of the use of the provider_zsr element can be found elsewhere on the Forum Datenaustausch website.

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:zsrAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:company mcd:person
attributes parameters
Name | Type | Use | Default | Fixed
zsr | mcd:zsrPartyType | required
attributes annotations
Name | Notes
zsr | zsr is the biller's or provider's required ZSR as defined by Santésuisse
source | <element name="provider_zsr" type="mcd:zsrAddressType" minOccurs="0"/>


element bodyType/insurance

Annotation The insurance element defines the insurance of the corresponding request.
This insurance section is copied unaltered from the received request into this response.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:insuranceAddressType
properties
isRef | 0
content | complex
children | mcd:company mcd:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source | <element name="insurance" type="mcd:insuranceAddressType"/>


element insuranceAddressType/company

Annotation | The insurance is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:companyType
properties
isRef | 0
content | complex
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
source | <element name="company" type="mcd:companyType"/>


element insuranceAddressType/person

Annotation | The insurance is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:personType
properties
isRef | 0
content | complex
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="mcd:personType"/>


element bodyType/patient

Annotation The patient element defines the patient of the corresponding request.
This patient section is copied unaltered from the received request into this response.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:patientAddressType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
sex | derived by: NMTOKEN | required
birthdate | date | required
attributes annotations
Name | Notes
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body. The attribute sex is encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
  • unknown: the sex of the patient is unknown
birthdate | birthdate defines the birthdate of the patient
attributes enumerations
Name | Extension | Base | Value | Annotations
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
sex | NMTOKEN | unknown | the sex of the patient is unknown
source | <element name="patient" type="mcd:patientAddressType"/>


element bodyType/contact

Annotation | The contact element defines a contact for the response coded either as person or company address. The latter can optionally be augmented by data of an employee.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:contactAddressType
properties
isRef | 0
content | complex
children | mcd:person mcd:company mcd:employee
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType
attributes annotations
Name Notes
gln gln is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never a GLN of an employee!)
source | <element name="contact" type="mcd:contactAddressType"/>


element contactAddressType/person

Annotation | The contact is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:personType
properties
isRef | 0
content | complex
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="mcd:personType"/>


element contactAddressType/company

Annotation | The contact is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:companyType
properties
isRef | 0
content | complex
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
source | <element name="company" type="mcd:companyType"/>


element contactAddressType/employee

Annotation The optional employee element augments the company address by the data of an employee handling the request
The address of an employee is identical to a person's address except that the postal address is not given but implicitly inherited by the company's address container.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:employeeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:familyname mcd:givenname mcd:telecom mcd:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | mcd:stringType1_35
title | mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="employee" type="mcd:employeeType" minOccurs="0"/>


element employeeType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="mcd:stringType1_35"/>


element employeeType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="mcd:stringType1_35" minOccurs="0"/>


element employeeType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:phone
source | <element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>


element employeeType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:email mcd:uri
source | <element name="online" type="mcd:onlineAddressType" minOccurs="0"/>


element bodyType/grouper

Annotation | The grouper element repeats/copies some data from the request's grouper element.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:grouperType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
grouping | derived by: NMTOKEN | required
acid | mcd:stringType1_35
attributes annotations
Name Notes
grouping grouping is the principle type of grouping encoded by a terminal set of tokens.
  • ambulatory: the request's grouping type was ambulatory
  • stationary: the request's grouping type was stationary
acid acid is an optional administrative case identification defined in the request and copied unaltered into the response.

Please note, that the acid cannot serve as a unique identification of the MCD as opposed to the unique object reference!

attributes enumerations
Name | Extension | Base | Value | Annotations
grouping | NMTOKEN | ambulatory | the request's grouping type was ambulatory
grouping | NMTOKEN | stationary | the request's grouping type was stationary
source | <element name="grouper" type="mcd:grouperType"/>


element bodyType/pending

Annotation The pending element defines the answer of type «pending»
Per definition this means that the request can not be processed to a final stage as some data are missing. An optional explanation and [0,n] messages (instructions) are supplied to inform the recipient what is needed to "unfreeze" the request.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:pendingType
properties
isRef | 0
content | complex
children | mcd:explanation mcd:message
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="pending" type="mcd:pendingType"/>


element pendingType/explanation

Annotation The explanation element defines the overall explanation for the pending status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_2800
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 2800
source | <element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>


element pendingType/message

Annotation The message element defines either a reason why the request is in the pending state or an instruction how to proceed for leaving this state. E.g. the insurance is awaiting further documents like needed medication plans.
There is an unbounded number of such messages possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:notificationType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | mcd:stringType1_35 | required
text | mcd:stringType1_700 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source | <element name="message" type="mcd:notificationType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/rejected

Annotation The rejected element defines the answer of type «rejected».
Per definition this means that the request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional explanation and [0,n] errors are supplied to justify the decision.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:rejectedType
properties
isRef | 0
content | complex
children | mcd:explanation mcd:error
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="rejected" type="mcd:rejectedType"/>


element rejectedType/explanation

Annotation The explanation element defines the overall explanation for the rejected status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_2800
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 2800
source | <element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>


element rejectedType/error

Annotation The error element defines one detailed error why the request is rejected.
There is an unbounded number of such errors possible all given in the language defined by the response@language attribute.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:errorType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | mcd:stringType1_35 | required
text | mcd:stringType1_700 | required
error_value | mcd:stringType1_350
valid_value | mcd:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a textual description what within the currently used contracts is erroneous (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a textual description that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
source | <element name="error" type="mcd:errorType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/accepted

Annotation The accepted element defines the answer of type «accepted».
Per definition this means that the request is from a principle point of view accepted and will be processed to a final stage. An optional explanation is supplied to justify the decision.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:acceptedType
properties
isRef | 0
content | complex
children | mcd:explanation
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="accepted" type="mcd:acceptedType"/>


element acceptedType/explanation

Annotation The optional explanation element defines the overall explanation for the accepted status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:stringType1_2800
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 2800
source | <element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>


element bodyType/documents

Annotation | The documents element is an optional container for including inline, Base64-coded documents.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | mcd:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="mcd:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines at least one physical document of an allowed MIME type that is included in the infoset Base64-coded.
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | mcd:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | mcd:base64
attributes parameters
Name | Type | Use | Default | Fixed
filename | mcd:filenameType | required
documentType | derived by: NMTOKEN | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
documentType documentType describes the document in terms of its semantic content encoded by a terminal set of tokens
  • Report: the semantic content is of type Report
  • Image: the semantic content is of type Image
  • Unemployability: the semantic content is of type Unemployability
  • Questionnaire: the semantic content is of type Questionnaire
  • Notification: the semantic content is of type Notification
  • Planning: the semantic content is of type Planning
  • Prescription: the semantic content is of type Prescription
  • SalaryCession: the semantic content is of type Salary Cession
  • UndefinedDoc: the semantic content is unknown or undefined and thus the type is Undefined Document
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
attributes enumerations
Name | Extension | Base | Value | Annotations
documentType | NMTOKEN | Report | the semantic content is of type Report
documentType | NMTOKEN | Image | the semantic content is of type Image
documentType | NMTOKEN | Unemployability | the semantic content is of type Unemployability
documentType | NMTOKEN | Questionnaire | the semantic content is of type Questionnaire
documentType | NMTOKEN | Notification | the semantic content is of type Notification
documentType | NMTOKEN | Planning | the semantic content is of type Planning
documentType | NMTOKEN | Prescription | the semantic content is of type Prescription
documentType | NMTOKEN | SalaryCession | the semantic content is of type Salary Cession
documentType | NMTOKEN | UndefinedDoc | the semantic content is unknown or undefined and thus the type is Undefined Document
source | <element name="document" type="mcd:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet streams
diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the end recipient of this infoset (the biller of the request).
See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sending party represented by the transport@to GLN (the mirrored transport@from from the request).
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType responseType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

A
acceptedType
B
billerGLNAddressType
billersAddressType
bodyType
C
companyType
contactAddressType
countryType
D
dependsOnType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
employeeType
errorType
F
filenameType
G
glnPartyType
grouperType
guidType
I
insuranceAddressType
invoiceType
iso3166A2Type
M
mcdType
N
notificationType
O
onlineAddressType
P
patientAddressType
payloadType
pendingType
personType
postalAddressType
processingType
prologType
providerGLNAddressType
providersAddressType
R
rejectedType
responseType
S
softwareType
ssnPartyType
statusType
streetType
stringType1_10
stringType1_15
stringType1_25
stringType1_255
stringType1_2800
stringType1_3
stringType1_35
stringType1_350
stringType1_50
stringType1_70
stringType1_700
stringType1_80
stringType1_9
T
telecomAddressType
transportType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z


complexType acceptedType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:statusType
properties
base mcd:statusType
children | mcd:explanation
used by
element bodyType/accepted
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «accepted» | mcd:statusType
source <complexType name="acceptedType">
<complexContent>
<extension base="mcd:statusType">
<sequence>
<element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType billerGLNAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:company mcd:person
used by
element billersAddressType/biller_gln
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
attributes annotations
Name Notes
gln The gln is the biller's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the corresponding treatment is carried out by the patient himself or a relative of the patient.
source <complexType name="billerGLNAddressType">
<choice>
<element name="company" type="mcd:companyType"/>
<element name="person" type="mcd:personType"/>
</choice>
<attribute name="gln" type="mcd:glnPartyType" use="required"/>
</complexType>


complexType billersAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:biller_gln mcd:biller_zsr
used by
element bodyType/billers
source <complexType name="billersAddressType">
<sequence>
<element name="biller_gln" type="mcd:billerGLNAddressType"/>
<element name="biller_zsr" type="mcd:zsrAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType bodyType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:prolog mcd:billers mcd:providers mcd:insurance mcd:patient mcd:contact mcd:grouper mcd:pending mcd:rejected mcd:accepted mcd:documents
used by
element payloadType/body
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="mcd:prologType"/>
<element name="billers" type="mcd:billersAddressType"/>
<element name="providers" type="mcd:providersAddressType"/>
<element name="insurance" type="mcd:insuranceAddressType"/>
<element name="patient" type="mcd:patientAddressType"/>
<element name="contact" type="mcd:contactAddressType"/>
<element name="grouper" type="mcd:grouperType"/>
<choice>
<element name="pending" type="mcd:pendingType"/>
<element name="rejected" type="mcd:rejectedType"/>
<element name="accepted" type="mcd:acceptedType"/>
</choice>
<element name="documents" type="mcd:documentsType" minOccurs="0"/>
</sequence>
</complexType>


complexType companyType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:companyname mcd:department mcd:subaddressing mcd:postal mcd:telecom mcd:online
used by
elements billerGLNAddressType/company providerGLNAddressType/company zsrAddressType/company insuranceAddressType/company contactAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="mcd:stringType1_35"/>
<element name="department" type="mcd:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="mcd:stringType1_35" minOccurs="0"/>
<element name="postal" type="mcd:postalAddressType"/>
<element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>
<element name="online" type="mcd:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType contactAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:person mcd:company mcd:employee
used by
element bodyType/contact
attributes parameters
Name Type Use Default Fixed
gln mcd:glnPartyType
attributes annotations
Name Notes
gln gln is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never a GLN of an employee!)
source <complexType name="contactAddressType">
<choice>
<element name="person" type="mcd:personType"/>
<sequence>
<element name="company" type="mcd:companyType"/>
<element name="employee" type="mcd:employeeType" minOccurs="0"/>
</sequence>
</choice>
<attribute name="gln" type="mcd:glnPartyType"/>
</complexType>


complexType countryType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:stringType1_35
properties
base mcd:stringType1_35
used by
element postalAddressType/country
facets
minLength | 1
maxLength | 35
attributes parameters
Name Type Use Default Fixed
country_code mcd:iso3166A2Type
attributes annotations
Name | Notes
country_code | the optional country_code is the ISO designator of the country as two-letter ISO 3166-1 alpha-2 code.
Extensions
Annotation | Base
Definition for the country container (a subcontainer of the address definition) giving the country and its ISO 3166-1 alpha-2 designator | mcd:stringType1_35
source <complexType name="countryType">
<simpleContent>
<extension base="mcd:stringType1_35">
<attribute name="country_code" type="mcd:iso3166A2Type"/>
</extension>
</simpleContent>
</complexType>


complexType dependsOnType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | mcd:stringType1_50 | required
copyright mcd:stringType1_50
description mcd:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="mcd:stringType1_50" use="required"/>
<attribute name="copyright" type="mcd:stringType1_50"/>
<attribute name="description" type="mcd:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType documentsType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="mcd:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | mcd:filenameType | required
documentType | derived by: NMTOKEN | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
documentType documentType describes the document in terms of its semantic content encoded by a terminal set of tokens
  • Report: the semantic content is of type Report
  • Image: the semantic content is of type Image
  • Unemployability: the semantic content is of type Unemployability
  • Questionnaire: the semantic content is of type Questionnaire
  • Notification: the semantic content is of type Notification
  • Planning: the semantic content is of type Planning
  • Prescription: the semantic content is of type Prescription
  • SalaryCession: the semantic content is of type Salary Cession
  • UndefinedDoc: the semantic content is unknown or undefined and thus the type is Undefined Document
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
attributes enumerations
Name | Extension | Base | Value | Annotations
documentType | NMTOKEN | Report | the semantic content is of type Report
documentType | NMTOKEN | Image | the semantic content is of type Image
documentType | NMTOKEN | Unemployability | the semantic content is of type Unemployability
documentType | NMTOKEN | Questionnaire | the semantic content is of type Questionnaire
documentType | NMTOKEN | Notification | the semantic content is of type Notification
documentType | NMTOKEN | Planning | the semantic content is of type Planning
documentType | NMTOKEN | Prescription | the semantic content is of type Prescription
documentType | NMTOKEN | SalaryCession | the semantic content is of type Salary Cession
documentType | NMTOKEN | UndefinedDoc | the semantic content is unknown or undefined and thus the type is Undefined Document
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="filename" type="mcd:filenameType" use="required"/>
<attribute name="documentType" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="Report"/>
<enumeration value="Image"/>
<enumeration value="Unemployability"/>
<enumeration value="Questionnaire"/>
<enumeration value="Notification"/>
<enumeration value="Planning"/>
<enumeration value="Prescription"/>
<enumeration value="SalaryCession"/>
<enumeration value="UndefinedDoc"/>
</restriction>
</simpleType>
</attribute>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType employeeType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:familyname mcd:givenname mcd:telecom mcd:online
used by
element contactAddressType/employee
attributes parameters
Name Type Use Default Fixed
salutation mcd:stringType1_35
title mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="employeeType">
<sequence>
<element name="familyname" type="mcd:stringType1_35"/>
<element name="givenname" type="mcd:stringType1_35" minOccurs="0"/>
<element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>
<element name="online" type="mcd:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="mcd:stringType1_35"/>
<attribute name="title" type="mcd:stringType1_35"/>
</complexType>


complexType errorType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:notificationType
properties
base mcd:notificationType
used by
element rejectedType/error
attributes parameters
Name | Type | Use | Default | Fixed
code | mcd:stringType1_35 | required
text | mcd:stringType1_700 | required
error_value mcd:stringType1_350
valid_value mcd:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a textual description what within the currently used contracts is erroneous (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a textual description that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
Extensions
Annotation | Base
Definition for an error container | mcd:notificationType
source <complexType name="errorType">
<complexContent>
<extension base="mcd:notificationType">
<attribute name="error_value" type="mcd:stringType1_350"/>
<attribute name="valid_value" type="mcd:stringType1_350"/>
<attribute name="record_id" type="positiveInteger"/>
</extension>
</complexContent>
</complexType>


complexType grouperType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element bodyType/grouper
attributes parameters
Name | Type | Use | Default | Fixed
grouping | derived by: NMTOKEN | required
acid mcd:stringType1_35
attributes annotations
Name Notes
grouping grouping is the principle type of grouping encoded by a terminal set of tokens.
  • ambulatory: the request's grouping type was ambulatory
  • stationary: the request's grouping type was stationary
acid acid is an optional administrative case identification defined in the request and copied unaltered into the response.

Please note, that the acid cannot serve as a unique identification of the MCD as opposed to the unique object reference!

attributes enumerations
Name | Extension | Base | Value | Annotations
grouping | NMTOKEN | ambulatory | the request's grouping type was ambulatory
grouping | NMTOKEN | stationary | the request's grouping type was stationary
source <complexType name="grouperType">
<attribute name="grouping" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="acid" type="mcd:stringType1_35"/>
</complexType>


complexType insuranceAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:company mcd:person
used by
element bodyType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source <complexType name="insuranceAddressType">
<choice>
<element name="company" type="mcd:companyType"/>
<element name="person" type="mcd:personType"/>
</choice>
<attribute name="gln" type="mcd:glnPartyType" use="required"/>
</complexType>


complexType invoiceType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element payloadType/invoice
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | mcd:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the invoice's infoset generation
This is one of 3 identifiers that form the invoice object reference. request_timestamp will be generated once for a certain invoice object reference and thereafter always referenced!
request_date request_date is the main software's date of the invoice request ("Rechnungsdatum")
This is one of 3 identifiers that form the invoice object reference. request_date must always be the same for a certain invoice object reference!
request_id request_id is the main software's ID of the invoice request ("Rechnungsnummer")
This is one of 3 identifiers that form the invoice object reference. request_id must always be the same for a certain invoice object reference!
source <complexType name="invoiceType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="2890245600"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="mcd:stringType1_35" use="required"/>
</complexType>


complexType mcdType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element payloadType/mcd
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | mcd:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the MCD's infoset generation
This is one of 3 identifiers that form the MCD object reference. request_timestamp will be generated once for a certain MCD object reference and thereafter always referenced!
request_date request_date is the main software's date of the MCD request
This is one of 3 identifiers that form the MCD object reference. request_date must be identical for the same MCD object reference!
request_id request_id is the main software's ID of the MCD request
This is one of 3 identifiers that form the MCD object reference. request_id must be identical for the same MCD object reference!
source <complexType name="mcdType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="2890245600"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="mcd:stringType1_35" use="required"/>
</complexType>


complexType notificationType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element | pendingType/message
complexType | errorType
attributes parameters
Name | Type | Use | Default | Fixed
code | mcd:stringType1_35 | required
text | mcd:stringType1_700 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source <complexType name="notificationType">
<attribute name="code" type="mcd:stringType1_35" use="required"/>
<attribute name="text" type="mcd:stringType1_700" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:email mcd:uri
used by
elements personType/online companyType/online employeeType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="mcd:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType patientAddressType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
sex | derived by: NMTOKEN | required
birthdate | date | required
attributes annotations
Name | Notes
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body. The attribute sex is encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
  • unknown: the sex of the patient is unknown
birthdate | birthdate defines the birthdate of the patient
attributes enumerations
Name | Extension | Base | Value | Annotations
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
sex | NMTOKEN | unknown | the sex of the patient is unknown
source <complexType name="patientAddressType">
<attribute name="sex" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="date" use="required"/>
</complexType>


complexType payloadType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:invoice mcd:mcd mcd:body xenc:EncryptedData
used by
element responseType/payload
attributes parameters
Name | Type | Use | Default | Fixed
request_subtype | derived by: NMTOKEN | normal
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
request_subtype request_subtype specifies the XML infoset with respect to its modification from the standard data space. Such a modification can be seen as a request variation, subsuming a specific data set, where the set of discrete subtypes is encoded by a terminal set of tokens.
  • normal: normal defines the standard (normal) XML infoset describing an ordinary MCD infoset (Default)
  • copy: copy qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the copy flag.
  • storno: storno qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the storno flag.

    It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
attributes enumerations
Name | Extension | Base | Value | Annotations
request_subtype | NMTOKEN | normal | normal defines the standard (normal) XML infoset describing an ordinary MCD infoset (Default)
request_subtype | NMTOKEN | copy | copy qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the copy flag.
request_subtype | NMTOKEN | storno | storno qualifies the XML infoset as the exact copy of a previously defined "normal" MCD infoset except for the storno flag.
source <complexType name="payloadType">
<sequence>
<element name="invoice" type="mcd:invoiceType"/>
<element name="mcd" type="mcd:mcdType"/>
<choice>
<element name="body" type="mcd:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="request_subtype" default="normal">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="normal"/>
<enumeration value="copy"/>
<enumeration value="storno"/>
</restriction>
</simpleType>
</attribute>
<attribute name="response_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="2890245600"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType pendingType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:statusType
properties
base mcd:statusType
children | mcd:explanation mcd:message
used by
element bodyType/pending
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «pending» | mcd:statusType
source <complexType name="pendingType">
<complexContent>
<extension base="mcd:statusType">
<sequence>
<element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>
<element name="message" type="mcd:notificationType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType personType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:familyname mcd:givenname mcd:subaddressing mcd:postal mcd:telecom mcd:online
used by
elements billerGLNAddressType/person providerGLNAddressType/person zsrAddressType/person insuranceAddressType/person contactAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation mcd:stringType1_35
title mcd:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="mcd:stringType1_35"/>
<element name="givenname" type="mcd:stringType1_35"/>
<element name="subaddressing" type="mcd:stringType1_35" minOccurs="0"/>
<element name="postal" type="mcd:postalAddressType"/>
<element name="telecom" type="mcd:telecomAddressType" minOccurs="0"/>
<element name="online" type="mcd:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="mcd:stringType1_35"/>
<attribute name="title" type="mcd:stringType1_35"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:pobox mcd:street mcd:zip mcd:city mcd:country
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="mcd:stringType1_35" minOccurs="0"/>
<element name="street" type="mcd:streetType" minOccurs="0"/>
<element name="zip" type="mcd:zipType"/>
<element name="city" type="mcd:stringType1_35"/>
<element name="country" type="mcd:countryType" minOccurs="0"/>
</sequence>
</complexType>


complexType processingType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:transport
used by
element responseType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="mcd:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:package mcd:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="mcd:softwareType" minOccurs="0"/>
<element name="generator" type="mcd:softwareType"/>
</sequence>
</complexType>


complexType providerGLNAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:company mcd:person
used by
element providersAddressType/provider_gln
attributes parameters
Name | Type | Use | Default | Fixed
gln | mcd:glnPartyType | required
gln_location | mcd:glnPartyType | required
uid mcd:stringType1_15
attributes annotations
Name | Notes
gln The gln is the provider's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
gln_location | The gln_location codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace defined then input the gln as gln_location, basically defining the default workplace/location.
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source <complexType name="providerGLNAddressType">
<choice>
<element name="company" type="mcd:companyType"/>
<element name="person" type="mcd:personType"/>
</choice>
<attribute name="gln" type="mcd:glnPartyType" use="required"/>
<attribute name="gln_location" type="mcd:glnPartyType" use="required"/>
<attribute name="uid" type="mcd:stringType1_15"/>
</complexType>


complexType providersAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:provider_gln mcd:provider_zsr
used by
element bodyType/providers
source <complexType name="providersAddressType">
<sequence>
<element name="provider_gln" type="mcd:providerGLNAddressType"/>
<element name="provider_zsr" type="mcd:zsrAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType rejectedType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:statusType
properties
base mcd:statusType
children | mcd:explanation mcd:error
used by
element bodyType/rejected
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «rejected» | mcd:statusType
source <complexType name="rejectedType">
<complexContent>
<extension base="mcd:statusType">
<sequence>
<element name="explanation" type="mcd:stringType1_2800" minOccurs="0"/>
<element name="error" type="mcd:errorType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType responseType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:processing mcd:payload ds:Signature
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
guid | mcd:guidType | required
attributes annotations
Name Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian

The language used is copied from and thus defined by the request.
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing.

By definition there must not be any money flow!
guid the required guid (Globally Unique IDentifier) is an unique identifier for the current XML infoset defined as a 32 hex-digit string covered by the pattern [A-Fa-f0-9]{32}.
Please note that the generation of the guid must be in accordance with RFC 9562.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source <complexType name="responseType">
<sequence>
<element name="processing" type="mcd:processingType"/>
<element name="payload" type="mcd:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
<attribute name="guid" type="mcd:guidType" use="required"/>
</complexType>


complexType softwareType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | mcd:stringType1_50 | required
copyright mcd:stringType1_50
description mcd:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="mcd:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="mcd:stringType1_50" use="required"/>
<attribute name="copyright" type="mcd:stringType1_50"/>
<attribute name="description" type="mcd:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType statusType

diagram
namespace http://www.forum-datenaustausch.ch/mcd
used by
complexTypes acceptedType pendingType rejectedType
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
status_in | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_in | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_in | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_in | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_in | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_in | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_in | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
status_out | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_out | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_out | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_out | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_out | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_out | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_out | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
source <complexType name="statusType">
<attribute name="status_in" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
<attribute name="status_out" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType streetType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:stringType1_35
properties
base mcd:stringType1_35
used by
element postalAddressType/street
facets
minLength | 1
maxLength | 35
attributes parameters
Name Type Use Default Fixed
street_name mcd:stringType1_35
house_no mcd:stringType1_10
attributes annotations
Name | Notes
street_name | street_name is the optional street name being part of the full street definition. Please note that the street name is an extracted copy from the full street definition.
house_no | house_no is the optional house number being part of full street definition. Please note that the house number is an extracted copy from the full street definition.
Extensions
Annotation | Base
Definition for the street container (a subcontainer of the address definition) supplying the full street as element and the split up into street name and house number both defined as attributes. | mcd:stringType1_35
source <complexType name="streetType">
<simpleContent>
<extension base="mcd:stringType1_35">
<attribute name="street_name" type="mcd:stringType1_35"/>
<attribute name="house_no" type="mcd:stringType1_10"/>
</extension>
</simpleContent>
</complexType>


complexType telecomAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:phone
used by
elements personType/telecom companyType/telecom employeeType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="mcd:stringType1_25" maxOccurs="3"/>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | mcd:glnPartyType | required
to | mcd:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="mcd:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="mcd:glnPartyType" use="required"/>
<attribute name="to" type="mcd:glnPartyType" use="required"/>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
type | extension of mcd:stringType1_9
properties
base mcd:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name Type Use Default Fixed
state_code mcd:stringType1_9
attributes annotations
Name | Notes
state_code | state_code is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code and an optional state code | mcd:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="mcd:stringType1_9">
<attribute name="state_code" type="mcd:stringType1_9"/>
</extension>
</simpleContent>
</complexType>


complexType zsrAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/mcd
children | mcd:company mcd:person
used by
elements billersAddressType/biller_zsr providersAddressType/provider_zsr
attributes parameters
Name | Type | Use | Default | Fixed
zsr | mcd:zsrPartyType | required
attributes annotations
Name | Notes
zsr | zsr is the biller's or provider's required ZSR as defined by Santésuisse
source <complexType name="zsrAddressType">
<choice>
<element name="company" type="mcd:companyType"/>
<element name="person" type="mcd:personType"/>
</choice>
<attribute name="zsr" type="mcd:zsrPartyType" use="required"/>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType filenameType

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute documentType/@filename
facets
pattern ([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{3,4})
source <simpleType name="filenameType">
<restriction base="string">
<pattern value="([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{3,4})"/>
</restriction>
</simpleType>


simpleType glnPartyType

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attributes transportType/@from billerGLNAddressType/@gln providerGLNAddressType/@gln insuranceAddressType/@gln contactAddressType/@gln providerGLNAddressType/@gln_location transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="glnPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType guidType

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute responseType/@guid
facets
pattern [A-Fa-f0-9]{32}
source <simpleType name="guidType">
<restriction base="string">
<pattern value="[A-Fa-f0-9]{32}"/>
</restriction>
</simpleType>


simpleType iso3166A2Type

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute countryType/@country_code
facets
pattern ([A-Z]{2})
source <simpleType name="iso3166A2Type">
<restriction base="string">
<pattern value="([A-Z]{2})"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
facets
pattern [0-9]{4,10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType1_10

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute streetType/@house_no
facets
minLength | 1
maxLength | 10
source <simpleType name="stringType1_10">
<restriction base="string">
<minLength value="1"/>
<maxLength value="10"/>
</restriction>
</simpleType>


simpleType stringType1_15

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute providerGLNAddressType/@uid
facets
minLength | 1
maxLength | 15
source <simpleType name="stringType1_15">
<restriction base="string">
<minLength value="1"/>
<maxLength value="15"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
element telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_2800

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
elements pendingType/explanation rejectedType/explanation acceptedType/explanation
facets
minLength | 1
maxLength | 2800
source <simpleType name="stringType1_2800">
<restriction base="string">
<minLength value="1"/>
<maxLength value="2800"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname employeeType/familyname personType/givenname employeeType/givenname postalAddressType/pobox personType/subaddressing companyType/subaddressing
complexTypes | countryType streetType
attributes | grouperType/@acid notificationType/@code invoiceType/@request_id mcdType/@request_id personType/@salutation employeeType/@salutation streetType/@street_name personType/@title employeeType/@title
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attributes errorType/@error_value errorType/@valid_value
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_700

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute notificationType/@text
facets
minLength | 1
maxLength | 700
source <simpleType name="stringType1_700">
<restriction base="string">
<minLength value="1"/>
<maxLength value="700"/>
</restriction>
</simpleType>


simpleType stringType1_80

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 80
source <simpleType name="stringType1_80">
<restriction base="string">
<minLength value="1"/>
<maxLength value="80"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
complexType | zipType
attribute | zipType/@state_code
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


simpleType zsrPartyType

namespace | http://www.forum-datenaustausch.ch/mcd
type | restriction of string
used by
attribute zsrAddressType/@zsr
facets
pattern ([A-Z][0-9]{6})
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="([A-Z][0-9]{6})"/>
</restriction>
</simpleType>


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>