XML Schema Browser - generalCreditResponse Version 450

Schema Documentation of
generalCreditResponse V450

proposed standard of Sumex1

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.

Copyright (©) by Sumex1, 01.11.2019 - all rights reserved


Revision history of the documentation

Documentation of the proposed generalCreditResponse_450.xsd standard
Copyright (©) by Sumex1, 01.11.2019
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalCreditResponse_450.xsd schema is not changed due to such an entry.
  • Initial documentation of the generalCreditResponse_450.xsd schema


Preface

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Sumex1 or the email address info@sumex1.net


Sumex1

Sumex1

The SUMEX1 project is a sweeping joint industry initiative of SUVA. The project provides various middleware ATL COM modules -all based on an open modular architectural blueprint- usable in software of the Swiss healthcare sector. It is the intent of SUVA to help software developers and last but not least the Swiss healthcare providers mastering the complexity of e.g. the TarMed tariff system and easily overcoming the obstacles of the electronic billing.

You may use all Sumex1 COM modules as a part of your software application product free of charge. By using such a COM module there is no necessity to develop validation services, electronic invoicing and OCR-capable printing in your own software application product or other primary services for which the Sumex1 COM module was intended for. These Sumex1 COM modules improve your software application product by performing a higher quality communication between your clients and the health care insurance companies. There is a EULA accompanying each installer of a Sumex1 COM module, that lays the juristic foundation of the usage e.g. the EULA of the tarmedValidator.

SUVA as copyright holder and principal maintainers of the software have the very intention to supply state of the art modules that benefits all partners in the Swiss healthcare sector. You can trust our willingness to keep that project alive - in fact, the past 15 years should be proof enough!


Copyright (©) notice

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Purpose of the schema file

This is the schema definition for a nursing "General Credit Response" (CCR) process encoded in XML. The content is a planning record dataset of a nursing institution that basically defines the required input to a possible CCR grouper. Furthermore, the incurred costs are defined by a set of tariff based service records. To fully document the cost relation the planning records are linked to the corresponding service records.

The generalCreditResponse is generated by a nursing care provider and then sent to the designated debitor. The subchapter Purpose/Anatomy of a request provides a broad overview about the building blocks of a request.

Each individual request is defined by a unique triple of data denoted as object reference. The subchapter Purpose/Object reference provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

Besides the topmost object reference the XML request is further specified by a set of process attributes, namely

  • the optional copy attribute defining the XML request as an identical copy of an initial request.
  • the optional storno attribute basically canceling the XML request defined by the topmost object reference.
The copy and storno attributes can be combined to form a total of 4 different combinations. The subchapter Purpose/Process attributes provides an in-depth description of these attributes.

Upon receiving the XML request the recipient can respond by [0,n] nursing "Care Credit Response" messages, whereas the content per definition defines an answer to the topmost object reference - and only to that object!


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Anatomy of a response

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a response.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects that is copied from the request
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Credit Request" can hold a maximum of 2 object references, namely
  • an optional credit_ref object reference from a former "General Credit Request" process
  • a mandatory credit object reference from the initial "General Credit Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> credit) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


Notes about the signature

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/ccr:request/ccr:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-1
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/>
  <Reference URI="#xpointer(/credit:request/credit:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used- cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA1) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to Triple DES
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#tripledes-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-1_5"/>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://sumex1.net/gcr"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:gcr="http://sumex1.net/gcr"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag gcr followed by the element name. Furthermore, the target namespace and the specific namespace gcr maps to http://sumex1.net/gcr.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<gcr:response xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:gcr="http://sumex1.net/gcr"
        xmlns="http://sumex1.net/gcr"
        xsi:schemaLocation="http://sumex1.net/gcr generalCreditResponse_450.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </gcr:response>


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element response down as the appropriate definition is encountered.


element response

Annotation The response element is the root of the generalCreditResponse process.
The response is divided into 2 parts
  • the processing element supplies the necessary data for the transport process
  • the payload element supplies the response to the request credit data
diagram
namespace | http://sumex1.net/gcr
type | gcr:responseType
properties
content complex
children | gcr:processing gcr:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name | Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
The language used is copied from and thus defined by the request.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source | <element name="response" type="gcr:responseType"/>


element responseType/processing

Annotation | The processing element is a container with transport instructions basically mirrored from the request.
diagram
namespace | http://sumex1.net/gcr
type | gcr:processingType
properties
isRef | 0
content | complex
children | gcr:transport
source | <element name="processing" type="gcr:processingType"/>


element processingType/transport

Annotation The transport element defines the routing of the infoset.
In fact the meaning and the data is mirrored from the corresponding request thus the initial sender becomes the recipient and the initial recipient becomes the sender. Furthermore the chain of intermediates from the request is reversed and the infoset is sent to the first intermediate of the reversed list.
All the involved parties are defined by GLN as defined by RefData
diagram
namespace | http://sumex1.net/gcr
type | gcr:transportType
properties
isRef | 0
content | complex
children | gcr:via
attributes parameters
Name | Type | Use | Default | Fixed
from | gcr:eanPartyType | required
to | gcr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="gcr:transportType"/>


element transportType/via

Annotation The via element defines one intermediate hop through which the infoset was routed.
It is in the responsibility of an intermediate to correctly send the infoset to the next intermediate in the mirrored list of intermediates or eventually deliver the infoset to the recipient (the sender of the request).
diagram
namespace http://sumex1.net/gcr
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | gcr:eanPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming the mirrored chain of intermediate hops.
source <element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="gcr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element responseType/payload

Annotation | The payload element supplies the response to the request data. In fact the response includes all data given in the request augmented by the response. The payload can optionally be signed by a W3C signing process.
diagram
namespace | http://sumex1.net/gcr
type | gcr:payloadType
properties
isRef | 0
content | complex
children | gcr:credit_ref gcr:credit gcr:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
storno storno augments the topmost object reference by a storno command.
This attribute is copied from the received request
copy copy augments the topmost object reference by a copy command
This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
source | <element name="payload" type="gcr:payloadType"/>


element payloadType/credit_ref

Annotation | The credit_ref element defines a former credit object reference to which the current credit object reference make a reference.
diagram
namespace | http://sumex1.net/gcr
type | gcr:creditType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | gcr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit_ref" type="gcr:creditType" minOccurs="0"/>


element payloadType/credit

Annotation | The credit element defines the unique credit object reference.
diagram
namespace | http://sumex1.net/gcr
type | gcr:creditType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | gcr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit" type="gcr:creditType"/>


element payloadType/body

Annotation | The body element contains copied data containers from the request and the answer to the request. Since there are privacy relevant patient data in the response the body element can be replace by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://sumex1.net/gcr
type | gcr:bodyType
properties
isRef | 0
content | complex
children | gcr:prolog gcr:biller gcr:provider gcr:patient gcr:insurance gcr:debitor gcr:contact gcr:treatment gcr:pending gcr:accepted gcr:rejected gcr:documents
source | <element name="body" type="gcr:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator and main software, respectively).
diagram
namespace | http://sumex1.net/gcr
type | gcr:prologType
properties
isRef | 0
content | complex
children | gcr:package gcr:generator
source | <element name="prolog" type="gcr:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://sumex1.net/gcr
type | gcr:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | gcr:stringType1_50 | required
copyright | gcr:stringType1_50
description | gcr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="gcr:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://sumex1.net/gcr
type | gcr:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | gcr:stringType1_50 | required
copyright | gcr:stringType1_50
description | gcr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="gcr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://sumex1.net/gcr
type | gcr:softwareType
properties
isRef | 0
content | complex
children | gcr:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | gcr:stringType1_50 | required
copyright | gcr:stringType1_50
description | gcr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="gcr:softwareType"/>


element bodyType/biller

Annotation The biller element defines the address of the entity that generated the general credit request.

Element and all subelements copied unaltered from request

diagram
namespace | http://sumex1.net/gcr
type | gcr:baseAddressType
properties
isRef | 0
content | complex
children | gcr:company gcr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType | required
zsr | gcr:zsrPartyType
specialty | gcr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="biller" type="gcr:baseAddressType"/>


element baseAddressType/company

Annotation | The base address is one of a company given by the company element
diagram
namespace | http://sumex1.net/gcr
type | gcr:companyType
properties
isRef | 0
content | complex
children | gcr:companyname gcr:department gcr:subaddressing gcr:postal gcr:telecom gcr:online
source | <element name="company" type="gcr:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="gcr:stringType1_35"/>


element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="gcr:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="gcr:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:postalAddressType
properties
isRef | 0
content | complex
children | gcr:pobox gcr:street gcr:zip gcr:city
source | <element name="postal" type="gcr:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="gcr:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the street part of the postal address
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="street" type="gcr:stringType1_35" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://sumex1.net/gcr
type | gcr:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | gcr:stringType1_9
countrycode | gcr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="zip" type="gcr:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="gcr:stringType1_35"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:phone gcr:fax
source | <element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="gcr:stringType1_25" maxOccurs="3"/>


element telecomAddressType/fax

Annotation | The fax element supplies a telefax number
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_25
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="fax" type="gcr:stringType1_25" minOccurs="0" maxOccurs="3"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:email gcr:url
source | <element name="online" type="gcr:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://sumex1.net/gcr
type | restriction of gcr:stringType1_70
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 70
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="gcr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/url

Annotation | The url element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://sumex1.net/gcr
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 100
source <element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>


element baseAddressType/person

Annotation | The base address is one of a person given by the person element
diagram
namespace | http://sumex1.net/gcr
type | gcr:personType
properties
isRef | 0
content | complex
children | gcr:familyname gcr:givenname gcr:subaddressing gcr:postal gcr:telecom gcr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | gcr:stringType1_35
title | gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="gcr:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="gcr:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="gcr:stringType1_35"/>


element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="gcr:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:postalAddressType
properties
isRef | 0
content | complex
children | gcr:pobox gcr:street gcr:zip gcr:city
source | <element name="postal" type="gcr:postalAddressType"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:phone gcr:fax
source | <element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:email gcr:url
source | <element name="online" type="gcr:onlineAddressType" minOccurs="0"/>


element bodyType/provider

Annotation The provider element defines the address of the main service provider

Element and all subelements copied unaltered from request

diagram
namespace | http://sumex1.net/gcr
type | gcr:baseAddressType
properties
isRef | 0
content | complex
children | gcr:company gcr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType | required
zsr | gcr:zsrPartyType
specialty | gcr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="provider" type="gcr:baseAddressType"/>


element bodyType/patient

Annotation The patient element defines the patient with all relevant data

Element and all subelements copied unaltered from request

diagram
namespace | http://sumex1.net/gcr
type | gcr:patientAddressType
properties
isRef | 0
content | complex
children | gcr:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | gcr:ssnPartyType
attributes annotations
Name | Notes
gender | gender defines the gender encoded by a terminal set of tokens
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source | <element name="patient" type="gcr:patientAddressType"/>


element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://sumex1.net/gcr
type | gcr:personType
properties
isRef | 0
content | complex
children | gcr:familyname gcr:givenname gcr:subaddressing gcr:postal gcr:telecom gcr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | gcr:stringType1_35
title | gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="gcr:personType"/>


element bodyType/insurance

Annotation The insurance address element is the insurance, that provides the insurance protection.

Element and all subelements copied unaltered from request

diagram
namespace | http://sumex1.net/gcr
type | gcr:baseAddressType
properties
isRef | 0
content | complex
children | gcr:company gcr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType | required
zsr | gcr:zsrPartyType
specialty | gcr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="insurance" type="gcr:baseAddressType"/>


element bodyType/debitor

Annotation The debitor element defines the debitor of the corresponding request which is of course the current sender.
This element is copied from the received request
diagram
namespace | http://sumex1.net/gcr
type | gcr:baseAddressType
properties
isRef | 0
content | complex
children | gcr:company gcr:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType | required
zsr | gcr:zsrPartyType
specialty | gcr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source | <element name="debitor" type="gcr:baseAddressType"/>


element bodyType/contact

Annotation | The contact element defines a contact for the response coded either as person or company address. The latter can optionally be augmented by data of an employee.
diagram
namespace | http://sumex1.net/gcr
type | gcr:contactAddressType
properties
isRef | 0
content | complex
children | gcr:person gcr:company gcr:employee
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType
attributes annotations
Name Notes
ean_party ean_party is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never an GLN of an employee!)
source | <element name="contact" type="gcr:contactAddressType"/>


element contactAddressType/person

Annotation | The contact is a legal entity defined by a company address element
diagram
namespace | http://sumex1.net/gcr
type | gcr:personType
properties
isRef | 0
content | complex
children | gcr:familyname gcr:givenname gcr:subaddressing gcr:postal gcr:telecom gcr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | gcr:stringType1_35
title | gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="gcr:personType"/>


element contactAddressType/company

Annotation | The contact is a natural person defined by the person address element
diagram
namespace | http://sumex1.net/gcr
type | gcr:companyType
properties
isRef | 0
content | complex
children | gcr:companyname gcr:department gcr:subaddressing gcr:postal gcr:telecom gcr:online
source | <element name="company" type="gcr:companyType"/>


element contactAddressType/employee

Annotation The optional employee element augments the company address by the data of an employee handling the request
The address of an employee is identical to a person's address except that the postal address is not given but implicitly inherited by the company's address container.
diagram
namespace | http://sumex1.net/gcr
type | gcr:employeeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:familyname gcr:givenname gcr:telecom gcr:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | gcr:stringType1_35
title | gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="employee" type="gcr:employeeType" minOccurs="0"/>


element employeeType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="gcr:stringType1_35"/>


element employeeType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="gcr:stringType1_35" minOccurs="0"/>


element employeeType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:phone gcr:fax
source | <element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>


element employeeType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://sumex1.net/gcr
type | gcr:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:email gcr:url
source | <element name="online" type="gcr:onlineAddressType" minOccurs="0"/>


element bodyType/treatment

Annotation The treatment element defines the basic treatment parameters possibly augmented by extra data in case of a stationary treatment (element stationary).

Element and all subelements copied unaltered from request

diagram
namespace | http://sumex1.net/gcr
type | gcr:treatmentType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
attributes annotations
Name Notes
date_begin date_begin is the start of the intended treatment

This attribute is copied unaltered from request

date_end the optional date_end is the end of the intended treatment interval.

This attribute is copied unaltered from request

treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.

This attribute is copied unaltered from request

treatment_type treatment_type is the principle type of treatment encoded by a terminal set of tokens.
The attribute is defined based on the existence of the XML element stationary of the corresponding request:
  • treatment_type=ambulatory, if there is no element request/payload/body/treatment/stationary given
  • treatment_type=stationary, if there is one element request/payload/body/treatment/stationary given
treatment_reason treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens

This attribute is copied unaltered from request

attributes enumerations
Name | Extension | Base | Value | Annotations
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source | <element name="treatment" type="gcr:treatmentType"/>


element bodyType/pending

Annotation The pending element defines the answer of type «pending»
Per definition this means that the request can not be processed to a final stage as some data are missing. An optional explanation and [0,n] messages (instructions) are supplied to "unfreeze" the request.
diagram
namespace | http://sumex1.net/gcr
type | gcr:pendingType
properties
isRef | 0
content | complex
children | gcr:explanation gcr:message
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="pending" type="gcr:pendingType"/>


element pendingType/explanation

Annotation The explanation element defines the overall explanation for the pending status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_1400
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 1400
source | <element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>


element pendingType/message

Annotation The message element defines either a reason why the request is in the pending state or an instruction how to proceed for leaving this state. E.g. the insurance is awaiting further documents like the "Minimal clinical dataset" (mcdRequest).
There is an unbounded number of such messages possible all given in the language defined by the response@language attribute.
diagram
namespace | http://sumex1.net/gcr
type | gcr:notificationType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | gcr:stringType1_35 | required
text | gcr:stringType1_350 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source | <element name="message" type="gcr:notificationType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/accepted

Annotation The accepted element defines the answer of type «accepted».
Per definition this means that the request is fully accepted and will be processed to a final stage. An optional explanation is supplied to justify the decision.
diagram
namespace | http://sumex1.net/gcr
type | gcr:acceptedType
properties
isRef | 0
content | complex
children | gcr:explanation
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="accepted" type="gcr:acceptedType"/>


element acceptedType/explanation

Annotation The optional explanation element defines the overall explanation for the accepted status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_1400
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 1400
source | <element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>


element bodyType/rejected

Annotation The rejected element defines the answer of type «rejected».
Per definition this means that the request is rejected and as a consequence the status of the request goes to the "canceled" state. An optional explanation and [0,n] errors are supplied to justify the decision.
diagram
namespace | http://sumex1.net/gcr
type | gcr:rejectedType
properties
isRef | 0
content | complex
children | gcr:explanation gcr:error
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
source | <element name="rejected" type="gcr:rejectedType"/>


element rejectedType/explanation

Annotation The explanation element defines the overall explanation for the rejected status
The explanation is formulated in plain text in the language defined by the response@language attribute
diagram
namespace | http://sumex1.net/gcr
type | gcr:stringType1_1400
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 1400
source | <element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>


element rejectedType/error

Annotation The error element defines one detailed error why the request is rejected.
There is an unbounded number of such errors possible all given in the language defined by the response@language attribute.
diagram
namespace | http://sumex1.net/gcr
type | gcr:errorType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | gcr:stringType1_35 | required
text | gcr:stringType1_350 | required
error_value | gcr:stringType1_350
valid_value | gcr:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
source | <element name="error" type="gcr:errorType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/documents

Annotation | The documents element is an optional container for including inline, Base64-coded documents.
diagram
namespace | http://sumex1.net/gcr
type | gcr:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | gcr:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="gcr:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline and Base64-coded.
diagram
namespace | http://sumex1.net/gcr
type | gcr:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | gcr:base64
attributes parameters
Name | Type | Use | Default | Fixed
title | gcr:stringType1_35 | required
filename | gcr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Sumex1.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source | <element name="document" type="gcr:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet streams
diagram
namespace | http://sumex1.net/gcr
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the recipient represented by the transport@to EAN (which is the mirrored transport@from of the request).

See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sender represented by the transport@from EAN (which is the mirrored transport@to of the request).
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType responseType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

A
acceptedType
B
baseAddressType
bodyType
C
companyType
contactAddressType
creditType
D
dependsOnType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
eanPartyType
employeeType
errorType
N
nifPartyType
nonEmptyStringType
notificationType
O
onlineAddressType
P
patientAddressType
payloadType
pendingType
personType
postalAddressType
processingType
prologType
R
rejectedType
responseType
S
softwareType
ssnPartyType
statusType
stringType0_350
stringType1_100
stringType1_12
stringType1_1400
stringType1_25
stringType1_255
stringType1_3
stringType1_30
stringType1_35
stringType1_350
stringType1_50
stringType1_6
stringType1_70
stringType1_9
T
telecomAddressType
transportType
treatmentType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z


complexType acceptedType

diagram
namespace | http://sumex1.net/gcr
type | extension of gcr:statusType
properties
base gcr:statusType
children | gcr:explanation
used by
element bodyType/accepted
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «accepted» | gcr:statusType
source <complexType name="acceptedType">
<complexContent>
<extension base="gcr:statusType">
<sequence>
<element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType baseAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:company gcr:person
used by
elements bodyType/biller bodyType/debitor bodyType/insurance bodyType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | gcr:eanPartyType | required
zsr gcr:zsrPartyType
specialty gcr:stringType1_350
attributes annotations
Name | Notes
ean_party | ean_party is the company's/person's EAN number as defined by www.medwin.ch
zsr | The optional zsr is the company's/person's ZSR (KSK) number as defined by Santésuisse
specialty | The optional specialty is the person's specialty (branch of medical science a doctor practices)
source <complexType name="baseAddressType">
<choice>
<element name="company" type="gcr:companyType"/>
<element name="person" type="gcr:personType"/>
</choice>
<attribute name="ean_party" type="gcr:eanPartyType" use="required"/>
<attribute name="zsr" type="gcr:zsrPartyType"/>
<attribute name="specialty" type="gcr:stringType1_350"/>
</complexType>


complexType bodyType

diagram
namespace | http://sumex1.net/gcr
children | gcr:prolog gcr:biller gcr:provider gcr:patient gcr:insurance gcr:debitor gcr:contact gcr:treatment gcr:pending gcr:accepted gcr:rejected gcr:documents
used by
element payloadType/body
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="gcr:prologType"/>
<element name="biller" type="gcr:baseAddressType"/>
<element name="provider" type="gcr:baseAddressType"/>
<element name="patient" type="gcr:patientAddressType"/>
<element name="insurance" type="gcr:baseAddressType"/>
<element name="debitor" type="gcr:baseAddressType"/>
<element name="contact" type="gcr:contactAddressType"/>
<element name="treatment" type="gcr:treatmentType"/>
<choice>
<element name="pending" type="gcr:pendingType"/>
<element name="accepted" type="gcr:acceptedType"/>
<element name="rejected" type="gcr:rejectedType"/>
</choice>
<element name="documents" type="gcr:documentsType" minOccurs="0"/>
</sequence>
</complexType>


complexType companyType

diagram
namespace | http://sumex1.net/gcr
children | gcr:companyname gcr:department gcr:subaddressing gcr:postal gcr:telecom gcr:online
used by
elements baseAddressType/company contactAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="gcr:stringType1_35"/>
<element name="department" type="gcr:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="gcr:stringType1_35" minOccurs="0"/>
<element name="postal" type="gcr:postalAddressType"/>
<element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>
<element name="online" type="gcr:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType contactAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:person gcr:company gcr:employee
used by
element bodyType/contact
attributes parameters
Name Type Use Default Fixed
ean_party gcr:eanPartyType
attributes annotations
Name Notes
ean_party ean_party is the contact's GLN as defined by RefData
Note, that this is the GLN of the given person or company (it is never an GLN of an employee!)
source <complexType name="contactAddressType">
<choice>
<element name="person" type="gcr:personType"/>
<sequence>
<element name="company" type="gcr:companyType"/>
<element name="employee" type="gcr:employeeType" minOccurs="0"/>
</sequence>
</choice>
<attribute name="ean_party" type="gcr:eanPartyType"/>
</complexType>


complexType creditType

diagram
namespace http://sumex1.net/gcr
used by
elements payloadType/credit payloadType/credit_ref
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | gcr:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_timestamp must be identical for the same credit object reference!
request_date request_date is the main software's date of the credit request ("Kostengutsprache-Datum") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("Kostengutsprache-Nummer") given by the request and copied unaltered to the response.
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source <complexType name="creditType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="gcr:stringType1_35" use="required"/>
</complexType>


complexType dependsOnType

diagram
namespace http://sumex1.net/gcr
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | gcr:stringType1_50 | required
copyright gcr:stringType1_50
description gcr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="gcr:stringType1_50" use="required"/>
<attribute name="copyright" type="gcr:stringType1_50"/>
<attribute name="description" type="gcr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType documentsType

diagram
namespace | http://sumex1.net/gcr
children | gcr:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="gcr:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://sumex1.net/gcr
children | gcr:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
title | gcr:stringType1_35 | required
filename | gcr:stringType1_255 | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title title is the document's title on the primary system and thus describes the document in terms of its semantic content.
A list of possible suggestions -heuristic and incomplete in its nature- can be found at the Sumex1.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reduce the allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="title" type="gcr:stringType1_35" use="required"/>
<attribute name="filename" type="gcr:stringType1_255" use="required"/>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType employeeType

diagram
namespace | http://sumex1.net/gcr
children | gcr:familyname gcr:givenname gcr:telecom gcr:online
used by
element contactAddressType/employee
attributes parameters
Name Type Use Default Fixed
salutation gcr:stringType1_35
title gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="employeeType">
<sequence>
<element name="familyname" type="gcr:stringType1_35"/>
<element name="givenname" type="gcr:stringType1_35" minOccurs="0"/>
<element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>
<element name="online" type="gcr:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="gcr:stringType1_35"/>
<attribute name="title" type="gcr:stringType1_35"/>
</complexType>


complexType errorType

diagram
namespace | http://sumex1.net/gcr
type | extension of gcr:notificationType
properties
base gcr:notificationType
used by
element rejectedType/error
attributes parameters
Name | Type | Use | Default | Fixed
code | gcr:stringType1_35 | required
text | gcr:stringType1_350 | required
error_value gcr:stringType1_350
valid_value gcr:stringType1_350
record_id | positiveInteger
attributes annotations
Name | Notes
error_value | error_value is a value that is erroneous within the current used contracts (e.g. wrong tax point values, illegal use of services and the like).
code | code is a code of the notification. These codes are insurance specific.
valid_value | valid_value is a value that should be used instead of the error_value.
text | text is the text of the notification in the language defined by the response@language attribute
record_id record_id is a record sequence number from the request uniquely identifying the service record.
Of course, if it is not a service related error then record_id is undefined.
Extensions
Annotation | Base
Definition for an error container | gcr:notificationType
source <complexType name="errorType">
<complexContent>
<extension base="gcr:notificationType">
<attribute name="error_value" type="gcr:stringType1_350"/>
<attribute name="valid_value" type="gcr:stringType1_350"/>
<attribute name="record_id" type="positiveInteger"/>
</extension>
</complexContent>
</complexType>


complexType notificationType

diagram
namespace http://sumex1.net/gcr
used by
element | pendingType/message
complexType | errorType
attributes parameters
Name | Type | Use | Default | Fixed
code | gcr:stringType1_35 | required
text | gcr:stringType1_350 | required
attributes annotations
Name | Notes
code | code is a code of the notification. These codes are insurance specific.
text | text is the text of the notification in the language defined by the response@language attribute
source <complexType name="notificationType">
<attribute name="code" type="gcr:stringType1_35" use="required"/>
<attribute name="text" type="gcr:stringType1_350" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:email gcr:url
used by
elements personType/online companyType/online employeeType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="gcr:stringType1_70">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="url" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType patientAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:person
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn gcr:ssnPartyType
attributes annotations
Name | Notes
gender | gender defines the gender encoded by a terminal set of tokens
birthdate | birthdate defines the birthdate of the patient
ssn ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the gender is male
gender | NMTOKEN | female | the gender is female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="gcr:personType"/>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="gcr:ssnPartyType"/>
</complexType>


complexType payloadType

diagram
namespace | http://sumex1.net/gcr
children | gcr:credit_ref gcr:credit gcr:body xenc:EncryptedData
used by
element responseType/payload
attributes parameters
Name | Type | Use | Default | Fixed
storno | boolean | false
copy | boolean | false
response_timestamp | derived by: unsignedLong | required
attributes annotations
Name | Notes
storno storno augments the topmost object reference by a storno command.
This attribute is copied from the received request
copy copy augments the topmost object reference by a copy command
This attribute is copied from the received request
response_timestamp | response_timestamp is a UNIX timestamp defined at the moment of the response's infoset generation
source <complexType name="payloadType">
<sequence>
<element name="credit_ref" type="gcr:creditType" minOccurs="0"/>
<element name="credit" type="gcr:creditType"/>
<choice>
<element name="body" type="gcr:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="storno" type="boolean" default="false"/>
<attribute name="copy" type="boolean" default="false"/>
<attribute name="response_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType pendingType

diagram
namespace | http://sumex1.net/gcr
type | extension of gcr:statusType
properties
base gcr:statusType
children | gcr:explanation gcr:message
used by
element bodyType/pending
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «pending» | gcr:statusType
source <complexType name="pendingType">
<complexContent>
<extension base="gcr:statusType">
<sequence>
<element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>
<element name="message" type="gcr:notificationType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType personType

diagram
namespace | http://sumex1.net/gcr
children | gcr:familyname gcr:givenname gcr:subaddressing gcr:postal gcr:telecom gcr:online
used by
elements baseAddressType/person patientAddressType/person contactAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation gcr:stringType1_35
title gcr:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="gcr:stringType1_35"/>
<element name="givenname" type="gcr:stringType1_35"/>
<element name="subaddressing" type="gcr:stringType1_35" minOccurs="0"/>
<element name="postal" type="gcr:postalAddressType"/>
<element name="telecom" type="gcr:telecomAddressType" minOccurs="0"/>
<element name="online" type="gcr:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="gcr:stringType1_35"/>
<attribute name="title" type="gcr:stringType1_35"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:pobox gcr:street gcr:zip gcr:city
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="gcr:stringType1_35" minOccurs="0"/>
<element name="street" type="gcr:stringType1_35" minOccurs="0"/>
<element name="zip" type="gcr:zipType"/>
<element name="city" type="gcr:stringType1_35"/>
</sequence>
</complexType>


complexType processingType

diagram
namespace | http://sumex1.net/gcr
children | gcr:transport
used by
element responseType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="gcr:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://sumex1.net/gcr
children | gcr:package gcr:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="gcr:softwareType" minOccurs="0"/>
<element name="generator" type="gcr:softwareType"/>
</sequence>
</complexType>


complexType rejectedType

diagram
namespace | http://sumex1.net/gcr
type | extension of gcr:statusType
properties
base gcr:statusType
children | gcr:explanation gcr:error
used by
element bodyType/rejected
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
Extensions
Annotation | Base
Definition for a response status container of type «rejected» | gcr:statusType
source <complexType name="rejectedType">
<complexContent>
<extension base="gcr:statusType">
<sequence>
<element name="explanation" type="gcr:stringType1_1400" minOccurs="0"/>
<element name="error" type="gcr:errorType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</extension>
</complexContent>
</complexType>


complexType responseType

diagram
namespace | http://sumex1.net/gcr
children | gcr:processing gcr:payload ds:Signature
used by
element response
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
attributes annotations
Name | Notes
language language defines the used data language (for messages/errors etc.) encoded by a terminal set of ISO language specifiers.
The language used is copied from and thus defined by the request.
modus | modus defines the operating modus encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source <complexType name="responseType">
<sequence>
<element name="processing" type="gcr:processingType"/>
<element name="payload" type="gcr:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType softwareType

diagram
namespace | http://sumex1.net/gcr
children | gcr:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | gcr:stringType1_50 | required
copyright gcr:stringType1_50
description gcr:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="gcr:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="gcr:stringType1_50" use="required"/>
<attribute name="copyright" type="gcr:stringType1_50"/>
<attribute name="description" type="gcr:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType statusType

diagram
namespace http://sumex1.net/gcr
used by
complexTypes acceptedType pendingType rejectedType
attributes parameters
Name | Type | Use | Default | Fixed
status_in | derived by: NMTOKEN | required
status_out | derived by: NMTOKEN | required
attributes annotations
Name | Notes
status_in | status_in is the status of the request (given by the object reference chain) before any processing or analysis is done encoded by a terminal set of tokens
status_out | status_out is the status of the request (given by the object reference chain) after all processing or analysis is done encoded by a terminal set of tokens
attributes enumerations
Name | Extension | Base | Value | Annotations
status_in | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_in | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_in | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_in | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_in | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_in | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_in | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
status_out | NMTOKEN | unknown | the status is unknown - the given object reference is unknown
status_out | NMTOKEN | ambiguous | the status is ambiguous - the given object reference delivers more than one result
status_out | NMTOKEN | received | the status is received - nothing done so far except receiving the request
status_out | NMTOKEN | frozen | the status is frozen - the request is not processed until further data is provided
status_out | NMTOKEN | processed | the status is processed - the request has passed all processing and analysis
status_out | NMTOKEN | granted | the status is granted - the request is accepted and archived.
status_out | NMTOKEN | canceled | the status is canceled - the request is canceled and archived with reject status
source <complexType name="statusType">
<attribute name="status_in" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
<attribute name="status_out" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="unknown"/>
<enumeration value="ambiguous"/>
<enumeration value="received"/>
<enumeration value="frozen"/>
<enumeration value="processed"/>
<enumeration value="granted"/>
<enumeration value="canceled"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType telecomAddressType

diagram
namespace | http://sumex1.net/gcr
children | gcr:phone gcr:fax
used by
elements personType/telecom companyType/telecom employeeType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="gcr:stringType1_25" maxOccurs="3"/>
<element name="fax" type="gcr:stringType1_25" minOccurs="0" maxOccurs="3"/>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://sumex1.net/gcr
children | gcr:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | gcr:eanPartyType | required
to | gcr:eanPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the infoset to the first intermediate
In fact this is the mirrored to attribute from the request.
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the infoset from the last intermediate.
In fact this is the mirrored from attribute from the request.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="gcr:eanPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="gcr:eanPartyType" use="required"/>
<attribute name="to" type="gcr:eanPartyType" use="required"/>
</complexType>


complexType treatmentType

diagram
namespace http://sumex1.net/gcr
used by
element bodyType/treatment
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime
treatment_canton | derived by: NMTOKEN | required
treatment_type | derived by: NMTOKEN | ambulatory
treatment_reason | derived by: NMTOKEN | required
attributes annotations
Name Notes
date_begin date_begin is the start of the intended treatment

This attribute is copied unaltered from request

date_end the optional date_end is the end of the intended treatment interval.

This attribute is copied unaltered from request

treatment_canton treatment_canton is Swiss canton or a country close to the border in which the treatment is taking place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.

This attribute is copied unaltered from request

treatment_type treatment_type is the principle type of treatment encoded by a terminal set of tokens.
The attribute is defined based on the existence of the XML element stationary of the corresponding request:
  • treatment_type=ambulatory, if there is no element request/payload/body/treatment/stationary given
  • treatment_type=stationary, if there is one element request/payload/body/treatment/stationary given
treatment_reason treatment_reason is the primary reason why the treatment is taking place encoded by a terminal set of tokens

This attribute is copied unaltered from request

attributes enumerations
Name | Extension | Base | Value | Annotations
treatment_canton | NMTOKEN | AG | the canton is AG - Aargau
treatment_canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
treatment_canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
treatment_canton | NMTOKEN | BE | the canton is BE - Bern
treatment_canton | NMTOKEN | BL | the canton is BL - Baselland
treatment_canton | NMTOKEN | BS | the canton is BS - Basel
treatment_canton | NMTOKEN | FR | the canton is FR - Fribourg
treatment_canton | NMTOKEN | GE | the canton is GE - Geneva
treatment_canton | NMTOKEN | GL | the canton is GL - Glarus
treatment_canton | NMTOKEN | GR | the canton is GR - Graubünden
treatment_canton | NMTOKEN | JU | the canton is JU - Jura
treatment_canton | NMTOKEN | LU | the canton is LU - Lucerne
treatment_canton | NMTOKEN | NE | the canton is NE - Neuchâtel
treatment_canton | NMTOKEN | NW | the canton is NW - Nidwalden
treatment_canton | NMTOKEN | OW | the canton is OW - Obwalden
treatment_canton | NMTOKEN | SG | the canton is SG - St. Gallen
treatment_canton | NMTOKEN | SH | the canton is SH - Schaffhausen
treatment_canton | NMTOKEN | SO | the canton is SO - Solothurn
treatment_canton | NMTOKEN | SZ | the canton is SZ - Schwyz
treatment_canton | NMTOKEN | TI | the canton is TI - Ticino
treatment_canton | NMTOKEN | TG | the canton is TG - Thurgau
treatment_canton | NMTOKEN | UR | the canton is UR - Uri
treatment_canton | NMTOKEN | VD | the canton is VD - Vaud
treatment_canton | NMTOKEN | VS | the canton is VS - Valais
treatment_canton | NMTOKEN | ZG | the canton is ZG - Zug
treatment_canton | NMTOKEN | ZH | the canton is ZH - Zürich
treatment_canton | NMTOKEN | LI | the country is LI - Liechtenstein
treatment_canton | NMTOKEN | A | the country is A - Austria
treatment_canton | NMTOKEN | D | the country is D - Germany
treatment_canton | NMTOKEN | F | the country is F - France
treatment_canton | NMTOKEN | I | the country is I - Italy
treatment_reason | NMTOKEN | disease | the reason of treatment is a disease
treatment_reason | NMTOKEN | accident | the reason of treatment is an accident
treatment_reason | NMTOKEN | maternity | the reason of treatment is a maternity
treatment_reason | NMTOKEN | prevention | the reason of treatment is prevention
treatment_reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
treatment_reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment_type | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment_type | NMTOKEN | stationary | the treatment type is stationary
source <complexType name="treatmentType">
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime"/>
<attribute name="treatment_canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_type" default="ambulatory">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment_reason" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="disease"/>
<enumeration value="accident"/>
<enumeration value="maternity"/>
<enumeration value="prevention"/>
<enumeration value="birthdefect"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://sumex1.net/gcr
type | extension of gcr:stringType1_9
properties
base gcr:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode gcr:stringType1_9
countrycode | gcr:stringType1_3 | CH
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code | gcr:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="gcr:stringType1_9">
<attribute name="statecode" type="gcr:stringType1_9"/>
<attribute name="countrycode" type="gcr:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType eanPartyType

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attributes baseAddressType/@ean_party contactAddressType/@ean_party transportType/@from transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="eanPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType nifPartyType

namespace | http://sumex1.net/gcr
type | restriction of string
facets
pattern [0-9]{1,7}
source <simpleType name="nifPartyType">
<restriction base="string">
<pattern value="[0-9]{1,7}"/>
</restriction>
</simpleType>


simpleType nonEmptyStringType

namespace | http://sumex1.net/gcr
type | restriction of string
facets
minLength 1
source <simpleType name="nonEmptyStringType">
<restriction base="string">
<minLength value="1"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType0_350

namespace | http://sumex1.net/gcr
type | restriction of string
facets
maxLength 350
source <simpleType name="stringType0_350">
<restriction base="string">
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_100

namespace | http://sumex1.net/gcr
type | restriction of string
facets
minLength | 1
maxLength | 100
source <simpleType name="stringType1_100">
<restriction base="string">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>


simpleType stringType1_12

namespace | http://sumex1.net/gcr
type | restriction of string
facets
minLength | 1
maxLength | 12
source <simpleType name="stringType1_12">
<restriction base="string">
<minLength value="1"/>
<maxLength value="12"/>
</restriction>
</simpleType>


simpleType stringType1_1400

namespace | http://sumex1.net/gcr
type | restriction of string
used by
elements pendingType/explanation acceptedType/explanation rejectedType/explanation
facets
minLength | 1
maxLength | 1400
source <simpleType name="stringType1_1400">
<restriction base="string">
<minLength value="1"/>
<maxLength value="1400"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://sumex1.net/gcr
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attribute documentType/@filename
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_30

namespace | http://sumex1.net/gcr
type | restriction of string
facets
minLength | 1
maxLength | 30
source <simpleType name="stringType1_30">
<restriction base="string">
<minLength value="1"/>
<maxLength value="30"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://sumex1.net/gcr
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname employeeType/familyname personType/givenname employeeType/givenname postalAddressType/pobox postalAddressType/street personType/subaddressing companyType/subaddressing
attributes | notificationType/@code creditType/@request_id personType/@salutation employeeType/@salutation personType/@title employeeType/@title documentType/@title
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attributes errorType/@error_value baseAddressType/@specialty notificationType/@text errorType/@valid_value
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_6

namespace | http://sumex1.net/gcr
type | restriction of string
facets
minLength | 1
maxLength | 6
source <simpleType name="stringType1_6">
<restriction base="string">
<minLength value="1"/>
<maxLength value="6"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://sumex1.net/gcr
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://sumex1.net/gcr
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


simpleType zsrPartyType

namespace | http://sumex1.net/gcr
type | restriction of string
used by
attribute baseAddressType/@zsr
facets
pattern [A-Z][0-9]{6}|[0-9]{6}[A-Z]
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="[A-Z][0-9]{6}|[0-9]{6}[A-Z]"/>
</restriction>
</simpleType>


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>