XML Schema Browser - generalNotification Version 500

Schema Documentation of
generalNotification V500

produced by the standardization body
Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
The Forum Datenaustausch has endorsed this schema
as a standard at its meeting on 27th November 2024.

The standard becomes applicable on 1st January 2026.

Copyright (©) by Forum Datenaustausch, 27.11.2024 - all rights reserved


Revision history of the documentation

Documentation of generalNotification_500.xsd

Copyright (©) by Forum Datenaustausch, 27.11.2024
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalNotification_500.xsd schema is not changed due to such an entry.
  • Revision 1 from 27.11.2024 (initial version)


Revision history: Documentation of Revision 1

Documentation of Revision 1

Rev. 1/27.11.2024: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the generalNotification_500.xsd schema


Preface

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Forum Datenaustausch

Der Verein "Forum Datenaustausch" (FoDa) fördert den effizienten und sicheren digitalen Datenaustausch zwischen Leistungserbringern und Kostenträgern im administrativen Gesundheitswesen. Er tut dies, indem er sich für folgende, grundsätzliche Ziele einsetzt:
  • Leistungserbringer und Kostenträger nutzen für die digitale Kommunikation untereinander die gleichen, gemeinsam entwickelten und festgelegten Standards.
  • Die digitale Kommunikation zwischen Leistungserbringern und Kostenträger ist sicher, verlässlich und Datenschutzkonform. Sie fördert die Effizienz der Prozesse und ist für alle Partner mit einem positiven Kosten-/Nutzenverhältnis verbunden.

Mitglieder des Forums sind nationale Verbände und Organisationen der Leistungserbringer und der Kostenträger, sowie Körperschaften und Anstalten des öffentlichen Rechts. Hier finden Sie die aktuelle Mitgliederliste.

Die vom Forum Datenaustausch freigegebenen Standards bzw. neue Standard-Versionen, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert.
L'association "Forum Datenaustausch" (FoDa) promeut un échange de données numériques efficace et sûr entre les fournisseurs de prestations et les organismes payeurs dans le domaine administratif de la santé. Pour ce faire, elle s'engage en faveur des objectifs fondamentaux suivants:
  • Les fournisseurs de prestations et les organismes payeurs utilisent les mêmes normes, développées et définies en commun, pour la communication numérique entre eux.
  • La communication numérique entre les fournisseurs de prestations et les organismes payeurs est sûre, fiable et conforme à la protection des données. Elle favorise l'efficacité des processus et est liée à un rapport coûts/bénéfices positif pour tous les partenaires.

Les membres du forum sont des associations nationales et des organisations de prestataires de services et de payeurs, ainsi que des collectivités et des établissements de droit public. Vous trouverez ici la liste actuelle des membres.

Les normes validées par le forum ou les nouvelles versions de normes, comme les messages XML pour l'échange électronique de données, sont publiées ici.


Copyright (©) notice

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Documentation of generalNotification_4500.xsd

Purpose of the schema file

This is the schema definition for a "General Notification" process encoded in XML. It is an email like process to exchange important notifications about a dependent reference object. The process can be initiated by any entity that has knowledge about the given reference object. The communication process goes back and forth, however in each new round the old messages are historicized in a hierarchical manner and the new message is prepended. Besides the textual message a PDF file can be attached in each communication cycle.

Furthermore, the "General Notification" system allows to start a form request process in a structured way such that the fillout and sending of a certain PDF form is initiated. The XML infoset acts as a transaction agent between the dependent reference object and a new form object reference. The given data allows a sender to signal to the receiver to start a form process with a certain PDF form, map that form request to the given dependent reference object, and send that new form request to a recipient (cf. the description of the message@pdf_form_oid attribute).

The XML infoset is sent via 1 or more intermediates to the final recipient. It is the intermediate's responsibility to route the infoset to another intermediate until it can be delivered to the final recipient.

The subchapter Purpose::Anatomy of an infoset provides a broad overview about the building blocks of such an infoset.
The initial infoset is defined by a unique triple of data denoted as object reference as well as one denoting the target object reference for which the notification is sent. It is possible to reference one of the primary types, namely credit, invoice/reminder, MCD, or form. The subchapter Purpose::Object reference provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

This XML project is normative for the electronic notification process in Switzerland.


Conventions, terms, and definitions used

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Anatomy of a notification

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a notification.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information or external institutions must validate the data, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Notification" can hold a maximum of 2 object references, namely
  • an optional dependent object reference of type { credit | invoice | reminder | mcd | form } due to which a notification is produced
  • a mandatory notification object reference from the initial "General Notfication" process
This set of object references by itself defines an ordered object reference chain (e.g. credit_ref -> notification) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference and only for that.


Notes about the signature

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the GLN given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/notification:request/notification:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA256) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-256
  • the used canonicalization algorithm must be http://www.w3.org/2010/xml-c14n2, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2010/xml-c14n2"/>
  <SignatureMethod Algorithm="http://www.w3.org/2001/04/xmlenc#sha256"/>
  <Reference URI="#xpointer(/notification:request/notification:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2001/04/xmlenc#sha256"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the GLN given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used - cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to RSA-OAEP (including MGF1 and SHA1)
  • The block encryption algorithm is fixed to AES256-GCM
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
   <EncryptionMethod Algorithm="http://www.w3.org/2009/xmlenc11#aes256-gcm"/>
   <ds:KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
      <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
         <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p">
           <OAEPparams>...</OAEPparams>
         </EncryptionMethod>
         <ds:KeyInfo>
            <ds:KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</ds:KeyName>
         </ds:KeyInfo>
         <CipherData>
            <CipherValue>...(asymmetrically encrypted key)...</CipherValue>
         </CipherData>
      </EncryptedKey>
   </ds:KeyInfo>
   <CipherData>
      <CipherValue>...(symmetrically encrypted content)...</CipherValue>
   </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/notification"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:notification="http://www.forum-datenaustausch.ch/notification"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag notification followed by the element name. Furthermore, the target namespace and the specific namespace notification maps to http://www.forum-datenaustausch.ch/notification.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<notification:notification xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:notification="http://www.forum-datenaustausch.ch/notification"
        xmlns="http://www.forum-datenaustausch.ch/notification"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/notification generalNotification_500.xsd"
        language="de" modus="production" >
XML elements go here...

 </notification:notification>


Hierarchical list of used XSD definitions

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element notification down as the appropriate definition is encountered.


element notification

Annotation The notification element is the root of the generalNotification infoset.
The element is divided into 2 parts
  • the processing element supplies the necessary data for the transport and for actions done at the intermediate's site (e.g. print on behalf of the recipient)
  • the payload element supplies the core data which will not be altered by intermediates.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:notificationType
properties
content complex
children | notification:processing notification:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
guid | notification:guidType | required
is_confidential | boolean | false
attributes annotations
Name Notes
language language defines the used data language of the messages encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
guid the required guid (Globally Unique IDentifier) is an unique identifier for the current XML infoset defined as a 32 hex-digit string covered by the pattern [A-Fa-f0-9]{32}.
Please note that the generation of the guid must be in accordance with RFC 9562.
is_confidential is_confidential defines if the notification is confidential.

Note that the confidentiality status is defined at the moment of the initial XML infoset generation, thereafter it must be inherited into each new reply cycle.

attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source | <element name="notification" type="notification:notificationType"/>


element notificationType/processing

Annotation | The processing element is a container for routing and processing instructions at an intermediate's site (e.g. printing the notification, transport routing etc.).
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:processingType
properties
isRef | 0
content | complex
children | notification:transport
source | <element name="processing" type="notification:processingType"/>


element processingType/transport

Annotation | The transport element defines the routing of the infoset going from a sender party over any number of intermediates to a receiver party. All the involved parties are defined by Global Location Numbers (GLN) as defined by RefData
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:transportType
properties
isRef | 0
content | complex
children | notification:via
attributes parameters
Name | Type | Use | Default | Fixed
from | notification:glnPartyType | required
to | notification:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the XML infoset to the first defined intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the XML infoset from the last defined intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="notification:transportType"/>


element transportType/via

Annotation The optional via element defines one intermediate hop through which the XML infoset is routed.
It is in accordance with the standard that an intermediate -due to a technical necessity- can change the remaining list of intermediate hops in order to guarantee the delivery of the final recipient.
diagram
namespace http://www.forum-datenaustausch.ch/notification
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | notification:glnPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming a chain of intermediate hops
source <element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="notification:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


element notificationType/payload

Annotation | The payload element supplies the core data and will not be altered in the transport process. The payload can optionally be signed by a W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:payloadType
properties
isRef | 0
content | complex
children | notification:credit_ref notification:invoice_ref notification:reminder_ref notification:mcd_ref notification:form_ref notification:notification notification:body xenc:EncryptedData
source | <element name="payload" type="notification:payloadType"/>


element payloadType/credit_ref

Annotation The credit_ref element defines the dependent object reference of type credit. By definition this constitutes a object reference chain (credit_ref >> notification).
It is this referenced credit XML infoset that caused this message thread. This object reference is mirrored unaltered in any reply of the thread.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="credit_ref" type="notification:objectType"/>


element payloadType/invoice_ref

Annotation The invoice_ref element defines the dependent object reference of type invoice. By definition this constitutes a object reference chain (invoice_ref >> notification).
It is this referenced invoice XML infoset that caused this message thread. This object reference is mirrored unaltered in any reply of the thread.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="invoice_ref" type="notification:objectType"/>


element payloadType/reminder_ref

Annotation The reminder_ref element defines the dependent object reference of type reminder. By definition this constitutes a object reference chain (reminder_ref >> notification).
It is this referenced reminder XML infoset that caused this message thread. This object reference is mirrored unaltered in any reply of the thread.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="reminder_ref" type="notification:objectType"/>


element payloadType/mcd_ref

Annotation The mcd_ref element defines the dependent object reference of type MCD. By definition this constitutes a object reference chain (mcd_ref >> notification).
It is this referenced MCD XML infoset that caused this message thread. This object reference is mirrored unaltered in any reply of the thread.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="mcd_ref" type="notification:objectType"/>


element payloadType/form_ref

Annotation The form_ref element defines the dependent object reference of type form. By definition this constitutes a object reference chain (form_ref >> notification).
It is this referenced form XML infoset that caused this message thread. This object reference is mirrored unaltered in any reply of the thread.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:objectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source | <element name="form_ref" type="notification:objectType"/>


element payloadType/notification

Annotation The notification element defines the unique notification object reference.

This object is firstly produced when generating the very first message. Any further processing e.g. sending a reply does not alter this object reference.

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:mainObjectType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | derived by: unsignedLong | required
date | dateTime | required
id | notification:stringType1_35 | required
attributes annotations
Name Notes
timestamp timestamp is a UNIX timestamp defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the main object reference. timestamp will be generated once for this notification object reference and thereafter is always referenced!
date date is the main software's date defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the object reference. date will be generated once for this notification object reference and thereafter is always referenced!
id request_id is the main software's ID defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the object reference. ID will be generated once for this notification object reference and thereafter is always referenced!
source | <element name="notification" type="notification:mainObjectType"/>


element payloadType/body

Annotation | The body element contains all the necessary data including the highly sensitive patient data (data privacy relevant). Therefore, the body element can be replaced by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:bodyType
properties
isRef | 0
content | complex
children | notification:prolog notification:sender notification:recipient notification:patient notification:law notification:diagnosis notification:messages notification:documents
source | <element name="body" type="notification:bodyType"/>


element bodyType/prolog

Annotation | The prolog element is a container that holds information about the XML generator software.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:prologType
properties
isRef | 0
content | complex
children | notification:package notification:generator
source | <element name="prolog" type="notification:prologType"/>


element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | notification:stringType1_50 | required
copyright | notification:stringType1_50
description | notification:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="notification:softwareType" minOccurs="0"/>


element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | notification:stringType1_50 | required
copyright | notification:stringType1_50
description | notification:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="notification:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:softwareType
properties
isRef | 0
content | complex
children | notification:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | notification:stringType1_50 | required
copyright | notification:stringType1_50
description | notification:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="notification:softwareType"/>


element bodyType/sender

Annotation The sender element defines the sender address of the current message. Since the notification is for a certain dependent reference object it is the recipient of that request that must be used (insurance, cost bearer etc.)
Note, that the sender becomes the recipient in a possible reply to that message.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:baseAddressType
properties
isRef | 0
content | complex
children | notification:company notification:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | notification:glnPartyType | required
zsr | notification:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the debitor's GLN number as defined by RefData
zsr | The optional zsr is the company's/person's ZSR number as defined by Santésuisse
source | <element name="sender" type="notification:baseAddressType"/>


element baseAddressType/company

Annotation | The base address is one of a company given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:companyType
properties
isRef | 0
content | complex
children | notification:companyname notification:department notification:subaddressing notification:postal notification:telecom notification:online
source | <element name="company" type="notification:companyType"/>


element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="notification:stringType1_35"/>


element companyType/department

Annotation | The optional department element supplies the name of an involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="notification:stringType1_35" minOccurs="0"/>


element companyType/subaddressing

Annotation | The optional subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="notification:stringType1_35" minOccurs="0"/>


element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:postalAddressType
properties
isRef | 0
content | complex
children | notification:pobox notification:street notification:zip notification:city notification:country
source | <element name="postal" type="notification:postalAddressType"/>


element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="notification:stringType1_35" minOccurs="0"/>


element postalAddressType/street

Annotation | The street element supplies the full street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:streetType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
facets
minLength | 1
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
street_name | notification:stringType1_35
house_no | notification:stringType1_10
attributes annotations
Name | Notes
street_name | street_name is the optional street name being part of the full street definition. Please note that the street name is an extracted copy from the full street definition.
house_no | house_no is the optional house number being part of full street definition. Please note that the house number is an extracted copy from the full street definition.
source | <element name="street" type="notification:streetType" minOccurs="0"/>


element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
state_code | notification:stringType1_9
attributes annotations
Name | Notes
state_code | state_code is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
source | <element name="zip" type="notification:zipType"/>


element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="notification:stringType1_35"/>


element postalAddressType/country

Annotation The optional country element supplies the country name and country abbreviation of the postal address.

Please note that the absence of the country element implies that the country is Switzerland and consequently the country abbreviation is ISO 3166-1 alpha-2 = CH.

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:countryType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
facets
minLength | 1
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
country_code | notification:iso3166A2Type
attributes annotations
Name | Notes
country_code | the optional country_code is the ISO designator of the country as two-letter ISO 3166-1 alpha-2 code.
source | <element name="country" type="notification:countryType" minOccurs="0"/>


element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:phone
source | <element name="telecom" type="notification:telecomAddressType" minOccurs="0"/>


element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="notification:stringType1_25" maxOccurs="3"/>


element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:email notification:uri
source | <element name="online" type="notification:onlineAddressType" minOccurs="0"/>


element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of notification:stringType1_80
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 80
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="notification:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


element onlineAddressType/uri

Annotation | The uri element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 160
source <element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>


element baseAddressType/person

Annotation | The base address is one of a person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:personType
properties
isRef | 0
content | complex
children | notification:familyname notification:givenname notification:subaddressing notification:postal notification:telecom notification:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | notification:stringType1_35
title | notification:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="notification:personType"/>


element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="notification:stringType1_35"/>


element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="notification:stringType1_35"/>


element personType/subaddressing

Annotation | The optional subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="notification:stringType1_35" minOccurs="0"/>


element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:postalAddressType
properties
isRef | 0
content | complex
children | notification:pobox notification:street notification:zip notification:city notification:country
source | <element name="postal" type="notification:postalAddressType"/>


element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:phone
source | <element name="telecom" type="notification:telecomAddressType" minOccurs="0"/>


element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:email notification:uri
source | <element name="online" type="notification:onlineAddressType" minOccurs="0"/>


element bodyType/recipient

Annotation The recipient element defines the recipient address of the current message. Since the notification is for a certain dependent reference object it is the sender of that request that must be used (biller, requestor etc.)
Note, that the recipient becomes the sender in a possible reply to that message.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:baseAddressType
properties
isRef | 0
content | complex
children | notification:company notification:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | notification:glnPartyType | required
zsr | notification:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the debitor's GLN number as defined by RefData
zsr | The optional zsr is the company's/person's ZSR number as defined by Santésuisse
source | <element name="recipient" type="notification:baseAddressType"/>


element bodyType/patient

Annotation The patient element defines the patient with all relevant data. Since the notification is for a certain dependent reference object it is the patient of that request that must be used.
Note, that the patient element is copied unaltered in a possible reply to that message.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:patientAddressType
properties
isRef | 0
content | complex
children | notification:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | date | required
ssn | notification:ssnPartyType | required
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient identifies with the gender of male
  • female: the patient identifies with the gender of female
  • diverse: the patient identifies with neither/both female and male, or identifies as transgender. Furthermore, "diverse" is applicable if the gender is unknown, or the patient does not wish to disclosure his gender identity.
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body. The attribute sex is encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient identifies with the gender of male
gender | NMTOKEN | female | the patient identifies with the gender of female
gender | NMTOKEN | diverse | the patient identifies with the gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source | <element name="patient" type="notification:patientAddressType"/>


element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:personType
properties
isRef | 0
content | complex
children | notification:familyname notification:givenname notification:subaddressing notification:postal notification:telecom notification:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | notification:stringType1_35
title | notification:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="notification:personType"/>


element bodyType/law

Annotation The law element allows the characterization/referencing of the underlying message thread alternative to a reference object.
Note, that the law element is copied unaltered in a possible reply to that message.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:lawType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | required
card_id | notification:stringType1_35
insured_id | notification:stringType1_35
case_id | notification:stringType1_35
case_date | date
attributes annotations
Name | Notes
type type is the type of applicable law encoded by a terminal set of tokens
  • KVG: the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
  • VVG: the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
  • UVG: the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
  • IVG: the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
  • MVG: the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
  • ORG: the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
card_id the card_id defines the required 20-digits official card identification of the patient at the insurance.
If the card_id is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary insured_id identifying the patient at the insurance.
insured_id | the optional insured_id is the KVG customer number also known as insured number.
case_id case_id is the treatment/case identification number issued by by the insurance
It should be noted that the existence, form and specifications of case_id is dependent on the law:
  • KVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • VVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • UVG: defines the required accident number uniquely identifying the corresponding case at the insurance's site.
    If no accident number is supplied, a rejection must be expected.
  • IVG: defines the required case id having a well defined data pattern of ([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6}).
    If no case id is supplied, a rejection must be expected.
  • MVG: defines the optional case id
  • ORG: there is currently no such case id known.
case_date case_date is the treatment/case date issued by by the insurance
It should be noted that the existence, form and specifications of case_date is dependent on the law:
  • KVG: there is currently no such case date known at the insurance site.
  • VVG: there is currently no such case date known at the insurance site.
  • UVG: defines the optional accident date identifying the occurrence of the accident.
  • IVG: there is currently no such case date known at the insurance site.
  • MVG: defines the optional case date
  • ORG: there is currently no such case date known.
attributes enumerations
Name | Extension | Base | Value | Annotations
type | NMTOKEN | KVG | the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
type | NMTOKEN | VVG | the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
type | NMTOKEN | UVG | the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
type | NMTOKEN | IVG | the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
type | NMTOKEN | MVG | the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
type | NMTOKEN | ORG | the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
source | <element name="law" type="notification:lawType" minOccurs="0"/>


element bodyType/diagnosis

Annotation The optional diagnosis element allows the transport of a set of diagnoses.
Since the diagnoses are subject to the Data Protection Act (FADP), the attribute notification@is_confidential should be activated such as to directly address the medical officer of the health care insurance.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:diagnosisType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
facets
minLength | 1
maxLength | 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | by_contract
code | notification:stringType1_12
attributes annotations
Name | Notes
type type is the type of diagnosis catalog used encoded by a terminal set of tokens
  • ICD: the diagnosis catalog is ICD (e.g. ICD-10)
  • cantonal: the diagnosis catalog is the cantonal TI catalog
  • DRG: the diagnosis catalog is DRG (a DRG service position)
  • by_contract: the diagnosis is as defined by an individual contract (between provider and insurance)
  • freetext: the diagnosis is given as freetext
  • birthdefect: the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
  • ICPC: the diagnosis catalog is ICPC (e.g. ICPC-2)
code | the optional code is the used code of the designated diagnosis catalog unless the type='freetext'|'by_contract'
attributes enumerations
Name | Extension | Base | Value | Annotations
type | tion:stringType1_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | tion:stringType1_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | tion:stringType1_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | tion:stringType1_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | tion:stringType1_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | tion:stringType1_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | tion:stringType1_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
source | <element name="diagnosis" type="notification:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>


element bodyType/messages

Annotation | The messages container holds all notification message in a historicized manner.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:messagesType
properties
isRef | 0
content | complex
children | notification:message notification:messages
source | <element name="messages" type="notification:messagesType"/>


element messagesType/message

Annotation The message element defines the message - either the initial one or a reply to a prior received one.
Note that the message is limited to a maximum of 700 characters.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:messageType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 700
attributes parameters
Name | Type | Use | Default | Fixed
date | dateTime | required
pdf_form_oid | notification:stringType1_255
attributes annotations
Name | Notes
date | date is the date including the time when the message was generated.
pdf_form_oid pdf_form_oid is a unique OID of a PDF form used as target PDF form in the generalFormRequest/generalFormResponse system. Further information about the form OID space and the form system, respectively can be found in the documentation of the generalFormRequest schema and links therein.

The usage and impact of the pdf_form_oid attribute is of major importance. Its definition and presence is a signal from the sender to the receiver of the notification to start a new form process. The following measures are taken in the generalFormRequest system:

  • the given dependent reference object is used as dependent reference object of the form process. If no dependent reference object is supplied then and only then the notification reference object is used as dependent reference object in the form process.
  • the sender of the notification becomes the recipient of the form process (aka the consumer in the form XSD).
  • the recipient of the notification becomes the sender of the form process (aka the producer in the form XSD).
  • the mirrored transport element defines the new transport element of the form process.
  • the given pdf_form_oid defines the PDF form template to use in the form system.
    If the form system does not find the OID in question, the form process is cancelled.
  • Instructions whose token attribute begins with "form:" are interpreted as presetting instructions of the form variable space.
source | <element name="message" type="notification:messageType"/>


element messagesType/messages

Annotation | The messages element defines the prior sent messages in a historicized hierarchical structure
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:messagesType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:message notification:messages
source | <element name="messages" type="notification:messagesType" minOccurs="0"/>


element bodyType/documents

Annotation The documents element is an optional container for including inline, Base64-coded documents.

Please note, that the documents are not historicized and are therefore not included in a reply.

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | notification:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="notification:documentsType" minOccurs="0"/>


element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline or Base64-coded.
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | notification:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | notification:base64
attributes parameters
Name | Type | Use | Default | Fixed
filename | notification:filenameType | required
documentType | derived by: NMTOKEN | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME type sniffing.
documentType documentType describes the document in terms of its semantic content encoded by a terminal set of tokens
  • Report: the semantic content is of type Report
  • Image: the semantic content is of type Image
  • Unemployability: the semantic content is of type Unemployability
  • Questionnaire: the semantic content is of type Questionnaire
  • Notification: the semantic content is of type Notification
  • Planning: the semantic content is of type Planning
  • Prescription: the semantic content is of type Prescription
  • SalaryCession: the semantic content is of type Salary Cession
  • UndefinedDoc: the semantic content is unknown or undefined and thus the type is Undefined Document
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
attributes enumerations
Name | Extension | Base | Value | Annotations
documentType | NMTOKEN | Report | the semantic content is of type Report
documentType | NMTOKEN | Image | the semantic content is of type Image
documentType | NMTOKEN | Unemployability | the semantic content is of type Unemployability
documentType | NMTOKEN | Questionnaire | the semantic content is of type Questionnaire
documentType | NMTOKEN | Notification | the semantic content is of type Notification
documentType | NMTOKEN | Planning | the semantic content is of type Planning
documentType | NMTOKEN | Prescription | the semantic content is of type Prescription
documentType | NMTOKEN | SalaryCession | the semantic content is of type Salary Cession
documentType | NMTOKEN | UndefinedDoc | the semantic content is unknown or undefined and thus the type is Undefined Document
source | <element name="document" type="notification:documentType" maxOccurs="unbounded"/>


element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet stream
diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the recipient represented by the transport@to GLN.

See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sender represented by the transport@from GLN.

See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType notificationType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

B
baseAddressType
bodyType
C
companyType
countryType
D
dependsOnType
diagnosisType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
F
filenameType
G
glnPartyType
guidType
I
iso3166A2Type
L
lawType
M
mainObjectType
messageType
messagesType
N
notificationType
O
objectType
onlineAddressType
P
patientAddressType
payloadType
personType
postalAddressType
processingType
prologType
S
softwareType
ssnPartyType
streetType
stringType1_10
stringType1_12
stringType1_25
stringType1_255
stringType1_3
stringType1_35
stringType1_350
stringType1_50
stringType1_70
stringType1_700
stringType1_80
stringType1_9
T
telecomAddressType
transportType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
Z


complexType baseAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:company notification:person
used by
elements bodyType/recipient bodyType/sender
attributes parameters
Name | Type | Use | Default | Fixed
gln | notification:glnPartyType | required
zsr notification:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the debitor's GLN number as defined by RefData
zsr | The optional zsr is the company's/person's ZSR number as defined by Santésuisse
source <complexType name="baseAddressType">
<choice>
<element name="company" type="notification:companyType"/>
<element name="person" type="notification:personType"/>
</choice>
<attribute name="gln" type="notification:glnPartyType" use="required"/>
<attribute name="zsr" type="notification:zsrPartyType"/>
</complexType>


complexType bodyType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:prolog notification:sender notification:recipient notification:patient notification:law notification:diagnosis notification:messages notification:documents
used by
element payloadType/body
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="notification:prologType"/>
<element name="sender" type="notification:baseAddressType"/>
<element name="recipient" type="notification:baseAddressType"/>
<element name="patient" type="notification:patientAddressType"/>
<element name="law" type="notification:lawType" minOccurs="0"/>
<element name="diagnosis" type="notification:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>
<element name="messages" type="notification:messagesType"/>
<element name="documents" type="notification:documentsType" minOccurs="0"/>
</sequence>
</complexType>


complexType companyType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:companyname notification:department notification:subaddressing notification:postal notification:telecom notification:online
used by
element baseAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="notification:stringType1_35"/>
<element name="department" type="notification:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="notification:stringType1_35" minOccurs="0"/>
<element name="postal" type="notification:postalAddressType"/>
<element name="telecom" type="notification:telecomAddressType" minOccurs="0"/>
<element name="online" type="notification:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


complexType countryType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | extension of notification:stringType1_35
properties
base notification:stringType1_35
used by
element postalAddressType/country
facets
minLength | 1
maxLength | 35
attributes parameters
Name Type Use Default Fixed
country_code notification:iso3166A2Type
attributes annotations
Name | Notes
country_code | the optional country_code is the ISO designator of the country as two-letter ISO 3166-1 alpha-2 code.
Extensions
Annotation | Base
Definition for the country container (a subcontainer of the address definition) giving the country and its ISO 3166-1 alpha-2 designator | notification:stringType1_35
source <complexType name="countryType">
<simpleContent>
<extension base="notification:stringType1_35">
<attribute name="country_code" type="notification:iso3166A2Type"/>
</extension>
</simpleContent>
</complexType>


complexType dependsOnType

diagram
namespace http://www.forum-datenaustausch.ch/notification
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | notification:stringType1_50 | required
copyright notification:stringType1_50
description notification:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="notification:stringType1_50" use="required"/>
<attribute name="copyright" type="notification:stringType1_50"/>
<attribute name="description" type="notification:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType diagnosisType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | extension of notification:stringType1_350
properties
base notification:stringType1_350
used by
element bodyType/diagnosis
facets
minLength | 1
maxLength | 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | by_contract
code notification:stringType1_12
attributes annotations
Name | Notes
type type is the type of diagnosis catalog used encoded by a terminal set of tokens
  • ICD: the diagnosis catalog is ICD (e.g. ICD-10)
  • cantonal: the diagnosis catalog is the cantonal TI catalog
  • DRG: the diagnosis catalog is DRG (a DRG service position)
  • by_contract: the diagnosis is as defined by an individual contract (between provider and insurance)
  • freetext: the diagnosis is given as freetext
  • birthdefect: the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
  • ICPC: the diagnosis catalog is ICPC (e.g. ICPC-2)
code | the optional code is the used code of the designated diagnosis catalog unless the type='freetext'|'by_contract'
attributes enumerations
Name | Extension | Base | Value | Annotations
type | tion:stringType1_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | tion:stringType1_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | tion:stringType1_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | tion:stringType1_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | tion:stringType1_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | tion:stringType1_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | tion:stringType1_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
Extensions
Annotation | Base
Definition for the diagnosis container | notification:stringType1_350
source <complexType name="diagnosisType">
<simpleContent>
<extension base="notification:stringType1_350">
<attribute name="type" default="by_contract">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ICD"/>
<enumeration value="cantonal"/>
<enumeration value="DRG"/>
<enumeration value="by_contract"/>
<enumeration value="freetext"/>
<enumeration value="birthdefect"/>
<enumeration value="ICPC"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="notification:stringType1_12"/>
</extension>
</simpleContent>
</complexType>


complexType documentsType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="notification:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


complexType documentType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | notification:filenameType | required
documentType | derived by: NMTOKEN | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME type sniffing.
documentType documentType describes the document in terms of its semantic content encoded by a terminal set of tokens
  • Report: the semantic content is of type Report
  • Image: the semantic content is of type Image
  • Unemployability: the semantic content is of type Unemployability
  • Questionnaire: the semantic content is of type Questionnaire
  • Notification: the semantic content is of type Notification
  • Planning: the semantic content is of type Planning
  • Prescription: the semantic content is of type Prescription
  • SalaryCession: the semantic content is of type Salary Cession
  • UndefinedDoc: the semantic content is unknown or undefined and thus the type is Undefined Document
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
attributes enumerations
Name | Extension | Base | Value | Annotations
documentType | NMTOKEN | Report | the semantic content is of type Report
documentType | NMTOKEN | Image | the semantic content is of type Image
documentType | NMTOKEN | Unemployability | the semantic content is of type Unemployability
documentType | NMTOKEN | Questionnaire | the semantic content is of type Questionnaire
documentType | NMTOKEN | Notification | the semantic content is of type Notification
documentType | NMTOKEN | Planning | the semantic content is of type Planning
documentType | NMTOKEN | Prescription | the semantic content is of type Prescription
documentType | NMTOKEN | SalaryCession | the semantic content is of type Salary Cession
documentType | NMTOKEN | UndefinedDoc | the semantic content is unknown or undefined and thus the type is Undefined Document
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="filename" type="notification:filenameType" use="required"/>
<attribute name="documentType" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="Report"/>
<enumeration value="Image"/>
<enumeration value="Unemployability"/>
<enumeration value="Questionnaire"/>
<enumeration value="Notification"/>
<enumeration value="Planning"/>
<enumeration value="Prescription"/>
<enumeration value="SalaryCession"/>
<enumeration value="UndefinedDoc"/>
</restriction>
</simpleType>
</attribute>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


complexType lawType

diagram
namespace http://www.forum-datenaustausch.ch/notification
used by
element bodyType/law
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | required
card_id notification:stringType1_35
insured_id notification:stringType1_35
case_id notification:stringType1_35
case_date | date
attributes annotations
Name | Notes
type type is the type of applicable law encoded by a terminal set of tokens
  • KVG: the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
  • VVG: the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
  • UVG: the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
  • IVG: the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
  • MVG: the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
  • ORG: the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
card_id the card_id defines the required 20-digits official card identification of the patient at the insurance.
If the card_id is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary insured_id identifying the patient at the insurance.
insured_id | the optional insured_id is the KVG customer number also known as insured number.
case_id case_id is the treatment/case identification number issued by by the insurance
It should be noted that the existence, form and specifications of case_id is dependent on the law:
  • KVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • VVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • UVG: defines the required accident number uniquely identifying the corresponding case at the insurance's site.
    If no accident number is supplied, a rejection must be expected.
  • IVG: defines the required case id having a well defined data pattern of ([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6}).
    If no case id is supplied, a rejection must be expected.
  • MVG: defines the optional case id
  • ORG: there is currently no such case id known.
case_date case_date is the treatment/case date issued by by the insurance
It should be noted that the existence, form and specifications of case_date is dependent on the law:
  • KVG: there is currently no such case date known at the insurance site.
  • VVG: there is currently no such case date known at the insurance site.
  • UVG: defines the optional accident date identifying the occurrence of the accident.
  • IVG: there is currently no such case date known at the insurance site.
  • MVG: defines the optional case date
  • ORG: there is currently no such case date known.
attributes enumerations
Name | Extension | Base | Value | Annotations
type | NMTOKEN | KVG | the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
type | NMTOKEN | VVG | the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
type | NMTOKEN | UVG | the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
type | NMTOKEN | IVG | the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
type | NMTOKEN | MVG | the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
type | NMTOKEN | ORG | the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
source <complexType name="lawType">
<attribute name="type" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="KVG"/>
<enumeration value="VVG"/>
<enumeration value="UVG"/>
<enumeration value="IVG"/>
<enumeration value="MVG"/>
<enumeration value="ORG"/>
</restriction>
</simpleType>
</attribute>
<attribute name="card_id" type="notification:stringType1_35"/>
<attribute name="insured_id" type="notification:stringType1_35"/>
<attribute name="case_id" type="notification:stringType1_35"/>
<attribute name="case_date" type="date"/>
</complexType>


complexType mainObjectType

diagram
namespace http://www.forum-datenaustausch.ch/notification
used by
element payloadType/notification
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | derived by: unsignedLong | required
date | dateTime | required
id | notification:stringType1_35 | required
attributes annotations
Name Notes
timestamp timestamp is a UNIX timestamp defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the main object reference. timestamp will be generated once for this notification object reference and thereafter is always referenced!
date date is the main software's date defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the object reference. date will be generated once for this notification object reference and thereafter is always referenced!
id request_id is the main software's ID defined at the moment of the initial notification's infoset generation.
This is one of 3 identifiers that form the object reference. ID will be generated once for this notification object reference and thereafter is always referenced!
source <complexType name="mainObjectType">
<attribute name="timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="2890245600"/>
</restriction>
</simpleType>
</attribute>
<attribute name="date" type="dateTime" use="required"/>
<attribute name="id" type="notification:stringType1_35" use="required"/>
</complexType>


complexType messagesType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:message notification:messages
used by
elements messagesType/messages bodyType/messages
source <complexType name="messagesType">
<sequence>
<element name="message" type="notification:messageType"/>
<element name="messages" type="notification:messagesType" minOccurs="0"/>
</sequence>
</complexType>


complexType messageType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | extension of notification:stringType1_700
properties
base notification:stringType1_700
used by
element messagesType/message
facets
minLength | 1
maxLength | 700
attributes parameters
Name | Type | Use | Default | Fixed
date | dateTime | required
pdf_form_oid notification:stringType1_255
attributes annotations
Name | Notes
date | date is the date including the time when the message was generated.
pdf_form_oid pdf_form_oid is a unique OID of a PDF form used as target PDF form in the generalFormRequest/generalFormResponse system. Further information about the form OID space and the form system, respectively can be found in the documentation of the generalFormRequest schema and links therein.

The usage and impact of the pdf_form_oid attribute is of major importance. Its definition and presence is a signal from the sender to the receiver of the notification to start a new form process. The following measures are taken in the generalFormRequest system:

  • the given dependent reference object is used as dependent reference object of the form process. If no dependent reference object is supplied then and only then the notification reference object is used as dependent reference object in the form process.
  • the sender of the notification becomes the recipient of the form process (aka the consumer in the form XSD).
  • the recipient of the notification becomes the sender of the form process (aka the producer in the form XSD).
  • the mirrored transport element defines the new transport element of the form process.
  • the given pdf_form_oid defines the PDF form template to use in the form system.
    If the form system does not find the OID in question, the form process is cancelled.
  • Instructions whose token attribute begins with "form:" are interpreted as presetting instructions of the form variable space.
Extensions
Annotation | Base
Definition for a message container | notification:stringType1_700
source <complexType name="messageType">
<simpleContent>
<extension base="notification:stringType1_700">
<attribute name="date" type="dateTime" use="required"/>
<attribute name="pdf_form_oid" type="notification:stringType1_255"/>
</extension>
</simpleContent>
</complexType>


complexType notificationType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:processing notification:payload ds:Signature
used by
element notification
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
guid | notification:guidType | required
is_confidential | boolean | false
attributes annotations
Name Notes
language language defines the used data language of the messages encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
guid the required guid (Globally Unique IDentifier) is an unique identifier for the current XML infoset defined as a 32 hex-digit string covered by the pattern [A-Fa-f0-9]{32}.
Please note that the generation of the guid must be in accordance with RFC 9562.
is_confidential is_confidential defines if the notification is confidential.

Note that the confidentiality status is defined at the moment of the initial XML infoset generation, thereafter it must be inherited into each new reply cycle.

attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus | NMTOKEN | test | the modus test is for software developers to test the processing.
source <complexType name="notificationType">
<sequence>
<element name="processing" type="notification:processingType"/>
<element name="payload" type="notification:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
<attribute name="guid" type="notification:guidType" use="required"/>
<attribute name="is_confidential" type="boolean" default="false"/>
</complexType>


complexType objectType

diagram
namespace http://www.forum-datenaustausch.ch/notification
used by
elements payloadType/credit_ref payloadType/form_ref payloadType/invoice_ref payloadType/mcd_ref payloadType/reminder_ref
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | notification:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form a object reference. request_timestamp will be generated once for a certain object reference and thereafter is always referenced!
request_date request_date is the main software's date defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_date will be generated once for a certain object reference and thereafter is always referenced!
request_id request_id is the main software's ID defined at the moment of the initial request infoset generation.
This is one of 3 identifiers that form the object reference. request_ID will be generated once for a certain object reference and thereafter is always referenced!
source <complexType name="objectType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="2890245600"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="notification:stringType1_35" use="required"/>
</complexType>


complexType onlineAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:email notification:uri
used by
elements personType/online companyType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="notification:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


complexType patientAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:person
used by
element bodyType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | date | required
ssn | notification:ssnPartyType | required
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient identifies with the gender of male
  • female: the patient identifies with the gender of female
  • diverse: the patient identifies with neither/both female and male, or identifies as transgender. Furthermore, "diverse" is applicable if the gender is unknown, or the patient does not wish to disclosure his gender identity.
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body. The attribute sex is encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 3 distinguished styles are allowed:
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient identifies with the gender of male
gender | NMTOKEN | female | the patient identifies with the gender of female
gender | NMTOKEN | diverse | the patient identifies with the gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="notification:personType"/>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
<enumeration value="diverse"/>
</restriction>
</simpleType>
</attribute>
<attribute name="sex" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="date" use="required"/>
<attribute name="ssn" type="notification:ssnPartyType" use="required"/>
</complexType>


complexType payloadType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:credit_ref notification:invoice_ref notification:reminder_ref notification:mcd_ref notification:form_ref notification:notification notification:body xenc:EncryptedData
used by
element notificationType/payload
source <complexType name="payloadType">
<sequence>
<choice minOccurs="0">
<element name="credit_ref" type="notification:objectType"/>
<element name="invoice_ref" type="notification:objectType"/>
<element name="reminder_ref" type="notification:objectType"/>
<element name="mcd_ref" type="notification:objectType"/>
<element name="form_ref" type="notification:objectType"/>
</choice>
<element name="notification" type="notification:mainObjectType"/>
<choice>
<element name="body" type="notification:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
</complexType>


complexType personType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:familyname notification:givenname notification:subaddressing notification:postal notification:telecom notification:online
used by
elements baseAddressType/person patientAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation notification:stringType1_35
title notification:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="notification:stringType1_35"/>
<element name="givenname" type="notification:stringType1_35"/>
<element name="subaddressing" type="notification:stringType1_35" minOccurs="0"/>
<element name="postal" type="notification:postalAddressType"/>
<element name="telecom" type="notification:telecomAddressType" minOccurs="0"/>
<element name="online" type="notification:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="notification:stringType1_35"/>
<attribute name="title" type="notification:stringType1_35"/>
</complexType>


complexType postalAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:pobox notification:street notification:zip notification:city notification:country
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="notification:stringType1_35" minOccurs="0"/>
<element name="street" type="notification:streetType" minOccurs="0"/>
<element name="zip" type="notification:zipType"/>
<element name="city" type="notification:stringType1_35"/>
<element name="country" type="notification:countryType" minOccurs="0"/>
</sequence>
</complexType>


complexType processingType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:transport
used by
element notificationType/processing
source <complexType name="processingType">
<sequence>
<element name="transport" type="notification:transportType"/>
</sequence>
</complexType>


complexType prologType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:package notification:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="notification:softwareType" minOccurs="0"/>
<element name="generator" type="notification:softwareType"/>
</sequence>
</complexType>


complexType softwareType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | notification:stringType1_50 | required
copyright notification:stringType1_50
description notification:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="notification:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="notification:stringType1_50" use="required"/>
<attribute name="copyright" type="notification:stringType1_50"/>
<attribute name="description" type="notification:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


complexType streetType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | extension of notification:stringType1_35
properties
base notification:stringType1_35
used by
element postalAddressType/street
facets
minLength | 1
maxLength | 35
attributes parameters
Name Type Use Default Fixed
street_name notification:stringType1_35
house_no notification:stringType1_10
attributes annotations
Name | Notes
street_name | street_name is the optional street name being part of the full street definition. Please note that the street name is an extracted copy from the full street definition.
house_no | house_no is the optional house number being part of full street definition. Please note that the house number is an extracted copy from the full street definition.
Extensions
Annotation | Base
Definition for the street container (a subcontainer of the address definition) supplying the full street as element and the split up into street name and house number both defined as attributes. | notification:stringType1_35
source <complexType name="streetType">
<simpleContent>
<extension base="notification:stringType1_35">
<attribute name="street_name" type="notification:stringType1_35"/>
<attribute name="house_no" type="notification:stringType1_10"/>
</extension>
</simpleContent>
</complexType>


complexType telecomAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:phone
used by
elements personType/telecom companyType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="notification:stringType1_25" maxOccurs="3"/>
</sequence>
</complexType>


complexType transportType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
children | notification:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | notification:glnPartyType | required
to | notification:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the XML infoset to the first defined intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the XML infoset from the last defined intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="notification:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="notification:glnPartyType" use="required"/>
<attribute name="to" type="notification:glnPartyType" use="required"/>
</complexType>


complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


complexType zipType

diagram
namespace | http://www.forum-datenaustausch.ch/notification
type | extension of notification:stringType1_9
properties
base notification:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name Type Use Default Fixed
state_code notification:stringType1_9
attributes annotations
Name | Notes
state_code | state_code is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code and an optional state code | notification:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="notification:stringType1_9">
<attribute name="state_code" type="notification:stringType1_9"/>
</extension>
</simpleContent>
</complexType>


element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


simpleType filenameType

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute documentType/@filename
facets
pattern ([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{3,4})
source <simpleType name="filenameType">
<restriction base="string">
<pattern value="([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{3,4})"/>
</restriction>
</simpleType>


simpleType glnPartyType

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attributes transportType/@from baseAddressType/@gln transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="glnPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


simpleType guidType

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute notificationType/@guid
facets
pattern [A-Fa-f0-9]{32}
source <simpleType name="guidType">
<restriction base="string">
<pattern value="[A-Fa-f0-9]{32}"/>
</restriction>
</simpleType>


simpleType iso3166A2Type

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute countryType/@country_code
facets
pattern ([A-Z]{2})
source <simpleType name="iso3166A2Type">
<restriction base="string">
<pattern value="([A-Z]{2})"/>
</restriction>
</simpleType>


simpleType ssnPartyType

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [0-9]{4,10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


simpleType stringType1_10

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute streetType/@house_no
facets
minLength | 1
maxLength | 10
source <simpleType name="stringType1_10">
<restriction base="string">
<minLength value="1"/>
<maxLength value="10"/>
</restriction>
</simpleType>


simpleType stringType1_12

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute diagnosisType/@code
facets
minLength | 1
maxLength | 12
source <simpleType name="stringType1_12">
<restriction base="string">
<minLength value="1"/>
<maxLength value="12"/>
</restriction>
</simpleType>


simpleType stringType1_25

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
element telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


simpleType stringType1_255

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute messageType/@pdf_form_oid
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


simpleType stringType1_3

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


simpleType stringType1_35

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox personType/subaddressing companyType/subaddressing
complexTypes | countryType streetType
attributes | lawType/@card_id lawType/@case_id mainObjectType/@id lawType/@insured_id objectType/@request_id personType/@salutation streetType/@street_name personType/@title
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


simpleType stringType1_350

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
complexType diagnosisType
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


simpleType stringType1_50

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


simpleType stringType1_70

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


simpleType stringType1_700

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
complexType messageType
facets
minLength | 1
maxLength | 700
source <simpleType name="stringType1_700">
<restriction base="string">
<minLength value="1"/>
<maxLength value="700"/>
</restriction>
</simpleType>


simpleType stringType1_80

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 80
source <simpleType name="stringType1_80">
<restriction base="string">
<minLength value="1"/>
<maxLength value="80"/>
</restriction>
</simpleType>


simpleType stringType1_9

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
complexType | zipType
attribute | zipType/@state_code
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


simpleType zsrPartyType

namespace | http://www.forum-datenaustausch.ch/notification
type | restriction of string
used by
attribute baseAddressType/@zsr
facets
pattern ([A-Z][0-9]{6})
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="([A-Z][0-9]{6})"/>
</restriction>
</simpleType>


simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>