Browser XML - xmitDocuments

Version 4.0

Realisiert durch das Forum Datenaustausch

Die Darstellung und die Software-Applikation dürfen nur mit Zustimmung des Forum Datenaustausch geändert werden.

Im April 2005.


Referenzhandbuch xmit-Dokumente

xmitDocuments_400 0.9 deu

Referenzhandbuch xmit-Dokumente


© - copyright

xmitDocuments_400 0.9 deu

© - copyright
Rechnungsstandard im schweizerischen Gesundheitswesen
Referenzhandbuch: xmit-Documente Release 4.0
xmitDocuments_400.xsd
Erstell-Datum: 14.4.2005

© - copyright: Forum Datenaustausch. Alle Rechte vorbehalten.
Dieses Dokument darf beliebig kopiert und verteilt werden, sofern dies in unveränderter Form geschieht und nicht-kommerzielle Absichten damit verfolgt werden.
Dasselbe gilt für alle in diesem Dokument referenzierten XML Schema Files unter denselben Pämissen.
Das Forum übernimmt aber keine Haftung für die Aktualität und Korrektheit des Inhaltes.


Forum Datenaustausch

xmitDocuments_400 0.9 deu

Forum Datenaustausch

Im Forum Datenaustausch haben sich verschiedene Akteure des Schweizer Gesundheitswesens zusammengeschlossen. Das Forum verfolgt u.a. das Ziel, einheitliche gemeinsam entwickelte Standards für den elektronischen Datenaustausch festzusetzen.

Forumsmitglieder sind die Verbände der Leistungserbringer H+ sowie der Schweizerische Apothekerverband (SAV). Auf Seiten der Kostenträger sind es die santésuisse, der Schweizerische Versicherungsverband (SVV), die Suva, das Bundesamt für Militärversicherung (BAMV) und die Invalidenversicherung (IV).

Die vom Forum verabschiedeten Standards wie die XML-Nachrichten zum elektronischen Datenaustausch werden auf

www.forum-datenaustausch.ch

publiziert. Dazu gehört auch die elektronische, XML - basierende Leistungsabrechnung für Ärzte.

Die Aufgaben des Forums bestehen in der Vereinbarung von strategischen Zielen, der Verhandlung auf politischer Ebene sowie Vertragsverhandlungen. Dem Forum unterstellt ist das Fachorgan, welches von den gleichen Akteuren vertreten wird wie das Forum selber.

Die Aufgaben des Fachorgans umfassen:

- Umsetzung Zielsetzung
- Verhandlung auf fachlicher Ebene (Koordination und Kommunikation mit den Akteuren)
- Durchführen von Veranstaltungen und Vernehmlassungen

Das vorliegende xmit-Document wurde durch die Mitglieder des Fachorgans erarbeitet, definiert und vom Forum Datenaustausch verabschiedet.


XML-Datentypen

xmitDocuments_400 0.9 deu

XML-Datentypen

Die folgende Tabelle beschreibt das Format der wichtigsten Datentypen im Schemafile (xmitDocuments_400.xsd):

Name | Beschreibung
anyURI | anyURI bezeichnet jede gemäss RFC 2396 bzw. RFC 2732 gültige URI.
boolean | Ist der Boolsche Datentyp, welcher die Werte {true|false|1|0} annehmen kann. 0 bedeutet in diesem Kontext wie in sequentiellen Programmiersprachen üblich false und 1 true.
dateTime | dateTime repräsentiert einen genau spezifizierten Moment der Zeit. Der Wertebereich von dateTime wird dabei aus einer Kombination von Datum und Zeit gemäss ISO 8601 gebildet. Zum Beispiel würde 13:20h am 31.5.1999 als '1999-05-31T13:20:00' kodiert werden. Achtung: Spielt bei der Angabe eines Datums die Uhrzeit keine Rolle, ist als Zeit 00:00:00h aufzuführen. Beispiel: '1999-05-31T00:00:00'. Ob ein Datum mit einer Zeitangabe geliefert werden muss wird, in den (Tarif-/Rahmen-)Verträgen geregelt.
double | Ist ein Gleitkomma-Zahlentyp gemäss der IEEE double precision 64-bit floating point Definition (IEEE 754-1985).
duration | duration repräsentiert ein Zeitintervall. Der Wertebereich von duration kann dabei sekundengenau gemäss ISO 8601 gebildet werden.
enumeration | enumeration definiert eine endliche Menge von fixierten Werten, aus welcher ein Element ausgewählt werden muss, z.B. {1|2|3}.
long | Ist ein Ganzzahl-Zahlentyp (64-bit) mit der oberen Schranke 9223372036854775807 und der unteren Schranke -9223372036854775808.
NMTOKEN | Ein NMTOKEN ist eine Sequenz aus einem oder mehreren Buchstaben, Ziffern und einigen Interpunktionssymbolen.
pattern | pattern bezeichnet ein vordefiniertes "Muster". Die Syntax von pattern wird als grep pattern gemäss der Perl 5 Implementation angegeben.
string | string repräsentiert den Datentyp character string in XML. Der Wertebereich von string ist eine endliche Sequenz von characters.

Die erwähnten ISO-Standards sind zum Teil auf 'www.w3c.org' zu finden. In jedem Fall können die ISO-Standards unter www.iso.ch bestellt werden.

Die RFC-Dokumente der IETF (Internet Engineering Task Force) sind online unter 'www.ietf.org' verfügbar.


Zeichensatz und Zeichen-Entities

xmitDocuments_400 0.9 deu

Zeichensatz und Zeichen-Entities

Der für die XML-Rechnung zu verwendende Zeichensatz ist Unicode UTF-8.

Einige Zeichen können im Text eines XML-Dokumentes nicht verwendet werden, weil sie zu Konflikten mit den speziellen Markup-Begrenzern führen. < oder & dürfen in einem XMLDokument nur direkt geschrieben werden, um einen 'Tag' bzw. eine 'Entity' einzuleiten.

Damit die Bedeutung der folgenden Zeichen im Text eines XML-Dokumentes eindeutig ist, empfiehlt es sich, sie durch die vordefinierten Zeichen-Entities darzustellen:

& | = | &amp
' | = | &apos
> | = | &gt
< | = | &lt
" | = | &quot

Beispiele zur ESR-Kodierzeile:

0100000121403>016291414110116441140576999+ 010370058> | =
<invoice:esr9 coding_line="0100000121403&gt;016291414110116441140576999+010370058&gt;"/> |
<080001000000500> 473434028588301+ 11218> | =
<invoice:esr5 coding_line="&lt;080001000000500&gt;473434028588301+ 11218&gt;"/> |


Rechnungs-Schema

xmitDocuments_400 0.9 deu
Rechnungs-Schema


 Schema xmitDocuments_400.xsd

attribute form default: | unqualified
element form default: | qualified
targetNamespace: | http://www.forum-datenaustausch.ch/de
Elements | Complex types | Simple types
transmission | bodyType | eanPartyType
 | caseSpecificType | nonEmptyStringType
 | caseType | ssnPartyType
 | companyType | stringType1_100
 | documentsType | stringType1_25
 | documentType | stringType1_3
 | onlineAddressType | stringType1_35
 | partyAddressType | stringType1_50
 | patientAddressType | stringType1_70
 | payloadType | stringType1_700
 | personType | stringType1_9
 | postalAddressType |
 | prologType |
 | referenceType |
 | softwareType |
 | telecomAddressType |
 | transmissionType |
 | transportIntermediateType |
 | zipType |

element transmission
Annotation Beginn XML-Dokument

XML-Deklaration inklusive Zeichensatz UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (Erste Zeile im XML-Dokument)

XML-Wurzelelement: xmitDocuments:transmission

- xsi Namensraum: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xmitDocuments Namensraum: xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de"
- Typ: xmit-Documente 4.0
- Ort: xsi schemaLocation="http://www.forum-datenaustausch.ch/de xmitDocuments_400.xsd"

Für alle Elemente gilt der Namensraum "xmitDocuments".
Im XML-Dokument muss für jedes Element dieser Namensraum angegeben werden!

In der vorliegenden Dokumentation wird im Folgenden jeweils nur noch der Elementname aufgeführt, ohne Namensraum, z.B: "transmission" statt "xmitDocuments:transmission".

Für Attribute muss im XML-Dokument kein Namensraum angegeben werden.

Siehe Definition im Schema:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transmissionType
properties
content complex
children | xmitDocuments:prolog xmitDocuments:payload xmitDocuments:documents
source
<element name="transmission" type="xmitDocuments:transmissionType"/>

complexType bodyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
used by
elements payloadType/body bodyType/tracking
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<complexType name="bodyType">
  <sequence>
    <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>
    <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>
    <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>
  </sequence>
  <attribute name="timestamp" type="unsignedLong" use="required"/>
  <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>
  <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

element bodyType/comment
Annotation Kommentar
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_700
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 700
source
<element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>

element bodyType/tracking
Annotation Kummunikations-History

Unbegrenztes Tracking.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>

element bodyType/reference
Annotation Referenz
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:referenceType
properties
isRef | 0
content | complex
children | xmitDocuments:patient xmitDocuments:case_credit xmitDocuments:case_invoice xmitDocuments:case_reminder xmitDocuments:case
source
<element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>

complexType caseSpecificType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:caseType
properties
base xmitDocuments:caseType
used by
elements referenceType/case_credit referenceType/case_invoice referenceType/case_reminder
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
Extensions
Annotation | Base
Fall | transmission:caseType
source
<complexType name="caseSpecificType">
  <complexContent>
    <extension base="xmitDocuments:caseType">
      <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>
      <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>
    </extension>
  </complexContent>
</complexType>

complexType caseType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element | referenceType/case
complexType | caseSpecificType
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identifikation
source
<complexType name="caseType">
  <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>
</complexType>

complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:companyname xmitDocuments:department xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
used by
element partyAddressType/company
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Kontakt
source
<complexType name="companyType">
  <sequence>
    <sequence>
      <element name="companyname" type="xmitDocuments:stringType1_35"/>
      <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>
</complexType>

element companyType/companyname
Annotation Firmenbezeichnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="xmitDocuments:stringType1_35"/>

element companyType/department
Annotation Abteilung / Division
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element companyType/postal
Annotation Adresse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>

element companyType/telecom
Annotation Telecom

Definiert telekommunikatorische Kontaktinformationen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:phone xmitDocuments:fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

element companyType/online
Annotation Online

Definiert Informationen zu online-Diensten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:email xmitDocuments:url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

complexType documentsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:document
used by
element transmissionType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Dokumentennummer
source
<complexType name="documentsType">
  <sequence>
    <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="number" type="unsignedLong" use="required"/>
</complexType>

element documentsType/document
Annotation Dokument
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:documentType
properties
isRef | 0
content | complex
children | xmitDocuments:data xmitDocuments:url
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Dokumente Filename
size | Dokumente Grösse
mimeType | Dokumente MIME-Typ
viewer | Viewersoftware
source
<element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>

complexType documentType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:data xmitDocuments:url
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Dokumente Filename
size | Dokumente Grösse
mimeType | Dokumente MIME-Typ
viewer | Viewersoftware
source
<complexType name="documentType">
  <choice>
    <element name="data" type="base64Binary"/>
    <element name="url" type="anyURI"/>
  </choice>
  <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="size" type="unsignedLong" use="required"/>
  <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="viewer" type="anyURI"/>
</complexType>

element documentType/data
Annotation Datenblock
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | base64Binary
properties
isRef | 0
content | simple
source
<element name="data" type="base64Binary"/>

element documentType/url
Annotation URL-Adresse

Bezeichnet eine vollständige URL Adresse, welche zum Zweck der Informationsbeschaffung oder Kontaktaufnahme verwendet werden kann.

Es ist zu beachten, dass der online-Dienst "mailto"eine eMail-Adresse via einen URL bezeichnet.

eMail-Adressen sollten jedoch über das gesonderte Element email abgebildet werden.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | anyURI
properties
isRef | 0
content | simple
source
<element name="url" type="anyURI"/>

complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:email xmitDocuments:url
used by
elements companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="xmitDocuments:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>

element onlineAddressType/email
Annotation eMail-Adresse

Bezeichnet eine eMail-Adresse gemäss RFC821.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of xmitDocuments:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="xmitDocuments:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>

element onlineAddressType/url
Annotation URL-Adresse

Bezeichnet eine vollständige URL Adresse, welche zum Zweck der Informationsbeschaffung oder Kontaktaufnahme verwendet werden kann.

Es ist zu beachten, dass der online-Dienst "mailto"eine eMail-Adresse via einen URL bezeichnet.

eMail-Adressen sollten jedoch über das gesonderte Element email abgebildet werden.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>

complexType partyAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:company xmitDocuments:person
used by
elements payloadType/recipient payloadType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<complexType name="partyAddressType">
  <choice>
    <element name="company" type="xmitDocuments:companyType"/>
    <element name="person" type="xmitDocuments:personType"/>
  </choice>
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

element partyAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:companyType
properties
isRef | 0
content | complex
children | xmitDocuments:companyname xmitDocuments:department xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Kontakt
source
<element name="company" type="xmitDocuments:companyType"/>

element partyAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="xmitDocuments:personType"/>

complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:person
used by
element referenceType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="xmitDocuments:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>
  <attribute name="senderID" type="xmitDocuments:stringType1_35"/>
  <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>
</complexType>

element patientAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="xmitDocuments:personType"/>

complexType payloadType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:transport_intermediate xmitDocuments:sender xmitDocuments:recipient xmitDocuments:subject xmitDocuments:body
used by
element transmissionType/payload
source
<complexType name="payloadType">
  <sequence>
    <choice>
      <element name="transport_intermediate" type="xmitDocuments:transportIntermediateType"/>
    </choice>
    <element name="sender" type="xmitDocuments:partyAddressType"/>
    <element name="recipient" type="xmitDocuments:partyAddressType"/>
    <element name="subject" type="xmitDocuments:stringType1_100"/>
    <element name="body" type="xmitDocuments:bodyType"/>
  </sequence>
</complexType>

element payloadType/transport_intermediate
Annotation Intermediärer Transporteur
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transportIntermediateType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
sender_ean | xmitDocuments:eanPartyType | required |  |
recipient_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
sender_ean | EAN-Nummer des Senders
recipient_ean | EAN-Nummer des intermediären Partners
source
<element name="transport_intermediate" type="xmitDocuments:transportIntermediateType"/>

element payloadType/sender
Annotation Sender

Bezeichnet den Adressblock mit Angaben des Senders.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:company xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<element name="sender" type="xmitDocuments:partyAddressType"/>

element payloadType/recipient
Annotation Empfänger

Bezeichnet den Adressblock mit Angaben des Empfängers.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:company xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<element name="recipient" type="xmitDocuments:partyAddressType"/>

element payloadType/subject
Annotation Kurztitel der Information
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_100
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="subject" type="xmitDocuments:stringType1_100"/>

element payloadType/body
Annotation Dateninhalt
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<element name="body" type="xmitDocuments:bodyType"/>

complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
used by
elements partyAddressType/person patientAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<complexType name="personType">
  <sequence>
    <sequence>
      <element name="familyname" type="xmitDocuments:stringType1_35"/>
      <element name="givenname" type="xmitDocuments:stringType1_35"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="xmitDocuments:stringType1_35"/>
  <attribute name="title" type="xmitDocuments:stringType1_35"/>
</complexType>

element personType/familyname
Annotation Nachname
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="xmitDocuments:stringType1_35"/>

element personType/givenname
Annotation Vorname

Bezeichnet das Element, in welchem als Dateninhalt der Vor- oder die Zweitnamen einer natürlichen Person angegeben werden.

Das erste gegebene Element wird immer als Vorname gewertet, allfällig weitere Elemente als Zweitnamen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="xmitDocuments:stringType1_35"/>

element personType/postal
Annotation Adresse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>

element personType/telecom
Annotation Telecom

Definiert telekommunikatorische Kontaktinformationen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:phone xmitDocuments:fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

element personType/online
Annotation Online

Definiert Informationen zu online-Diensten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:email xmitDocuments:url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="zip" type="xmitDocuments:zipType"/>
    <element name="city" type="xmitDocuments:stringType1_35"/>
  </sequence>
</complexType>

element postalAddressType/pobox
Annotation Postfach
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element postalAddressType/street
Annotation Strasse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element postalAddressType/zip
Annotation PLZ
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Kanton
countrycode | Land (ISO Ländercode)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<element name="zip" type="xmitDocuments:zipType"/>

element postalAddressType/city
Annotation Ort
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="xmitDocuments:stringType1_35"/>

complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:package xmitDocuments:generator
used by
element transmissionType/prolog
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Testkennzeichnung Bezeichnet den Typ resp. die Rolle im Sinne eines produktiven Datensatzes oder eines Testdatensatzes.
type | Softwaretypenbezeichnung
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Produktionsnachricht
role |  | NMTOKEN | test | Testnachricht
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>
    <element name="generator" type="xmitDocuments:softwareType"/>
  </sequence>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="type" type="nonNegativeInteger" default="0"/>
</complexType>

element prologType/package
Annotation Branchenapplikation

Enthält Informationen bez. der übergeordneten Branchenapplikation, welche zur Dokumentenerstellung verwendet wird. Als Dateninhalt dieses Elements wird der Name der Branchenapplikation angegeben.

Werden Angaben zur Branchenapplikation geliefert, muss der Name aufgeführt sein.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
source
<element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>

element prologType/generator
Annotation Name des Softwaregenerators
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
source
<element name="generator" type="xmitDocuments:softwareType"/>

complexType referenceType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:patient xmitDocuments:case_credit xmitDocuments:case_invoice xmitDocuments:case_reminder xmitDocuments:case
used by
element bodyType/reference
source
<complexType name="referenceType">
  <sequence>
    <element name="patient" type="xmitDocuments:patientAddressType"/>
    <choice minOccurs="0">
      <element name="case_credit" type="xmitDocuments:caseSpecificType"/>
      <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>
      <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>
      <element name="case" type="xmitDocuments:caseType"/>
    </choice>
  </sequence>
</complexType>

element referenceType/patient
Annotation Patient

Bezeichnet den Adressblock mit Angaben des Patienten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:patientAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<element name="patient" type="xmitDocuments:patientAddressType"/>

element referenceType/case_credit
Annotation Betrifft Kostengutsprache
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_credit" type="xmitDocuments:caseSpecificType"/>

element referenceType/case_invoice
Annotation Betrifft Rechnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_invoice" type="xmitDocuments:caseSpecificType"/>

element referenceType/case_reminder
Annotation Betrifft Mahnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_reminder" type="xmitDocuments:caseSpecificType"/>

element referenceType/case
Annotation Fall
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identifikation
Extensions
Annotation | Base
Fall | transmission:caseType
source
<element name="case" type="xmitDocuments:caseType"/>

complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_50
properties
base xmitDocuments:stringType1_50
used by
elements prologType/generator prologType/package
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
Extensions
Annotation | Base
Software | transmission:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_50">
      <attribute name="version" type="nonNegativeInteger" use="required"/>
    </extension>
  </simpleContent>
</complexType>

complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:phone xmitDocuments:fax
used by
elements companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>

element telecomAddressType/phone
Annotation Telefon-Nummer

Festanschluss- oder Mobil-Telefonnummer
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>

element telecomAddressType/fax
Annotation Fax-Nummer
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>

complexType transmissionType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:prolog xmitDocuments:payload xmitDocuments:documents
used by
element transmission
source
<complexType name="transmissionType">
  <sequence>
    <element name="prolog" type="xmitDocuments:prologType"/>
    <element name="payload" type="xmitDocuments:payloadType"/>
    <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>
  </sequence>
</complexType>

element transmissionType/prolog
Annotation Prolog

Block mit Informationen über:

- das übergeordnete Software-Packet (Branchenapplikation)
- den Generator, welcher die entsprechenden XML Strukturen generiert und validiert hat
- die verwendeten Daten-Validatoren
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:prologType
properties
isRef | 0
content | complex
children | xmitDocuments:package xmitDocuments:generator
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Testkennzeichnung Bezeichnet den Typ resp. die Rolle im Sinne eines produktiven Datensatzes oder eines Testdatensatzes.
type | Softwaretypenbezeichnung
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Produktionsnachricht
role |  | NMTOKEN | test | Testnachricht
source
<element name="prolog" type="xmitDocuments:prologType"/>

element transmissionType/payload
Annotation Datenpacket
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:payloadType
properties
isRef | 0
content | complex
children | xmitDocuments:transport_intermediate xmitDocuments:sender xmitDocuments:recipient xmitDocuments:subject xmitDocuments:body
source
<element name="payload" type="xmitDocuments:payloadType"/>

element transmissionType/documents
Annotation Dokumente
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:documentsType
properties
isRef | 0
content | complex
children | xmitDocuments:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Dokumentennummer
source
<element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>

complexType transportIntermediateType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element payloadType/transport_intermediate
attributes parameters
Name | Type | Use | Default | Fixed
sender_ean | xmitDocuments:eanPartyType | required |  |
recipient_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
sender_ean | EAN-Nummer des Senders
recipient_ean | EAN-Nummer des intermediären Partners
source
<complexType name="transportIntermediateType">
  <attribute name="sender_ean" type="xmitDocuments:eanPartyType" use="required"/>
  <attribute name="recipient_ean" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_9
properties
base xmitDocuments:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Kanton
countrycode | Land (ISO Ländercode)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_9">
      <attribute name="statecode" type="xmitDocuments:stringType1_9"/>
      <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>

simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes partyAddressType/@ean_party caseSpecificType/@provider_ean transportIntermediateType/@recipient_ean bodyType/@sender transportIntermediateType/@sender_ean
facets
pattern ([0-9]{13})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="([0-9]{13})"/>
  </restriction>
</simpleType>

simpleType nonEmptyStringType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes companyType/@contact documentType/@filename documentType/@mimeType
facets
minLength 1
source
<simpleType name="nonEmptyStringType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>

simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}|unknown
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>
  </restriction>
</simpleType>

simpleType stringType1_100
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element | payloadType/subject
attribute | caseType/@id
facets
minLength | 1
maxLength | 100
source
<simpleType name="stringType1_100">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="100"/>
  </restriction>
</simpleType>

simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>

simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>

simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | bodyType/@id patientAddressType/@recipientID personType/@salutation patientAddressType/@senderID personType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>

simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType softwareType
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>

simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>

simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element bodyType/comment
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>

simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>


Schema

1 <?xml version="1.0" encoding="UTF-8"?>

2 <!-- ==========================================================================

3

4 This is the schema definition for process of transmitting one or more documents

5 encoded in XML. The process is modelled after a plain email system.

6

7 Permission to use, and distribute this schema and its accompanying

8 documentation for any purpose and without fee is hereby granted in perpetuity,

9 provided that the above copyright notice and this paragraph appear in all copies

10 and this schema file is not altered.

11 The copyright holders make no representation about the suitability of the schema

12 for any purpose.

13

14 It is provided "as is" without expressed or implied warranty.

15

16 Copyright (c) 2005 Forum Datenaustausch,

17 All Rights Reserved.

18 ========================================================================== -->

19 <schema xmlns="http://www.w3.org/2001/XMLSchema" xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de" targetNamespace="

http://www.forum-datenaustausch.ch/de" elementFormDefault="qualified" attributeFormDefault="unqualified">

20 <!-- =======================================================================

21 General data type definitions

22 ======================================================================= -->

23 <!-- string not null -->

24 <simpleType name="nonEmptyStringType">

25 <restriction base="string">

26 <minLength value="1"/>

27 </restriction>

28 </simpleType>

29 <!-- string type with length 1-3 characters -->

30 <simpleType name="stringType1_3">

31 <restriction base="string">

32 <minLength value="1"/>

33 <maxLength value="3"/>

34 </restriction>

35 </simpleType>

36 <!-- string type with length 1-9 characters -->

37 <simpleType name="stringType1_9">

38 <restriction base="string">

39 <minLength value="1"/>

40 <maxLength value="9"/>

41 </restriction>

42 </simpleType>

43 <!-- string type with length 1-25 characters -->

44 <simpleType name="stringType1_25">

45 <restriction base="string">

46 <minLength value="1"/>

47 <maxLength value="25"/>

48 </restriction>

49 </simpleType>

50 <!-- string type with length 1-35 characters -->

51 <simpleType name="stringType1_35">

52 <restriction base="string">

53 <minLength value="1"/>

54 <maxLength value="35"/>

55 </restriction>

56 </simpleType>

57 <!-- string type with length 1-50 characters -->

58 <simpleType name="stringType1_50">

59 <restriction base="string">

60 <minLength value="1"/>

61 <maxLength value="50"/>

62 </restriction>

63 </simpleType>

64 <!-- string type with length 1-70 characters -->

65 <simpleType name="stringType1_70">

66 <restriction base="string">

67 <minLength value="1"/>

68 <maxLength value="70"/>

69 </restriction>

70 </simpleType>

71 <!-- string type with length 1-100 characters -->

72 <simpleType name="stringType1_100">

73 <restriction base="string">

74 <minLength value="1"/>

75 <maxLength value="100"/>

76 </restriction>

77 </simpleType>

78 <!-- string type with length 1-700 characters -->

79 <simpleType name="stringType1_700">

80 <restriction base="string">

81 <minLength value="1"/>

82 <maxLength value="700"/>

83 </restriction>

84 </simpleType>

85 <!-- EAN- und AHV-Nr. -->

86 <simpleType name="eanPartyType">

87 <restriction base="string">

88 <pattern value="([0-9]{13})"/>

89 </restriction>

90 </simpleType>

91 <simpleType name="ssnPartyType">

92 <restriction base="string">

93 <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>

94 </restriction>

95 </simpleType>

96 <!-- =======================================================================

97 address data type definitions for companies and persons

98 ======================================================================= -->

99 <!-- Company -->

100 <complexType name="companyType">

101 <sequence>

102 <sequence>

103 <element name="companyname" type="xmitDocuments:stringType1_35"/>

104 <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>

105 </sequence>

106 <element name="postal" type="xmitDocuments:postalAddressType"/>

107 <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

108 <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

109 </sequence>

110 <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>

111 </complexType>

112 <!-- Person -->

113 <complexType name="personType">

114 <sequence>

115 <sequence>

116 <element name="familyname" type="xmitDocuments:stringType1_35"/>

117 <element name="givenname" type="xmitDocuments:stringType1_35"/>

118 </sequence>

119 <element name="postal" type="xmitDocuments:postalAddressType"/>

120 <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

121 <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

122 </sequence>

123 <attribute name="salutation" type="xmitDocuments:stringType1_35"/>

124 <attribute name="title" type="xmitDocuments:stringType1_35"/>

125 </complexType>

126 <complexType name="zipType">

127 <simpleContent>

128 <extension base="xmitDocuments:stringType1_9">

129 <attribute name="statecode" type="xmitDocuments:stringType1_9"/>

130 <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>

131 </extension>

132 </simpleContent>

133 </complexType>

134 <complexType name="postalAddressType">

135 <sequence>

136 <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>

137 <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>

138 <element name="zip" type="xmitDocuments:zipType"/>

139 <element name="city" type="xmitDocuments:stringType1_35"/>

140 </sequence>

141 </complexType>

142 <complexType name="telecomAddressType">

143 <sequence>

144 <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>

145 <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>

146 </sequence>

147 </complexType>

148 <complexType name="onlineAddressType">

149 <sequence>

150 <element name="email" maxOccurs="3">

151 <simpleType>

152 <restriction base="xmitDocuments:stringType1_70">

153 <pattern value=".+@.+"/>

154 </restriction>

155 </simpleType>

156 </element>

157 <element name="url" minOccurs="0" maxOccurs="3">

158 <simpleType>

159 <restriction base="anyURI">

160 <minLength value="1"/>

161 <maxLength value="100"/>

162 </restriction>

163 </simpleType>

164 </element>

165 </sequence>

166 </complexType>

167 <!-- =======================================================================

168 the specific address type data definitions

169 ======================================================================= -->

170 <!-- address = "Sender/Recipient" -->

171 <complexType name="partyAddressType">

172 <choice>

173 <element name="company" type="xmitDocuments:companyType"/>

174 <element name="person" type="xmitDocuments:personType"/>

175 </choice>

176 <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>

177 </complexType>

178 <!-- address = "Patient" -->

179 <complexType name="patientAddressType">

180 <sequence>

181 <element name="person" type="xmitDocuments:personType"/>

182 </sequence>

183 <attribute name="gender" use="required">

184 <simpleType>

185 <restriction base="NMTOKEN">

186 <enumeration value="male"/>

187 <enumeration value="female"/>

188 </restriction>

189 </simpleType>

190 </attribute>

191 <attribute name="birthdate" type="dateTime" use="required"/>

192 <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>

193 <attribute name="senderID" type="xmitDocuments:stringType1_35"/>

194 <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>

195 </complexType>

196 <!-- =======================================================================

197 transport data type definitions

198 ======================================================================= -->

199 <complexType name="transportIntermediateType">

200 <attribute name="sender_ean" type="xmitDocuments:eanPartyType" use="required"/>

201 <attribute name="recipient_ean" type="xmitDocuments:eanPartyType" use="required"/>

202 </complexType>

203 <!-- =======================================================================

204 prolog: misc administrative data type definitions

205 ======================================================================= -->

206 <!-- prolog section -->

207 <complexType name="prologType">

208 <sequence>

209 <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>

210 <element name="generator" type="xmitDocuments:softwareType"/>

211 </sequence>

212 <attribute name="role" default="production">

213 <simpleType>

214 <restriction base="NMTOKEN">

215 <enumeration value="production"/>

216 <enumeration value="test"/>

217 </restriction>

218 </simpleType>

219 </attribute>

220 <attribute name="type" type="nonNegativeInteger" default="0"/>

221 </complexType>

222 <complexType name="softwareType">

223 <simpleContent>

224 <extension base="xmitDocuments:stringType1_50">

225 <attribute name="version" type="nonNegativeInteger" use="required"/>

226 </extension>

227 </simpleContent>

228 </complexType>

229 <!-- =======================================================================

230 body data type definitions used for (back)tracking

231 ======================================================================= -->

232 <complexType name="bodyType">

233 <sequence>

234 <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>

235 <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>

236 <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>

237 </sequence>

238 <attribute name="timestamp" type="unsignedLong" use="required"/>

239 <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>

240 <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>

241 </complexType>

242 <!-- =======================================================================

243 reference data type definitions

244 ======================================================================= -->

245 <complexType name="referenceType">

246 <sequence>

247 <element name="patient" type="xmitDocuments:patientAddressType"/>

248 <choice minOccurs="0">

249 <element name="case_credit" type="xmitDocuments:caseSpecificType"/>

250 <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>

251 <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>

252 <element name="case" type="xmitDocuments:caseType"/>

253 </choice>

254 </sequence>

255 </complexType>

256 <!-- =======================================================================

257 case data type definitions

258 ======================================================================= -->

259 <complexType name="caseType">

260 <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>

261 </complexType>

262 <complexType name="caseSpecificType">

263 <complexContent>

264 <extension base="xmitDocuments:caseType">

265 <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>

266 <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>

267 </extension>

268 </complexContent>

269 </complexType>

270 <!-- =======================================================================

271 payload data type definitions

272 ======================================================================= -->

273 <complexType name="payloadType">

274 <sequence>

275 <choice>

276 <element name="transport_intermediate" type="xmitDocuments:transportIntermediateType"/>

277 </choice>

278 <element name="sender" type="xmitDocuments:partyAddressType"/>

279 <element name="recipient" type="xmitDocuments:partyAddressType"/>

280 <element name="subject" type="xmitDocuments:stringType1_100"/>

281 <element name="body" type="xmitDocuments:bodyType"/>

282 </sequence>

283 </complexType>

284 <!-- =======================================================================

285 document(s) data type definitions

286 ======================================================================= -->

287 <complexType name="documentsType">

288 <sequence>

289 <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>

290 </sequence>

291 <attribute name="number" type="unsignedLong" use="required"/>

292 </complexType>

293 <complexType name="documentType">

294 <choice>

295 <element name="data" type="base64Binary"/>

296 <element name="url" type="anyURI"/>

297 </choice>

298 <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>

299 <attribute name="size" type="unsignedLong" use="required"/>

300 <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>

301 <attribute name="viewer" type="anyURI"/>

302 </complexType>

303 <!-- =======================================================================

304 =======================================================================

305 Here starts the request with its root element

306 =======================================================================

307 ======================================================================= -->

308 <element name="transmission" type="xmitDocuments:transmissionType"/>

309 <complexType name="transmissionType">

310 <sequence>

311 <element name="prolog" type="xmitDocuments:prologType"/>

312 <element name="payload" type="xmitDocuments:payloadType"/>

313 <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>

314 </sequence>

315 </complexType>

316 </schema>


xmitDocuments alphabetisch

xmitDocuments_400 0.9 deu
xmitDocuments alphabetisch


 element transmission
Annotation Beginn XML-Dokument

XML-Deklaration inklusive Zeichensatz UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (Erste Zeile im XML-Dokument)

XML-Wurzelelement: xmitDocuments:transmission

- xsi Namensraum: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xmitDocuments Namensraum: xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de"
- Typ: xmit-Documente 4.0
- Ort: xsi schemaLocation="http://www.forum-datenaustausch.ch/de xmitDocuments_400.xsd"

Für alle Elemente gilt der Namensraum "xmitDocuments".
Im XML-Dokument muss für jedes Element dieser Namensraum angegeben werden!

In der vorliegenden Dokumentation wird im Folgenden jeweils nur noch der Elementname aufgeführt, ohne Namensraum, z.B: "transmission" statt "xmitDocuments:transmission".

Für Attribute muss im XML-Dokument kein Namensraum angegeben werden.

Siehe Definition im Schema:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transmissionType
properties
content complex
children | xmitDocuments:prolog xmitDocuments:payload xmitDocuments:documents
source
<element name="transmission" type="xmitDocuments:transmissionType"/>


 complexType bodyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
used by
elements payloadType/body bodyType/tracking
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<complexType name="bodyType">
  <sequence>
    <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>
    <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>
    <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>
  </sequence>
  <attribute name="timestamp" type="unsignedLong" use="required"/>
  <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>
  <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 element bodyType/comment
Annotation Kommentar
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_700
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 700
source
<element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>


 element bodyType/tracking
Annotation Kummunikations-History

Unbegrenztes Tracking.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>


 element bodyType/reference
Annotation Referenz
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:referenceType
properties
isRef | 0
content | complex
children | xmitDocuments:patient xmitDocuments:case_credit xmitDocuments:case_invoice xmitDocuments:case_reminder xmitDocuments:case
source
<element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>


 complexType caseSpecificType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:caseType
properties
base xmitDocuments:caseType
used by
elements referenceType/case_credit referenceType/case_invoice referenceType/case_reminder
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
Extensions
Annotation | Base
Fall | transmission:caseType
source
<complexType name="caseSpecificType">
  <complexContent>
    <extension base="xmitDocuments:caseType">
      <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>
      <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>
    </extension>
  </complexContent>
</complexType>


 complexType caseType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element | referenceType/case
complexType | caseSpecificType
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identifikation
source
<complexType name="caseType">
  <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>
</complexType>


 complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:companyname xmitDocuments:department xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
used by
element partyAddressType/company
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Kontakt
source
<complexType name="companyType">
  <sequence>
    <sequence>
      <element name="companyname" type="xmitDocuments:stringType1_35"/>
      <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>
</complexType>


 element companyType/companyname
Annotation Firmenbezeichnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="xmitDocuments:stringType1_35"/>


 element companyType/department
Annotation Abteilung / Division
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element companyType/postal
Annotation Adresse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>


 element companyType/telecom
Annotation Telecom

Definiert telekommunikatorische Kontaktinformationen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:phone xmitDocuments:fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>


 element companyType/online
Annotation Online

Definiert Informationen zu online-Diensten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:email xmitDocuments:url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>


 complexType documentsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:document
used by
element transmissionType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Dokumentennummer
source
<complexType name="documentsType">
  <sequence>
    <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="number" type="unsignedLong" use="required"/>
</complexType>


 element documentsType/document
Annotation Dokument
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:documentType
properties
isRef | 0
content | complex
children | xmitDocuments:data xmitDocuments:url
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Dokumente Filename
size | Dokumente Grösse
mimeType | Dokumente MIME-Typ
viewer | Viewersoftware
source
<element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>


 complexType documentType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:data xmitDocuments:url
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Dokumente Filename
size | Dokumente Grösse
mimeType | Dokumente MIME-Typ
viewer | Viewersoftware
source
<complexType name="documentType">
  <choice>
    <element name="data" type="base64Binary"/>
    <element name="url" type="anyURI"/>
  </choice>
  <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="size" type="unsignedLong" use="required"/>
  <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="viewer" type="anyURI"/>
</complexType>


 element documentType/data
Annotation Datenblock
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | base64Binary
properties
isRef | 0
content | simple
source
<element name="data" type="base64Binary"/>


 element documentType/url
Annotation URL-Adresse

Bezeichnet eine vollständige URL Adresse, welche zum Zweck der Informationsbeschaffung oder Kontaktaufnahme verwendet werden kann.

Es ist zu beachten, dass der online-Dienst "mailto"eine eMail-Adresse via einen URL bezeichnet.

eMail-Adressen sollten jedoch über das gesonderte Element email abgebildet werden.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | anyURI
properties
isRef | 0
content | simple
source
<element name="url" type="anyURI"/>


 complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:email xmitDocuments:url
used by
elements companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="xmitDocuments:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>


 element onlineAddressType/email
Annotation eMail-Adresse

Bezeichnet eine eMail-Adresse gemäss RFC821.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of xmitDocuments:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="xmitDocuments:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>


 element onlineAddressType/url
Annotation URL-Adresse

Bezeichnet eine vollständige URL Adresse, welche zum Zweck der Informationsbeschaffung oder Kontaktaufnahme verwendet werden kann.

Es ist zu beachten, dass der online-Dienst "mailto"eine eMail-Adresse via einen URL bezeichnet.

eMail-Adressen sollten jedoch über das gesonderte Element email abgebildet werden.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>


 complexType partyAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:company xmitDocuments:person
used by
elements payloadType/recipient payloadType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<complexType name="partyAddressType">
  <choice>
    <element name="company" type="xmitDocuments:companyType"/>
    <element name="person" type="xmitDocuments:personType"/>
  </choice>
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 element partyAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:companyType
properties
isRef | 0
content | complex
children | xmitDocuments:companyname xmitDocuments:department xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Kontakt
source
<element name="company" type="xmitDocuments:companyType"/>


 element partyAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="xmitDocuments:personType"/>


 complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:person
used by
element referenceType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="xmitDocuments:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>
  <attribute name="senderID" type="xmitDocuments:stringType1_35"/>
  <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>
</complexType>


 element patientAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="xmitDocuments:personType"/>


 complexType payloadType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:transport_intermediate xmitDocuments:sender xmitDocuments:recipient xmitDocuments:subject xmitDocuments:body
used by
element transmissionType/payload
source
<complexType name="payloadType">
  <sequence>
    <choice>
      <element name="transport_intermediate" type="xmitDocuments:transportIntermediateType"/>
    </choice>
    <element name="sender" type="xmitDocuments:partyAddressType"/>
    <element name="recipient" type="xmitDocuments:partyAddressType"/>
    <element name="subject" type="xmitDocuments:stringType1_100"/>
    <element name="body" type="xmitDocuments:bodyType"/>
  </sequence>
</complexType>


 element payloadType/transport_intermediate
Annotation Intermediärer Transporteur
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transportIntermediateType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
sender_ean | xmitDocuments:eanPartyType | required |  |
recipient_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
sender_ean | EAN-Nummer des Senders
recipient_ean | EAN-Nummer des intermediären Partners
source
<element name="transport_intermediate" type="xmitDocuments:transportIntermediateType"/>


 element payloadType/sender
Annotation Sender

Bezeichnet den Adressblock mit Angaben des Senders.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:company xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<element name="sender" type="xmitDocuments:partyAddressType"/>


 element payloadType/recipient
Annotation Empfänger

Bezeichnet den Adressblock mit Angaben des Empfängers.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:company xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | EAN-Nummer
source
<element name="recipient" type="xmitDocuments:partyAddressType"/>


 element payloadType/subject
Annotation Kurztitel der Information
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_100
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="subject" type="xmitDocuments:stringType1_100"/>


 element payloadType/body
Annotation Dateninhalt
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | xmitDocuments:comment xmitDocuments:tracking xmitDocuments:reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Erstellungs-Datum und -Uhrzeit
id | Identifikation
sender | Sender
source
<element name="body" type="xmitDocuments:bodyType"/>


 complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:familyname xmitDocuments:givenname xmitDocuments:postal xmitDocuments:telecom xmitDocuments:online
used by
elements partyAddressType/person patientAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<complexType name="personType">
  <sequence>
    <sequence>
      <element name="familyname" type="xmitDocuments:stringType1_35"/>
      <element name="givenname" type="xmitDocuments:stringType1_35"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="xmitDocuments:stringType1_35"/>
  <attribute name="title" type="xmitDocuments:stringType1_35"/>
</complexType>


 element personType/familyname
Annotation Nachname
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="xmitDocuments:stringType1_35"/>


 element personType/givenname
Annotation Vorname

Bezeichnet das Element, in welchem als Dateninhalt der Vor- oder die Zweitnamen einer natürlichen Person angegeben werden.

Das erste gegebene Element wird immer als Vorname gewertet, allfällig weitere Elemente als Zweitnamen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="xmitDocuments:stringType1_35"/>


 element personType/postal
Annotation Adresse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>


 element personType/telecom
Annotation Telecom

Definiert telekommunikatorische Kontaktinformationen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:phone xmitDocuments:fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>


 element personType/online
Annotation Online

Definiert Informationen zu online-Diensten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:email xmitDocuments:url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>


 complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:pobox xmitDocuments:street xmitDocuments:zip xmitDocuments:city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="zip" type="xmitDocuments:zipType"/>
    <element name="city" type="xmitDocuments:stringType1_35"/>
  </sequence>
</complexType>


 element postalAddressType/pobox
Annotation Postfach
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element postalAddressType/street
Annotation Strasse
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element postalAddressType/zip
Annotation PLZ
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Kanton
countrycode | Land (ISO Ländercode)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<element name="zip" type="xmitDocuments:zipType"/>


 element postalAddressType/city
Annotation Ort
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="xmitDocuments:stringType1_35"/>


 complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:package xmitDocuments:generator
used by
element transmissionType/prolog
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Testkennzeichnung Bezeichnet den Typ resp. die Rolle im Sinne eines produktiven Datensatzes oder eines Testdatensatzes.
type | Softwaretypenbezeichnung
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Produktionsnachricht
role |  | NMTOKEN | test | Testnachricht
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>
    <element name="generator" type="xmitDocuments:softwareType"/>
  </sequence>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="type" type="nonNegativeInteger" default="0"/>
</complexType>


 element prologType/package
Annotation Branchenapplikation

Enthält Informationen bez. der übergeordneten Branchenapplikation, welche zur Dokumentenerstellung verwendet wird. Als Dateninhalt dieses Elements wird der Name der Branchenapplikation angegeben.

Werden Angaben zur Branchenapplikation geliefert, muss der Name aufgeführt sein.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
source
<element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>


 element prologType/generator
Annotation Name des Softwaregenerators
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
source
<element name="generator" type="xmitDocuments:softwareType"/>


 complexType referenceType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:patient xmitDocuments:case_credit xmitDocuments:case_invoice xmitDocuments:case_reminder xmitDocuments:case
used by
element bodyType/reference
source
<complexType name="referenceType">
  <sequence>
    <element name="patient" type="xmitDocuments:patientAddressType"/>
    <choice minOccurs="0">
      <element name="case_credit" type="xmitDocuments:caseSpecificType"/>
      <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>
      <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>
      <element name="case" type="xmitDocuments:caseType"/>
    </choice>
  </sequence>
</complexType>


 element referenceType/patient
Annotation Patient

Bezeichnet den Adressblock mit Angaben des Patienten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:patientAddressType
properties
isRef | 0
content | complex
children | xmitDocuments:person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<element name="patient" type="xmitDocuments:patientAddressType"/>


 element referenceType/case_credit
Annotation Betrifft Kostengutsprache
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_credit" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case_invoice
Annotation Betrifft Rechnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_invoice" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case_reminder
Annotation Betrifft Mahnung
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
id | Identifikation
request_timestamp | Datum und -Uhrzeit
provider_ean | EAN-Nummer des Leistungserbringers
source
<element name="case_reminder" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case
Annotation Fall
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:caseType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identifikation
Extensions
Annotation | Base
Fall | transmission:caseType
source
<element name="case" type="xmitDocuments:caseType"/>


 complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_50
properties
base xmitDocuments:stringType1_50
used by
elements prologType/generator prologType/package
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version der Generator-Software/Branchenapplikation Versionsnummer der verwendeten Generator-Software/Branchenapplikation. Dabei wird die Version als Ganzzahl codiert nach folgendem Schema angegeben: - version = int(100*x+y). - x = Hauptversionsnummer (major version) - y = Nebenversionsnummer (minor version)
Extensions
Annotation | Base
Software | transmission:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_50">
      <attribute name="version" type="nonNegativeInteger" use="required"/>
    </extension>
  </simpleContent>
</complexType>


 complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:phone xmitDocuments:fax
used by
elements companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>


 element telecomAddressType/phone
Annotation Telefon-Nummer

Festanschluss- oder Mobil-Telefonnummer
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>


 element telecomAddressType/fax
Annotation Fax-Nummer
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>


 complexType transmissionType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | xmitDocuments:prolog xmitDocuments:payload xmitDocuments:documents
used by
element transmission
source
<complexType name="transmissionType">
  <sequence>
    <element name="prolog" type="xmitDocuments:prologType"/>
    <element name="payload" type="xmitDocuments:payloadType"/>
    <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>
  </sequence>
</complexType>


 element transmissionType/prolog
Annotation Prolog

Block mit Informationen über:

- das übergeordnete Software-Packet (Branchenapplikation)
- den Generator, welcher die entsprechenden XML Strukturen generiert und validiert hat
- die verwendeten Daten-Validatoren
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:prologType
properties
isRef | 0
content | complex
children | xmitDocuments:package xmitDocuments:generator
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Testkennzeichnung Bezeichnet den Typ resp. die Rolle im Sinne eines produktiven Datensatzes oder eines Testdatensatzes.
type | Softwaretypenbezeichnung
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Produktionsnachricht
role |  | NMTOKEN | test | Testnachricht
source
<element name="prolog" type="xmitDocuments:prologType"/>


 element transmissionType/payload
Annotation Datenpacket
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:payloadType
properties
isRef | 0
content | complex
children | xmitDocuments:transport_intermediate xmitDocuments:sender xmitDocuments:recipient xmitDocuments:subject xmitDocuments:body
source
<element name="payload" type="xmitDocuments:payloadType"/>


 element transmissionType/documents
Annotation Dokumente
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:documentsType
properties
isRef | 0
content | complex
children | xmitDocuments:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Dokumentennummer
source
<element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>


 complexType transportIntermediateType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element payloadType/transport_intermediate
attributes parameters
Name | Type | Use | Default | Fixed
sender_ean | xmitDocuments:eanPartyType | required |  |
recipient_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
sender_ean | EAN-Nummer des Senders
recipient_ean | EAN-Nummer des intermediären Partners
source
<complexType name="transportIntermediateType">
  <attribute name="sender_ean" type="xmitDocuments:eanPartyType" use="required"/>
  <attribute name="recipient_ean" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_9
properties
base xmitDocuments:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Kanton
countrycode | Land (ISO Ländercode)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_9">
      <attribute name="statecode" type="xmitDocuments:stringType1_9"/>
      <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>


 simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes partyAddressType/@ean_party caseSpecificType/@provider_ean transportIntermediateType/@recipient_ean bodyType/@sender transportIntermediateType/@sender_ean
facets
pattern ([0-9]{13})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="([0-9]{13})"/>
  </restriction>
</simpleType>


 simpleType nonEmptyStringType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes companyType/@contact documentType/@filename documentType/@mimeType
facets
minLength 1
source
<simpleType name="nonEmptyStringType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>


 simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}|unknown
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>
  </restriction>
</simpleType>


 simpleType stringType1_100
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element | payloadType/subject
attribute | caseType/@id
facets
minLength | 1
maxLength | 100
source
<simpleType name="stringType1_100">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="100"/>
  </restriction>
</simpleType>


 simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>


 simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>


 simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | bodyType/@id patientAddressType/@recipientID personType/@salutation patientAddressType/@senderID personType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>


 simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType softwareType
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>


 simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>


 simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element bodyType/comment
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>


 simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>


xmitDocuments hierarchisch

xmitDocuments_400 0.9 deu
xmitDocuments hierarchisch

muss - Element
kann - Element
entweder/oder - Element


 complexType contactAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:person credit:employee credit:company
used by
element creditType/contact
source
<complexType name="contactAddressType">
  <choice>
    <element name="person" type="credit:personType"/>
    <sequence>
      <element name="employee" type="credit:employeeType"/>
      <element name="company" type="credit:companyType"/>
    </sequence>
  </choice>
</complexType>


 complexType costsType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements | kvgLawType/costs uvgLawType/costs ivgLawType/costs mvgLawType/costs kvgLawType/total_costs vvgLawType/total_costs uvgLawType/total_costs ivgLawType/total_costs mvgLawType/total_costs
complexType | xndCostsType
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<complexType name="costsType">
  <attribute name="amount" type="credit:amountType"/>
  <attribute name="currency" type="string" fixed="CHF"/>
</complexType>


 complexType creditType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:requestor credit:contact credit:provider credit:patient credit:referrer credit:treating_person credit:family_doctor credit:sponsor credit:employer credit:detail
used by
element requestType/credit
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
resend_number | unsignedLong |  | 0 |
resend_date | dateTime |  |  |
copy | boolean |  | false |
type |  |  | new |
attributes annotations
Name Notes
source
<complexType name="creditType">
  <sequence>
    <element name="requestor" type="credit:requestorAddressType"/>
    <element name="contact" type="credit:contactAddressType"/>
    <element name="provider" type="credit:providerAddressType"/>
    <element name="patient" type="credit:patientAddressType"/>
    <element name="referrer" type="credit:referrerAddressType" minOccurs="0"/>
    <element name="treating_person" type="credit:referrerAddressType" minOccurs="0"/>
    <element name="family_doctor" type="credit:referrerAddressType" minOccurs="0"/>
    <sequence maxOccurs="4">
      <element name="sponsor" type="credit:sponsorType"/>
    </sequence>
    <element name="employer" type="credit:employerAddressType" minOccurs="0"/>
    <element name="detail" type="credit:detailType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong" use="required"/>
  <attribute name="credit_id" type="credit:stringType1_35" use="required"/>
  <attribute name="credit_date" type="dateTime" use="required"/>
  <attribute name="resend_number" type="unsignedLong" default="0"/>
  <attribute name="resend_date" type="dateTime"/>
  <attribute name="copy" type="boolean" default="false"/>
  <attribute name="type" default="new">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 complexType detailType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:diagnosis credit:therapy credit:functional_deficits credit:accompanying_affections credit:treatment_goals credit:remark
used by
element creditType/detail
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
date_end | dateTime | required |  |
days | duration | required |  |
treatment_canton |  | required |  |
treatment_type |  | required |  |
reason |  | required |  |
hospitalization_type |  | required |  |
hospitalization_mode |  | required |  |
section_major | credit:stringType1_6 |  |  |
section_name | credit:stringType1_35 |  |  |
relapse | boolean |  | false |
attributes annotations
Name Notes
source
<complexType name="detailType">
  <sequence>
    <element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>
    <element name="therapy" type="credit:therapyType" minOccurs="0" maxOccurs="unbounded"/>
    <element name="functional_deficits" type="string" minOccurs="0"/>
    <element name="accompanying_affections" type="string" minOccurs="0"/>
    <element name="treatment_goals" type="string" minOccurs="0"/>
    <element name="remark" type="string" minOccurs="0"/>
  </sequence>
  <attribute name="date_begin" type="dateTime" use="required"/>
  <attribute name="date_end" type="dateTime" use="required"/>
  <attribute name="days" type="duration" use="required"/>
  <attribute name="treatment_canton" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="AG"/>
        <enumeration value="AI"/>
        <enumeration value="AR"/>
        <enumeration value="BE"/>
        <enumeration value="BL"/>
        <enumeration value="BS"/>
        <enumeration value="FR"/>
        <enumeration value="GE"/>
        <enumeration value="GL"/>
        <enumeration value="GR"/>
        <enumeration value="JU"/>
        <enumeration value="LU"/>
        <enumeration value="NE"/>
        <enumeration value="NW"/>
        <enumeration value="OW"/>
        <enumeration value="SG"/>
        <enumeration value="SH"/>
        <enumeration value="SO"/>
        <enumeration value="SZ"/>
        <enumeration value="TI"/>
        <enumeration value="TG"/>
        <enumeration value="UR"/>
        <enumeration value="VD"/>
        <enumeration value="VS"/>
        <enumeration value="ZG"/>
        <enumeration value="ZH"/>
        <enumeration value="LI"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="treatment_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="ambulatory"/>
        <enumeration value="semi_stationary"/>
        <enumeration value="stationary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="reason" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="disease"/>
        <enumeration value="accident"/>
        <enumeration value="maternity"/>
        <enumeration value="prevention"/>
        <enumeration value="birthdefect"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="hospitalization_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="regular"/>
        <enumeration value="emergency"/>
        <enumeration value="welfare"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="hospitalization_mode" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="cantonal"/>
        <enumeration value="noncantonal_indicated"/>
        <enumeration value="noncantonal_nonindicated"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="section_major" type="credit:stringType1_6"/>
  <attribute name="section_name" type="credit:stringType1_35"/>
  <attribute name="relapse" type="boolean" default="false"/>
</complexType>


 complexType diagnosisType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType0_350
properties
base credit:stringType0_350
used by
element detailType/diagnosis
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<complexType name="diagnosisType">
  <simpleContent>
    <extension base="credit:stringType0_350">
      <attribute name="type" default="by_contract">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="ICD10"/>
            <enumeration value="DRG"/>
            <enumeration value="by_contract"/>
            <enumeration value="freetext"/>
            <enumeration value="birthdefect"/>
            <enumeration value="ICPC"/>
          </restriction>
        </simpleType>
      </attribute>
      <attribute name="code" type="credit:stringType1_12"/>
    </extension>
  </simpleContent>
</complexType>


 complexType employeeType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:familyname credit:givenname
used by
element contactAddressType/employee
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="employeeType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>


 complexType employerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/employer
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="employerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType"/>
  <attribute name="reg_number" type="credit:stringType1_35"/>
</complexType>


 complexType headerPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element headerType/intermediate
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="headerPartyType">
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>


 complexType headerType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:sender credit:intermediate credit:recipient
used by
element requestType/header
source
<complexType name="headerType">
  <sequence>
    <element name="sender" type="credit:xtendHeaderPartyType"/>
    <element name="intermediate" type="credit:headerPartyType"/>
    <element name="recipient" type="credit:xtendHeaderPartyType"/>
  </sequence>
</complexType>


 complexType insuranceAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company
used by
element sponsorType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="insuranceAddressType">
  <sequence>
    <element name="company" type="credit:companyType"/>
  </sequence>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>


 complexType ivgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="ivgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="case_id" use="required">
    <simpleType>
      <restriction base="string">
        <pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType" use="required"/>
  <attribute name="nif" type="credit:nifPartyType" use="required"/>
</complexType>


 complexType kvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="kvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType mvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="mvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType providerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<complexType name="providerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType" use="required"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 complexType referrerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
elements creditType/family_doctor creditType/referrer creditType/treating_person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="referrerAddressType">
  <choice minOccurs="0">
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:xtendEanPartyType" default="unknown"/>
  <attribute name="zsr" type="credit:zsrPartyType"/>
</complexType>


 complexType requestorAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/requestor
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<complexType name="requestorAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 complexType requestType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:header credit:prolog credit:credit
used by
element request
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name Notes
source
<complexType name="requestType">
  <sequence>
    <element name="header" type="credit:headerType"/>
    <element name="prolog" type="credit:prologType"/>
    <element name="credit" type="credit:creditType"/>
  </sequence>
  <attribute name="assignment_role" fixed="physician"/>
  <attribute name="assignment_place" fixed="hospital"/>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 complexType sponsorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:insurance credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg
used by
element creditType/sponsor
attributes parameters
Name | Type | Use | Default | Fixed
is_recipient | boolean |  | false |
attributes annotations
Name Notes
source
<complexType name="sponsorType">
  <sequence>
    <element name="insurance" type="credit:insuranceAddressType"/>
    <choice>
      <element name="kvg" type="credit:kvgLawType"/>
      <element name="vvg" type="credit:vvgLawType"/>
      <element name="uvg" type="credit:uvgLawType"/>
      <element name="ivg" type="credit:ivgLawType"/>
      <element name="mvg" type="credit:mvgLawType"/>
    </choice>
  </sequence>
  <attribute name="is_recipient" type="boolean" default="false"/>
</complexType>


 complexType therapyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType0_350
properties
base credit:stringType0_350
used by
element detailType/therapy
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<complexType name="therapyType">
  <simpleContent>
    <extension base="credit:stringType0_350">
      <attribute name="type" default="by_contract">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="CHOP"/>
            <enumeration value="by_contract"/>
            <enumeration value="freetext"/>
          </restriction>
        </simpleType>
      </attribute>
      <attribute name="code" type="credit:stringType1_12"/>
    </extension>
  </simpleContent>
</complexType>


 complexType uvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="uvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType vvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:medical_costs credit:treatment_costs credit:total_costs
used by
element sponsorType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="vvgLawType">
  <sequence>
    <element name="medical_costs" type="credit:xndCostsType"/>
    <element name="treatment_costs" type="credit:xndCostsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType xndCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements vvgLawType/medical_costs vvgLawType/treatment_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<complexType name="xndCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="class">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="private"/>
            <enumeration value="semi_private"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </complexContent>
</complexType>


 complexType xtendHeaderPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements headerType/recipient headerType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="xtendHeaderPartyType">
  <attribute name="ean_party" type="credit:xtendEanPartyType" use="required"/>
</complexType>


 element contactAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element contactAddressType/employee
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:employeeType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="employee" type="credit:employeeType"/>


 element contactAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element creditType/contact
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | credit:person credit:employee credit:company
source
<element name="contact" type="credit:contactAddressType"/>


 element creditType/detail
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:detailType
properties
isRef | 0
content | complex
children | credit:diagnosis credit:therapy credit:functional_deficits credit:accompanying_affections credit:treatment_goals credit:remark
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
date_end | dateTime | required |  |
days | duration | required |  |
treatment_canton |  | required |  |
treatment_type |  | required |  |
reason |  | required |  |
hospitalization_type |  | required |  |
hospitalization_mode |  | required |  |
section_major | credit:stringType1_6 |  |  |
section_name | credit:stringType1_35 |  |  |
relapse | boolean |  | false |
attributes annotations
Name Notes
source
<element name="detail" type="credit:detailType"/>


 element creditType/employer
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:employerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="employer" type="credit:employerAddressType" minOccurs="0"/>


 element creditType/family_doctor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="family_doctor" type="credit:referrerAddressType" minOccurs="0"/>


 element creditType/patient
Annotation Patient

Bezeichnet den Adressblock mit Angaben des Patienten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:patientAddressType
properties
isRef | 0
content | complex
children | credit:person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<element name="patient" type="credit:patientAddressType"/>


 element creditType/provider
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:providerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<element name="provider" type="credit:providerAddressType"/>


 element creditType/referrer
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="referrer" type="credit:referrerAddressType" minOccurs="0"/>


 element creditType/requestor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:requestorAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<element name="requestor" type="credit:requestorAddressType"/>


 element creditType/sponsor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:sponsorType
properties
isRef | 0
content | complex
children | credit:insurance credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg
attributes parameters
Name | Type | Use | Default | Fixed
is_recipient | boolean |  | false |
attributes annotations
Name Notes
source
<element name="sponsor" type="credit:sponsorType"/>


 element creditType/treating_person
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="treating_person" type="credit:referrerAddressType" minOccurs="0"/>


 element detailType/accompanying_affections
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="accompanying_affections" type="string" minOccurs="0"/>


 element detailType/diagnosis
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:diagnosisType
properties
isRef | 0
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>


 element detailType/functional_deficits
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="functional_deficits" type="string" minOccurs="0"/>


 element detailType/remark
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="remark" type="string" minOccurs="0"/>


 element detailType/therapy
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:therapyType
properties
isRef | 0
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<element name="therapy" type="credit:therapyType" minOccurs="0" maxOccurs="unbounded"/>


 element detailType/treatment_goals
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="treatment_goals" type="string" minOccurs="0"/>


 element employeeType/familyname
Annotation Nachname
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>


 element employeeType/givenname
Annotation Vorname

Bezeichnet das Element, in welchem als Dateninhalt der Vor- oder die Zweitnamen einer natürlichen Person angegeben werden.

Das erste gegebene Element wird immer als Vorname gewertet, allfällig weitere Elemente als Zweitnamen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>


 element employerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element employerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element headerType/intermediate
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:headerPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="intermediate" type="credit:headerPartyType"/>


 element headerType/recipient
Annotation Empfänger

Bezeichnet den Adressblock mit Angaben des Empfängers.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="recipient" type="credit:xtendHeaderPartyType"/>


 element headerType/sender
Annotation Sender

Bezeichnet den Adressblock mit Angaben des Senders.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="sender" type="credit:xtendHeaderPartyType"/>


 element insuranceAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element ivgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element ivgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element kvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element kvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element mvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element mvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element providerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element providerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element referrerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element referrerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element request
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:requestType
properties
content complex
children | credit:header credit:prolog credit:credit
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name Notes
source
<element name="request" type="credit:requestType"/>


 element requestorAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element requestorAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element requestType/credit
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:creditType
properties
isRef | 0
content | complex
children | credit:requestor credit:contact credit:provider credit:patient credit:referrer credit:treating_person credit:family_doctor credit:sponsor credit:employer credit:detail
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
resend_number | unsignedLong |  | 0 |
resend_date | dateTime |  |  |
copy | boolean |  | false |
type |  |  | new |
attributes annotations
Name Notes
source
<element name="credit" type="credit:creditType"/>


 element requestType/header
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:headerType
properties
isRef | 0
content | complex
children | credit:sender credit:intermediate credit:recipient
source
<element name="header" type="credit:headerType"/>


 element requestType/prolog
Annotation Prolog

Block mit Informationen über:

- das übergeordnete Software-Packet (Branchenapplikation)
- den Generator, welcher die entsprechenden XML Strukturen generiert und validiert hat
- die verwendeten Daten-Validatoren
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:prologType
properties
isRef | 0
content | complex
children | credit:package credit:generator
source
<element name="prolog" type="credit:prologType"/>


 element sponsorType/insurance
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:insuranceAddressType
properties
isRef | 0
content | complex
children | credit:company
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="insurance" type="credit:insuranceAddressType"/>


 element sponsorType/ivg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:ivgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name Notes
source
<element name="ivg" type="credit:ivgLawType"/>


 element sponsorType/kvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:kvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="kvg" type="credit:kvgLawType"/>


 element sponsorType/mvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:mvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<element name="mvg" type="credit:mvgLawType"/>


 element sponsorType/uvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:uvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<element name="uvg" type="credit:uvgLawType"/>


 element sponsorType/vvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:vvgLawType
properties
isRef | 0
content | complex
children | credit:medical_costs credit:treatment_costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="vvg" type="credit:vvgLawType"/>


 element uvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element uvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element vvgLawType/medical_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<element name="medical_costs" type="credit:xndCostsType"/>


 element vvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element vvgLawType/treatment_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<element name="treatment_costs" type="credit:xndCostsType"/>


 simpleType amountType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of double
used by
attribute costsType/@amount
facets
minInclusive 0
source
<simpleType name="amountType">
  <restriction base="double">
    <minInclusive value="0"/>
  </restriction>
</simpleType>


 simpleType nifPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source
<simpleType name="nifPartyType">
  <restriction base="string">
    <pattern value="[0-9]{1,7}"/>
  </restriction>
</simpleType>


 simpleType stringType0_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexTypes diagnosisType therapyType
facets
maxLength 350
source
<simpleType name="stringType0_350">
  <restriction base="string">
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType stringType1_6
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute detailType/@section_major
facets
minLength | 1
maxLength | 6
source
<simpleType name="stringType1_6">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="6"/>
  </restriction>
</simpleType>


 simpleType stringType1_12
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes diagnosisType/@code therapyType/@code
facets
minLength | 1
maxLength | 12
source
<simpleType name="stringType1_12">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="12"/>
  </restriction>
</simpleType>


 simpleType stringType1_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes requestorAddressType/@specialty providerAddressType/@specialty
facets
minLength | 1
maxLength | 350
source
<simpleType name="stringType1_350">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType unionPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | union of ( credit:xtendEanPartyType , credit:zsrPartyType )
source
<simpleType name="unionPartyType">
  <union memberTypes="credit:xtendEanPartyType credit:zsrPartyType"/>
</simpleType>


 simpleType xtendEanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attributes | referrerAddressType/@ean_party xtendHeaderPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11}|unknown)
source
<simpleType name="xtendEanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>
  </restriction>
</simpleType>


 simpleType zsrPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attributes | requestorAddressType/@zsr providerAddressType/@zsr referrerAddressType/@zsr
facets
pattern ([A-Z][0-9]{6}|[0-9]{6}[A-Z])
source
<simpleType name="zsrPartyType">
  <restriction base="string">
    <pattern value="([A-Z][0-9]{6}|[0-9]{6}[A-Z])"/>
  </restriction>
</simpleType>