Browser XML - xmitDocuments

Version 4.10

Réalisez par le Forum pour l'échange des données

Le contenu, la présentation et le logiciel ne peuvent être modifiés sans la permission expresse du Forum pour l'échange des données.

En décembre 2005.


Manuel de référence xmit-documents

xmitDocuments_410 fra

Manuel de référence xmit-documents


© - copyright

xmitDocuments_410 fra

© - copyright
Standard de facturation dans le domaine de la santé publique suisse
Manuel de référence: xmit-documents release 4.10
xmitDocuments_410.xsd
Date: 6.12.2005

© - copyright: Le Forum pour l'échange des données. Tous droits réservés.
Ce document peut être copié et distribué à volonté, pour autant que sa forme reste inchangée et que la reproduction et la diffusion s'effectuent à des fins non commerciales.
Les mêmes conditions s'appliquent à tous les fichiers de schéma XML référencés dans ce document.
Toutefois, le Forum pour l'échange des données décline toute responsabilité quant à l'actualité et à l'exactitude du contenu.


Forum Datenaustausch

xmitDocuments_410 fra

Forum Datenaustausch

Dans Forum Datenaustausch, différents acteurs du domaine de la santé publique suisse se sont associés. Entre autre, le but que poursuit le Forum est de fixer les standards développés en commun pour l'échange électronique des données.

Les membres du Forum sont les associations des fournisseurs de prestations H+, ainsi que Société Suisse des Pharmaciens (SSPh). Du côté des répondants des coûts il s'agit de santé suisse, de l'Association suisse des assureurs (ASA), de la Suva, de l'Office fédéral pour l'Assurance militaire (OFAM) et de l'Assurance-invalidité (AI).

Les standards approuvés par le Forum comme les communications XML pour l'échange électronique des données sont publiés sur

www.forum-datenaustausch.ch

publié. En font également partie les décomptes électroniques de prestations pour les médecins, basés sur XML.

Les tâches du Forum consistent dans l'accord de buts stratégiques, la négociation au niveau politique, ainsi qu'en des pourparlers contractuels. L'organe compétent représenté par les mêmes acteurs, comme le Forum lui-même, est subordonné au Forum.

Les tâches de l'organe compétent comprennent:

- Réalisation des buts fixés
- Négociation à l'échelon compétent (coordination et communication avec les acteurs)
- Réalisation d'organisations et consultations

Le présent xmit-document a été élaboré et définie par les membres de l'organe compétent, ainsi qu'approuvée par le Forum Datenaustausch.


Types de données XML

xmitDocuments_410 fra

Types de données XML

Le tableau ci-dessous décrit le format des types de données les plus importants dans le 'schemafile' (xmitDocuments_410.xsd):

Nom | Description
anyURI | anyURI désigne tout URI valable selon RFC 2396 resp. RFC 2732.
boolean | Est le type de données booléen qui peut prendre les valeurs {true|false|1|0}. Dans ce contexte et comme c'est usuel dans les langages de programmation séquentiels, 0 signifie false et 1 true.
dateTime | dateTime représente un moment temporel spécifié de manière précise, la zone des valeurs de dateTime étant formée d'une combinaison de la date et de l'heure selon ISO 8601. Par exemple, le code de 13:20h en date du 31.5.1999 serait "1999-05-31T13:20:00". Attention: Si lors de l'indication d'une date, l'heure ne joue aucun rôle, c'est 00:00:00h qui doit être indiqué comme heure. Exemple: "1999-05-31T00:00:00". Si une date doit être livrée avec une indication de temps, cela est réglementé dans les contrats (tarifs-/ contrats-cadre).
double | Est un type numérique de virgule flottante selon la définition IEEE double precision 64-bit floating point (IEEE 754-1985).
duration | duration représente un intervalle de temps. La zone des valeurs de duration pouvant être formée à la seconde près selon ISO 8601.
enumeration | enumeration définit une quantité limitée de valeurs fixées parmi lesquelles un élément doit être choisi, p. ex. {1|2|3}.
long | Est un type numérique de nombre entier (64-bit) avec la barrière supérieure 9223372036854775807 et la barrière inférieure -9223372036854775808.
NMTOKEN | Un NMTOKEN est une séquence d'une ou de plusieurs lettres, chiffres et quelques symboles de ponctuation.
pattern | pattern désigne un "modèle" prédéfini. La syntaxe de pattern est indiquée comme grep pattern selon Perl 5 Implementation.
string | string représente le type de données character string en XML. La zone des valeurs de string est une séquence limitée de caractères.

Les standards ISO mentionnés se trouvent en partie sur 'www.w3c.org'. En tout cas, les standards ISO peuvent être commandés sous 'www.iso.ch'.

Les documents RFC de l'IETF (Internet Engineering Task Force) sont disponibles en ligne sous www.ietf.org.


Jeu de caractères

xmitDocuments_410 fra

Jeu de caractères

Der für die XML-Rechnung zu verwendende Zeichensatz ist Unicode UTF-8.

Quelques signes ne peuvent pas être utilisés dans le texte d'un document XML parce qu'ils peuvent entrer en conflit avec des séparateurs markup spéciaux. < ou & ne peuvent être écrits directement dans un document XML que pour introduire un 'tag' ou une 'entity'.

Afin que la signification des signes suivants soit univoque dans le texte d'un document XML, il est recommandé de les représenter par les entités de caractères prédéfinies:

& | = | &amp
' | = | &apos
> | = | &gt
< | = | &lt
" | = | &quot

Exemples pour une ligne de codage BVR:

0100000121403>016291414110116441140576999+ 010370058> | =
<invoice:esr9 coding_line="0100000121403&gt;016291414110116441140576999+010370058&gt;"/> |
<080001000000500> 473434028588301+ 11218> | =
<invoice:esr5 coding_line="&lt;080001000000500&gt;473434028588301+ 11218&gt;"/> |


Schéma des xmit-documents

xmitDocuments_410 fra
Schéma des xmit-documents


 Schema xmitDocuments_410.xsd
attribute form default: | unqualified
element form default: | unqualified
targetNamespace: | http://www.forum-datenaustausch.ch/de
Elements | Complex types | Simple types
transmission | bodyType | eanPartyType
 | caseSpecificType | nonEmptyStringType
 | caseType | ssnPartyType
 | companyType | stringType1_100
 | documentsType | stringType1_25
 | documentType | stringType1_3
 | headerPartyType | stringType1_35
 | headerType | stringType1_50
 | onlineAddressType | stringType1_70
 | partyAddressType | stringType1_700
 | patientAddressType | stringType1_9
 | payloadType | xtendEanPartyType
 | personType |
 | postalAddressType |
 | prologType |
 | referenceType |
 | softwareType |
 | telecomAddressType |
 | transmissionType |
 | xtendHeaderPartyType |
 | zipType |

element transmission
Annotation Début du document XML

Déclaration XML, y compris jeu de caractères UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (première ligne dans le document XML)

Elément racine: xmitDocuments:transmission

- XML Espace nominal xsi: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- Espace nominal xmitDocuments: xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de"
- Type: xmit-documents 4.1
- Lieu: xsi :schemaLocation="http://www.forum-datenaustausch.ch/de xmitDocuments_410.xsd"

L'espace nominal pour tous les éléments est "xmitDocuments".
Dans le document XML, cet espace nominal doit être indiqué pour chaque élément!

Parla suite, la présente documentation ne fera état plus que du nom de l'élément, sans espace nominal, p. ex: "transmission" au lieu de "xmitDocuments:transmission".

Pour les attributs, il n'est pas nécessaire d'indiquer un espace nominal dans le document XML.

Voir définition dans le schéma:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transmissionType
properties
content complex
children | header prolog payload documents
source
<element name="transmission" type="xmitDocuments:transmissionType"/>

complexType bodyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | comment tracking reference
used by
elements payloadType/body bodyType/tracking
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<complexType name="bodyType">
  <sequence>
    <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>
    <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>
    <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>
  </sequence>
  <attribute name="timestamp" type="unsignedLong" use="required"/>
  <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>
  <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

element bodyType/comment
Annotation Commentaire
diagram
type xmitDocuments:stringType1_700
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 700
source
<element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>

element bodyType/tracking
Annotation History communication Tracking illimité
diagram
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | comment tracking reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>

element bodyType/reference
Annotation Référence
diagram
type | xmitDocuments:referenceType
properties
isRef | 0
content | complex
children | patient case_credit case_invoice case_reminder case
source
<element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>

complexType caseSpecificType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:caseType
properties
base xmitDocuments:caseType
used by
elements referenceType/case_credit referenceType/case_invoice referenceType/case_reminder
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
Extensions
Annotation | Base
Cas | transmission:caseType
source
<complexType name="caseSpecificType">
  <complexContent>
    <extension base="xmitDocuments:caseType">
      <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>
      <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>
    </extension>
  </complexContent>
</complexType>

complexType caseType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element | referenceType/case
complexType | caseSpecificType
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identification
source
<complexType name="caseType">
  <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>
</complexType>

complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | companyname department postal telecom online
used by
element partyAddressType/company
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Contact
source
<complexType name="companyType">
  <sequence>
    <sequence>
      <element name="companyname" type="xmitDocuments:stringType1_35"/>
      <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>
</complexType>

element companyType/companyname
Annotation Désignation de l'entreprise
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="xmitDocuments:stringType1_35"/>

element companyType/department
Annotation Service / Division
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element companyType/postal
Annotation Adresse
diagram
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>

element companyType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

element companyType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

complexType documentsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | document
used by
element transmissionType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Numéro de document
source
<complexType name="documentsType">
  <sequence>
    <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="number" type="unsignedLong" use="required"/>
</complexType>

element documentsType/document
Annotation Document
diagram
type | xmitDocuments:documentType
properties
isRef | 0
content | complex
children | data url
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Nom de fichier des documents
size | Taille documents
mimeType | Documents de type MIME
viewer | Viewersoftware
source
<element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>

complexType documentType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | data url
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Nom de fichier des documents
size | Taille documents
mimeType | Documents de type MIME
viewer | Viewersoftware
source
<complexType name="documentType">
  <choice>
    <element name="data" type="base64Binary"/>
    <element name="url" type="anyURI"/>
  </choice>
  <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="size" type="unsignedLong" use="required"/>
  <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="viewer" type="anyURI"/>
</complexType>

element documentType/data
Annotation Le bloc de données
diagram
type base64Binary
properties
isRef | 0
content | simple
source
<element name="data" type="base64Binary"/>

element documentType/url
Annotation Adresse URL

Désigne une adresse URL complète qui peut être utilisée à des fins d'information ou de prise de contact.
diagram
type anyURI
properties
isRef | 0
content | simple
source
<element name="url" type="anyURI"/>

complexType headerPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element headerType/intermediate
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="headerPartyType">
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

complexType headerType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender intermediate recipient
used by
element transmissionType/header
source
<complexType name="headerType">
  <sequence>
    <element name="sender" type="xmitDocuments:xtendHeaderPartyType"/>
    <element name="intermediate" type="xmitDocuments:headerPartyType"/>
    <element name="recipient" type="xmitDocuments:xtendHeaderPartyType"/>
  </sequence>
</complexType>

element headerType/sender
Annotation Expéditeur de la facture (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie le destinataire final de la facture par le biais d'un numéro EAN univoque.
diagram
type xmitDocuments:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="sender" type="xmitDocuments:xtendHeaderPartyType"/>

element headerType/intermediate
Annotation Intermédiaire de la facture (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie par le biais d'un numéro EAN l'institution intermédiaire (clearing center) qui est responsable de la gestion administrative et fait office d'intermédiaire entre le fournisseur de prestations / factureur et le répondant des coûts.

Si la facture est envoyée par le fournisseur de prestations / factureur directement au répondant des coûts, il y aura lieu d'indiquer ici le numéro EAN du répondant des coûts.

Dans ce cas, le répondant des coûts assume les tâches de l'intermédiaire.
diagram
type xmitDocuments:headerPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="intermediate" type="xmitDocuments:headerPartyType"/>

element headerType/recipient
Annotation

diagram
type xmitDocuments:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="recipient" type="xmitDocuments:xtendHeaderPartyType"/>

complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | email url
used by
elements companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="xmitDocuments:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>

element onlineAddressType/email
Annotation Adresse e-mail

Désigne une adresse e-mail selon RFC821.
diagram
type restriction of xmitDocuments:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="xmitDocuments:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>

element onlineAddressType/url
Annotation Adresse URL

Désigne une adresse URL complète qui peut être utilisée à des fins d'information ou de prise de contact.
diagram
type restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>

complexType partyAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
elements payloadType/recipient payloadType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<complexType name="partyAddressType">
  <choice>
    <element name="company" type="xmitDocuments:companyType"/>
    <element name="person" type="xmitDocuments:personType"/>
  </choice>
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>

element partyAddressType/company
Annotation Adresse d'une entreprise / institution en qualité de factureur
diagram
type | xmitDocuments:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Contact
source
<element name="company" type="xmitDocuments:companyType"/>

element partyAddressType/person
Annotation Adresse d'une personne en qualité de factureur
diagram
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="xmitDocuments:personType"/>

complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person
used by
element referenceType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
senderID | Identification du patient ou du cas de l'expéditeur par ex. numéro de patient ou numéro de cas du fournisseur de prestations
recipientID | Identification de l'assuré ou de l'accident du destinataire par ex. numéro d'assuré ou numéro d'accident du répondant des coûts
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="xmitDocuments:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>
  <attribute name="senderID" type="xmitDocuments:stringType1_35"/>
  <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>
</complexType>

element patientAddressType/person
Annotation Adresse d'une personne en qualité de factureur
diagram
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="xmitDocuments:personType"/>

complexType payloadType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender recipient subject body
used by
element transmissionType/payload
source
<complexType name="payloadType">
  <sequence>
    <element name="sender" type="xmitDocuments:partyAddressType"/>
    <element name="recipient" type="xmitDocuments:partyAddressType"/>
    <element name="subject" type="xmitDocuments:stringType1_100"/>
    <element name="body" type="xmitDocuments:bodyType"/>
  </sequence>
</complexType>

element payloadType/sender
Annotation Expéditeur

Désigne le bloc adresse avec les cordonnées de l'expéditeur.
diagram
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<element name="sender" type="xmitDocuments:partyAddressType"/>

element payloadType/recipient
Annotation Destinataire

Désigne le bloc adresse avec les cordonnées du destinataire.
diagram
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<element name="recipient" type="xmitDocuments:partyAddressType"/>

element payloadType/subject
Annotation Bref titre de l'information
diagram
type xmitDocuments:stringType1_100
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="subject" type="xmitDocuments:stringType1_100"/>

element payloadType/body
Annotation Contenu
diagram
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | comment tracking reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<element name="body" type="xmitDocuments:bodyType"/>

complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname postal telecom online
used by
elements partyAddressType/person patientAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<complexType name="personType">
  <sequence>
    <sequence>
      <element name="familyname" type="xmitDocuments:stringType1_35"/>
      <element name="givenname" type="xmitDocuments:stringType1_35"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="xmitDocuments:stringType1_35"/>
  <attribute name="title" type="xmitDocuments:stringType1_35"/>
</complexType>

element personType/familyname
Annotation Nom
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="xmitDocuments:stringType1_35"/>

element personType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="xmitDocuments:stringType1_35"/>

element personType/postal
Annotation Adresse
diagram
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>

element personType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

element personType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | pobox street zip city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="zip" type="xmitDocuments:zipType"/>
    <element name="city" type="xmitDocuments:stringType1_35"/>
  </sequence>
</complexType>

element postalAddressType/pobox
Annotation Case postale
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element postalAddressType/street
Annotation Rue
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>

element postalAddressType/zip
Annotation NPA
diagram
type xmitDocuments:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<element name="zip" type="xmitDocuments:zipType"/>

element postalAddressType/city
Annotation Localité
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="xmitDocuments:stringType1_35"/>

complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | package generator
used by
element transmissionType/prolog
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
type | Désignation du type de logiciel
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>
    <element name="generator" type="xmitDocuments:softwareType"/>
  </sequence>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="type" type="nonNegativeInteger" default="0"/>
</complexType>

element prologType/package
Annotation Application de la branche

Contient des informations concernant l'application prioritaire de la branche, qui est utilisée pour la facturation. Le nom de l'application de la branche sera indiqué comme contenu des données de cet élément.

Si des indications relatives à l'application de la branche sont livrées, le nom doit être mentionné.
diagram
type xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
source
<element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>

element prologType/generator
Annotation Nom du générateur de logiciel
diagram
type xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
source
<element name="generator" type="xmitDocuments:softwareType"/>

complexType referenceType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | patient case_credit case_invoice case_reminder case
used by
element bodyType/reference
source
<complexType name="referenceType">
  <sequence>
    <element name="patient" type="xmitDocuments:patientAddressType"/>
    <choice minOccurs="0">
      <element name="case_credit" type="xmitDocuments:caseSpecificType"/>
      <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>
      <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>
      <element name="case" type="xmitDocuments:caseType"/>
    </choice>
  </sequence>
</complexType>

element referenceType/patient
Annotation Patient

Désigne le bloc adresse avec les coordonnées du patient.
diagram
type | xmitDocuments:patientAddressType
properties
isRef | 0
content | complex
children | person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
senderID | Identification du patient ou du cas de l'expéditeur par ex. numéro de patient ou numéro de cas du fournisseur de prestations
recipientID | Identification de l'assuré ou de l'accident du destinataire par ex. numéro d'assuré ou numéro d'accident du répondant des coûts
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
source
<element name="patient" type="xmitDocuments:patientAddressType"/>

element referenceType/case_credit
Annotation Concerne : facture générale
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_credit" type="xmitDocuments:caseSpecificType"/>

element referenceType/case_invoice
Annotation Concerne : facture
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_invoice" type="xmitDocuments:caseSpecificType"/>

element referenceType/case_reminder
Annotation Concerne : rappel
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_reminder" type="xmitDocuments:caseSpecificType"/>

element referenceType/case
Annotation Cas
diagram
type xmitDocuments:caseType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identification
Extensions
Annotation | Base
Cas | transmission:caseType
source
<element name="case" type="xmitDocuments:caseType"/>

complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_50
properties
base xmitDocuments:stringType1_50
used by
elements prologType/generator prologType/package
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
Extensions
Annotation | Base
Software | transmission:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_50">
      <attribute name="version" type="nonNegativeInteger" use="required"/>
    </extension>
  </simpleContent>
</complexType>

complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | phone fax
used by
elements companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>

element telecomAddressType/phone
Annotation Numéro de téléphone

Numéro de téléphone du raccordement fixe ou du téléphone mobile
diagram
type xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>

element telecomAddressType/fax
Annotation Numéro de fax
diagram
type xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>

complexType transmissionType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | header prolog payload documents
used by
element transmission
source
<complexType name="transmissionType">
  <sequence>
    <element name="header" type="xmitDocuments:headerType"/>
    <element name="prolog" type="xmitDocuments:prologType"/>
    <element name="payload" type="xmitDocuments:payloadType"/>
    <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>
  </sequence>
</complexType>

element transmissionType/header
Annotation Informations d'en-tête

Définit les informations "routing" qui sont nécessaires ou significatives pour le flux de la facture jusqu'au destinataire final et le retour du destinataire à l'expéditeur initial.
diagram
type | xmitDocuments:headerType
properties
isRef | 0
content | complex
children | sender intermediate recipient
source
<element name="header" type="xmitDocuments:headerType"/>

element transmissionType/prolog
Annotation Prologue

Bloc avec informations sur:

- le paquet logiciel prioritaire (application de la branche)
- le générateur qui a généré et validé les structures XML correspondantes
- les validateurs de données utilisés
diagram
type | xmitDocuments:prologType
properties
isRef | 0
content | complex
children | package generator
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
type | Désignation du type de logiciel
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<element name="prolog" type="xmitDocuments:prologType"/>

element transmissionType/payload
Annotation Paquet de données
diagram
type | xmitDocuments:payloadType
properties
isRef | 0
content | complex
children | sender recipient subject body
source
<element name="payload" type="xmitDocuments:payloadType"/>

element transmissionType/documents
Annotation Documents
diagram
type | xmitDocuments:documentsType
properties
isRef | 0
content | complex
children | document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Numéro de document
source
<element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>

complexType xtendHeaderPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements headerType/recipient headerType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="xtendHeaderPartyType">
  <attribute name="ean_party" type="xmitDocuments:xtendEanPartyType" use="required"/>
</complexType>

complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_9
properties
base xmitDocuments:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_9">
      <attribute name="statecode" type="xmitDocuments:stringType1_9"/>
      <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>

simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes partyAddressType/@ean_party headerPartyType/@ean_party caseSpecificType/@provider_ean bodyType/@sender
facets
pattern ([0-9]{13})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="([0-9]{13})"/>
  </restriction>
</simpleType>

simpleType nonEmptyStringType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes companyType/@contact documentType/@filename documentType/@mimeType
facets
minLength 1
source
<simpleType name="nonEmptyStringType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>

simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}|unknown
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>
  </restriction>
</simpleType>

simpleType stringType1_100
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element | payloadType/subject
attribute | caseType/@id
facets
minLength | 1
maxLength | 100
source
<simpleType name="stringType1_100">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="100"/>
  </restriction>
</simpleType>

simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>

simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>

simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | bodyType/@id patientAddressType/@recipientID personType/@salutation patientAddressType/@senderID personType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>

simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType softwareType
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>

simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>

simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element bodyType/comment
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>

simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>

simpleType xtendEanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute xtendHeaderPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11}|unknown)
source
<simpleType name="xtendEanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>
  </restriction>
</simpleType>


Schema

1 <?xml version="1.0" encoding="UTF-8"?>

2 <!-- ==========================================================================

3

4 This is the schema definition for process of transmitting one or more documents

5 encoded in XML. The process is modelled after a plain email system.

6

7 Permission to use, and distribute this schema and its accompanying

8 documentation for any purpose and without fee is hereby granted in perpetuity,

9 provided that the above copyright notice and this paragraph appear in all copies

10 and this schema file is not altered.

11 The copyright holders make no representation about the suitability of the schema

12 for any purpose.

13

14 It is provided "as is" without expressed or implied warranty.

15

16 Copyright (c) 2005 Forum Datenaustausch,

17 All Rights Reserved.

18 ========================================================================== -->

19 <schema xmlns="http://www.w3.org/2001/XMLSchema" xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de" targetNamespace="

http://www.forum-datenaustausch.ch/de" elementFormDefault="qualified" attributeFormDefault="unqualified">

20 <!-- =======================================================================

21 General data type definitions

22 ======================================================================= -->

23 <!-- string not null -->

24 <simpleType name="nonEmptyStringType">

25 <restriction base="string">

26 <minLength value="1"/>

27 </restriction>

28 </simpleType>

29 <!-- string type with length 1-3 characters -->

30 <simpleType name="stringType1_3">

31 <restriction base="string">

32 <minLength value="1"/>

33 <maxLength value="3"/>

34 </restriction>

35 </simpleType>

36 <!-- string type with length 1-9 characters -->

37 <simpleType name="stringType1_9">

38 <restriction base="string">

39 <minLength value="1"/>

40 <maxLength value="9"/>

41 </restriction>

42 </simpleType>

43 <!-- string type with length 1-25 characters -->

44 <simpleType name="stringType1_25">

45 <restriction base="string">

46 <minLength value="1"/>

47 <maxLength value="25"/>

48 </restriction>

49 </simpleType>

50 <!-- string type with length 1-35 characters -->

51 <simpleType name="stringType1_35">

52 <restriction base="string">

53 <minLength value="1"/>

54 <maxLength value="35"/>

55 </restriction>

56 </simpleType>

57 <!-- string type with length 1-50 characters -->

58 <simpleType name="stringType1_50">

59 <restriction base="string">

60 <minLength value="1"/>

61 <maxLength value="50"/>

62 </restriction>

63 </simpleType>

64 <!-- string type with length 1-70 characters -->

65 <simpleType name="stringType1_70">

66 <restriction base="string">

67 <minLength value="1"/>

68 <maxLength value="70"/>

69 </restriction>

70 </simpleType>

71 <!-- string type with length 1-100 characters -->

72 <simpleType name="stringType1_100">

73 <restriction base="string">

74 <minLength value="1"/>

75 <maxLength value="100"/>

76 </restriction>

77 </simpleType>

78 <!-- string type with length 1-700 characters -->

79 <simpleType name="stringType1_700">

80 <restriction base="string">

81 <minLength value="1"/>

82 <maxLength value="700"/>

83 </restriction>

84 </simpleType>

85 <!-- EAN and SSN numbers -->

86 <simpleType name="eanPartyType">

87 <restriction base="string">

88 <pattern value="([0-9]{13})"/>

89 </restriction>

90 </simpleType>

91 <simpleType name="xtendEanPartyType">

92 <restriction base="string">

93 <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>

94 </restriction>

95 </simpleType>

96 <simpleType name="ssnPartyType">

97 <restriction base="string">

98 <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>

99 </restriction>

100 </simpleType>

101 <!-- =======================================================================

102 address data type definitions for companies and persons

103 ======================================================================= -->

104 <!-- Company -->

105 <complexType name="companyType">

106 <sequence>

107 <sequence>

108 <element name="companyname" type="xmitDocuments:stringType1_35"/>

109 <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>

110 </sequence>

111 <element name="postal" type="xmitDocuments:postalAddressType"/>

112 <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

113 <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

114 </sequence>

115 <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>

116 </complexType>

117 <!-- Person -->

118 <complexType name="personType">

119 <sequence>

120 <sequence>

121 <element name="familyname" type="xmitDocuments:stringType1_35"/>

122 <element name="givenname" type="xmitDocuments:stringType1_35"/>

123 </sequence>

124 <element name="postal" type="xmitDocuments:postalAddressType"/>

125 <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>

126 <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>

127 </sequence>

128 <attribute name="salutation" type="xmitDocuments:stringType1_35"/>

129 <attribute name="title" type="xmitDocuments:stringType1_35"/>

130 </complexType>

131 <complexType name="zipType">

132 <simpleContent>

133 <extension base="xmitDocuments:stringType1_9">

134 <attribute name="statecode" type="xmitDocuments:stringType1_9"/>

135 <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>

136 </extension>

137 </simpleContent>

138 </complexType>

139 <complexType name="postalAddressType">

140 <sequence>

141 <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>

142 <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>

143 <element name="zip" type="xmitDocuments:zipType"/>

144 <element name="city" type="xmitDocuments:stringType1_35"/>

145 </sequence>

146 </complexType>

147 <complexType name="telecomAddressType">

148 <sequence>

149 <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>

150 <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>

151 </sequence>

152 </complexType>

153 <complexType name="onlineAddressType">

154 <sequence>

155 <element name="email" maxOccurs="3">

156 <simpleType>

157 <restriction base="xmitDocuments:stringType1_70">

158 <pattern value=".+@.+"/>

159 </restriction>

160 </simpleType>

161 </element>

162 <element name="url" minOccurs="0" maxOccurs="3">

163 <simpleType>

164 <restriction base="anyURI">

165 <minLength value="1"/>

166 <maxLength value="100"/>

167 </restriction>

168 </simpleType>

169 </element>

170 </sequence>

171 </complexType>

172 <!-- =======================================================================

173 the specific address type data definitions

174 ======================================================================= -->

175 <!-- address = "Sender/Recipient" -->

176 <complexType name="partyAddressType">

177 <choice>

178 <element name="company" type="xmitDocuments:companyType"/>

179 <element name="person" type="xmitDocuments:personType"/>

180 </choice>

181 <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>

182 </complexType>

183 <!-- address = "Patient" -->

184 <complexType name="patientAddressType">

185 <sequence>

186 <element name="person" type="xmitDocuments:personType"/>

187 </sequence>

188 <attribute name="gender" use="required">

189 <simpleType>

190 <restriction base="NMTOKEN">

191 <enumeration value="male"/>

192 <enumeration value="female"/>

193 </restriction>

194 </simpleType>

195 </attribute>

196 <attribute name="birthdate" type="dateTime" use="required"/>

197 <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>

198 <attribute name="senderID" type="xmitDocuments:stringType1_35"/>

199 <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>

200 </complexType>

201 <!-- =======================================================================

202 Header data type definitions

203 ======================================================================= -->

204 <complexType name="headerPartyType">

205 <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>

206 </complexType>

207 <complexType name="xtendHeaderPartyType">

208 <attribute name="ean_party" type="xmitDocuments:xtendEanPartyType" use="required"/>

209 </complexType>

210 <complexType name="headerType">

211 <sequence>

212 <element name="sender" type="xmitDocuments:xtendHeaderPartyType"/>

213 <element name="intermediate" type="xmitDocuments:headerPartyType"/>

214 <element name="recipient" type="xmitDocuments:xtendHeaderPartyType"/>

215 </sequence>

216 </complexType>

217 <!-- =======================================================================

218 prolog: misc administrative data type definitions

219 ======================================================================= -->

220 <!-- prolog section -->

221 <complexType name="prologType">

222 <sequence>

223 <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>

224 <element name="generator" type="xmitDocuments:softwareType"/>

225 </sequence>

226 <attribute name="role" default="production">

227 <simpleType>

228 <restriction base="NMTOKEN">

229 <enumeration value="production"/>

230 <enumeration value="test"/>

231 </restriction>

232 </simpleType>

233 </attribute>

234 <attribute name="type" type="nonNegativeInteger" default="0"/>

235 </complexType>

236 <complexType name="softwareType">

237 <simpleContent>

238 <extension base="xmitDocuments:stringType1_50">

239 <attribute name="version" type="nonNegativeInteger" use="required"/>

240 </extension>

241 </simpleContent>

242 </complexType>

243 <!-- =======================================================================

244 body data type definitions used for (back)tracking

245 ======================================================================= -->

246 <complexType name="bodyType">

247 <sequence>

248 <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>

249 <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>

250 <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>

251 </sequence>

252 <attribute name="timestamp" type="unsignedLong" use="required"/>

253 <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>

254 <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>

255 </complexType>

256 <!-- =======================================================================

257 reference data type definitions

258 ======================================================================= -->

259 <complexType name="referenceType">

260 <sequence>

261 <element name="patient" type="xmitDocuments:patientAddressType"/>

262 <choice minOccurs="0">

263 <element name="case_credit" type="xmitDocuments:caseSpecificType"/>

264 <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>

265 <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>

266 <element name="case" type="xmitDocuments:caseType"/>

267 </choice>

268 </sequence>

269 </complexType>

270 <!-- =======================================================================

271 case data type definitions

272 ======================================================================= -->

273 <complexType name="caseType">

274 <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>

275 </complexType>

276 <complexType name="caseSpecificType">

277 <complexContent>

278 <extension base="xmitDocuments:caseType">

279 <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>

280 <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>

281 </extension>

282 </complexContent>

283 </complexType>

284 <!-- =======================================================================

285 payload data type definitions

286 ======================================================================= -->

287 <complexType name="payloadType">

288 <sequence>

289 <element name="sender" type="xmitDocuments:partyAddressType"/>

290 <element name="recipient" type="xmitDocuments:partyAddressType"/>

291 <element name="subject" type="xmitDocuments:stringType1_100"/>

292 <element name="body" type="xmitDocuments:bodyType"/>

293 </sequence>

294 </complexType>

295 <!-- =======================================================================

296 document(s) data type definitions

297 ======================================================================= -->

298 <complexType name="documentsType">

299 <sequence>

300 <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>

301 </sequence>

302 <attribute name="number" type="unsignedLong" use="required"/>

303 </complexType>

304 <complexType name="documentType">

305 <choice>

306 <element name="data" type="base64Binary"/>

307 <element name="url" type="anyURI"/>

308 </choice>

309 <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>

310 <attribute name="size" type="unsignedLong" use="required"/>

311 <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>

312 <attribute name="viewer" type="anyURI"/>

313 </complexType>

314 <!-- =======================================================================

315 =======================================================================

316 Here starts the request with its root element

317 =======================================================================

318 ======================================================================= -->

319 <element name="transmission" type="xmitDocuments:transmissionType"/>

320 <complexType name="transmissionType">

321 <sequence>

322 <element name="header" type="xmitDocuments:headerType"/>

323 <element name="prolog" type="xmitDocuments:prologType"/>

324 <element name="payload" type="xmitDocuments:payloadType"/>

325 <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>

326 </sequence>

327 </complexType>

328 </schema>


Éléments des xmit-documents alphabétique

xmitDocuments_410 fra
Éléments des xmit-documents alphabétique


 element transmission
Annotation Début du document XML

Déclaration XML, y compris jeu de caractères UTF-8: <?xml version="1.0" encoding="UTF-8" standalone="no"?> (première ligne dans le document XML)

Elément racine: xmitDocuments:transmission

- XML Espace nominal xsi: xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- Espace nominal xmitDocuments: xmlns:xmitDocuments="http://www.forum-datenaustausch.ch/de"
- Type: xmit-documents 4.1
- Lieu: xsi :schemaLocation="http://www.forum-datenaustausch.ch/de xmitDocuments_410.xsd"

L'espace nominal pour tous les éléments est "xmitDocuments".
Dans le document XML, cet espace nominal doit être indiqué pour chaque élément!

Parla suite, la présente documentation ne fera état plus que du nom de l'élément, sans espace nominal, p. ex: "transmission" au lieu de "xmitDocuments:transmission".

Pour les attributs, il n'est pas nécessaire d'indiquer un espace nominal dans le document XML.

Voir définition dans le schéma:

- elementFormDefault="qualified"
- attributeFormDefault="unqualified"
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | xmitDocuments:transmissionType
properties
content complex
children | header prolog payload documents
source
<element name="transmission" type="xmitDocuments:transmissionType"/>


 complexType bodyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | comment tracking reference
used by
elements payloadType/body bodyType/tracking
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<complexType name="bodyType">
  <sequence>
    <element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>
    <element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>
    <element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>
  </sequence>
  <attribute name="timestamp" type="unsignedLong" use="required"/>
  <attribute name="id" type="xmitDocuments:stringType1_35" use="required"/>
  <attribute name="sender" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 element bodyType/comment
Annotation Commentaire
diagram
type xmitDocuments:stringType1_700
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 700
source
<element name="comment" type="xmitDocuments:stringType1_700" minOccurs="0"/>


 element bodyType/tracking
Annotation History communication Tracking illimité
diagram
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | comment tracking reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<element name="tracking" type="xmitDocuments:bodyType" minOccurs="0"/>


 element bodyType/reference
Annotation Référence
diagram
type | xmitDocuments:referenceType
properties
isRef | 0
content | complex
children | patient case_credit case_invoice case_reminder case
source
<element name="reference" type="xmitDocuments:referenceType" minOccurs="0"/>


 complexType caseSpecificType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:caseType
properties
base xmitDocuments:caseType
used by
elements referenceType/case_credit referenceType/case_invoice referenceType/case_reminder
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
Extensions
Annotation | Base
Cas | transmission:caseType
source
<complexType name="caseSpecificType">
  <complexContent>
    <extension base="xmitDocuments:caseType">
      <attribute name="request_timestamp" type="nonNegativeInteger" use="required"/>
      <attribute name="provider_ean" type="xmitDocuments:eanPartyType" use="required"/>
    </extension>
  </complexContent>
</complexType>


 complexType caseType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element | referenceType/case
complexType | caseSpecificType
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identification
source
<complexType name="caseType">
  <attribute name="id" type="xmitDocuments:stringType1_100" use="required"/>
</complexType>


 complexType companyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | companyname department postal telecom online
used by
element partyAddressType/company
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Contact
source
<complexType name="companyType">
  <sequence>
    <sequence>
      <element name="companyname" type="xmitDocuments:stringType1_35"/>
      <element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="contact" type="xmitDocuments:nonEmptyStringType"/>
</complexType>


 element companyType/companyname
Annotation Désignation de l'entreprise
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="companyname" type="xmitDocuments:stringType1_35"/>


 element companyType/department
Annotation Service / Division
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="department" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element companyType/postal
Annotation Adresse
diagram
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>


 element companyType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>


 element companyType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>


 complexType documentsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | document
used by
element transmissionType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Numéro de document
source
<complexType name="documentsType">
  <sequence>
    <element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>
  </sequence>
  <attribute name="number" type="unsignedLong" use="required"/>
</complexType>


 element documentsType/document
Annotation Document
diagram
type | xmitDocuments:documentType
properties
isRef | 0
content | complex
children | data url
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Nom de fichier des documents
size | Taille documents
mimeType | Documents de type MIME
viewer | Viewersoftware
source
<element name="document" type="xmitDocuments:documentType" maxOccurs="unbounded"/>


 complexType documentType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | data url
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
filename | xmitDocuments:nonEmptyStringType | required |  |
size | unsignedLong | required |  |
mimeType | xmitDocuments:nonEmptyStringType | required |  |
viewer | anyURI |  |  |
attributes annotations
Name | Notes
filename | Nom de fichier des documents
size | Taille documents
mimeType | Documents de type MIME
viewer | Viewersoftware
source
<complexType name="documentType">
  <choice>
    <element name="data" type="base64Binary"/>
    <element name="url" type="anyURI"/>
  </choice>
  <attribute name="filename" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="size" type="unsignedLong" use="required"/>
  <attribute name="mimeType" type="xmitDocuments:nonEmptyStringType" use="required"/>
  <attribute name="viewer" type="anyURI"/>
</complexType>


 element documentType/data
Annotation Le bloc de données
diagram
type base64Binary
properties
isRef | 0
content | simple
source
<element name="data" type="base64Binary"/>


 element documentType/url
Annotation Adresse URL

Désigne une adresse URL complète qui peut être utilisée à des fins d'information ou de prise de contact.
diagram
type anyURI
properties
isRef | 0
content | simple
source
<element name="url" type="anyURI"/>


 complexType headerPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
element headerType/intermediate
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="headerPartyType">
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 complexType headerType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender intermediate recipient
used by
element transmissionType/header
source
<complexType name="headerType">
  <sequence>
    <element name="sender" type="xmitDocuments:xtendHeaderPartyType"/>
    <element name="intermediate" type="xmitDocuments:headerPartyType"/>
    <element name="recipient" type="xmitDocuments:xtendHeaderPartyType"/>
  </sequence>
</complexType>


 element headerType/sender
Annotation Expéditeur de la facture (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie le destinataire final de la facture par le biais d'un numéro EAN univoque.
diagram
type xmitDocuments:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="sender" type="xmitDocuments:xtendHeaderPartyType"/>


 element headerType/intermediate
Annotation Intermédiaire de la facture (numéro EAN: EAN/UCC Global Location Number (GLN))

Identifie par le biais d'un numéro EAN l'institution intermédiaire (clearing center) qui est responsable de la gestion administrative et fait office d'intermédiaire entre le fournisseur de prestations / factureur et le répondant des coûts.

Si la facture est envoyée par le fournisseur de prestations / factureur directement au répondant des coûts, il y aura lieu d'indiquer ici le numéro EAN du répondant des coûts.

Dans ce cas, le répondant des coûts assume les tâches de l'intermédiaire.
diagram
type xmitDocuments:headerPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="intermediate" type="xmitDocuments:headerPartyType"/>


 element headerType/recipient
Annotation

diagram
type xmitDocuments:xtendHeaderPartyType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="recipient" type="xmitDocuments:xtendHeaderPartyType"/>


 complexType onlineAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | email url
used by
elements companyType/online personType/online
source
<complexType name="onlineAddressType">
  <sequence>
    <element name="email" maxOccurs="3">
      <simpleType>
        <restriction base="xmitDocuments:stringType1_70">
          <pattern value=".+@.+"/>
        </restriction>
      </simpleType>
    </element>
    <element name="url" minOccurs="0" maxOccurs="3">
      <simpleType>
        <restriction base="anyURI">
          <minLength value="1"/>
          <maxLength value="100"/>
        </restriction>
      </simpleType>
    </element>
  </sequence>
</complexType>


 element onlineAddressType/email
Annotation Adresse e-mail

Désigne une adresse e-mail selon RFC821.
diagram
type restriction of xmitDocuments:stringType1_70
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 70
pattern | .+@.+
source
<element name="email" maxOccurs="3">
  <simpleType>
    <restriction base="xmitDocuments:stringType1_70">
      <pattern value=".+@.+"/>
    </restriction>
  </simpleType>
</element>


 element onlineAddressType/url
Annotation Adresse URL

Désigne une adresse URL complète qui peut être utilisée à des fins d'information ou de prise de contact.
diagram
type restriction of anyURI
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="url" minOccurs="0" maxOccurs="3">
  <simpleType>
    <restriction base="anyURI">
      <minLength value="1"/>
      <maxLength value="100"/>
    </restriction>
  </simpleType>
</element>


 complexType partyAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | company person
used by
elements payloadType/recipient payloadType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<complexType name="partyAddressType">
  <choice>
    <element name="company" type="xmitDocuments:companyType"/>
    <element name="person" type="xmitDocuments:personType"/>
  </choice>
  <attribute name="ean_party" type="xmitDocuments:eanPartyType" use="required"/>
</complexType>


 element partyAddressType/company
Annotation Adresse d'une entreprise / institution en qualité de factureur
diagram
type | xmitDocuments:companyType
properties
isRef | 0
content | complex
children | companyname department postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
contact | xmitDocuments:nonEmptyStringType |  |  |
attributes annotations
Name | Notes
contact | Contact
source
<element name="company" type="xmitDocuments:companyType"/>


 element partyAddressType/person
Annotation Adresse d'une personne en qualité de factureur
diagram
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="xmitDocuments:personType"/>


 complexType patientAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | person
used by
element referenceType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
senderID | Identification du patient ou du cas de l'expéditeur par ex. numéro de patient ou numéro de cas du fournisseur de prestations
recipientID | Identification de l'assuré ou de l'accident du destinataire par ex. numéro d'assuré ou numéro d'accident du répondant des coûts
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
source
<complexType name="patientAddressType">
  <sequence>
    <element name="person" type="xmitDocuments:personType"/>
  </sequence>
  <attribute name="gender" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="male"/>
        <enumeration value="female"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="birthdate" type="dateTime" use="required"/>
  <attribute name="ssn" type="xmitDocuments:ssnPartyType"/>
  <attribute name="senderID" type="xmitDocuments:stringType1_35"/>
  <attribute name="recipientID" type="xmitDocuments:stringType1_35"/>
</complexType>


 element patientAddressType/person
Annotation Adresse d'une personne en qualité de factureur
diagram
type | xmitDocuments:personType
properties
isRef | 0
content | complex
children | familyname givenname postal telecom online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<element name="person" type="xmitDocuments:personType"/>


 complexType payloadType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | sender recipient subject body
used by
element transmissionType/payload
source
<complexType name="payloadType">
  <sequence>
    <element name="sender" type="xmitDocuments:partyAddressType"/>
    <element name="recipient" type="xmitDocuments:partyAddressType"/>
    <element name="subject" type="xmitDocuments:stringType1_100"/>
    <element name="body" type="xmitDocuments:bodyType"/>
  </sequence>
</complexType>


 element payloadType/sender
Annotation Expéditeur

Désigne le bloc adresse avec les cordonnées de l'expéditeur.
diagram
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<element name="sender" type="xmitDocuments:partyAddressType"/>


 element payloadType/recipient
Annotation Destinataire

Désigne le bloc adresse avec les cordonnées du destinataire.
diagram
type | xmitDocuments:partyAddressType
properties
isRef | 0
content | complex
children | company person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
ean_party | Numéro EAN
source
<element name="recipient" type="xmitDocuments:partyAddressType"/>


 element payloadType/subject
Annotation Bref titre de l'information
diagram
type xmitDocuments:stringType1_100
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 100
source
<element name="subject" type="xmitDocuments:stringType1_100"/>


 element payloadType/body
Annotation Contenu
diagram
type | xmitDocuments:bodyType
properties
isRef | 0
content | complex
children | comment tracking reference
attributes parameters
Name | Type | Use | Default | Fixed
timestamp | unsignedLong | required |  |
id | xmitDocuments:stringType1_35 | required |  |
sender | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
timestamp | Date et heure d'établissement
id | Identification
sender | Expéditeur
source
<element name="body" type="xmitDocuments:bodyType"/>


 complexType personType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | familyname givenname postal telecom online
used by
elements partyAddressType/person patientAddressType/person
attributes parameters
Name | Type | Use | Default | Fixed
salutation | xmitDocuments:stringType1_35 |  |  |
title | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Formule d'appel
title | Titre
source
<complexType name="personType">
  <sequence>
    <sequence>
      <element name="familyname" type="xmitDocuments:stringType1_35"/>
      <element name="givenname" type="xmitDocuments:stringType1_35"/>
    </sequence>
    <element name="postal" type="xmitDocuments:postalAddressType"/>
    <element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>
    <element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>
  </sequence>
  <attribute name="salutation" type="xmitDocuments:stringType1_35"/>
  <attribute name="title" type="xmitDocuments:stringType1_35"/>
</complexType>


 element personType/familyname
Annotation Nom
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="xmitDocuments:stringType1_35"/>


 element personType/givenname
Annotation Prénom

Désigne l'élément dans lequel le prénom ou le second nom d'une personne physique sont indiqués comme contenu.

Le premier élément donné est toujours considéré comme prénom, d'autres éléments le cas échéant comme second nom.
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="xmitDocuments:stringType1_35"/>


 element personType/postal
Annotation Adresse
diagram
type | xmitDocuments:postalAddressType
properties
isRef | 0
content | complex
children | pobox street zip city
source
<element name="postal" type="xmitDocuments:postalAddressType"/>


 element personType/telecom
Annotation Telecom

Définit les informations de contact en matière de télécommunications.
diagram
type | xmitDocuments:telecomAddressType
properties
isRef | 0
content | complex
children | phone fax
source
<element name="telecom" type="xmitDocuments:telecomAddressType" minOccurs="0"/>


 element personType/online
Annotation Online

Définit les informations sur les services en ligne.
diagram
type | xmitDocuments:onlineAddressType
properties
isRef | 0
content | complex
children | email url
source
<element name="online" type="xmitDocuments:onlineAddressType" minOccurs="0"/>


 complexType postalAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | pobox street zip city
used by
elements companyType/postal personType/postal
source
<complexType name="postalAddressType">
  <sequence>
    <element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>
    <element name="zip" type="xmitDocuments:zipType"/>
    <element name="city" type="xmitDocuments:stringType1_35"/>
  </sequence>
</complexType>


 element postalAddressType/pobox
Annotation Case postale
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="pobox" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element postalAddressType/street
Annotation Rue
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="street" type="xmitDocuments:stringType1_35" minOccurs="0"/>


 element postalAddressType/zip
Annotation NPA
diagram
type xmitDocuments:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<element name="zip" type="xmitDocuments:zipType"/>


 element postalAddressType/city
Annotation Localité
diagram
type xmitDocuments:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="city" type="xmitDocuments:stringType1_35"/>


 complexType prologType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | package generator
used by
element transmissionType/prolog
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
type | Désignation du type de logiciel
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<complexType name="prologType">
  <sequence>
    <element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>
    <element name="generator" type="xmitDocuments:softwareType"/>
  </sequence>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="type" type="nonNegativeInteger" default="0"/>
</complexType>


 element prologType/package
Annotation Application de la branche

Contient des informations concernant l'application prioritaire de la branche, qui est utilisée pour la facturation. Le nom de l'application de la branche sera indiqué comme contenu des données de cet élément.

Si des indications relatives à l'application de la branche sont livrées, le nom doit être mentionné.
diagram
type xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
source
<element name="package" type="xmitDocuments:softwareType" minOccurs="0"/>


 element prologType/generator
Annotation Nom du générateur de logiciel
diagram
type xmitDocuments:softwareType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
source
<element name="generator" type="xmitDocuments:softwareType"/>


 complexType referenceType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | patient case_credit case_invoice case_reminder case
used by
element bodyType/reference
source
<complexType name="referenceType">
  <sequence>
    <element name="patient" type="xmitDocuments:patientAddressType"/>
    <choice minOccurs="0">
      <element name="case_credit" type="xmitDocuments:caseSpecificType"/>
      <element name="case_invoice" type="xmitDocuments:caseSpecificType"/>
      <element name="case_reminder" type="xmitDocuments:caseSpecificType"/>
      <element name="case" type="xmitDocuments:caseType"/>
    </choice>
  </sequence>
</complexType>


 element referenceType/patient
Annotation Patient

Désigne le bloc adresse avec les coordonnées du patient.
diagram
type | xmitDocuments:patientAddressType
properties
isRef | 0
content | complex
children | person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | xmitDocuments:ssnPartyType |  |  |
senderID | xmitDocuments:stringType1_35 |  |  |
recipientID | xmitDocuments:stringType1_35 |  |  |
attributes annotations
Name | Notes
gender | Sexe du patient
birthdate | Date de naissance du patient Si l'indication de l'heure n'est pas significative, c'est 0 heure ("T00:00:00") qui doit être indiqué
ssn | Numéro AVS du patient
senderID | Identification du patient ou du cas de l'expéditeur par ex. numéro de patient ou numéro de cas du fournisseur de prestations
recipientID | Identification de l'assuré ou de l'accident du destinataire par ex. numéro d'assuré ou numéro d'accident du répondant des coûts
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | masculin
gender |  | NMTOKEN | female | féminin
source
<element name="patient" type="xmitDocuments:patientAddressType"/>


 element referenceType/case_credit
Annotation Concerne : facture générale
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_credit" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case_invoice
Annotation Concerne : facture
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_invoice" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case_reminder
Annotation Concerne : rappel
diagram
type xmitDocuments:caseSpecificType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
request_timestamp | nonNegativeInteger | required |  |
provider_ean | xmitDocuments:eanPartyType | required |  |
attributes annotations
Name | Notes
request_timestamp | Date et heuret
provider_ean | Numéro EAN du fournisseur de prestations
source
<element name="case_reminder" type="xmitDocuments:caseSpecificType"/>


 element referenceType/case
Annotation Cas
diagram
type xmitDocuments:caseType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
id | xmitDocuments:stringType1_100 | required |  |
attributes annotations
Name | Notes
id | Identification
Extensions
Annotation | Base
Cas | transmission:caseType
source
<element name="case" type="xmitDocuments:caseType"/>


 complexType softwareType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_50
properties
base xmitDocuments:stringType1_50
used by
elements prologType/generator prologType/package
facets
minLength | 1
maxLength | 50
attributes parameters
Name | Type | Use | Default | Fixed
version | nonNegativeInteger | required |  |
attributes annotations
Name | Notes
version | Version du logiciel générateur/de l'application de la branche Numéro de version du logiciel générateur/de l'application de la branche utilisée. La version y sera indiquée en tant que numéro entier et codé selon le schéma suivant: - version = int(100*x+y). - x désignant le numéro de la version principale (major version) - y le numéro de la version secondaire (minor version)
Extensions
Annotation | Base
Software | transmission:stringType1_50
source
<complexType name="softwareType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_50">
      <attribute name="version" type="nonNegativeInteger" use="required"/>
    </extension>
  </simpleContent>
</complexType>


 complexType telecomAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | phone fax
used by
elements companyType/telecom personType/telecom
source
<complexType name="telecomAddressType">
  <sequence>
    <element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>
    <element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>
  </sequence>
</complexType>


 element telecomAddressType/phone
Annotation Numéro de téléphone

Numéro de téléphone du raccordement fixe ou du téléphone mobile
diagram
type xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="phone" type="xmitDocuments:stringType1_25" maxOccurs="3"/>


 element telecomAddressType/fax
Annotation Numéro de fax
diagram
type xmitDocuments:stringType1_25
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 25
source
<element name="fax" type="xmitDocuments:stringType1_25" minOccurs="0" maxOccurs="3"/>


 complexType transmissionType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | header prolog payload documents
used by
element transmission
source
<complexType name="transmissionType">
  <sequence>
    <element name="header" type="xmitDocuments:headerType"/>
    <element name="prolog" type="xmitDocuments:prologType"/>
    <element name="payload" type="xmitDocuments:payloadType"/>
    <element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>
  </sequence>
</complexType>


 element transmissionType/header
Annotation Informations d'en-tête

Définit les informations "routing" qui sont nécessaires ou significatives pour le flux de la facture jusqu'au destinataire final et le retour du destinataire à l'expéditeur initial.
diagram
type | xmitDocuments:headerType
properties
isRef | 0
content | complex
children | sender intermediate recipient
source
<element name="header" type="xmitDocuments:headerType"/>


 element transmissionType/prolog
Annotation Prologue

Bloc avec informations sur:

- le paquet logiciel prioritaire (application de la branche)
- le générateur qui a généré et validé les structures XML correspondantes
- les validateurs de données utilisés
diagram
type | xmitDocuments:prologType
properties
isRef | 0
content | complex
children | package generator
attributes parameters
Name | Type | Use | Default | Fixed
role |  |  | production |
type | nonNegativeInteger |  | 0 |
attributes annotations
Name | Notes
role | Caractéristique test Désigne respectivement le type et le rôle au sens d'un article productif ou d'un article test.
type | Désignation du type de logiciel
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
role |  | NMTOKEN | production | Message production
role |  | NMTOKEN | test | Message test
source
<element name="prolog" type="xmitDocuments:prologType"/>


 element transmissionType/payload
Annotation Paquet de données
diagram
type | xmitDocuments:payloadType
properties
isRef | 0
content | complex
children | sender recipient subject body
source
<element name="payload" type="xmitDocuments:payloadType"/>


 element transmissionType/documents
Annotation Documents
diagram
type | xmitDocuments:documentsType
properties
isRef | 0
content | complex
children | document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required |  |
attributes annotations
Name | Notes
number | Numéro de document
source
<element name="documents" type="xmitDocuments:documentsType" minOccurs="0"/>


 complexType xtendHeaderPartyType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements headerType/recipient headerType/sender
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | xmitDocuments:xtendEanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="xtendHeaderPartyType">
  <attribute name="ean_party" type="xmitDocuments:xtendEanPartyType" use="required"/>
</complexType>


 complexType zipType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of xmitDocuments:stringType1_9
properties
base xmitDocuments:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | xmitDocuments:stringType1_9 |  |  |
countrycode | xmitDocuments:stringType1_3 |  | CH |
attributes annotations
Name | Notes
statecode | Canton
countrycode | Pays (code pays ISO)
Extensions
Annotation | Base
Zip | transmission:stringType1_9
source
<complexType name="zipType">
  <simpleContent>
    <extension base="xmitDocuments:stringType1_9">
      <attribute name="statecode" type="xmitDocuments:stringType1_9"/>
      <attribute name="countrycode" type="xmitDocuments:stringType1_3" default="CH"/>
    </extension>
  </simpleContent>
</complexType>


 simpleType eanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes partyAddressType/@ean_party headerPartyType/@ean_party caseSpecificType/@provider_ean bodyType/@sender
facets
pattern ([0-9]{13})
source
<simpleType name="eanPartyType">
  <restriction base="string">
    <pattern value="([0-9]{13})"/>
  </restriction>
</simpleType>


 simpleType nonEmptyStringType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes companyType/@contact documentType/@filename documentType/@mimeType
facets
minLength 1
source
<simpleType name="nonEmptyStringType">
  <restriction base="string">
    <minLength value="1"/>
  </restriction>
</simpleType>


 simpleType ssnPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute patientAddressType/@ssn
facets
pattern [1-9][0-9]{10}|[1-9][0-9]{12}|unknown
source
<simpleType name="ssnPartyType">
  <restriction base="string">
    <pattern value="[1-9][0-9]{10}|[1-9][0-9]{12}|unknown"/>
  </restriction>
</simpleType>


 simpleType stringType1_100
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element | payloadType/subject
attribute | caseType/@id
facets
minLength | 1
maxLength | 100
source
<simpleType name="stringType1_100">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="100"/>
  </restriction>
</simpleType>


 simpleType stringType1_25
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements telecomAddressType/fax telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source
<simpleType name="stringType1_25">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="25"/>
  </restriction>
</simpleType>


 simpleType stringType1_3
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute zipType/@countrycode
facets
minLength | 1
maxLength | 3
source
<simpleType name="stringType1_3">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="3"/>
  </restriction>
</simpleType>


 simpleType stringType1_35
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox postalAddressType/street
attributes | bodyType/@id patientAddressType/@recipientID personType/@salutation patientAddressType/@senderID personType/@title
facets
minLength | 1
maxLength | 35
source
<simpleType name="stringType1_35">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="35"/>
  </restriction>
</simpleType>


 simpleType stringType1_50
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType softwareType
facets
minLength | 1
maxLength | 50
source
<simpleType name="stringType1_50">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="50"/>
  </restriction>
</simpleType>


 simpleType stringType1_70
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 70
source
<simpleType name="stringType1_70">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="70"/>
  </restriction>
</simpleType>


 simpleType stringType1_700
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
element bodyType/comment
facets
minLength | 1
maxLength | 700
source
<simpleType name="stringType1_700">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="700"/>
  </restriction>
</simpleType>


 simpleType stringType1_9
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexType | zipType
attribute | zipType/@statecode
facets
minLength | 1
maxLength | 9
source
<simpleType name="stringType1_9">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="9"/>
  </restriction>
</simpleType>


 simpleType xtendEanPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute xtendHeaderPartyType/@ean_party
facets
pattern (20[0-9]{11}|76[0-9]{11}|unknown)
source
<simpleType name="xtendEanPartyType">
  <restriction base="string">
    <pattern value="(20[0-9]{11}|76[0-9]{11}|unknown)"/>
  </restriction>
</simpleType>


Éléments des xmit-documents hiérarchique

xmitDocuments_410 fra
Éléments des xmit-documents hiérarchique

si doit - élément
peut - élément
soit ou - élément


 complexType contactAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:person credit:employee credit:company
used by
element creditType/contact
source
<complexType name="contactAddressType">
  <choice>
    <element name="person" type="credit:personType"/>
    <sequence>
      <element name="employee" type="credit:employeeType"/>
      <element name="company" type="credit:companyType"/>
    </sequence>
  </choice>
</complexType>


 complexType costsType
diagram
namespace http://www.forum-datenaustausch.ch/de
used by
elements | kvgLawType/costs uvgLawType/costs ivgLawType/costs mvgLawType/costs kvgLawType/total_costs vvgLawType/total_costs uvgLawType/total_costs ivgLawType/total_costs mvgLawType/total_costs
complexType | xndCostsType
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<complexType name="costsType">
  <attribute name="amount" type="credit:amountType"/>
  <attribute name="currency" type="string" fixed="CHF"/>
</complexType>


 complexType creditType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:requestor credit:contact credit:provider credit:patient credit:referrer credit:treating_person credit:family_doctor credit:sponsor credit:employer credit:detail
used by
element requestType/credit
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
resend_number | unsignedLong |  | 0 |
resend_date | dateTime |  |  |
copy | boolean |  | false |
type |  |  | new |
attributes annotations
Name Notes
source
<complexType name="creditType">
  <sequence>
    <element name="requestor" type="credit:requestorAddressType"/>
    <element name="contact" type="credit:contactAddressType"/>
    <element name="provider" type="credit:providerAddressType"/>
    <element name="patient" type="credit:patientAddressType"/>
    <element name="referrer" type="credit:referrerAddressType" minOccurs="0"/>
    <element name="treating_person" type="credit:referrerAddressType" minOccurs="0"/>
    <element name="family_doctor" type="credit:referrerAddressType" minOccurs="0"/>
    <sequence maxOccurs="4">
      <element name="sponsor" type="credit:sponsorType"/>
    </sequence>
    <element name="employer" type="credit:employerAddressType" minOccurs="0"/>
    <element name="detail" type="credit:detailType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="credit_timestamp" type="unsignedLong" use="required"/>
  <attribute name="credit_id" type="credit:stringType1_35" use="required"/>
  <attribute name="credit_date" type="dateTime" use="required"/>
  <attribute name="resend_number" type="unsignedLong" default="0"/>
  <attribute name="resend_date" type="dateTime"/>
  <attribute name="copy" type="boolean" default="false"/>
  <attribute name="type" default="new">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="new"/>
        <enumeration value="re-consideration"/>
        <enumeration value="prolongation"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 complexType detailType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:diagnosis credit:therapy credit:functional_deficits credit:accompanying_affections credit:treatment_goals credit:remark
used by
element creditType/detail
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
date_end | dateTime | required |  |
days | duration | required |  |
treatment_canton |  | required |  |
treatment_type |  | required |  |
reason |  | required |  |
hospitalization_type |  | required |  |
hospitalization_mode |  | required |  |
section_major | credit:stringType1_6 |  |  |
section_name | credit:stringType1_35 |  |  |
relapse | boolean |  | false |
attributes annotations
Name Notes
source
<complexType name="detailType">
  <sequence>
    <element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>
    <element name="therapy" type="credit:therapyType" minOccurs="0" maxOccurs="unbounded"/>
    <element name="functional_deficits" type="string" minOccurs="0"/>
    <element name="accompanying_affections" type="string" minOccurs="0"/>
    <element name="treatment_goals" type="string" minOccurs="0"/>
    <element name="remark" type="string" minOccurs="0"/>
  </sequence>
  <attribute name="date_begin" type="dateTime" use="required"/>
  <attribute name="date_end" type="dateTime" use="required"/>
  <attribute name="days" type="duration" use="required"/>
  <attribute name="treatment_canton" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="AG"/>
        <enumeration value="AI"/>
        <enumeration value="AR"/>
        <enumeration value="BE"/>
        <enumeration value="BL"/>
        <enumeration value="BS"/>
        <enumeration value="FR"/>
        <enumeration value="GE"/>
        <enumeration value="GL"/>
        <enumeration value="GR"/>
        <enumeration value="JU"/>
        <enumeration value="LU"/>
        <enumeration value="NE"/>
        <enumeration value="NW"/>
        <enumeration value="OW"/>
        <enumeration value="SG"/>
        <enumeration value="SH"/>
        <enumeration value="SO"/>
        <enumeration value="SZ"/>
        <enumeration value="TI"/>
        <enumeration value="TG"/>
        <enumeration value="UR"/>
        <enumeration value="VD"/>
        <enumeration value="VS"/>
        <enumeration value="ZG"/>
        <enumeration value="ZH"/>
        <enumeration value="LI"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="treatment_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="ambulatory"/>
        <enumeration value="semi_stationary"/>
        <enumeration value="stationary"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="reason" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="disease"/>
        <enumeration value="accident"/>
        <enumeration value="maternity"/>
        <enumeration value="prevention"/>
        <enumeration value="birthdefect"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="hospitalization_type" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="regular"/>
        <enumeration value="emergency"/>
        <enumeration value="welfare"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="hospitalization_mode" use="required">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="cantonal"/>
        <enumeration value="noncantonal_indicated"/>
        <enumeration value="noncantonal_nonindicated"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="section_major" type="credit:stringType1_6"/>
  <attribute name="section_name" type="credit:stringType1_35"/>
  <attribute name="relapse" type="boolean" default="false"/>
</complexType>


 complexType diagnosisType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType0_350
properties
base credit:stringType0_350
used by
element detailType/diagnosis
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<complexType name="diagnosisType">
  <simpleContent>
    <extension base="credit:stringType0_350">
      <attribute name="type" default="by_contract">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="ICD10"/>
            <enumeration value="DRG"/>
            <enumeration value="by_contract"/>
            <enumeration value="freetext"/>
            <enumeration value="birthdefect"/>
            <enumeration value="ICPC"/>
          </restriction>
        </simpleType>
      </attribute>
      <attribute name="code" type="credit:stringType1_12"/>
    </extension>
  </simpleContent>
</complexType>


 complexType employeeType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:familyname credit:givenname
used by
element contactAddressType/employee
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="employeeType">
  <sequence>
    <element name="familyname" type="credit:stringType1_35"/>
    <element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>
  </sequence>
  <attribute name="salutation" type="credit:stringType1_35"/>
  <attribute name="title" type="credit:stringType1_35"/>
</complexType>


 complexType employerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/employer
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="employerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType"/>
  <attribute name="reg_number" type="credit:stringType1_35"/>
</complexType>


 complexType insuranceAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company
used by
element sponsorType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="insuranceAddressType">
  <sequence>
    <element name="company" type="credit:companyType"/>
  </sequence>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
</complexType>


 complexType ivgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/ivg
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name Notes
source
<complexType name="ivgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="case_id" use="required">
    <simpleType>
      <restriction base="string">
        <pattern value="([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6})"/>
      </restriction>
    </simpleType>
  </attribute>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType" use="required"/>
  <attribute name="nif" type="credit:nifPartyType" use="required"/>
</complexType>


 complexType kvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/kvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="kvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType mvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/mvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="mvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType providerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/provider
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<complexType name="providerAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType" use="required"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 complexType referrerAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
elements creditType/family_doctor creditType/referrer creditType/treating_person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="referrerAddressType">
  <choice minOccurs="0">
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:xtendEanPartyType" default="unknown"/>
  <attribute name="zsr" type="credit:zsrPartyType"/>
</complexType>


 complexType requestorAddressType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:company credit:person
used by
element creditType/requestor
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<complexType name="requestorAddressType">
  <choice>
    <element name="company" type="credit:companyType"/>
    <element name="person" type="credit:personType"/>
  </choice>
  <attribute name="ean_party" type="credit:eanPartyType" use="required"/>
  <attribute name="zsr" type="credit:zsrPartyType"/>
  <attribute name="specialty" type="credit:stringType1_350"/>
</complexType>


 complexType requestType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:header credit:prolog credit:credit
used by
element request
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name Notes
source
<complexType name="requestType">
  <sequence>
    <element name="header" type="credit:headerType"/>
    <element name="prolog" type="credit:prologType"/>
    <element name="credit" type="credit:creditType"/>
  </sequence>
  <attribute name="assignment_role" fixed="physician"/>
  <attribute name="assignment_place" fixed="hospital"/>
  <attribute name="role" default="production">
    <simpleType>
      <restriction base="NMTOKEN">
        <enumeration value="production"/>
        <enumeration value="test"/>
      </restriction>
    </simpleType>
  </attribute>
</complexType>


 complexType sponsorType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:insurance credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg
used by
element creditType/sponsor
attributes parameters
Name | Type | Use | Default | Fixed
is_recipient | boolean |  | false |
attributes annotations
Name Notes
source
<complexType name="sponsorType">
  <sequence>
    <element name="insurance" type="credit:insuranceAddressType"/>
    <choice>
      <element name="kvg" type="credit:kvgLawType"/>
      <element name="vvg" type="credit:vvgLawType"/>
      <element name="uvg" type="credit:uvgLawType"/>
      <element name="ivg" type="credit:ivgLawType"/>
      <element name="mvg" type="credit:mvgLawType"/>
    </choice>
  </sequence>
  <attribute name="is_recipient" type="boolean" default="false"/>
</complexType>


 complexType therapyType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:stringType0_350
properties
base credit:stringType0_350
used by
element detailType/therapy
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<complexType name="therapyType">
  <simpleContent>
    <extension base="credit:stringType0_350">
      <attribute name="type" default="by_contract">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="CHOP"/>
            <enumeration value="by_contract"/>
            <enumeration value="freetext"/>
          </restriction>
        </simpleType>
      </attribute>
      <attribute name="code" type="credit:stringType1_12"/>
    </extension>
  </simpleContent>
</complexType>


 complexType uvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:costs credit:total_costs
used by
element sponsorType/uvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<complexType name="uvgLawType">
  <sequence>
    <element name="costs" type="credit:costsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
  <attribute name="ssn" type="credit:ssnPartyType"/>
</complexType>


 complexType vvgLawType
diagram
namespace | http://www.forum-datenaustausch.ch/de
children | credit:medical_costs credit:treatment_costs credit:total_costs
used by
element sponsorType/vvg
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<complexType name="vvgLawType">
  <sequence>
    <element name="medical_costs" type="credit:xndCostsType"/>
    <element name="treatment_costs" type="credit:xndCostsType"/>
    <element name="total_costs" type="credit:costsType"/>
  </sequence>
  <attribute name="patient_id" type="credit:stringType1_35"/>
  <attribute name="case_id" type="credit:stringType1_35"/>
  <attribute name="case_date" type="dateTime"/>
  <attribute name="contract_number" type="credit:stringType1_35"/>
</complexType>


 complexType xndCostsType
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | extension of credit:costsType
properties
base credit:costsType
used by
elements vvgLawType/medical_costs vvgLawType/treatment_costs
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<complexType name="xndCostsType">
  <complexContent>
    <extension base="credit:costsType">
      <attribute name="class">
        <simpleType>
          <restriction base="NMTOKEN">
            <enumeration value="private"/>
            <enumeration value="semi_private"/>
          </restriction>
        </simpleType>
      </attribute>
    </extension>
  </complexContent>
</complexType>


 element contactAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element contactAddressType/employee
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:employeeType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="employee" type="credit:employeeType"/>


 element contactAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element creditType/contact
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:contactAddressType
properties
isRef | 0
content | complex
children | credit:person credit:employee credit:company
source
<element name="contact" type="credit:contactAddressType"/>


 element creditType/detail
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:detailType
properties
isRef | 0
content | complex
children | credit:diagnosis credit:therapy credit:functional_deficits credit:accompanying_affections credit:treatment_goals credit:remark
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required |  |
date_end | dateTime | required |  |
days | duration | required |  |
treatment_canton |  | required |  |
treatment_type |  | required |  |
reason |  | required |  |
hospitalization_type |  | required |  |
hospitalization_mode |  | required |  |
section_major | credit:stringType1_6 |  |  |
section_name | credit:stringType1_35 |  |  |
relapse | boolean |  | false |
attributes annotations
Name Notes
source
<element name="detail" type="credit:detailType"/>


 element creditType/employer
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:employerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType |  |  |
reg_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="employer" type="credit:employerAddressType" minOccurs="0"/>


 element creditType/family_doctor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="family_doctor" type="credit:referrerAddressType" minOccurs="0"/>


 element creditType/patient
Annotation Patient

Bezeichnet den Adressblock mit Angaben des Patienten.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:patientAddressType
properties
isRef | 0
content | complex
children | credit:person
attributes parameters
Name | Type | Use | Default | Fixed
gender |  | required |  |
birthdate | dateTime | required |  |
ssn | credit:ssnPartyType |  |  |
tax_city | credit:stringType1_35 |  |  |
tax_canton |  |  |  |
attributes annotations
Name | Notes
gender | Geschlecht des Patienten
birthdate | Geburtsdatum des Patienten Ist die Angabe der Uhrzeit nicht relevant, ist 0 Uhr ("T00:00:00") anzugeben.
ssn | AHV-Nummer des Patienten
senderID | Identifikation des Patienten oder Falls des Senders z.B. Patientennummer oder Fallnummer des Leistungserbringers
recipientID | Identifikation des Versicherten oder Unfalls des Empfängers z.B. Versichertennummer oder Unfallnummer des Kostenträgers
attributes enumerations
Name | Extension | Base | Wert | Bedeutung
gender |  | NMTOKEN | male | männlich
gender |  | NMTOKEN | female | weiblich
source
<element name="patient" type="credit:patientAddressType"/>


 element creditType/provider
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:providerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType | required |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<element name="provider" type="credit:providerAddressType"/>


 element creditType/referrer
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="referrer" type="credit:referrerAddressType" minOccurs="0"/>


 element creditType/requestor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:requestorAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
zsr | credit:zsrPartyType |  |  |
specialty | credit:stringType1_350 |  |  |
attributes annotations
Name Notes
source
<element name="requestor" type="credit:requestorAddressType"/>


 element creditType/sponsor
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:sponsorType
properties
isRef | 0
content | complex
children | credit:insurance credit:kvg credit:vvg credit:uvg credit:ivg credit:mvg
attributes parameters
Name | Type | Use | Default | Fixed
is_recipient | boolean |  | false |
attributes annotations
Name Notes
source
<element name="sponsor" type="credit:sponsorType"/>


 element creditType/treating_person
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:referrerAddressType
properties
isRef | 0
content | complex
children | credit:company credit:person
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:xtendEanPartyType |  | unknown |
zsr | credit:zsrPartyType |  |  |
attributes annotations
Name Notes
source
<element name="treating_person" type="credit:referrerAddressType" minOccurs="0"/>


 element detailType/accompanying_affections
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="accompanying_affections" type="string" minOccurs="0"/>


 element detailType/diagnosis
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:diagnosisType
properties
isRef | 0
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<element name="diagnosis" type="credit:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>


 element detailType/functional_deficits
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="functional_deficits" type="string" minOccurs="0"/>


 element detailType/remark
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="remark" type="string" minOccurs="0"/>


 element detailType/therapy
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:therapyType
properties
isRef | 0
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type |  |  | by_contract |
code | credit:stringType1_12 |  |  |
attributes annotations
Name Notes
source
<element name="therapy" type="credit:therapyType" minOccurs="0" maxOccurs="unbounded"/>


 element detailType/treatment_goals
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | string
properties
isRef | 0
content | simple
source
<element name="treatment_goals" type="string" minOccurs="0"/>


 element employeeType/familyname
Annotation Nachname
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="familyname" type="credit:stringType1_35"/>


 element employeeType/givenname
Annotation Vorname

Bezeichnet das Element, in welchem als Dateninhalt der Vor- oder die Zweitnamen einer natürlichen Person angegeben werden.

Das erste gegebene Element wird immer als Vorname gewertet, allfällig weitere Elemente als Zweitnamen.
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source
<element name="givenname" type="credit:stringType1_35" maxOccurs="3"/>


 element employerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element employerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element insuranceAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element ivgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element ivgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element kvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element kvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element mvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element mvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element providerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element providerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element referrerAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element referrerAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element request
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:requestType
properties
content complex
children | credit:header credit:prolog credit:credit
attributes parameters
Name | Type | Use | Default | Fixed
assignment_role |  |  |  | physician
assignment_place |  |  |  | hospital
role |  |  | production |
attributes annotations
Name Notes
source
<element name="request" type="credit:requestType"/>


 element requestorAddressType/company
Annotation Sender-/Empfänger-Adresse Firma
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:companyType
properties
isRef | 0
content | complex
children | credit:companyname credit:department credit:postal credit:telecom credit:online
source
<element name="company" type="credit:companyType"/>


 element requestorAddressType/person
Annotation Sender-/Empfänger-Adresse Person
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:personType
properties
isRef | 0
content | complex
children | credit:familyname credit:givenname credit:postal credit:telecom credit:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | credit:stringType1_35 |  |  |
title | credit:stringType1_35 |  |  |
attributes annotations
Name | Notes
salutation | Anrede
title | Titel
source
<element name="person" type="credit:personType"/>


 element requestType/credit
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:creditType
properties
isRef | 0
content | complex
children | credit:requestor credit:contact credit:provider credit:patient credit:referrer credit:treating_person credit:family_doctor credit:sponsor credit:employer credit:detail
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
credit_timestamp | unsignedLong | required |  |
credit_id | credit:stringType1_35 | required |  |
credit_date | dateTime | required |  |
resend_number | unsignedLong |  | 0 |
resend_date | dateTime |  |  |
copy | boolean |  | false |
type |  |  | new |
attributes annotations
Name Notes
source
<element name="credit" type="credit:creditType"/>


 element requestType/header
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:headerType
properties
isRef | 0
content | complex
children | credit:sender credit:intermediate credit:recipient
source
<element name="header" type="credit:headerType"/>


 element requestType/prolog
Annotation Prolog

Block mit Informationen über:

- das übergeordnete Software-Packet (Branchenapplikation)
- den Generator, welcher die entsprechenden XML Strukturen generiert und validiert hat
- die verwendeten Daten-Validatoren
diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:prologType
properties
isRef | 0
content | complex
children | credit:package credit:generator
source
<element name="prolog" type="credit:prologType"/>


 element sponsorType/insurance
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:insuranceAddressType
properties
isRef | 0
content | complex
children | credit:company
attributes parameters
Name | Type | Use | Default | Fixed
ean_party | credit:eanPartyType | required |  |
attributes annotations
Name Notes
source
<element name="insurance" type="credit:insuranceAddressType"/>


 element sponsorType/ivg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:ivgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
case_id |  | required |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType | required |  |
nif | credit:nifPartyType | required |  |
attributes annotations
Name Notes
source
<element name="ivg" type="credit:ivgLawType"/>


 element sponsorType/kvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:kvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="kvg" type="credit:kvgLawType"/>


 element sponsorType/mvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:mvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<element name="mvg" type="credit:mvgLawType"/>


 element sponsorType/uvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:uvgLawType
properties
isRef | 0
content | complex
children | credit:costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
ssn | credit:ssnPartyType |  |  |
attributes annotations
Name Notes
source
<element name="uvg" type="credit:uvgLawType"/>


 element sponsorType/vvg
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:vvgLawType
properties
isRef | 0
content | complex
children | credit:medical_costs credit:treatment_costs credit:total_costs
attributes parameters
Name | Type | Use | Default | Fixed
patient_id | credit:stringType1_35 |  |  |
case_id | credit:stringType1_35 |  |  |
case_date | dateTime |  |  |
contract_number | credit:stringType1_35 |  |  |
attributes annotations
Name Notes
source
<element name="vvg" type="credit:vvgLawType"/>


 element uvgLawType/costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="costs" type="credit:costsType"/>


 element uvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element vvgLawType/medical_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<element name="medical_costs" type="credit:xndCostsType"/>


 element vvgLawType/total_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:costsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
attributes annotations
Name Notes
source
<element name="total_costs" type="credit:costsType"/>


 element vvgLawType/treatment_costs
Annotation

diagram
namespace | http://www.forum-datenaustausch.ch/de
type | credit:xndCostsType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
amount | credit:amountType |  |  |
currency | string |  |  | CHF
class |  |  |  |
attributes annotations
Name Notes
source
<element name="treatment_costs" type="credit:xndCostsType"/>


 simpleType amountType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of double
used by
attribute costsType/@amount
facets
minInclusive 0
source
<simpleType name="amountType">
  <restriction base="double">
    <minInclusive value="0"/>
  </restriction>
</simpleType>


 simpleType nifPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute ivgLawType/@nif
facets
pattern [0-9]{1,7}
source
<simpleType name="nifPartyType">
  <restriction base="string">
    <pattern value="[0-9]{1,7}"/>
  </restriction>
</simpleType>


 simpleType stringType0_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
complexTypes diagnosisType therapyType
facets
maxLength 350
source
<simpleType name="stringType0_350">
  <restriction base="string">
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType stringType1_6
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attribute detailType/@section_major
facets
minLength | 1
maxLength | 6
source
<simpleType name="stringType1_6">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="6"/>
  </restriction>
</simpleType>


 simpleType stringType1_12
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes diagnosisType/@code therapyType/@code
facets
minLength | 1
maxLength | 12
source
<simpleType name="stringType1_12">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="12"/>
  </restriction>
</simpleType>


 simpleType stringType1_350
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
attributes requestorAddressType/@specialty providerAddressType/@specialty
facets
minLength | 1
maxLength | 350
source
<simpleType name="stringType1_350">
  <restriction base="string">
    <minLength value="1"/>
    <maxLength value="350"/>
  </restriction>
</simpleType>


 simpleType unionPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | union of ( credit:xtendEanPartyType , credit:zsrPartyType )
source
<simpleType name="unionPartyType">
  <union memberTypes="credit:xtendEanPartyType credit:zsrPartyType"/>
</simpleType>


 simpleType zsrPartyType
namespace | http://www.forum-datenaustausch.ch/de
type | restriction of string
used by
simpleType | unionPartyType
attributes | requestorAddressType/@zsr providerAddressType/@zsr referrerAddressType/@zsr
facets
pattern ([A-Z][0-9]{6}|[0-9]{6}[A-Z])
source
<simpleType name="zsrPartyType">
  <restriction base="string">
    <pattern value="([A-Z][0-9]{6}|[0-9]{6}[A-Z])"/>
  </restriction>
</simpleType>